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1. Introduction

1.1 Operating Environment

1.1.1 Operating systems

Windows 2000, Windows XP or Windows Vista

1.1.2 Hardware requirements

CPU: Pentium 133 or better
Memory: 64Mbytes or more
Disk space: 30Mbytes or more

1.2 Functions and Features

With PEP Designer, user can design the own operating menu and function screen for the

Parameter Entry Panel (PEP) products. Features of PEP Designer include:

Various function items, such as menus, value items, action items, and lists.

Hierarchical menu design supports 6 levels of menu and up to 10 menus for each level
Hints for each menu items and can be shown on the screen if required.

Design entry formatted with Unicode provides the capability of multilingual display on
the panel.

Unicode design for PEP designer provides the multilingual operation with a single
package.

Offline and online simulations accelerates design progress by saving the time for
elaborated design downloads.

Special character-input tool can store commonly used special symbols for future use.
Configurable display font at design time for the panel.

Multiple startup pages (graphics).

Menu import and export.

Flexible program editing functions accelerate design progress, including copy, paste,
delete, and scroll up and down.

Search function for searching data in the register and strings. Can call out and display the
corresponding design section of matched item in the window with single click to the
matched list.

Alarms function with up to 64 alarm display pages and each page can define up to 3
dynamic data.
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2. Examples of Operations

2.1 Operating Window

There are four parts in the operating window: Menu Bar, Toolbar, Project Tree, and Status Bar
as shown below.

Menu Bar
- g V ==l o
File Edit Project Tools Options Hel
B~ | ¢ BFERRE RS SBE XL e+ TFYSE 5 |
-1-'-;roject . : . :
0 Alarms Tool Bar |
Startup Screen
--Ed Screen Saver Project Tree - Start
L5 Configuration Menu
Status Bar
‘Modified | ] [
X Menu Bar: The menu bar provides access to all the functions of PEP Designer,

including the following six categories: File, Edit, Project, Tool,
Options, and Help..

Tool Bar: The tool bar provides quick launch in iconic display to the
commonly used functions in PEP Designer. By clicking on the
respective icon, can directly launch to the selected function.

Project Tree: The project tree categorize the whole project into six top nodes:
Device Info, Main Menu, Alarms, Startup Screen, Screen Saver,
and Configuration.

Status Bar: The status bar displays the present menu item and project
modification status. When the message “Modified” appears on the
leftmost frame, the selected project has been modified but not yet
saved.
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2.2 Contents of Example

The following example illustrates how to plan a project with the hierarchical menu and

actions for the room appliance control. The two common features in room control, lights and

air-conditioner, will be discussed in this example. First, we will divide the space into two

areas: bedroom and bathroom, both of which are equipped with lights. The bedroom lights are

equipped with dimming function, while the bathroom lights only with the on/off function. The

air-conditioner is only equipped in the room with the set temperature and set fan speed

functions. After editing all menus and functions, the entire operating process can be expressed

in the tree diagram below:

Theroom light

Brightness Adjustment | 3(0.0.0)

Adjust the brightness [ 4(0.0.0.0)

—
—_
—

Main Menu | 0
The lights Control | 1(0) The air-con Control
2(0.0) The bathroom light [2(0.1) | Temperature Settings |2(10) | Speed Settings
On/off |3(0.0.1) On/off |3(0.00) Set the temperature [3(100) | Setthe speed

[3%)

(1.10)

Onfoff |2(1.2)

% There is a set of numbers inside parentheses next to each item. The sequence of these
numbers is 0, 1, 2, 3 and so on. The number on the leftmost indicates the level to
facilitate users to plan a project and will not be displayed in PEP. The numbers
within the parentheses, represent the level and item locations of the menu as shown

below.

Lights Control (0):

Air-con Control (1):

Room Lights (0.0):
Bathroom Lights (0.1):

Set the Temperature (1.0.0):

Set the Speed (1.1.0):

Menu 0 on Level 0
Menu 1 on Level 0.

on Level 0.

on Level 0.
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Menu 0 on Level 1, i.e. one level below Menu 0 on Level 0.
Menu 1 on Level 1; i.e. one level below Menu 0 on Level 0.
Menu 0, one level below Menu O on the level below Menu 1

Menu 0, one level below Menu 1 on the level below Menu 1



% If you want to adjust the brightness of the room lights, adjust through the following
path (0.0.0.0).
—> Lights Control(0) — Room Lights(0) — Brightness Adjustment(0) — Adjust
Brightness(0)

If you want to set the fan speed of the room air-con, adjust through the following
path (1.1.0).
= Air-con Control (1) — Speed Settings (1) — Set the Speed (0)

2.3 Add Menu

Menu acts as a function button. As PEP Designer provides the hierarchical menu architecture,
user can systemically categorize operating functions by function and by application at
different levels. You can also freely plan and design the categories and names of menus and
add hint to the menus.

Step 1:  Double-click left mouse button at the E icon to start up PEP Designer.

Step 2:  After opening PEP Designer, a blank operating window will be opened. Select

[File]>[New] from the menu bar with the mouse or click on icon EJ on the

toolbar or press the [Ctrl] + [N] keys to open a new file as shown below.

| ﬁ PEPD = | S| -
File JEdit Project Tools Options Help
B New .. Ctri+MN |2
Py = T N
F] Exit Alt+F4

& The Device Info. window will pop up as shown below. The Device Name item
represents the parameter entry device to be used in this project. You can input
descriptions for this project in the Descriptions item. These descriptions will be
displayed in the Open file dialog window which can facilitate the identifying and
selecting among the different project files.
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(R eero =[=] =2 ]

File Edit Project Tools Options Help

-  mRraR E3% SOBHLy XKL+ FFwa5H |

—Project

-
EA Device Infornation L o e |
Device Mame:
[BPEP] 128764 Cled Display =]

Description:

|

% You can add description to this program in the Description field. Otherwise, press

the button and the project tree nodes in the red frame below will be

generated automatically. These include the Device Info, Main menu, Alarms, Startup
Screen, Screen Saver and Configuration menus. Now, you can begin planning and
setting up the project contents.

Ed rePD o=
File Edit Project Tools Options Help

B -] BFRER ES% SAEHY XkiLe + EFqaamn |

(.Bf Main Menu
& Alarms
Startup Screen
Screen Saver
o Configuration

Modified |

[
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Step 3:  Select Main menu on the screen with the mouse. Then select [Edit]>[Add Menu]
from the menu bar. You may also simply right-click the item to call out the pop-up
menu and select [Add Menu] as shown below.

EA pePD Lo o |

File] | Edit |Project Tools Options Help

HSBE X LS+ |

SEER——

“°H| =, Add Action _.
‘=, Add List

Ctrl+F

Modified | o 4

The Add Menu window will be shown as below.
[ ®A peen [=[=] & ]

File Edit Project Tools Options Help

B -] ek E3%SGE Yy XKL + HFPSEH |

—Project
EA Add Menu |3
String: ||
i “gd Config Description: -

W OK I x Cancell

Modified | [o [ &

W

% “String” refers to the title of the menu item. Text in the “Description” field is the hint
for this menu.
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Step 4:  Enter the title of the first function menu “The Lights Control” in the String field and

enter the functions or explanations of this menu in the Description field as shown
below.

:> rﬂ Add Menu

String: IThe lights Control

Description:

" OK I x Cancell

Step 5:  After inputting data to both fields, press the button to add the Lights

Control menu to the project, and this Add Menu will appear under the Main menu
node as shown below.

.
Ed FEPD

File Edit Project Tools

Options  Help

—Project

BB -] e E4 4 SQEy XKL + FTFHgH |

- The lights Control
Fa t=1a gyr=]

Startup Screen

; Screen Saver

“-=rd Configuration

Modified |
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Step 6:  Repeat Step 5 to add the second function menu Air-con Control to the project as

shown below.

-
EA PEPD

File Edit Project Tools Options

b | E

Help

D -@] ' BTk B3R SAEHY XKL+ EFPHam |
—Project

Ef The lights Control
Bl The air-con Control

Startup Screen
-[Ed Screen Saver
Oﬁ Configuration

Modified | [0 [

&

% After creating the two main function menus of the project, continue creating the
internal space and function menus for the project.

Step 7:  Select Lights control on the screen with the mouse. Then select [Edit]2>[Add Menu]
from the menu bar. You may also simply right-click the item to call out the pop-up

menu and select [Add Menu]. Now you can create the Room lights and the
Bathroom lights menus under the Lights control menu as shown below.

s
Ef FEFD
File Edit Project Tools Options

Dﬁlg

Help

DS -E s Ty RGN SRL Y XkELS + TPy e
—Project

-~ § Device Info.

=
:~E] The room light
“-ET The bathroom light
€ all-Comn Contro
i Alarms

-2 Startup Screen

& Screen Saver

~-%¢¢ Configuration

Modified | 1 [0
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Step 8: Select the Room lights on the screen with the mouse. Then select [Edit]>[Add
Menu] from the menu bar. You may also simply right-click the item to call out the
pop-up menu and select [Add Menu]. Now, you can create the Brightness
Adjustment menu under the Room lights menu as shown below.

Ed PEPD = T

File Edit Project Tools Options Help

DS ' 4B m Bt SBEy XL e + TPy E |

—Project
-~ & Device Info.

=-Ef Main Menu

-Ef Brightness Adjustment
= e bathroom Ig
Bl The air-con Control
i Alarms

-2 Startup Screen

--E& Screen Sawver

-4 Configuration

Modified | 2 0.0

Step 9:  Select the Air-con Control on the screen with the mouse. Then select [Edit]>[Add
Menu] from the menu bar. You may also simply right-click the item to call out the
pop-up menu and select [Add Menu]. Now, you can create the Temperature settings
and Speed Settings menus under the Air-con Control menu as shown below.

RS [E=RNE >

File Edit Project Tools Options Help

D -E{ BTFER B9 %SGy Xk s NP5 8 |

—Project

- & Device Info.
=B Main Menu
=-E The lights Control
{ =-Ef The room light

.. Bf Brightness Adjustment

T DO g

F
EIE The air-con Control

B Temperature Settings
Bl Speed Settings
4P Alarms

@& Startup Screen

--Ed Screen Saver

%} Configuration

Modified | 1 [1

N
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After creating the two main function menus and their sub-menus, these menus will be

displayed under the Main menu as shown below.

Ef FEFD

E@g

File Edit Project Tools Options Help

| DE-E] s+ ek B 4% SAHY XKL+ EFwgH |

—Project

e
EI E The lights Control
: E The room light
~Ef Brightness Adjustment
E The bathroom light
EIE The air-con Control

------ E Temperature Settings

------ ..} Speed Settings
---Wms
i Startup Screen
i Screen Saver
-5 Configuration

Modified | [o

N

2.4 Set Action

After creating all menus in the Main menu, you may continue with the controls: Light Switch
and Air-con Switch. As a switch is used to turn the power ON and OFF, the functions in the
Action item can fulfill this demand. Therefore, you can set the switch actions by selecting

[Add Action].

Step 1: Select the Room Lights on the screen with the mouse. Then select [Edit]>[Add
Action] from the menu bar. You may also simply right-click the item to call out the

pop-up menu and select [Add Action] as shown below.

Ed PEPD

D@g

File Edit Project Tools Options Help

EEEIIFE Y T

SEMEY Xkt o + TP = |

—Project

- & Device Info.
L__| E Main Menu

B The- bathroom
=8 E The air-con Contr

------ & Temperature £
------ . Bf Speed Settings

----- & Alarms

2 : Startup Screen

£ Screen Saver

----- %l Configuration

w* Edit .
> Delete Del
e Delete Leaf Ctrl+Del

¥, Delete MNode

Modified | [2

S —————————— o leszils
F Mowve Down

#7 Import Menu ...
BP Export Menu ...
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The [Add Action] window will pop up as shown below.

@ rero (=]=] = |
File Edig
= " EA Add Action [P IS
| B = 8 B
[Project Action Type: IToggIe State ;I
=-E Ma String (ON): ||
=B
LB String (OFF) : |

Description:

Reference Mo.:

" OK I x Cancell

hModified 2

% In the Action Type item, select Toggle State for Light Switch. You can enter the action
strings according to the information in the following example. According to the
example, when the action is activated, “Y0” will be the reference number
corresponding to the PLC, and the actions On and Off will be displayed alternately.

|::> | EA Edit Action [E=REE
Action Type: I'I'oggle State LI
String (ON): ITurn on the light
String (OFF) : ITurn off the light
Description:
. ,, —

Reference Mo.: [yv0

" 0K I x Cancell
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Step 2:  After complete the input data, press the button to add the Turn on the

Light action to the Room Lights menu as shown below.

E@g

| Ed PEPD

File Edit Project Tools Options Help
| DS - $ T R RGN SBEHY XL + TP e H |
—Project
-1 Device Info.

~&%= Turn on the light
== I'he bathroom hight
=B The air-con Control

Alarms
Startup Screen
-] SCreen Sawver
-5 Configuration

Modified | |2 [0.0 A
% If you want to modify the action, select the action with the mouse and select

[Edit]=>[Edit] from the menu bar. You may also simply double-click the item to call
out the Edit Action function and modify the action. After modifying the action, press

the button to confirm modifications.

Step 3:  Repeat Steps 1 and 2 to add actions to the Bathroom lights and the Air-con Control.
After adding functions to these actions, they will be displayed under the respective
items as shown below.

E@g

PEPD
File Edit Project Tools Options Help
| DE-E $ e e R (B EHhSMEH Yy X k> + TP ag e |
—Project
-~ § Device Info.
=B Main Menu
=B The lights Control

- =-Ef The room light

- +.FE erightness Adjustment
L= T oo the light
The bathroom light
E == Turn on the light
EI I ne ainr-con Lonouon

--E& Startup Screen
--E& Screen Sawver
----- i Configuration

Modified | 1 1 )

% In this example, the reference numbers corresponding to the PLC are: *“Y0” for The
Room lights (On/Off), “Y1” for The Bathroom lights (On/Off), and “Y?2” for The
Air-con Switch. As shown below.
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Ed FPEFD =R s

File Edit Project Tools Options Help

B -d|| i ek B34 5QH Yy XKL+ F¥ruam |
—Project
-~ & Device Info.
=8 = Main Menu
E The lights Control
B} The room light
LB} Brightness Adjustment
= Turn on the light

Reference No.: YO

i L= Turp on the light

& E The air-con Control

B} Temperature Settings

[ Speed Settings
‘# =% Turn on the air-con

- alarms

Startup Screen

- Screen Sawver

% configuration

Reference No.: Y1

Reference No.: Y2

Modified | [0

2.5 Set Value

There are two operations concerning the Air-con: Temperature Settings and Fan Speed
Settings. Let us begin with Temperature settings. As temperature is set by means of value, the
Add Value function can fulfill this demand. Therefore, we can achieve Temperature Settings
with the Add Value function.

Step 1:  Select Temperature Settings on the screen with the mouse. Then select [Edit]>[Add
Value]. You may also right-click the item to call out the pop-up menu and select
[Add Value] as shown below.

A Cut Ctrl+X
Ctrl+C
EA Peeo Y adavae e
File Edit Project Tools Opti !* == |
| D - & || g omer | A 2R 1N
[ Project 4
- § Device Info.
EE Main Menu Del
=Bl The lights Control e
=BT The room light o
B erightness adjustn
= Turn on the light
g The bathroom light &+ Mowve Down
. -l— Turn on the Ilght
T Import Menu .

Ten]perature Settings E [EfEEE L.

=
. Turn on the air-con

Startup Screen
Screen Saver
—-%rd Configuration

Modified | [2 [10 2
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The Add Value window will pop up as shown below.
r PEPD (== 2 ]

File Edit Project Tools Options Help

DS -@ e B S% S @by XL+ TPy 8 |

—Project =
-1 Devig Add value =
E‘E Main String: ||
SE T
=5 Description: -
4 »
Reference Mo.: I [~ signed
Max. I Decimal Point: Ig vl
Min
| Unit: |
[~ Read Only
o 0K I oK cancel |
Modified | [2 [1o £

e

% “String” refers to the title of the value item. Assign a register in “Reference No.” to
store the value input by users. “Max.” and “Min.” represent the range of the value
restriction when input the value.

:> ' Edit Value [—=2z—]

String: Set the temperature
Description: -

. ,, I
Reference MNo.: IRD I~ Signed
Mane. I4U Decimal Point: m
Min- [10 Unit: fc—
[ Read Only

W 0K I X cancel I

% In this example, “R0” is the reference number corresponding to the PLC, i.e. the
register assigned to save the value for Set the Temperature. The Maximum and
Minimum values are 40 and 10 respectively. The temperature unit is °C.
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Step 2:  After complete the input, press the button to add the Set the Temperature

value item under the Temperature Settings menu as shown below.
i PEPD | TR ==

File Edit Project Tools Options Help

D -E| e AR U S ML XKL > + F P H |
[ Project

I Device Info.

=B Main Menu

E.'g The lights Control

. =-Ef The room light

+Ef Brightness Adjustment

= Turn on the light

=-Ef The bathroom light

L.#5 Turn on the light

S 1=1
L1228 Set the temperature
Speed Settings

== Twurn on the air-con
- Alarms

- Startup Screen

-] Screen Sawver

~-&rl Configuration

Modified | |2 1.0

2.6 Set List

There are five choices for the Fan Speed Settings item in the Air-con Control menu: High,

N

Medium, Low, Mild, and Auto. The choices for the Brightness Adjustment item in the Room
Lights menu include High, Medium, and Low. As every function in the list must contain a
corresponding value, when you select an choice, the corresponding value of the choice will be
written in the PLC register as desired. Therefore, we can implement the Fan Speed Settings
and Brightness Adjustment with the Add List function.

Step 1:  Select Speed Settings on the screen with the mouse. Then select [Edit]>[Add List].
You may also right-click the item to call out the pop-up menu and select [Add List]
as shown below.

R e

Ctrl+W = 5

Ef PEFD
File Edit Project Tools

E: Add Menu .
122 add value ...

| D= - || & B la aggacon v Xt & o T wmE
[ O —
- & Device Info. B Raci=
=-Ef Main Menu Add Startup Screen
=-Bf The lights Control| .~ Edit .
=B The room light v¢ pelete Del
Ef Brightness T Delete Leaf Ctrl+De
= Turn on the #. Delete Mo
=B The bathroom
.3 Turn on the €+ Move Up
EE The air-con Contri % Mowve Down

[ Project

¥ Import Menu ..

- SCreen Saver
----- =i Configuration

Modified | [2 11 P
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The Add List window will pop up as shown below.
r PEPD |_ = | = 22 _|1

File Edit' Add List
J B = ——

e String: ||

& Dew Description:

*

Reference Mo.: I [~ Read Only

EIE Count: |2 ;I

List String: Value |String

1

" OK I x Cancell
Modified

|
% “String” refers to the title of the list item. Assign a register in Reference No. to store
the list value chosen by users. Based on the demand of users, the number of List
String depends on the total number of options in the pull-down menu. The string in
string field of “List String” allows users to denote the choices.

— add List [

String: Set the speed
Description: -

bl »
Reference Mo.: IRl I Read Only

Count: |5 LI

List String: Walue [String |

0 Maz

1 Middle

2 Small

3 Slight

4 Auto

" 0K I x Cancell

% In this example, “R1” is the reference number corresponding to the PLC, i.e. the

register assigned to save the value for Speed. If the choice is “Small”, the value 2 will
be written to the R1 register of PLC.
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After complete the input data, press the button to add the Set the Speed

Step 2:
list to the Speed Settings menu as shown below
[ EA reeD =N
File Edit Project Tools Options Help

DE-H| i mTFek BN SeLv XKL e EFwgg |

—Project
& Device Info.
= E Main Menu
=B The lights Control
i =-Ef The room light
Ef erightness adjustment
L#% Turn on the light
EIE'_ The bathroom light
i L& Turn on the light
= B The air-con Control
EI E Temperature Settings

e ®E Turn on the air-con
-} Alarms
: Startup Screen
i Screen Saver
- %ed Configuration

N

Modified | [2 [F

Repeat Steps 1 and 2 to add the Adjust Brightness list to the Brightness Adjustment

Step 3:
menu as shown below.
[ ®@ reeo =R
File Edit Project Tools Options Help
D -] i Bribk BEE%SQEHY XKL + PN |
—Project

- & Device Info.
=-Bf Main Menu
EI g The lights Control

= E Brightness Adjustment
= Adjust the brightness
we®m Turn on the light

EE The bathroom light
H L= Turn on the light
- ‘Bf The air-con Control

EIE Temperature Settings
¢ 122 Set the temperature

‘Bf Speed Settings

i= Set the speed
L-#&% Turn on the air-con
----- & Alarms
Startup Screen
Screen Saver
..... “¢l Configuration

Modified | [3 [0.0.0
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% In this example, the register R1 is assigned to list item - “Set the Speed”, while the
register R2 is assigned to list item - “Adjust Brightness”.

'ﬂ PEPD | (S
File Edit Project Tools Options Help
beE-H- B G i T EwE S

Project

-~ & Device Info.

B BF

=B The lights Contral

- =+Ef The room light
E| 55‘ f= a waf=Yal

i :i= adjust the brightness Reference No: R2

i ct

=-Bf The air-con Control
=-E Temperature Settings
. i.122 Set the temperature

Reference No: R1

i@ Startup Screen
Screen Saver
----- “rl Configuration

Modified [v]

2.7 Simulation and Downloading of Designs

After creating the user menus, you may want to validate if they are consistent with the
planning. Run the On-line Simulation to test these menus. With the On-line Simulation, you
can save labor and time from loading menus to run the test on the operating device every time
after editing a function. After finished the simulation test, only when everything is verified
and validated, menus design is required to download to PEP device.

2.7.1 On-line Simulation

Similar to the Off-line Simulation, which runs the simulation on the PC, the only difference
between the offline and online simulation is that the former does not connect to the PLC,
while the latter connects to the PLC via the communication port on the PC running the
simulation.
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Step 1:  Select [Project]>[On-line Simulation] from the menu bar with the mouse. You may
also click the E icon on the toolbar or press the [F10] function key on the
keyboard to directly launch to the On-line Simulation as shown below.

[ A pePD =N

File Edit] Project | Tools Options Help
7w Complle _ B S@Ev Xkt s FPagH |
Off-line Simulation F9
==/ Cn-line o

EI Bl The lights Control
R E The room light
: =-E Brightness Adjustment
-iE Adjust the brightness
Turn on the light

El E The bathroom light
i L= Turn on the light
B E The air-con Control

EI E Temperature Settings
-123 Set the temperature
El E Speed Settings
= Set the speed

w®% Turn on the air-con

----- i Alarms
Startup Screen

4 Screen Saver
----- “rd Configuration

Modified | [o )
Step 2:  The “Compile Result” window will pop up. The information in the window
includes Code Size Usage and Output File as shown below.
[ EA reeD [==] & ]
File Edit Project Tools Options Help
B -1 rak BE3%5QH XML+ EFagH |
—Project
Elé‘_ Eﬂ::\crﬂ Compile Result B
EI E T

| Code Size Usage: 3892 Bytes used / 131072 Bytes available

| Output file : C:\Program

Files\Fatek\Pepd\Pepd.mda

I

2%

‘ Turn on the air-con
- Alarms
Startup Screen
creen Saver
%l Configuration

Modified | [0

[
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Step 3:  After verify the compile result is OK, press the button and the Setup Port

Parameter window will pop up as shown below.

PEPD = 2
File Edit Project Tools Options Help
B =gy = = e il B0
Project
¢~ & Device Infog =
- E_— T B Setup Port Parameter —E
EI E T_he ligh Baud Rate: |Ell -
Com Port: [COM4 |

Start Exit

— i} Alarms L
- Startup Screen
Screen Saver
°ﬁ Configuration

Modified [o]

Step 4:  After setting up the Baud Rate and Com Port, press the _ st | button. The

[On-line Simulation] screen will pop up as shown below.

rﬂ PEPD = = |
File Edit Project Tools Options Help
e -H = . 3 T Ere B H
Project

- & Device Info.
B E‘_ Main Menu
EI E‘_ The lights Contra
= E The room ligh
=n= Brlghtness

=5 E The bathroom
| .# Turn on th
B E The air-con Confl
EIE Temperature
-122 Set the teg
= E Speed Setting
' Set the spi
= Turn on the al

Startup Screen
Screen Saver “
----- “r? Configuration

Modified [v]

2.7.2 Download Design to PEP

After validating the function of design with the simulation, you may download the design to
PEP. Before download design to PEP, you must first switch PEP device into system menu

mode.
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Step 1: At PEP device side: Press the key on the PEP device for at least 6 seconds to

enter the System Menu as shown below. Select [Load User Menu] and press the

OK key. The screen will show “Load User Menu?” and “|gGrRRO) St @it .

OK key. The screen will show

If you want to load user menus, press the

“Waiting for connection...” and “|gEsNORWAGING . This means the PEP device
is waiting for PEP Designer to transfer the design.

Step 2: At PC side: Select [Tool]>[Download Menu Data] from the menu bar with the
mouse as shown below.

i PEPD | o S
7] -
File Edit Project]l Tools | Options Help

B = = | ..1 Download Menu Data .. B sy R =R
Project Download Firmware ..

-~ Device Info. 88 Character Map Tool |
E-Bf

EIE The lights Control
B The room light
2-EF Brightness Adjustment
R Adjust the brightness
£ Turn on the light
2B The bathroom light
L.# Turn on the light
=-B The air-con Control
El%‘_ Temperature Settings
i.123 Set the temperature
2-EF Speed Settings
. L= setthe speed

Turn on the air-con
-} Alarms
..... Startup Screen
--E& Screen Sawver
..... 41 Configuration

Modified [v]
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The “Download Menu” window will pop up as shown below.

S =[=] = ]

File Edit Project Tools Options Help

DE-H] ' B rRR E5% S Q@EHY XKL s FFegH |
—Project
- & Device Info
=-Ef Main Men

KA Cownload Menu PRI
Baud Rate: IS&UU vI

Com Port: |COM4

File Name:

IC:\Program Files\Fatek\Pepd\Pepd.mda _I

Screen Saver
----- i Configuration

Modified | [0 i

Step 3:

_s# | putton to download design to PEP device as shown below.

A FerD =]=] = ]

File Edit Project Tools Options Help

DS -E] s ek BE5A%ASAE Y XkiLs + EPSHH |

—Project

KA Cownload Menu PRI

= EF Main Men

Bt Baud Rate: |9500 'I
Com Port: [COM4 ~|
=-E The File Name:

IC:\F’rog ram Files\Fatek\Pepd\FPepd.mda

WWrite packets 23

Modified | [o é

Page 24 /81

After setting the Baud Rate and Port and the compiled design filename, press the



%€ When there is a communication connection error, the “Communication Error!”
message box as shown below will pop up.

ER& reFD =[E=] & |

File Edit Project Tools Options Help

B~ prak BEE9%NSBEY Xk + S5 |

—Project

- & Device Infoy I
. Download M (=]=] = |
=-Ef Main Menu Bl Doauad Meny

=-E The ligh Eaut[n Communication Error o oS e S|

o The

I = B ] Cort i t

) -_:_- --|— Cr\P Communication Time Out Error _I

=Bl The airy Froceed to retry ?

S|
Gel ation Mumber. 4
\

i Startup Screen
i Screen Saver
-5 Configuration

Modified | [o

% When design is completely downloaded to PEP, the message “Download finished!”

will display in the status bar of the Download Menu window as shown below.
(g perD [=[=] = ]

File Edit Project Tools Options Help

s -] ek B ASGEH Yy X kL + FPFSEH |

—Project

- & Device Infog”
et EA Download Menu [E=REGE

=B Main Menu

E'E_ The lighl | 5.4 Rate: [s600 -]

Com Port: [cOM4 ~|

File Name:

EI = 'I'h ] IC:\F’rogram Files\Fatek\Pepd\Pepd.mda
e air-

I Download finished ! I |

Startup Screen
Screen Saver
----- “rd Configuration

Modified | [0

N

Step 4:  Lastly, press any key on PEP to return to the System Menu screen. Select [Run User

Menu] and press the key to let PEP back to normal work.
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3. Operations in Detall

3.1 File

Select File with the mouse from the menu bar or press [Alt] + [F] keys on the keyboard. The
File pull-down menu as shown below will appear.

Ed pePD = [ =) [
R —

File Edit Project Toold Options Help

B mNew .. Cirl+M

= Open .. ctrl+0O [

B Exit Alt+F4

3.1.1 Create a File (New)

Select [File]>[New] with the mouse from the pull-down menu, or click the B from the

toolbar, or press the [Ctrl] + [N] keys on the keyboard to open a new file. Items in the file as
shown in the red frame below, including Main menu, Alarms, Startup Screen, Screen Saver,
and Configuration, will be generated automatically. Now, you can start planning the desired
screens and settings.
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EA pePD = TR s

File Edit Project Tools Options Help

-t BTk R IR SAEYX KLY+ FFPugH |

—Project
Bl M Device Info.

Startup Screen
4 Screen Saver
L-wr¢ Configuration

Modified | A

3.1.2 Open a File (Open)

Select [File]=>[Open] with the mouse from the menu bar or press the [Ctrl] + [O] keys on the
keyboard to open an existing file.

e =)

Pl (I I |, FEF Designer-sample LI - = ER

= = S A  <Eil F
- Efsample.pep
RIFRIITE '

0

TC-WANG
Ay
oA
.
o
i

wEeE: | | EEEe
| #setE8IT):  [PEP files (* pepy =] I B |

Description: -

% The file extension of project file of PEP Designer is .pep.
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u
You may also click the pull-down menu next to the E’ icon to open a file that has been

edited previously.

i Ef PEPD - C\Users\admin\Desktop\PEP Designer\sample.pep L e e S
File _Edit _Project Tools _Optigne Helo
S]] 4+ T 2R |E G*% S @E Y XL+ + g |

—Projfd 5 Open ... Ctrl+O

1 ChUsershadminyDesktophPEP Designerysample.pep

2 ChUsershadminyDesktop\PEP Designen g3 #Is208.pep

3 CAUsersyadminyDesktop\PEP Designen, 23 F|s2AE(E).pep
4 ChUserssadminyDesktophPEFP Designen i 2= pep

5 ChUsersyadminyDesktop\PEP Designen 23 F].pep

6 ChUsershadminyDesktop \PEP DesignenZE#SE . pep

7 ChUsershadminyDesktophPEP Designen == E=5.pep

Y

3.1.3 Save a file (Save)

After editing an existing file, if you want to save the changes, select [File]>[Save] from the

menu bar, or click the E on the toolbar, or press the [Ctrl] + [S] keys on the keyboard to

save the file in the same filename and location.

i Ef PEPD - C\Usershadmin\Desktop\PEP Designer\sample.pep L e e
File Edit Project Tools Options Help

DS -E] s el RS G %N SBEY XKL+ P HH |

—Project

o~ & Device Info.
B
{ @m-Ef The lights Control

{ @m-E The air-con Control

Startup Screen
Screen Saver
LoE) Configuration

N

| Modified | o [

& Modified: This means the file has been modified but not yet saved.
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3.1.4 Save as Another File (Save As)

After editing a new file, you can only save it as another file by selecting [File]>[Save As]
from the menu bar to save the new file in the designated folder. If you want to change the

name of an existing file, you can select [File]>[Save As] from the menu bar to save the file

using a new file name (generated by the system).

i PEPD - C\Users\admin\DesktopiPEP Designerisample.pep |.E|Mr

File

| SE=E [

—Froj fETFE ) I . PEP Designer-sample LI - ﬁf{ Ed~
o I == ETL=F! =R Fuh

L i Bor

: ? iR BEA:ample pep
Cd ;
!

e
b
Wil
TC-PANG

i
=his

[ =Y
e
s

| m=amo: | - | [=as_|

TETEEEAU(T): |PEP files (* pep) | HiH |

Modified | [0

N

% Attention! If you want to save an existing file in another file, you must give this file a
new name that does not appear in the folder where it is saved. Otherwise, this file
will replace the file having the same file name in the folder as shown below.

PEPD - C\Users\admintDesktop\PEP Designer\sample.pep == = |
File Edit Project Tools Options Help

DS ~d| i R ERE (B 5% Sy Xkt + TSR |

—Project
s & Dewice Inf
L= Ml[ — S
BT The lig

=)

=-E The air]
O Alarms
= Startup Sc

Screen S5a
4 Configurat

T

=

File Existed,Over Write ?

Modified | [o
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3.1.5 Export a File (Export)

As some menus can be shared with other projects, you can use the Export function to export a
menu and its submenus to another file for future use. When you need to use them, you can use

the Import function to import the selected menu file. Follow the steps below to export a menu
and its submenus.

Step 1:  Select the menu with the mouse as shown below.

i PEPD - Ch\Usershadmin\Desktop\PEP Designerisample. pep [E=n e s
File Edit Project Tools Options Help
| DS -] ¢ Er R REE OGN SBE Yy Xk, + TPy
[ Project

-~ § Device Info.

Alarms
Startup Screen
i Screen Saver
L%pd Configuration

E lo

Step 2:  Select [File]>[Export] from the menu bar. The following window will pop up.
Select the folder where the menu is exported and input the file name, and press the

HEE | button to export the selected menu.

Sz ===

{=ETF L I I | PEP Designer-sample ;I e =k ER-

= = iZ22 B e Fin

4

AT A (2T 5 T Critrol b pon) ~1 e |
TFRERASZY(T): |PEF Menu files (* bpm) ~1 HTiH |

Description:

% The extension of the menus exported is .bpm.
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3.1.6 Import

When the present project needs some menus that have been created, we can search them from

the folder where the exported menus are stored. If there are suitable menus, use the Import

function to import them in order to save time from re-creating them. Follow the steps below

to import the menus.

Step 1:  Select the destination of import with the mouse. As shown below, the destination is
Main menu.
i E# PEPD - ChUsers\adminyDesktoph123 pep o B |
File Edit Project Tools Options Help
B = R = TPy B S

Project

d Startup Screen
i -Ed Screen Sawver
=8 Configuration

Step 2:

Select [File]>[Import] from the menu bar. The following window will pop up.

Select the required file and press the Open button to import the selected file.

Ed sssi=i=

s = O | . PEP Designer-sarmnpls j = il FEEE o d
s = =k e e
i b =
R T L] The lights Control bpm
HEE
¢ 1)
- WANG
L™
=l
[ ™
e
f G i
AT A T (1) |The Lights Control bpm, 1 RaErEStE 00 |
TEFTEEAY (T |PEP Menu files {* bpm) -1 ]
Description: .
— - »

% The extension of the files imported must be
descriptions to an export file

.bmp. Like the project file, users can add
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Step 3:  After importing the menu, the menu and its submenus will be displayed under the
destination (Main menu) as shown below.

[ B PEPD - CAUsers\admin\Desktoph123.pep (=RECIN X
File Edit Project Tools Options Help
A= - & B B e W B B T ErwE B

Project
i Device Info.

---E
-Ef The room Ilght
E Brightness Adjustment
= Adjust the brightness
# Turn on the light
EI E The bathroom light
. #5 Turn on the light
----- Alarms
Startup Screen
Screen Saver
----- ¢4 Configuration

3.2 Load and Edit Designs

PEP Designer shows screen planning in terms of tree structure. Each “menu”, “value”,
“action” and “list” is displayed hierarchically for users to clearly identify what they are in the
operations in order to check if the sorting and structure of the entire planning are consistent
with the requirements.

3.2.1 Menu

The main function of menu is to categorize “values",

" o<

actions” and “lists” into various levels
according to their applications and functions. This way, users can operate them instinctively.
The following example describes how the menu function works in terms of temperature,
switch, and adjustment.

Step 1: Select the Main menu on the screen with the mouse. Then select [Edit]>[Add
Menu] from the menu bar, or right-click the item to call out the pop-up menu and
select [Add Menu].

Step 2:  When the [Add Menu] window pops up, enter Temperature settings in the String

field and press the button to add the Temperature settings menu to the

Main menu as shown below.
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[ EA Add Menu ==

String: Temperature Settings

Description: Used to set or adjust the temperature, -

" OK | X cancel |

¢ String: The title of the added Menu.
Description: Hint text for the added Menu.

Step 3:  Repeat Steps 1 and 2 to add the “Switch Control” and “Size Adjustment” menu as
shown below.

Ed PEFD =RECIN X

File Edit Project Tools Options Help

BeE-HE E a ) T Ew BB

Project

----- E Temperature Settings
----- B Switch Control

----- Bl size adjustment
ANATTTT

-2& Startup Screen

-[2d Screen Saver

.wpd Configuration

Modified [+

-

% Please note that each level can place 10 menus or functions at most. Also, a menu can
only mix with other menus or actions at same level. That is, if you want to add a
menu/action item at certain level, there should not already have the value or list
items in that level. The menu item can have an attached lower level while value,
action and list item is not (button level).

3.2.2 Value

The value item allows users to read or set the PLC register contents from PEP. Users can use
this function when designing actions involving value setup. We can use the above example to
illustrate this: Temperature Settings.
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Step 1:  Select Temperature Settings on the screen with the mouse. Then select [Edit]>[Add
Value] from the menu bar or right-click the item to call out the pop-up menu and
select [Add Value].

Step 2:  When the [Edit Value] window pops up, enter the requirements and settings to

respective fields

and press the button to add a value item to the Main

menu as shown below. Descriptions of the Edit Value window are as follows:

[ EA Edit value (i B |
String: |Set Value's example
Description:
Reference Mo.: |Rg v Signed
Max. |3275? Decimal Point: m
Min- [-32768 Unit: cr
I~ Read Only
IW' X cancel |
P String: Title of the value item
Description: Hint of the value item.

Reference Number:
Signed:

Maximum:
Minimum:
Decimal Point:
Read-only:
uUnit:

The reference number corresponding to the PLC register, either
16-bit (R, D) or 32-bit (DR, DD).

When the item is checked, values of the register is signed number
otherwise is non-signed number.

The upper limit of the value. No limit when blank.

The lower limit of the value. No limit when blank.

The decimal location of the displayed value.

Value can be displayed but cannot be modified or set.

Unit of the value, here is °C.

After completing these steps, the value item will be added to the Temperature settings menu

as shown below.
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Project

'ﬂ PEPD | o e S
File Edit Project Tools Options Help
DE-H | B % i = v X * e B S

-~ § Device Info.

RSl Temperature Settings|

--123 Set Value's example

Sta

Modified

Screen Saver
-4 Configuration

SWITCh Control

rtup Screen

3.2.3

Action

There are eight types of actions in PEP Designer. The “Switch Control” in this example is

only one
Value or

of them. Users can use the Action function to design Toggle State, ON/OFF, Set
Step Up/Down actions. In this section, in addition to the Switch Control in the

example, we will further introduce to you other action options in this function.

Step 1:

Step 2:

Select Switch Control on the screen. Then select [Edit]>[Add Action] from the
menu bar, or right-click the item to call out the pop-up menu and select [Add
Action].

After selecting the required action from the pull-down menu of the Action Type

item in the [Add Action] window, press the button to add the selected

action to the Switch Control menu. The example is as follows.
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| EA Add Action [E=R R

Action Type: | Toggle State |
oqggie e

String (ON): Set On
Set Off

String (OFF) :  [Momentary On
Momentary Off
Set Value 5
Step Up

Description:  |>rep Down

o4 »

Reference Mo.: I

W OK I x Cancell

& Options for actions include: Toggle State, Set On, Set Off, Momentary On,
Momentary Off, Set Value, Step Up, and Step Down as described below.

1. Toggle State: On and Off alternate actions

Add Action [E=R R
Action Type: E
string (ON): |

String (OFF) : |

Description:

4 L

Reference Mo.: I

« 0K I x Cancell

P String On:  When the corresponding status is On, the text to be displayed on
the menu.

String Off:  When the corresponding status is Off, the text to be displayed on
the menu.

Description: Hint of action.
Reference No.: Contact number corresponding to the PLC.
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2. Set On: Set corresponding status to On.

4

Reference MNo.: I

' 0K I x Cancell

Add Action o 0
Action Type: B
String = I
Description:

X String :  Title of the corresponding action.
Description: Hint of this action.

Reference No.: Contact number corresponding to the PLC.

3. Set to Off: Set corresponding status to Off.

4

Reference No.: I

" 0K I X Cancell

Add Actien o [0
Action Type: E
String : I
Description:

X String: Title of the corresponding action.
Description: Hint of this action.

Reference No.: Contactr number corresponding to the PLC.
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4. Mometary On: Set corresponding status to On when pressing and Off when releasing.

Add Action = | D
Action Type: Momentary On -
String : |
Description:

o L

Reference Mo.: I

W OK I x Cancell

X String:  Title of the corresponding action.
Description: Hint of this action.
Reference No.: Contact number corresponding to the PLC.

5. Mometary Off : Set corresponding status to Off when pressing and On when releasing.

Add Action [E= e
Action Type: Momentary Off =
String : I
Description:

4 3

Reference MNo.: I

o OK I x Cancell

X String:  Title of the corresponding action
Description: Hint of this action.
Reference No.: Contact number corresponding to the PLC.
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6. Set Value: When pressing the key, the value in the corresponding register increases by

one value.
[ EA 2dd Action [E=EE)

Action Type: =

String : |

Description:
o4 }
Reference MNo.: S0
" Signed * Unsigned
Set Value:
" OK | X cancel |
RS String: Title of the corresponding action.

Description: Hint of this action.
Reference Number: The reference number corresponding to the PLC register, either
16-bit (R, D) or 32-bit (DR, DD).
Set Value: Value to be set when press this action
Signed: When the item is checked, values of the register are signed ;
otherwise unsigned.

7. Step Up: When pressing the key, the value in the corresponding register increases by one

value.
| B& Add action [E=EE)
Action Type: =
String : |
Description:
o *
Reference Mo.: S
" Signed * Unsigned
Max. @
Min. : Step Size. :
" OK | X cancel |
X String: Title of the corresponding action.

Description: Hint of this action.
Reference Number: The reference number corresponding to the PLC register, either
16-bit (R, D) or 32-bit (DR, DD).
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Maximum:
Minimum:
Signed:

Step Size:

Maximum value. No limit when blank.

Minimum value. No limit when blank.

When the item is checked, values from the register are unsigned;
otherwise signed.

The number of values increases every time this button is pressed.

8. Step Down: When pressing the key, the value in the corresponding register decreases by

one value.
[ E@ Add Action o 5 P |

Action Type: =

String : |
Description:
Reference No.: Sign
" Signed + Unsigned
Ma.
Min. : Step Size. :
" 0K | x Cancel|
S String: Title of the corresponding action.
Description: Hint of this action.

Reference Number:
Maximum:
Minimum:

Signed:

Step Size:

The reference number corresponding to the PLC register, either
16-bit (R, D) or 32-bit (DR, DD).

Maximum value. No limit when blank.

Minimum value. No limit when blank.

When the item is checked, values from the register are either
unsigned or signed.

The number of values decreases every time this button is pressed.
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In this example, the action type of the Switch Control is alternate, meaning pressing the

button for the first time is On and second time Off as shown below.
S BN ET s
File Edit Project Tools Options Help

D -d| P T RERR EEGRSBEY XKL+ TP 8 |

—Project

& Device Info.
=B Main Menu
EE Temperature Settings

=]
il +#F Set Action's example
TSI

& Alarms

Startup Screen

Screen Sawver
Configuration

=

hModified | [ [1

N

3.2.4 List

The function of list is to represent the register content with a string or set the register

value(0-63) by chosen a string. Based on the above example, we can illustrate this function
with the Size Adjustment function.

Step 1:  Select Size Adjustment on the screen. Then select [Edit]>[Add List] from the menu
bar, or right-click the item to call out the pop-up menu and select [Add List].

Step 2:  Input the requirements and settings in the [Add List] window and press the
button to add the list. The example is as follows.

Add List -
String: Set List's example
Description: 1
4 [ 3
Reference Mo.: IRl [~ Read Only
Count: |3 'l
List String: Value |String |
0 Small
1 Middle
2 Big
’W‘ X cancel |
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¢ String:
Description:
Reference Number:
Count:

Read-only:

List String:

Title of the list.

Hint of the list.

The reference number corresponding to the PLC register.

The total number of strings (2-64) to which the register corresponds.
Value can be displayed but cannot be modified or set.
Corresponding String refers to the description of the corresponding
item, and Value refers to the value of the corresponding item.

After completing the list, it will be added to the Adjustment as shown below.

PEPFD

E@g

File Edit Project Tools Options Help

D - f e R R RSN SREY XKL T TR |

[ Project

i Device Info.
=-E Main Menu
=-Ef Temperature Settings

...i= Set List's example

----- O Alarms
Startup Screen
Screen Saver
----- ¢l Configuration

Modified | 1 [2

XY
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3.2.5 Find

In a complex and complicated project, users often need to spend much time finding a register
or string to modify it. With the [Find] function, users simply input the keyword and PEP
Designer will automatically search all registers or strings containing the “keyword” and
display them in a list. The information also includes the location of the matched registers or
strings; i.e. in which menu or function they are located. Therefore, it is very convenient. The

follow shows you how to use the Find function.

Step 1:

Select [Edit]=2>[Find] with the mouse from the menu bar, or press the [Ctrl] + [F]

keys from the keyboard to call out the function as shown below.

i EA PEPD - Ch\Usershadmin\Desktop\PEP Designerisample. pep

E@g

File | Edit [Project Tools

Options Help

[az

Ul B B RN S Xk Y+ E P |

EL Add Menu .
123 Ac

==, Add Action .

5, Add List ...

L .

D Screer

" Edi

>

el

-

-

g

L]

[ [0 [ A

The Find window will pop up.
i Ef PEPD - C\Users\adminDesktop\PEP Designer\sample pep |.E|E|il1

File Edit Project

Tools

Options Help

DS~ B R ES% @Gy XL e + TP 5 E |

—Project

-+ § Device Info.
=B Main Menu
Alarms

Startup Screen
H g Screen Saver
.%¢l Configuration

-
HEA Find ..

= | B |

Scope
" Reference Mumber
" String

Reference Mo. : ||

String = I

JDKI

X cancel |
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X Scope: Two options: Reference No. and String for users to choose.
Reference No.: Search contacts or registers in the project, e.g. RO, X1, Y2.
String: Search strings in the project, e.g. Temperature, Switch.

Step 2:  After selecting the Scope and inputting the search string in the String field, press

as shown below.

Find [E=SNIER
—Scope
" Reference Mumber
% String
String : IIightI

W OK I x Cancell

The matched items, registers or strings containing the keyword will be displayed in the list
below the window, including their locations as shown below.

PEPD - C\Users\admin',DesktopPEP Designerisample.pep L o ]
File Edit Project Tools Options Help

DE -] s TR (ES% SQEHY XKL + NP wg 5 |

—Project

- & Device Info.

= Startup Screen
Screen Sawver
%8 Configuration

0  The lights Control

0.0  The room light

0.0.1 Turn on the light

0.1 The bathroom light
0.1.0 Turn on the light
Total 5 search result(s) found

| 1o |

¢ Right-click list and two options will pop up: Clear Search Results and Close Window.
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Step 3:  Select a matched item in the list with the mouse to show the details of the item’s

location as shown below.

[ EA PEPD - Ch\Users\admin\Desktop\PEP Designerisample.pep o |
File Edit Project Tools Options Help
DS -]t e EG% SBEHY XKL + EFgH |
—Project

& Device Info.
B- E Main Menu
=-Ef The lights Control
' EI E The room Ilght

-2 Startup Screen
----- Screen Sawver
----- “£i Configuration

0 The ||ghts Control
o

| 0 0.1 Turn on thE light

0.1.0

Turr1 on the Ilght
Total 5 search result{s) found

| | 0 I 4

% Double-click the item and the edit window of the selected item will pop up. Users can
directly edit or modify the contents as shown below.

----- “£i Configuration

=-Ef The lights C
=-E The roo

- E The bath
=-Ef The air-con
i Alarms

Startup Screen
A4 Screen Saver

a

The lights Control

on i g

0.1,

Total 5 search result{s) fou

TN

0 Turn on ﬂ"IE Ilght

[ 0

String (OFF) :

Description:

Reference Mo.:

[ Ef PEPD - Ch\Users\admin\Desktop\PEP Designenisample pep l&lﬂlil
File Edit Project | ER tdit Action — | = g
R - 4
Project—————— Action Type: IToggIe State j
= i Device Info.
=-Ef Main Menu String (ON):

ITurn off the light

Y0

W 0K I x Cancell

h

3.3

Project

Select [Project] from the menu bar. The [Project Menu] will pop up. Options in the Project
Menu include [Compile Menu], [Off-line Simulation], and [On-line Simulation] as shown
below.
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E# PEPD - C\Users\admin\\Desktop\PEP Designerisample.pep =FECTY
File Edit}l Project Tools Options Help|

|B§""Compile... Fa ‘ﬁ*ﬁ.:ﬁ,ﬁféw’)(ﬁ(&**gg.taan

| Bl Off-line Simulation Fo
ct |
Bl On-line Simulation  F10

—Proje

Alarms
-E&d Startup Screen

- Screen Saver
54 Configuration

Modified | o |

3.3.1 Compile Menu

After editing a menu, compile the menu by selecting [Project]>[Compile Menu] from the

menu bar, or clicking the .! icon on the toolbar, or pressing the function key [F8] to

directly launch to the compile menu function. With the compilation function, the designed

menus are converted into task codes executable by PEP and the statistics of the used code size

are provided.

i B8 PEPD - C\Users\admin\Desktop\PEP Designerysample.pep == =& |
File Edit Project Tools Options Help

D -@ TR B 45%SOBEH Y XKL+ EFega |
—Project
=B Main
LB Alarm
- Start
-Ed Screq
Lol Config

EA Compile Result | B

| Code Size Usage: 3892 Bytes used [/ 131072 Bytes available

| Qutput file : C:\Users\admin\Desktop\PEF Designer\sample.mda

[ 2%

Modified | o [ L

e

& The information in the window includes “Code Size Usage” and “Output File”.
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3.3.2 Off-Line Simulation

After creating the user menus, you may want to validate if they are consistent with the
planning. You can use the Off-Line Simulation. Select [Project]>[Off-Line Simulation] with

the mouse from the menu bar, or click on the E icon on the toolbar, or press the function

key [F9] to launch the function. After verifying the compilation, press the button to

call out the simulation screen as shown below.

Project

EA PEPD - C\Users\admin\Desktop\PEP Designerisample pep = 29
B =gh g = e T Ewe e

o~ Device Info.

7-Bf Main Menu Simulation Screen

P Alarms
Startup Screen
i i Screen Saver
..%rl Configuration

Modified o

3.3.3 On-Line Simulation

Similar to the [off-line simulation] which runs the simulation on the PC, the only difference
between the offline and online simulation is that the former does not connect to the PLC,

while the latter connects to the PLC via the communication port on the PC running the

simulation. Select [Project]>[On-Line Simulation] with the mouse from the menu bar, or

click on the E icon on the toolbar, or press the function key [F10] to launch the function.

After verifying the compilation, press the button. The Setup Port Parameter

window as shown below will pop up.
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| n

L-5pd Configuratia

Start

Exit

-
PEPD - C\Users\admin\Desktop\PEP Designerisample. pep
File Edit Project Tools Options Help
O ~H B i e Tt =
Project
- § Device Info =
[ Setup Port Parameter = e e
B Main Menu E4 P
@ Alarms Baud Rate: |2lZil -
Startup Scr
i Screen Savi Com Port: |COM4 ZI

Modified [+]
X Baud Rate: The transfer baud rate between the PC running the simulation and
the PLC.
Com Port: The PORT on the PC connecting to the PLC

After setting up the “Baud Rate” and “Com Port”, press the _ st | button. The On-line

Simulation screen like that of the [Off-line Simulation] will pop up as shown below.

- ~
PEPD - C\Users\adminDesktop\PEP Designer\sample.pep = = |
File Edit Project Tools Options Help
OE~HE B "2 e e TEw RS
Project
#+ § Device Info. e : ——
i Simulation Screen

Ef Main Menu

O Alarms
Startup Screen
Screen Saver
L-5¢d Configuration

Maodified [

3.4 Tools

There are three tools in the [Tools] function on the menu bar: [Download Menu Data],
[Download Firmware], and [Character Map Tool] as described below.
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[ BA PEPD - C\Users\adumin\Deskiog\PED Decignensample pep [Py ===
File Edit Projecf  Tools Options Help
| @ e - @ |||/ DownloadMernubata . L@ v X Tl ¢ + F w5 o |
E— ¥ Download Firmware .

roject
38 Character Map Tool

- & Device Info.

B

-} Alarms

= Startup Screen
- Screen Saver

L%¢¢ Configuration

Modified | [o

3.4.1 Download Menu

After validating the menu design with the simulation, you may now download the design to
PEP. Before downloading design to PEP, you must switch PEP device to system menu mode.
Then, select [Tools]->[Download Menu Data] from the function menu as shown below.

rﬂ PEPD - Ch\Usershadmin\Desktop\PEP Designer\sample.pep u_lg':' (=5}
File Edit Project _Iggle Qofigne H
- |l @ =« < > + T |
—Project—————————————————| ||
-~ & Device Info. 38 Character Map Tool I

&

-} Alarms

-&& Startup Screen
-Ed Screen Saver
Lspd Configuration

Modified | [o

The Download Menu windows as shown below will pop up.
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i E# PEPD - Ch\Users\admin\Desktop\PEP Designer\sample.pep [=[=] =R ]
File Edit Project Tools Options Help

D -t ek (B S %S MEY Xkt + H Py 5 |

—Project

- & Device Info,

2B Main Menu EA Cownload Menu [E=R TR e
Baud Rate: IQGUU vl

Com Fort: [COM4 |
- «Ed Configuratie

File Name:

IC:\Users\admin\,Desktop\PEP Designer\sample.mda _I

Modified | [0 A

After setup the “Baud Rate” and “Com Port” settings and select the file name, press the

__s@t_ | pytton to download design to PEP for real operations.

3.4.2 Download Firmware

When it is necessary to update the PEP firmware, select [Tools]->[Download Firmware] from
the menu bar as shown below.

i E# PEPD - C\Users\admin\Desktop PEP Designer\sample. pep =R s
File Edit Project ] Tools | Options Help

e in o= ICEST IS S LLILN

| |
#~ § Device Info. il Sl
=]
o aslarms
Startup Screen
: Screen Sawver
%] Configuration

Modified | o

The Download Firmware window will pop up.
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BH PEPD - C\Users\admin\Desktop\PEP Designer\sample.pep l=[=1] = |
File Edit Project Tools Options Help

B - i ek B3NS @6y XML + X m |

—Project
- § Device Info.r

é;— M:::ﬂens EA Cownload Firmware [E=EEE

d» Alarms

: 51010
| Startup Scr Baud Rate: |Elaily -
] Screen Saw Com Port: |COM4 |
%l Configurati
File Name:

Modified | [or [ )

W

% File name: Select the OS file to be updated.
% Contact your dealer for details concerning firmware update.

3.4.3 Character Map

When it is necessary to display special characters or symbols on PEP, input these characters
and symbols with the [Character Map Tool] as shown below.

Step 1:  Select [Tools]>[Character Map] with the mouse from the menu bar as shown

below.
i E# PEPD - C\Users\3 mfsk‘top\PEP Designer\sample.pep =R s
File Edit Project | Tools | Options Help
I B | H %= Download Menu Data ... F. v X B - 2Ty B 2 ||
o l~ o -] Ciraa oo
[ Project -
o e o 1 EEEE T |
2Rl Main Menu
Alarms

Startup Screen
Screen Saver
-¢d Configuration

Modified | o )

The Character Map Program will be run and the following screen will be shown.

Page 51/81



[ 8 Character Map [E=RIE

Font Name : |T=noma =]

Subset : iUser Preference Characters :_]

G |

P Font Name: The name of font currently used by the PEP Designer (modifiable
from [Option]=>[Preference Output Font] on the menu bar).
Subset: If this combo list is selected to “User Preference Characters”, then
all the collected characters or symbols commonly used by users
will be shown. User can directly jump to specific character subsets
by control this combo list.

Step 2:  Select a font class from the pull-down menu or search the required character or
symbol. Select the required character or symbol with the mouse and it will be
displayed on the blank field as shown below.

3 Character Map [E=RIERESC
Font Name : |Tahoma =l

I Subset : iLetterhke Symbols ;‘ U+2105 I

% [% |C [CJe %5 € |9 Flg | & H |k | | =

FINg | bW Ne g P R %R ER

el FlZziE Qo3 KA |E|ele =

s 1F M 4l w2 3 |7 O0O0OO0OOO

o o o o o o o o =

OOk 3 % 1% %15 % |3 |Ve|¥56%)Y

LIV VI VIVIVI XX XL C DM E

1|d3 |3 v | [wilvii vl |ix | x |=d|=|] [c|d|m
OB @ Op (00000000000 o
e 0 I 0 S 0 0 sl il C
JECR TR PP PP PR B PR N SN P Y P PO P P ' U+2103
ey e e e .\i"_;.@ T [

Sl el Ol Ol = s 0 el e B

R B A N R e e

Dl 0 A ol 0 el 18 1 8 O G
O|0/0/0|O0|0|0/0|O0|0|g0|0|o|g|g|gd)| =]
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% Press the 9| putton to remove incorrectly chosen or unwanted characters or

symbols from the field.
% The “Character Map” is an independent application that will not affect the
operations or editing tasks of PEP Designer.

% Press the @ button to exit “Character Map”.

Step 3: Lastly, press the button to add the selected characters or symbols to “User

Preference Characters” as shown below.

[ 38 Character Map ok ) |

Font Name : ]75.-'..:-:‘.‘5 __]

I Subset: |User Preference Characters | I

DC_

U+2103

Clear

© 0 >

Step 4:  If you want to use a selected character or symbol, click it with the mouse to copy it.
Then move to the place where you want to use it, press the right mouse button and
select “Paste” from the pop-up menu to paste it. You may also press [Ctrl] + [V] to
paste the selected character or symbol.
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3.5 Options

There are two options in [Options]: [Language] and [Preference Output Font] as described
below.

i E# PEPD - C\Users\admin\Desktop PEP Designer\sample pep =R s
File Edit Project Tools | Options Help
| -& || ¢ By| ‘Language J I TEEY -2

Preference Output Font .

[ Project

- & Device Info.

-E& Startup Screen
.- [&d Screen Saver
-%¢d Configuration

Modified | [ )

3.5.1 Language

PEP Designer offers three language options: English, Traditional Chinese, and Simplified
Chinese. You can select any of them as shown below.

Step 1: Select [Options]—=>[Language] with the mouse from the menu bar as shown below.

i Ef PEPD - C:\Users\admin\Desk‘top\PEP Designer\sampl‘e pep Lo e B
File Edit Project Tools

IDBT"EIJ&HI_Enghsh Pag———

= Preference Output Font. Chinese (Traditional)
—Project

7 Device Info. Chinese (Simplified)
B

L. Alarms

& Startup Screen
-E& Screen Saver
o6 Configuration

Modified | [0 [ A
e ————————

% The above screen is displayed in English.
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Step 2:

Three language options will appear in the pop-up menu. You will not need to
re-start the PEP Designer after changing a language, and everything will be

displayed in the selected language.

i Ef PEPD - Ch\Usersh\admim\Desktop\PEP Designer\sample.pep

S| E | ]

B=F RE HF=E IE EER =B

D -] ¢ R R %GR

e :aqvxﬁnﬁ.vfﬁgﬁaﬁln

B

Modified | [0 [ A
& The above screen is displayed in Traditional Chinese.
[ B# PEPD - CUsers\admin\Desktop\PEP Designer\,S3 513285 pep E=RECIY
EB=RF £HE HE IEBE HI =
D -@] s B2 BE9%SsQHy Xkhs+HTFPega |
-kl FERHAIFEE
ol $HASIETE
Modified | o | %
o

% The above screen is displayed in Simplified Chinese.
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3.5.2 Preference Output Font

Select [Options]—> [Preference Output Font] with the mouse from the menu bar to select the

font of the characters, numbers and symbols displayed on the PEP as shown below.
i B PEFD - C\Userssadmin\DegsktophPED Designerisample pep Elﬂlg

File Edit Project Tools | Options [Help

by X BB v + E P RS

| Ds-8 | ¢ e
[ Freference oupuron |

[ Project
I ————————————————————

- § Device Info.

o Alarms
Startup Screen
Screen Saver
LoEd Configuration

Modified | o

The [Preference Output Font] window will pop up.

== 2= )

[ E# PEPD - Ch\Users\admin\Desktop\PEP Designer\sample.pep

File Edit Project Tools Options Help

DS - Rl k(B S%SBEY XN+ + P 5 |

+*

—Project

EH setup Output Font

Output Font: Im
o OK I X cancel |

Modified | [0

Select the preferred font from the pull-down menu in the Output Font field. There are many

choices.
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EA setup Output Font =RREE X

Output Font: |l j

Tall Paul
Tempus Sans ITC

Terminal

Times New Roman

Traditional Arabic

Trebuchet MS

Tunga =

After selecting the desired font, press the button. The font on the PEP will be

changed into the selected font. You can validate this with the [Off-line Simulation] function as
shown below.

::> [ Simulation Screen &y

e

¢ The font in the above screen is Tahoma.

::> [ Simulation Screen [ﬁ1

®

1) Ll
*[The lights Control]
The air-con Con .

e

¢ The font in the above screen is Arial Black.
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3.6 Configuration

In addition to the main menu, you can configure PEP from Configuration. Items in the
Configuration include “Alarm Source Register”, “Base Password Register”, “Working Space
Register”, "Screen Saver”, “Password Protection Type”, and “Set Level #1 as Top Level”.
When configuring “Alarm Source” and “Base Password”, you must assign a register first.
Procedures of configuration are described below.

Select Configuration on the screen with the mouse. Then select [Edit]>[Edit] from the menu
bar or right click the item and select [Edit] from the pop-up menu. You may also double click
Configuration as shown below.

i EA PEPD - ChUsershadmin\Desktop\PEP Designerisample. pep [ ETH 5

File | Edit IF’roject Tools Options Help

4 Cut

BB G SMEY XL s Tl |

o0

(=]

(8]
t

o BEiie

n
03

Ctrl+F

B H'>iw+*+

Modified | o 2

The Configuration Window as shown below will pop up.

i HEf PEPD - C\Users\adminDesktop\PEP Designer\sample pep [=[=] = )
File Edit Project Tools Options Help

DB -]t B FaR EIRSBEYy XL s TP a 5 |
—Project
~- & Device Info.

-
2B Main Menu EA Configuration ==

i Alarms )
Alarm Source register: I
Startup Scr Z |
: Screaniss Base Password register: I
S8 Configurati
Working Space register: I

Screen Saver

activate time: IlD Minute(s)
Effect: INone vl

Password Protection Type: IRead 8 Write vl

[~ Set Level #1 as Top Level

X cancel |

Modified
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The following shows an example of a Configuration. Features in the Configuration function

will be explained and described below. This is for your reference only.

Screen Saver

[ Ed cConfiguration =)
Alarm Source register: |R5 (R5)
Base Password register: |R1EI (R10~R11)
Working Space register: |R2EI (R20~R29)

activate time: |10 Minute(s)

Effect:

|Shnw Calendarj

Password Protection Type:

|Read & Write j

¥ Set Level 1 as Top Level

X cancel

& Alarm Source Register:

% Base Password Register:

% Working Space Register:

Set the address of the register storing conditions
activating alarms. It is a 16-bit register. As shown in
the example, the Alarm Source Register is RS, which
means RS5 is the register where the key wvalues
activating alarms are stored. When the values in RS
and the designed index are identical, the alarm
activates. When the field is blank, there is no alarm.

Set the address of the register storing the user and
supervisor passwords. Users can store a password with
one word or two words. The above example uses one
word for storing passwords. Register R10 stores the
Operator Password and R11 the supervisor password.
When the field is blank, there is no password
the of the
corresponding register is 0, it also means there is no

protection. However, when value
password. When the supervisor password is set, you
must enter the corresponding password before you can
access the system operating menu. When using two
words to store passwords, set register to DR, e.g.

DR10.

The number of working register allocated for PEP
application is 10 registers. In the above example, the
register is R20, this means registers R20-29 are the
Working Space Registers. After setting the Working
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% Screen Saver:

% Password Protection Type:

3% Set Level #1 as Top Level:

Space Registers, R20 will be used to store the path of
the last active screen before system powerdown, while
others are for future expansion. When the field is
blank, the last active screen is not retentive.

In the example, when the system idles for 10 minutes,
the Show Calendar screen saver will activate to protect
your screen. Please see 4.4 for details.

The policy has two options: “read/write protection”
and “write-only protection”. In read/write protection,
users will need to enter the correct password before
they can access the operating menu. In write-only
protection, users can access the operating menu, but
they need to enter the correct password in order to
operate the system or set values.

When this item is unchecked, if users press the

key for 2 seconds or longer when operating the PEP,
the system will immediately return to the menu on
Level 0, regardless of the level of the previous menu.
When this item is checked, the system will return to
Level 1. If users want to return to Level 0 with this
item checked, they must return to Level 1 first, and

press m for 2 seconds or longer to return to Level

0. This feature allows users to lock the menu at the top
level to Level 1 in order to provide multilingual
operations with this feature (by setting the language
menu at Level 0) and hide the menu function.
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4. Examples and PEP Screens

4.1 Alarms

PEP provides the alarm function. The alarm activates when the value in the “Alarm Source
Register” is identical to the “Index”. At the same time, the corresponding alarm message of
the Index will pop up on the screen. The index includes 01-64, which means users can set 64
alarms. When the Index is “0”, this means there is no alarm. The follow shows how to set an
alarm.

Step 1:  Select [File]>[New] with the mouse from the menu bar.
Step 2:  Select [Configuration] on the screen with the mouse. Then select [Edit]>[Edit]

from the menu bar, or right click the item and select [Edit] from the pop-up menu as
shown below.

Ed PEPD [ e | |
Filel Edit IF‘roject Tools Options Help
OeE = - ‘= B B

Praoject

-~ § Device Info.
B main Mmenu

- Alarms
Startup Screen

dEr

v E— |

rodified
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Step 3:  Assign a register in the “Alarm Source Register” item from the pop-up window as
shown below.

B cConfiguration =5

Alarm Source register: |R5| (R3)

Base Password register: I

Working Space reqgister: I

Screen Saver

activate time: |1E| Minute(s)

Effect: |N|:rn& j

Password Protection Type: |Rean:l & Write j

[ Set Level #1 as Top Level

i

% In the above example, register R5 is assigned to the Alarm Source Register, i.e. R5 is
the register where the key values activating the alarm are stored. When the values in
R5 are identical to the index that has associate setup, the alarm activates.

Step 4:  Select Alarm on the screen with the mouse. Then select [Edit]2>[Add Alarm] from
the menu bar, or right click the item to call out the pop-up menu and select [Add
Alarm] as shown below.

[ A rpan— oo ]
File | Edit IProject Tools Options Help

DE-E] ¢ ek BEE3% SQEHY XKL+ EFegH |
[ Project

-~ & Device Info.

[pEn]

e — e 1gan
~-Ed Screen
Losl Configy

L= B = B B |
W

1

AETTEE

o
1

..E‘Ii_if’,.j‘

mModified ||
—

|

TREH € 9 |73 X <

oo
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The Add Alarm window as shown below will pop up.

(EA rePD (=[=] = |
File Edit Project Tools Options Help
D -]t Tk B53%SOAHY XKL+ EFegH |
[ Project
& Devicef o
B o o| BB Add Alarm B
- F\Iarrrq
B2 Startyf | Index: jo1 d
-8 Scree : X
‘TE Config Linel: I
Reference Mo.: I
Line2: I
Reference Mo.: I
Line3: I
Reference Mo.: I
" OK I b4 Cancell
Modified | [0 [ |
RS Index : Users can set any number from 01-64. When the value in the

Line :

Reference No.:

Alarm Source Register in Configuration is identical with the
Alarm No., the alarm message of the corresponding Index will be
activated. Therefore, the maximum number of alarms is 64.

The PEP screen supports the display of three lines of text at the
same time. Therefore, Line 1 represents the text on Line 1, Line 2
on Line 2, and Line 3 on Line 3. Users can input the alarm
message here. One variable is allowed in each string, and users can

A

indicate its position with the symbol.

The PLC register number corresponds to the variable.

Step 5:  Set the “Index”, “Alarm Message”, and “Reference Number” in the [Add Alarm]
window as shown below.

Edit Alarm =5

Index:

Linel:

Reference Mo.: I

Line2: ICurrent is =~
Reference No.: IRE
Line3: |Mure than set ~ T

Reference No.: IR;;1

m =]

IHigh temperature !!

o DK I X Cancell

% In Line 2, the “~” symbol marks the display location of R6 content; and in Line 3,
the same symbol marks the display location of R7 content.
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After setting the alarm, press the button and the alarm will be added to Alarm as

shown below.

H PEPD | S | e S
File Edit Project Tools Options Help

BRI ) S B B
Project

- § Device Info.

Screen Sawver
Lo Configuration

Modified [v]

Step 6:  Check the alarm configuration with [On-line Simulation] as shown below.

[ Ed peeD = 2 ]
File Edit Project Tools Options Help
ERSR v " B 5
Project

- § Device Info.
B Main Menu
Alarms

& alarm - 01
-&& Startup Screen
-Ed Screen Sawver
..ol Configuration

Modified o

% You can also check the alarm configuration with [Off-line Simulation]. When an

alarm is set, the E icon will appear on the [Off-line Simulation] screen. Click the

icon to select the “Index” for running “Alarm Trigger” as shown below.
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Simulation Screen &J

Simulation Screen

EA Alarm Trigger

T o] B ]
[Alarm Test (Off-ine)] Alarm Number: |2 -

After selecting the desired “Index”, press the OK button and the corresponding “Alarm
Message” will be displayed on the simulation screen as shown below.

Simulation Screen @

4.2 Password Protection

PEP provides a password protection function. Users can set “Operator” and “supervisor”
passwords. When the “Operator Password” is set, users will need to enter the password
according to the settings in the Configuration before they are allowed to operate PEP. If the
“Supervisor Password” is set, users must enter the supervisor password before they can access
the System Functions. Both passwords can be stored in one word or two words (set register to
DR). When this field is blank, there is no password protection. When password protection is
enabled, but the value in the corresponding register is 0, no password is set. The following
shows how to set a one-word password.

Step 1:  Select [File]>[New] with the mouse from the menu bar.

Step 2:  Select Configuration on the screen with the mouse. Then select [Edit]>[Edit] from
the menu bar, or right click the item and select [Edit] from the pop-up menu.
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Step 3:

In the Configuration Setup window, assign a register in the “Base Password
Register” and select the “Password Protection Type” as shown below.

[ Ed peeD == & ]

File

Edit Project Tools Options Help

D@ -E s BTRRIBIR SEH XML+ + TP |

—Project

o~ & Device Info.
LBl Main Menu

-4 Alarms Alarm Source register: I

A4 Screen Sawve I Base Password register: IRlD (R10~R11) I
L9¢ Configuratio

B Configuration

s Startup Scre

Working Space register: I

Screen Sawver

activate time: IlD Minute(s)
Effect: INUFIE! vI

I Password Protection Type: Read & Write R

I Set Level #1 as Top Level

X cancel |

hModified A

e

% In the above example, register R10 is assigned to the “Base Password Register”,
which means that users can set the Operator Password in R10 and the supervisor
password in R11. The “Password Protection Type” is Read/Write Protection, which
means that users are requested to enter the correct password before they can access
the operating menu.

Step 4:

Step 5:

Select Main Menu on the screen with a mouse. Then select [Edit]2>[Add Menu]
from the menu bar, or right click the item and select [Add Menu] from the pop-up
menu. Now, create a menu called Set Password.

Select Set Password with the mouse. Then select [Edit]>[Add Value] from the
menu bar, or right click the item and select [Add Value] from the pop-up menu.
Now, set the Operator Password format as show below.

Add Value =
I String: Set User's Password I
Description: -

4 2
Reference Mo.: Ing [~ Signed

Max. |65535 Decimal Point: |D ,I
Min.
|D| Unit: |—

W OK I x CanceII

I Read Only
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% If you want to set the supervisor password, see the example below.

EA Add value ==
I String: |set Manager's Password I
Description: -

< »
Reference Mo.: |R11 [~ Signed

Max. |65535 Decimal Point: |0 -I
Min.
|D| Unit: |—

o 0K I x Cance-II

[~ Read Only

After setting the password values, press the button to add the value items under

the Set Password menu as shown below.

EA pepD =N s

File Edit Project Tools Options Help

D - 2R B3RS REH Y X k> + P H |

—Project

o~ & Device Info.

T
123 Set User's Password
i ~-123 Set Manager's Password
il
...EZ Startup Screen
-Ed Screen Saver
“-* Configuration

Modified | 1 [0

[

Page 67 /81



Step 6:  Check password functions with [On-line Simulation] as shown below.
[ Simulation Screen l-t_‘&-f Simulation Screen @‘ Simulation Screen e

After setting the passwords, shut down the simulation and re-start the [On-line Simulation].
Before entering the menu page, you will be requested to enter the password. You must enter
the correct password in order to access to the menu as shown below.

% The main difference between the operator password and supervisor password is that
the former allows users to access the menus but not the system functions when the
supervisor password protection is enabled. In this case, users need to use the
supervisor password to access the system functions.

4.3 Startup Screen

With PEP Designer, users can design and plan the startup screen of PEP. As there is space for
up to 16 startup screens, users can design a small live startupscreen. In the following example,
we will show you how it works with the registered trademark of FATEK Automation
Corporation.

Step 1:  Images used in the startup screen must be stored in the computer.

FATEL AUTOMATDN CORPDRSTION
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sk PEP Designer supports images in BMP, ICO, EMF and WMF formats.
% Image size: 128 x 64.

Step 2:  Select Startup Screen on the screen with the mouse. Then select [Edit]2>[Add
Screen] from the menu bar, or right click the item and select [Add Screen] from the
pop-up menu as shown below.

_— —

File | Edit rroject Tools Options Help

D -t 2R E SR SAEH Y XL + TP |
—Project

~~ & Device Info.
B Main Menu

A Startup Screen % Ccu Ctrl +2
= aveE Hy Copy Cirl+C
Configuration |z
- .
- .
&
= il
B Ac
122 a
'3 Ad
W, Ad
{5 Add List .
e ———
1
¢ Delet Del
T De Ctrl+Del
B De
hModified | [0.a ¢ |
————————————————— -
= Imp er
=" Exp er

The Add Screen window as shown below will pop up.

== =& |

EA FePD
File Edit

B -t T ek (B 5K S BHy XKL + Py s

—Project
B

Project Tools Options Help

.| B Add Screen

Image:

Inverse |
Clear |

o OK I x Cancell

Modified | [0 [ )

W

Load Image: Select an image from the computer for the startup screen

Inverse Image:
black)
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After loading the required image for the startup screen, press the button.

|:> 'ﬂ Add Screen (| |

Image:

FATEK

FECSHRESBERAT M
FATOE ANTAMATRE CORPT AT

" 0K | X cancel ‘
% Effect after image inverse
|:> [ EA ~dd Screen &Jw

e FATEK

FEREBEFERLD

FATOE ANTOMATE CORPIRAT|IN

W OK | X cancel ‘

The new startup screen Screen-0 is added to the Startup Screen menu as shown below.

il 5
Ed PePD =RREIE X
File Edit Project Tools Options Help
ER= v s B B
Project

- & Device Info.
-Ef Main Menu

1]
Startup Screen

Screen - 0

Modified o

-

% The “0” in Screen-0 represents the first startup screen. There is space for up to 16
startup screens.

Page 70/ 81



Step 3:  Select Startup Screen on the screen with the mouse. Then select [Edit]2>[Edit] from
the menu bar, or right click the item and select [Edit] from the pop-up menu as
shown below.

rn F’EED E=rpret g
FiIeIEdit IProjec’c Tools Options Help

R - T RER (M 4G% SBH Y XL+ + T Pag =
—Project

- § Device Info.
B M™ain Menu
T AT

Startup Screen 1+

o0

Screen Saver
L.o¢l Configuration

WP e

—1
EIRE gl P (Y 5 FiF T
]

I
i

tModified | [

The Startup Screen window as shown below will pop up.
S == = J]

File Edit Project Tools Options Help

B -] ¢ e R RIE SR SAEHY XL+ T T eaE |

[ Project

é Eﬂ:qn Startup Screen &
A Alar —End Condition

Startl

i Screi
L%E Confi
i " By Time or Keypad
—Action Time
Flip Time: Ilg x0.1 sec (5-100)

Cycle Count: IU 'I

W OK I x Cancell

Modified | o [

XY

e

% End Condition: In what conditions the startup screen will end.

By Time: The display of the startup screen is controlled by time.
By Keypad: The display of the startup screen is controlled by key: press any
key to end the startup screen.
By Time or Keypad The display of the startup screen is controlled by time or key at
the same time.
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€ Action Time: Set the time of startup screen activation.

Flip Time: The time of display of the startup screen page(5-100): 0.5 seconds
is the shortest, and 10 seconds is the longest.

Cycle Count: The repetition of startup screen, maximum 10 times.

The settings in the following example are: Screen Flip Time: 5 seconds, without repetition.

When the flip time is up or the user presses any key, the system will enter the main screen.

EA startup Screen

|

End Condition

" By Time

" By Keypad

I i+ By Time or Keypad I

Action Time

LT 50 x0.1 sec (5-100)

Cycle Count: _ -

W OK | X cancel ‘

After setting the conditions and actions, press the button. You can check the

settings with [Off-line Simulation] as shown below.

+-Bf Main Menu

Ed cerD = = |
File Edit Project Tools Options Help

DS -& v " RS
Project

~+ & Device Info. r

[t Uevice nio Simulation Screen lﬁ

- Alarms

I Startup Screen
P Screen - 0
2 Screen Saver
L.wpd Configuration

FATEK

FESEEFBRES O

FATCN AITARATII £0RMI AT| 9N

ESC

Modified [v]
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% If you want to design a small live startup screen, you can design more startup screens
(preferable with related images) and select the Flip Time and Cycle Count as shown
below.

'ﬂ PEPD =l i:h‘
File Edit Project Tools Options Help
DS~ v s B B

Project
- § Device Info.
B Main Menu

& Screen - 0
@& Screen -1
2 Screen -2

.[2& Screen - 3
.
-5 Configuration

Modified o

After setting the conditions and actions, check the settings with [Off-line Simulation] as

shown below.

Simulation Screen E& Simulation Screen et} Skmulation Screen L] Simulation Screen ot

% If you want to enter the Main menu after running the startup screen once, set Cycle
Count to 0. If you want to run several time, you can set the Cycle Count according to
the desired times. The maximum is 10 Cycle Counts.

4.4 Screen Saver

The screen saver function of PEP Designer delivers the following five effects: “None”,
“Dimout”, “Show Image”, “Show Calendar”, and “Blackout”. You can configure the idling

time of the system before activating the screen saver.
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Step 1: Select “Screen Saver” on the screen with the mouse. Then select [Edit]>[Edit]
from the menu bar, or right click the item and select [Edit] from the pop-up menu as

show below.
[ B PePD | = Tl =)
File | Edit [|Project Tools Options Help
| D - ¢ Rk EBEGUKNSEE Y Xk + S e
—Project
& Dewice Info.
-B Main Menu
- Alarms
C Ctrl+%
B C Ctri+C
5 Ps
e
a Pz Ctrl+
=
123
*
"
S,
[ ]
— —
[ﬂ
Tt
Modified | .
T A
o
=1
Er

The “Screen Saver” window as shown below will pop up.
(®@ pepo [=[=] = ]

File Edit Project Tools Options Help

P -d| ¢ il RRIE SN SBE XKL + P SEE |

—Project

i i
EA Screen saver | B |

Image:

Inverse |
Clear |

" 0K | x Cancell

Modified | [0 [ )

W

* Load Image: Load the image for the screen saver from the computer.
Inverse Image: Inverse image colors (black to white and white to black). Set the
background to black to prolong the screen life.
Clear: Clear the selected image.
% To extent the screen life, please choice the black color as picture background as
possible.
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Step 2:  Select “Configuration” on the screen with the mouse. Then select [Edit]>[Edit]
from the menu bar, or right click the item and select [Edit] from the pop-up menu as
shown below.

CE =l e

File EditIProject Tools OCptions Help

| D & G B R S% S@E Xt > Py m |
[ Project

- § Device Info.

“Ef main Menu

- Alarms

-E&d Startup Screen

o0

T-E
000

1
+

e

o
0

3 A
e
=
-
= .
[ |
Modified | & |
T ————— -e——m—————
- !
-
=1
B

The “Configuration” window as shown below will pop up.
(=g pepo l=1=] = J]

File Edit Project Tools Options Help
R R B 5% SBEY XKLy + F g &
—Project

- § Device Info.
-El Main Menu

- Alarms Alarm Source register: I

-2 Startup Scre
-Ed Screen Save Base Password register: I
Lol Conﬁguratid
Working Space register: I
Screen Saver
activate time: IlD Minute(s)
Effect: [Mone] vl

Dimout
Password Prote§ showe Image Write LI
Showr Calendar
[~ Set Level #1}{Black Out

HA Configuration

Y

Modified

-

RS Activate Time: Set the idling time before screen saver activation.
Effect: Select any of the following effects: None, Dimout, Image, Time,
or Blackout.

In the following example, when the system idles for one minute, the screen saver will activate.
The present time will be displayed on the screen, and the background will be Dimout as
shown below. You may need to enter the password, if enabled, in order to end the screen saver
and return to the normal screen.
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Configuration =5

Alarm Source register: |

Base Password reqgister: |

Waorking Space reqister: |

Screen Saver

activate time: |1 Minute(s)

Effect: Show Calendarjiieg

Password Protection Type: |Read B Write J

[~ Set Level #1 as Top Level

X cancel

After setting the time and effect, press the button. You can check the settings with

[Off-line Simulation] as shown below. When “None” is selectd, though no screen saver action
will be activated when the idling time is up, you still need to enter the password, if enabled, to
re-enter the normal screen.

-

PEPD (=[=] = |

Oe~-H ~ s H B
Project
- ¢ Device Info. . -
- . Simulation Screen lél

-Ef M™ain Menu
O alarms
-2& Startup Screen
-l Screen Saver
L-5pd Configuration

_|
i
i
7
8]
+]
5]
=
7

I
o
5]

Modified [v]
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4.5 BPEP

BPEP is a member of the PEP product family from Fatek. The following example shows the
BPEP simulation with the PEP Designer. The functions and screens of the panel features are
described below.

0.1
The roorm light
»[ The bathroom light ]

& Screen description: Black background and white font as shown below.

Up arrow symbol A i appears means there are more menus above.

Down arrow symbol Kl ir appears means there are more menus below.

Right arrow symbol IE: There is a hint for this item. Press the . key to view the hint.

Left arrow symbol EX: When you are viewing the hint. Press the . key to exit.

% Key description: There are six keys, including , , ., ., OK

as shown below.

: Press the key to return to the previous level. Press for 1.5 seconds to go to the

top level. Press for 6 seconds to go to the system function menu.

: When selecting functions, press the key to enter the selected function (or the

next level of the function). In function control, press the key to control the
selected function. In function setup, press the key to begin setup. After inputting
data, press the key to confirm data.
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: When selecting functions, press the key to move upward at the same level.

When inputting values, press the key to step up the value by “+1”. When there
are the “+” and “—*signs in the value item, press the key to switch to and from
“_"_” and C‘_.D’

: When selecting functions, press the key to move downwards at the same level.

When inputting values, press the key to step down the value by “-1”. When
there are the “+” and “—* signs in the value item, press the key to switch to and
from “+” and “—*“. When the selected digit of a value is 0, press the key
continuously to reset the entire value to zero.

: When selecting functions, if the right arrow symbol E appears on the right top

corner, this means there is a hint for this item. Press the key to view the hint.
When inputting values, press the key to move to the next digit on the right.

: When viewing the hint, press the key to return to the respective function menu.

When inputting values, press the key to move to the next digit on the left. When
Set Level #1 as Top Level is set in the Configuration, you must return to Level 1
first and press the key continuously to return to the top level.
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5. FAQ

Q1:

AnS.

Q2:

Ans.

Q3:

AnS.

Q4.

AnSs.

Q5:

AnS.

Q6:

AnS.

How many levels of menus can be created in a project? How many functions
can be set in each level?

Users can create up to 6 levels of menus in a project and set up to 10 menus or
functions at each level. However, menus can only be created independently or in
association with actions. Therefore, when you create a menu with actions, you
cannot create a menu with lists at the same level.

Why can’t | create a menu with actions and a menu with lists at the same
level?

This is because the nature of actions and menus differs from that of the value and
list. In the former, you can put different items in the same screen; in the latter, you
can only put one item in the screen. Therefore, they cannot exist at the same level.

Can new menus or functions be added behind a value, action or list item?
No menus or functions can be added behind a value, action or list item. You can
only add menus or functions behind a menu.

Under what circumstances will we use the Character Map tool?

When designing menus, you may need to use some special characters and symbols,
such as temperature units like °C and °F. In this case, you can use the Character
Map. First, search the required characters or symbols from the Character Map. After
selecting them with the mouse, you can paste them to the designated fields by
pressing the hotkeys [Ctrl] + [V].

How many alarms can be set? How do | activate these alarms?

The Index ranges from 01-64, which means you can set up to 64 alarms. When the
value in the Alarm Source Register in Configuration is identical to the Index, the
alarm activates. At the same time, the corresponding alarm message (same Index)
will be displayed on the screen.

When editing an alarm, the text of the alarm message is input in the String
field. Now, what does the Reference Number field mean?

In the Add Alarm window, both the String and Reference number can be edited. The
String is the text displayed in the alarm message. When an alarm event occurs, in
addition to the preset alarm text, users may need to know the cause, severity and
scope of the alarm event. In this case, you can enter the number of the
corresponding register in the Reference Number field. The position of display of the
current register value in the alarm message can be marked with the “*” symbol.
This way, when an alarm event occurs, the current register value will replace the

A

symbol in the alarm message.

Page 79/81



Q7

Ans.

Q8:

Ans.

Q9:

Ans.

Q10:

AnSs.

How many startup screens can be created in a project?
You can create up to 16 startup screens for a project.

In Configuration, what is the difference if checking and un-checking the “Set
Level # 1 as Top Level” option when operating the PEP?

If the option is unchecked, when you press the

key for 2 seconds or longer

while operating PEP, the system always returns to the menus at Level 0 (top),
regardless at what level you were at. If the option is checked, the system will return
only to Level 1. When the item is checked and you want to return to Level 0 when

operating PEP, you must first return to Level 1 and press the - key for 2

seconds or longer in order to return to Level 0. See 3.6 for details.

How can users enter the System Menu of PEP?

Press the M key for 6 seconds or longer at any level to enter the System Menu.

However, when the supervisor password is enabled, you will need to enter the
correct supervisor password in order to enter the System Menu.

What should we do if PEP does not function properly as a result of download
menu failure?

First, turn off the power and press the key continuously (do not release it).

Then restart the system to go to the “System Mode”. Now, select [Erase Menu Flash]
to clear the menus previously loaded. Then, select [Run User Prog.] to enter the
System Menu. You can load the user menu again to see if it works properly.
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