WinProladder User Guide
Content
1 General Information..........cceovevvevenn. 1-1

1.1 Operation Environment REQUIFEMENTS.........iiiiieiiiieeiiiieee e e eeeeeeeiine e e e e e eeeanennns 1-1
1.1.1 Operating SYSIEIM .......uuuiiiieeeeeeeeiiiiie e e e e e e e e e e e e e e e e e e e eeaara e e e e eaeeeeannnnns 1-1

1.1.2 Hardware ReqUIFEMENTS........ccevuuiiiiiieieeeeeeeeeeiiiiss e e e e e e e eeeeaaae e e e e e eeeeeannnnns 1-1

1.2 Introduction to Functions and CharacteriStiCS...............uuuurvrrereieeeeiieriieeiieeieeeenene. 1-1
1.2.1 General CharaCteriStiCS .........cooviiiiiiiiiiiie e, 1-1

1.2.2 Software Program Editing............ouuiiiiiiiiiiiiieeiie e e e 1-1

1.2.3 Program TESHING ...eeeuueiiieeeeeeeeeeeiitiis e e e e e e e e eeeeta s e e e e e e e eeasasanseeeeeeeeeennnnnns 1-2

1.2.4 Program Annotations and Printing ..........cccoevuvuiiiiiiieeeeeeececeee e eee e 1-2

1.3 Introduction to the operation deSKIOP...........oveieeeiiiieeiiiiiee e e e e eeeaaaees 1-3

1.4 How the Manual iS Arranged...........cceeviiieiiiiiie e e e e e e e e e e eeaannnns 1-4

2 Operation Example.............c..coonn. 2-1
2.1  Description of Example Program ...........ccoeveeuiiiiiiie e e e e 2-1

2.2 Create @ PrOJECT. ... ————————— 2-2

2.3 Input and Edit the Example Program ..............ciiiiiieiiieiiciiiicee e 2-3
2.3.1 Using Your Mouse to Input and Edit the Example Program................. 2-3

2.3.2 Input and Edit the Example Program Using Your Keyboard ..................... 2-5

2.4 Annotating the Example Program .........cccccoooivrieiiiiiiee e 2-8

2.5 Testing and DebUQGQING .....uuiii i 2-11

2.6 Printing the Example Program .........ccccoooiiieiiiiiiie e e e 2-14

3 Project (File) Management.................. 3-1
3.1 EStabliSh NEW PrOJECT......uuuiiii e e e e e e e e e 3-1

A @ o 1= o 11 E 3-3
I @ [T aT= T @ 0= =i F 3-3

I ©Xo] o] 0 [T ox 1o o IO PSP P PP PP PPPRPPP 3-4

GG T - A< o (0] [T ! S 3-8

4 SAVE AS ..o 3-8
3.4.1 Save t0 StOrage DiSK .........cuuuuuiiiiii e 3-8

3.4.2 SAVE 10 PLC .. 3-8

4 Program Input and Editing ................. 4-1
4.1 On-line and Off-liN€ EdItiNg..........uuuiiiiiieeiiieec e e e 4-1

4.2 Input via Mouse and Hot Key Operation...........ccccoeeeeeeiieeiiiiiiiie e eeeeeeeiiine e e e 4-1



4.2.1 INPULEING Via MOUSE .....cceeeiiiiiie et e e e e e e e e e e e e eees 4-1

4.2.2 INPUL VIa HOL KBYS ...t e e e e e e e e e e 4-2
4.3 Main Program and Sub Program Unit Operations ............cccooeeeeeeevieeiiiiiieneeeeeenn, 4-2
4.3.1 Establish a New Program Unit.............coiiiiiiiiiiiiiiiee e 4-3
4.3.2 Program Unit DeIEtION ..........ccooeeeiiiiiiiiiieie e 4-4
4.3.3 Adjust the Order of the Program UNitS..........ccoovvvvviiiiiiii e 4-5
4.3.4 Modify Program Unit NAME .........ccovviiiiiiiiiie e 4-7
4.3.5 Enter Program Unit ANNOTAtIONS ..........vvuiiiieeeeeeeieiiiiiee e ee e 4-8
4.4 Contact Components OPEratiONS........cvieeeeiiieeeiiiiiiie e e e e e e eeeeaar e e e e e e e eeenn s 4-10
4.4.1 Input Contact COMPONENT......cuuiiiiiieiiie e 4-10
4.4.2 Change the Type or Reference Number of the Contact Component ....... 4-11
4.4.3 Deleting Contact COMPONENTS........cevuiiiiiieeeeeeeeeeeiiee e e e e e e e 4-12
4.5 Usage of Function BIOCK INStIUCLIONS...........ccevvviiiiiiiee e 4-12
4.5.1 Input Function BIOCK INSrUCLIONS...........coiiiieiiiiieiiciee e 4-13
4.5.2 Editing Function BIOCK INStrUCLION...........ccooiieiiiiiiiiiiiie e 4-13
4.5.3 Delete Function BlIoCKk COMPONENt .........oeviieiiiiieiiiiicie e 4-14
4.6 Usage of Step Ladder INSITUCHIONS........ciiieiiiiieeeiiiiie e e e 4-14
4.6.1 Input Step Ladder Stages (STP INStruction)...........cccceveeeeeiivieeiiiiiiieeeeeee, 4-15
4.6.2 Input Convergence (From INStrUCtION) ........coovvvveiviiiiiiee e 4-16
4.6.3 Input Divergence (TO INStIUCLION).........uiiiieeeiiiieiiiee e 4-20
o o 1111 T 1Y, o T = U 4-23
0 R =T o] = Lo = 1Y/ [T [ S 4-23
4.7.2 INSEITION MOUE ... s 4-24
4.8 Changing of Components and Reference NUmMbers ...........ccccceevveeeevevveeiiiinennn. 4-25
4.9 Searching for COMPONENLS ........covvuiiiiiie e e e e e 4-26
4.9.1 Search One at a Time in the Current Program Unit............ccccccceeeeeeeeene. 4-26
4.9.2 Batch Searching in PrOjJECTS........covvviviiiiiiee e 4-27
o KO N\ (=T Yo Q@] =T = 1[0 ] 1 P 4-28
4.10.1 Copy SINGIE NEIWOIK ......uueiiee e 4-29
4.10.2 Copy MUItIple NEIWOIKS .. ... 4-29
4.10.3 Copying Networks from Different Projects..........ccccoevveeeiiiieeiiiiciiieeeeee, 4-30
4.10.4 Deleting NEIWOIKS .....ccuveiiieie e e e e e e e eeeaann e e e e e eees 4-30
4.10.5 Network Row and Column Editing ........cccoeeevivieiiiiiiiee e 4-31
4.10.6 INSert Blank NEtWOTK. ... 4-33
4.10.7 Insert Network ANNOTALIONS ... 4-34
4.10.8 Network SEarChing ........ccceeeeeeiiiieeiiiiiie e e e e e e 4-35
4.11 Ladder Program Syntax ChECK .........ccceeeeiiiiieiiiiiiie e 4-36
4.11.1 Execute SYNtax CheCK .......cooieiiiiiiieiiie e 4-36

4.11.2 Syntax Check Setting OPLiONS.........oiieiieiiiiieiiie e 4-37



5 Table Entry and Editing ...................... 5-1

5.1 ASCH TABIE ..ot 5-1
5.1.1 NEeW ASCI TabIe: ...ooviiiiiiiiiiiiiiiiiieeeeeeeeee et 5-1
5.1.2 Modify ASCII Table Name .....coooeeiieeeeeee e 5-3
5.1.3 Delete ASCIH TabIe .....ooviiiiiiiiiiiiiiiiieieeeeeeeeeeeeee e 5-4

52  LINKTabIe.... 5-6
5.2.1  General CPU LINK Communication Table................cccccvvviiiiriiiiienennee. 5-6
5.2.2 High-speed CPU LINK Communication Table...............ccccevvvvvvvnnnnnnn.. 5-11
5.2.3  General Purpose Link Table (Model,2) .......ccovvvererviiieiieeeeeeeeiiiinn 5-12
5.2.4  ModBus Master Communication Table ...............ccccvvviiiiiiiiiiiiiiiiinne, 5-14

5.3 Servo Parameter Table.........oor 5-16
5.3.1 Create New Servo Parameter Table ...............ouevviiiiiiiiiiiiiiiiiiiiiiiieeee, 5-16
5.3.2 Modify Servo Parameter Table Name: .........ccccvviiiiii e 5-17
5.3.3 Delete Servo Parameter Table:............oovviiiiiiiiiiiiiiiiiiiiiiiiieeeeeeee 5-18

5.4  Servo Program Table ... 5-18
5.4.1  Create New Servo Program Table: .......cccoeeeviiiiieiiiiiiiie e 5-18
5.4.2 Modify Servo Program Table Name .........ccccoovvviiiiiiiiii e 5-20
5.4.3 Delete Servo Program Table:..........oovviiiiiiiiiieeeeeccee e 5-20

R T =T 151 (T g = o 5-20
5.5.1  Create New Register Table:..........ooovviiiiiiiiiieeccee e 5-20
5.5.2 Modify Register Table Name:..........oouviiiieiieiieeeeceee e 5-22
5.5.3 Delete Register Table:.........oiiii i 5-22

5.6 Table ConfigUration...........ccoeiiiiiiiiiiiiiee e e e e e e e e 5-22

5.7  Creating and Bringing Up Tables in the Ladder Diagram Using Hotkeys......5-24

6 Comments Information....................... 6-1

6.1 Program UNit COMMENT........uuuiiiie e e e e e e e e e e e e e eaaaae e e e e e e eaeeennnnns 6-1

6.2 NEtWOIK COMMENT ... s 6-2
6.2.1 Enter Network Comment Mode of Operation...............ceeeveeieeeeveeeiiiinnnnn. 6-2
6.2.2 Choose Single Network Comment Mode of Operation...............c..uvvuunnn... 6-3

6.3 EIemMent COMMENT ... ... s 6-3

6.4 SNOW COMIMENTS ... s 6-7

/7 Manipulating the Display of the Ladder
Diagram.......coooceeeiviiiiiiiieicieeeeeieeieeeenn. (-1

7.1 Usage Of the WINAOWS ..........uuiiiiiii i e e e e e e e e e e e eenannnes 7-1
7.1.1 Create Multiple Ladder Diagram Display Windows..........c.cccccevvvvevviinnnnnnn. 7-1
7.1.2 The Order of Display for Ladder Diagram Display Windows..................... 7-2



7.2 Manipulation of the Annotations Display in Ladder Diagram Display Windows... 7-4

7.2.1 Manipulation of Program Unit Annotations DisplaysS ........c.ccccceevvvvvvvinnnnnnn. 7-4
7.2.2 Manipulation of the Network Annotations Display.........ccccoeeeeeeevveeiiiinnnnn. 7-5
7.2.3 Manipulation of Element Annotations Displays..........ccccceeveieeeeevveeiiiinnnnn. 7-5

7.3 Manipulation of the Display of Register Data.............cccooeeeeeieiiiiiiiiiiieeeeeeeeeeeiinnns 7-6
7.4 Direct Display of Specific Program POINtS............covvuiiiiiiiie e eeeeeeiinnns 7-7
7.4.1 Locating Elements through Program UNitS ...........ccooevviiiiiiiiiieieeeceii. 7-7
7.4.2 Locating via Program LabelS .........ccoooovveeiiiiiiiieee e 7-8
A R o Tor= 1] [0 IRV = U] (= S 7-9

7.5 SeleCt DISPlay fONTS ....cccoveeecie e e e e e e e e eaaaaaa 7-9
7.6 Mnemonic Code Display CoNntrol .............uiiiii i e e e 7-9
8 Testing of Application Programs....... 8-1
S0 O o B g = 1= 1 Vo 8-1
8.2 RUN TiMeE StatusS DISPIAY ...uuuiieeeiieiieiiiieee et e e e e e e e e es 8-1
8.2.1 Bright Display of Conductive COMPONENLS ........cccevvviviiiiiiieeeeeeeeeriiienn 8-1
8.2.2 Current Register Value DiSplay .......ccovvveueiiiiiieieeeeeeeeeiie e 8-2
8.2.3 Component Enable/Disable Status Display ............ccouvviiiiiiieeeiveeiiiiennn. 8-2

8.3 Usage of the Status MoNItor Page ........ccoooveiiivieiiiiiiiiee e 8-3
8.3.1 Status Monitor Page Management .............cceieieeeeeveeeiiiiiieee e eee e 8-3
8.3.1.1 Creating a New Status Monitoring Page..........cccevvvvvviiiiiieeeeeeeeeeiieenn 8-3
8.3.1.4 Call out Specific Status MoONItOr PAgesS.........cccovvvvviviiiiiiiee e 8-5
8.3.2 Defining and Deletion of Monitor POINtS ...........ccoovvvviiiiiiiiee e 8-5
8.3.3 Monitor Point Status Display Format Control..............cccceevieeeiievieiiiiiinnnn. 8-5
8.3.4 Entering the Monitor Point StatusS.............uueiiiiiiiiiiieeieee e 8-9

9 Operation of the PLC ...........ccceenenn. 9-1
S I o IO @ 1 B N TSP URR SR 9-1
9.1.1 Direct Usage of Existing Connection Settings FileS.............ccccevvvvvvvinnnnnn.. 9-1
9.1.2 Modify Existing Connection Settings FileS..........cccovvvviiiiiiiiie e 9-1
9.1.3 Create a New Connection Settings File.........cccooovvrviiiiiiiiieeeee, 9-2

9.2 PLEC Off-LiN@ .ettiieee ettt e e e e e e e a e e e e e e e e eeeas 9-6
D.3 RUN PLC ..ottt e ettt e e e e e e e e et e e e e e e e e e e s nnnenneeeeas 9-6
S S o] o TN o I P URR RSO 9-6
ORI O 1= - T o I SRR 9-6
S G o IO =Y i 1] T SRR 9-7
9.6.1 SEttNG-PLC ID....uiiiiiiiiieeiiecee et e e e e eaes 9-7
9.6.2 Setting-Station NUMDET..........uuiiie e e s 9-7
9.6.3 Setting-Port Parameters ...........coiiiieeiiiieeeiieee e e e 9-8

9.6.4 Setting-ProtOCOl.........cccoiiieeecee e 9-8



9.6.5 Setting-Calendar..........ccoviieeiiie e 9-9

9.6.6 Setting-Phone NUMDET .........ouuiiiii e 9-9

9.7 QUICK CONLIOL....uuiiciiiiie et e e e e e e e e e e e e e s e e e e eaaa e 9-10
9.7.1 Get System Status Of PLC ........ooiiiiiiiieeeciee e 9-10
O.7.2 INIIANIZE PLC ...ttt s e s s s e e e eeseeeeeee e 9-11
10 Ladder Program Simulation ........... 10-1
Ot B o T (PP 10-1
10.2. Limitation of Program Simulation ............ccooiiieeiiiiiiiiicieee e 10-1
10.3. Operation of Program Simulation .............cccoeeeeiiiiiiiiiiiiieee e 10-2
10.3.1 Open Ladder Program ..............coiiieeeeeeeeiiiiiiiseseeeeeeeeeainnnneseeeeeeeennnnnns 10-2
10.3.2 Enter Simulation Mode...........ooooiiiiiiiiiii 10-2
10.3.3 Start Execution of Program Simulation..............ccccceevvevviiiiiieeeeeeeeeeiiens 10-2
10.3.4 Pause of Program Simulation ..............ccoeuuviiiiiiiiiiiiiieiice e 10-3
10.3.5 Proceed to Program Simulation .............ccuuuiiiiiiieiiiiieiciee e eeeeeeeiiees 10-3
10.3.6  CONrOl SCANNING ...vuuiieeeeeieeeeiiie e eee e e e e e e e e e e e e e e e eaeeeannnes 10-3
10.3.6.3  CONLINUOUS SCAN.....cciiiiiiiiiiieieeeeee e 10-4
10.3.7 Set Address Breakpoint of Program Execution .............cccceeeeeeevveeennnnns 10-5
10.3.8 View Address Breakpoint LiSt...........cccovvviuuiiiiiiiiieeeeeeeciiiiee e e eeeeeeinnns 10-5
10.3.9 Setup Data Breakpoint............uuuiiiieieeeiiiiiiiiiee e e e e e e e e e eeeenannns 10-6
10.3.10 StOP SIMUIALION .......uiii e e e e e e eeaannes 10-7
10.3.11 ENd SIMUIALION .....cooiiiiiii 10-7
10.4. Communicate with Simulation Program ...........cccccevviiiiiiiieeeieeeeeceee e 10-7
10.4.1 Communication FUNCLION SEtUP ......cccevviiieiiiiieee e e 10-7
11 Constructing Projects ......................11-1
11.1 Modifying Project INformation...........coovveviiiiiiiie e e 11-1
11.2 Program SECUNLY SEIINGS ..vvvuuueiiieeeeieeieiiiiiiis e e e e e e e et s e e e e e e e e e e e e e eeaeees 11-1
11.2.1  Set the Program PasSWOrd ...........cccooeviiiiiiiiiiiieeeeeeeeeeiiiine e e e eeeeeeennnnns 11-1
11.2.2 Set the Program ID .......ccccoeoiiieiiiiiiie e e e e e e eeananees 11-2
R e CoTo =T g I 0] 1Y/=T ] o] o 11-3
11.4 Set System ConfiguratioNS.........ccoeeeeeiiiieiiiiiiee e e e e e e e 11-3
11.4.1 Set 1/O ConfIQUIAtioN ........cccovieeiiiiie e e e e e e e e e e eeeeannnes 11-3
11.4.1.3 Configure the Output Signal Settings..........cccoeeiieiiiiieeiiiiiiee e 11-6
11.4.2 Configure the Memory Allocation Settings ...........cccevvvvvviiiiiieeeeeereeeinnns 11-11
11.4.3 Configure Read-Only Register Content .........ccooeeeeevviiiiiiiiiiieeeeeeeeeeiinns 11-14
12 Tabular Outputs.........ccocevvieenennnnn. 12-1
02 I T (= Y= 11 T S 12-1

12.2 PrintiNg SEENGS. ...uuuiiieeeeieiieeiiiie e e e e e et s e e e e e e e e e et s e e e e e e e eeansaanaaaaeeeeeees 12-1



12.2.1 Select the Ladder Program thatyou would like to Print.......................... 12-1

12.2.2 Select the Descriptions and Annotations that you wish to Print ............. 12-3
12.2.3 Select the Table that you wish to Print...........ccccooeieiiiiiiiiiiiiee e 12-5
12.2.4 Select the Status Monitoring Page that you wish to Print....................... 12-5
12.2.5 Select the Project Information or Configuration that you wish to Print...12-6
12.2.6 SEt Print FOIMAL .....ooooiiiiiiiieee e, 12-7
12.3 PlINE PIEVIEW. ...ttt sttt sttt e e s s s e e e eeeee e 12-8
02 11 Vo P 12-8
13 Auxiliary Functions .............ccceeune.. 13-1
13.1 CRC16/ChecksSum CalCUlAtOr.............uuuuuuieeeiieiiiiiiiiiiiiieieeeeseseseseesseseeeseeeeeeeeees 13-1
13.2 Contact and Register Usage Information............ccoovvvvviiiiiiiee e 13-1
R RS IS (=0 4 = 7= 10 (U o 13-2
13.4 SYSIEM RESIOIE ...t e e e e e e eaa s 13-5
13.5 ROM PaCK OPEIatiON.......ccceeeiiiiiieeeeeeeeeeeiiiise s e e e e e e e eetaas s s e e e e e e e e eaaaaananaaeeeeeees 13-8
13.6 1/0O Reference Number Allocation StatUSES...........uuvvvviiiiiiiiiiiiiiiiiiieeeeeeeeeieeeeeees 13-9

15 Managing the Desktop.................... 15-1

15.1 TOOl Bar ManageMENLT.........cuuuuuiiiieeeeeeeeeeiiiie e e e e e e e e e e e e e e e e e e e eeaanan e e e eeeeeees 15-1
15.2 Management of the Project WINAOW ............cooviieeiiiiieiiiiiiee e 15-2
15.3 Management of the Status Monitor Page............ccovvvviiiiiiiiie e 15-2
15.4 Management of Ladder Diagram WINAOWS............cccuuvuiiiiiiieeeeeeriiiiiiiiee e eeeee 15-3

16 Common Q&A’'s (FAQ).....cccceuvenne... 16-1
A AN 0] o 1= 4 [0 1 GO 17-1

A T 10 1= VRN 1= o = 17-1
17.2 EXport/Import File FOrMAL..........oiiiii e e e e e 17-4



1 General Information

1.1 Operation Environment Requirements

1.1.1 Operating System

Win95/98/Me/XP/Vista/Win7 or WinNT4.0,Win2000

1.1.2 Hardware Requirements

Pentium 133 or faster CPU
At least 256 MB of DRAM memory
At least 30 MB disk space

1.2 Introduction to Functions and Characteristics

1.2.1 General Characteristics

For use in a Windows operating environment, completely designed in accordance with Windows
environment operation methods and habits, easy to learn and use, and allows users of all types, beginner
or expert, to operate the software in a very efficient manner.

We use a project oriented approach, presenting your software development content visually in a ladder
diagram display, facilitating the clear and simple display of the content. All project content, be it for
software development or for program maintenance, can be viewed and worked on in an intuitive and
straight-forward manner.

We provide a unique and specially designed keyboard and mouse that is specifically tailored to match and
suit your specific office environment conditions, so that no matter what type of environment the user is in,
they will always be able to program and test their software in a very efficient manner.

We provide a diverse set of connection methods, including direct connection, modem connection, and
internet connection, etc., and also allow the user to save their connection settings (such as transmission
speed, telephone number, web address and IP, etc.) using a file name of their choice, so that next time
they need to use the same connection, they only need to pick out the connection settings file from the

saved files and will directly be able to proceed with the rest of the connection process.

1.2.2 Software Program Editing

We provide a run time on-line software program editing feature, in which the user can immediately
execute the program without having to re-download, significantly shortening the time needed for
development and modifications.

We provide a multi-window ladder diagram display, which allows the user to display program segments

from different sections for comparison, reproduction, and editing.
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We provide a flexible ladder diagram program edit function which can execute high-end operations such
as internet insertion, copying, pasting, and deletion, dramatically increasing program input speed.

We provide a programming unit insertion function allowing users to categorize their overall development
projects into several programming units (according to functionality or any other categorization method)
that are capable of performing isolated annotation insertion and testing, providing a great help to the
development process and subsequent management process of software programs.

We provide independent mnemonic display windows, allowing the use to display equivalent mnemonic
codes according to the location of their cursor in the network of ladder diagram programming windows.
Diverse program search functions, allowing the user to search devices and registers, and also allowing
the setting of filter criteria such as device type, etc., with the search results appearing in tabular form. If
the user were to directly click on the search result of their choice, they would be able to call out and
display the corresponding code in a ladder diagram window.

We provide programming syntax checking functionality, which executes when the user decides they
would like to perform a check, and also, when the user issues an operation order, the system will
automatically execute the syntax check. After the completion of its execution, it will display a syntax check
report window, with all the errors being listed out one by one. If the user were to click on one of the listed
syntax errors, they could call out the corresponding section of code where the syntax error had occurred
with the cursor placed exactly on top of the error. This function is a very significant development for

discovering and correcting errors.

1.2.3 Program Testing

We provide multiple status testing windows, allowing the user to specify which component and register
information that they would like to have displayed, and also allowing them to specify their data display
preferences. The settings for the status testing page will be stored inside the project files, and the next
time the user needs to access these settings, they can simply open the previously saved files, making the
monitoring and configuration of statuses much more convenient. During execution, the user can disable,
enable, or forcefully set a switching device, and set register values.

In addition to marking the various contact components that are closed using the color red directly on the
component, the multi-window high-brightness ladder diagram display also displays the register value of
each of its windows, which is a great help for program testers. Inside the window, the user can also
directly click on a contact component and disable, enable, or forcefully set it, and the node and circuit of
the disabled component will be displayed differently from the other normal components, which is very

helpful for handling the status of different components.

1.2.4 Program Annotations and Printing

We provide different degrees of annotation capabilities, namely, component, register, network,
programming unit, and program annotations, and all except the last one can be displayed in the ladder

diagram windows, which is very helpful for understanding the operation of ladder programs.
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® Component and register annotations can be input through our software and can also be established using
editing software that the user has learned to use, and then subsequently using the import function to
import it into our software. There is also an export function that allows the user to convert the annotations
of project components and registers into text files which are compatible with other applications software
such as Excel, etc.
® We provide the following report document printing features
— Ladder Program Printing:
The user can select the range of program and annotations that they wish to print and output the ladder
diagram program from a printer.
— Using component cross reporting:

The user can print out the location of all components and function instructions used in the program.

1.3 Introduction to the operation desktop

(Functions toolbar)
[£] winProLadder - [Ladder Diagram - Main_unit1] . (T00|? bar) LI—I—J':' EEREE)
File Edit WView Project Ladder PLC Tool Window Help | = .
DS-8 |EER em B-p-R-W-Q-8 Vo5 W5 BB,
RN QYR AT NS [ "EREECEXIX® |<+T(Componenttray)

&)X

"= TNDOD | 2}
= [ Project [FBs-24MC] | |
-8 System Configuration
- Ladder Diagram |
-3 Table Edit oL
- Comment i
B Status Page
&5 170 Mumbering NOOZ | : : : : : =
(Project Window) NOO3 | "~ (Ladder Diagram Window)
NOO4 |
NOG5 |
“\Main_uricl [ [ | 4 | | »
By | | Owverwrite MNOR1C1 |U:0 F:20223 S:A (Doc U0 F8191)

(Status bar)

File Edit Wiew Project Ladder PLC Tool Window Help
(Functions toolbar)
The functions toolbar is the collection of functions included in the applications software, presented in different
categories. When the user selects any of the categories in the above functions toolbar, a list of additional

selectable functions will be displayed for the user to select.
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De-d [[BEE |[gea|G-pw- R - -B -8 - -5 -B-&|BR-(E BN
(Tools bar)

In the process of the design of a project, it is often convenient to provide a toolbar with the most commonly

used functions included in it for the user to directly select, which can prove to be much faster and more

convenient that having to find the function through the functions toolbar.

he Rh o WL GG R = | (Sl R] @ ENE] X 1% W
(Component tray)
We provide a component tray which allows the user to easily select the components and command functions
that they need to use without having to search for what they want through the functions toolbar, which is faster

and more convenient.

% E“g | Crwerwrite MOR1C1 U0 20223 5:A (Doc U0 FB191)
(Status bar)
The status bar displays information on the status of the current application, such as whether the application is
connected, whether it is in execution or has been disconnected, and the current location of the cursor, etc.,

allowing the user to know the status of the current application at all times.

1.4 How the Manual is Arranged

® A cursor-selected function is expressed with its function name inside the brackets, and the order of
execution procedures are expressed using arrows, for example: [File] > [New Project].

® \Windows that appear after a functional item has been executed are also expressed in brackets, for
example: [On-Line] window.

® The finish buttons that can be selected in dialog windows are expressed using quotation marks, for
example: the “OK” button.

® The field names that appear in dialog windows are expressed in brackets, while input text is expressed in

guotation marks, for example: input “Test example” in the [Project Name] field.



2 Operation Example

To give new users a clear and basic understanding of our software, this manual uses examples to introduce

the basic functions that are used in the development process.

2.1 Description of Example Program

This example will demonstrate how to build a marquee control program in a FBs-PLC, and also test and
modify it, finally producing a cascaded program table. In this example, the output points are YO~Y7, YO is the
first to light up, followed by Y1 one second later, followed by Y2 one second later, and so on ... After YO~Y7
have all lit up, they will all go out for one second, and then repeat the same sequence all over again. The

signals and annotations that will be used in this example are presented in the table below.

Number Annotation Number Annotation
MO Internal light number 1 YO0 Light number 1
M1 Internal light number 2 Y1 Light number 2
M2 Internal light number 3 Y2 Light number 3
M3 Internal light number 4 Y3 Light number 4
M4 Internal light number 5 Y4 Light number 5
M5 Internal light number 6 Y5 Light number 6
M6 Internal light number 7 Y6 Light number 7
M7 Internal light number 8 Y7 Light number 8
M8 Reset Signal M1924 First scan
Co Number of illuminated lights TO0 One second timer

Below is the actual ladder diagram program:

OO0 TO So1%
4 .
- N‘r o 100 o
NOOL TO S1P. SHFL
1} EM ooz WMo OTE
Moz
INBE LERR-
" M1924 08 . MOV
I nd = s o
WMo
ma
11
NOOF TO S S E—
— | Ls{ <o FoCupP—
(2] 10
1s]
1.} CLF
O Mo YO
e —
HOOE M1 v
— { —
NOOE M2 ¥2
11 { ¥
OO M3 ¥3
1t {
NOOE r Vi
11 {
HOOS ms Y5
e { r—
NO MG V6
— { —
LIRS M7 ¥7
11 { ¥

Below is the description of the development process presented in sequential sections.
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2.2 Create a Project

Step 1: Execute the WinProlad.exe program.

Step 2: Select [File] > [New Project] from the function toolbar using your mouse, or press “Ctrl” + “N” on your

keyboard, and the [New Project] window will appear, as is shown below:

S5

Project Information

Froiect Mame  |[=7 1

Model Name  FBs-24mC Edit

Detachable terminal block, RTC.14 DC24Y inputs, 10 outputs,2 120KHz + 14
20kHz HSC.2 120KHz + B 20KHz pulse output,1 comm. port(can expand up

e

Descrigtion :

Options
v Calendar

« OK | x Cancel‘

Step 3: Enter “Test example” into the [Project Name] field.

Step 4: Click on the ..ﬂ] button to enter the PLC model type selection screen.

Project Information

ProiectMame  [Test example
Model Mama  FBs-24MC Edit | pLc model

Dietachable terminal block RTC.14 DC24Y inputs Shriae B Mlodal
20KHz HSC.2 120KHz + 6 20kHz pulse outputl g o - -
E 2 B ~lea ~Jmc -]

Description :
" OK | X Cancel]

3

Cptions
v Calendar

o 0K ] X Canu:el]

Step 5: Select the corresponding model type according to the actual testing machine.

Step 6: Click the button, and the following screen will appear:
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2.3

b
@ WinProLadder - [Ladder Diagram - Main_unit1] ﬂlﬂ-ﬂ
Z] File Edit View Project Ladder PLC Tool Window Help

= [
DE-E || BEE wem (@G ope R -G ®-8 P -5 W5 B 5 B
IR UMM ORYQYLs LSS L "EREDEE XIX %

=[Nooo : B
=-[E) Test example [FBs-24MC]
-] System Configuration
=B Ladder Diagram )
-5 Table Edit NOOL
=K Comment B
B Status Page
%2 /0 Numbering NGO3 : : : 3 . L
NOO3
NDOZ
NOOS
'\ Main_unitl £5ub_unit! 7 ] | ]
ﬁ Overwrite MOR1C1 U0 F:20223 S:C (Doc U:0 F8191)

Input and Edit the Example Program

2.3.1 Using Your Mouseto Input and Edit the Example Program

Step 1:

Step 2:

Step 3:

Step 4:

Step 5:

Now you can begin to input the ladder diagram program, first move your cursor to the upper left hand
corner of the ladder diagram window and click on it, you should then see a flashing blue square at

that same location.

Move your cursor to where the component tray is, there should be an icon that looks like the following:

RiE MU QR LN LT ERETEE X %

. 11 .
Left click on the & button and a B normal close contact cursor should appear, move this cursor to

the location of the blue square and perform a left click. The following dialog window should appear:

Element Edit @

44 =] » &

Input “TO” and then press “Enter” to input TO with a normal close contact.

move your cursor to the in the component tray and click on it, now a cursor in the shape ofa T
should appear. Left click on your mouse and the following dialog box window should appear.



[ Function ﬁ1

1..._ 32 Bits{Alt0) [ ;;:,::.5__...::.__.;;::.__:
T | X Cancel

T: ]TI i
PY: I oS

Step 6: After you input “0”, use your mouse or the “Down” arrow key to move the cursor to the [PV] field and
input “100” and then press “Enter” or click on the “OK” button using your mouse, now you have

completed the input of the TO timer function.

Step 7: Now input the TO normal open contact (-I ln;) using the same method as the TO normal close contact

(MB_), except you click the function toolbar icon : Iﬁ .

Step 8: After inputting the TO normal open contact you should then input SHFL (Fun51), use your mouse to

click on [E] , then you should see a cursor in the shape of an F, move this cursor behind the TO
normal open contact and click it, then you should see the following window appear:

{F} Function Lookup (MC):PLC.OS Verlvd.] |
Function Mame; l| ‘ ' 0K ]
Description: Begin of master contral loop x : I

ahcel

Clazz Mame

. m
Timer/Caunter | MCE B |
Dutput Operation = gEEE ;g% |= |
Set/Reset L5 DIFU ':43 —!
SFEL DIFD [s]
Aithrnetic BSHE [6]
Logic Operation UDCTR [71
Compare MOV [&]
D ata Movement - [mov/ [9] =
Chifb/Rabata T r1nl

Input “SHFL” or function code “51” in the Function Name field, if you are not familiar with function names or
function codes, you can also move your cursor to the [Class] field and click on “Shift/Rotate”, and all of the
instructions related to this category will be listed, after you select “SHFL”, it will appear in the [Function Name]

field, now if you press the “Enter” key or click on the “OK” button, the following window will appear:
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{F} Function Lookup (MC):PLC.OS Ver[vd.x] S

Function Marme: |SHFL ‘ o OK I

Description: [Data shift left
x Cancel

Class

Arithmetic

Logic Operation
Compare

[ ata Movernent

Shift/Botate
Code Convert

Flow Contral
Temperature Control

I/0

Curalzsbiva Tirsar

Functicn Li_E-J1
[ 32 Bits{alt+[) [ Fulsefalt+F)

2l | o]
I' S 2 |

8

Input “WMO” and “1” into the [D] and [N] fields, respectively, because most function block
instructions have flexible pulse trigger and 32 bit operand can now be selected using a mouse or a
keyboard. If you use your keyboard, use the “Alt” + "D” combination for [32 bits] ; use the “Alt” + “P”

combination to control the [Pulse], the [Pulse] function must be selected for this example.

Step 9: Move your mouse cursor to the " inthe component tray and click on it, a cursor with a horizontal
short circuit icon should appear, move it at specified location and continue to fill in the horizontal short

contact.

Step 10: We are now intentionally skipping the MOV instruction network, and we will revisit the following

portion later on.

2.3.2 Input and Edit the Example Program Using Your Keyboard

Below is a description of how to edit application program by using a keyboard:
Positioning and Control of the Cursor -

Moving the cursor up, down, left, and right — The four arrow keys (1 | < —)
Move to top — Ctrl + Home

Move to bottom — Ctrl + End

Move to the left-most position — Home

Move to the right-most position — End

Move up one page — Page Up

Move down one page — Page Down



When inputting various contact components using a keyboard, different letters of the alphabet are used to
represent different types of components.
Normal open contact: A

Normal close contact: B

Transition up contact: U

Transition down contact: D

Coil: O

Inverting coil: Q

Set coil: E

Reset coil: R

Invert the node status: |

Transition up of node status: P
Transition down of node status: N
Horizontal short: H

Vertical short: V

During input, first move your cursor to the location where you wish to make the input and then enter the
component and reference number, the order of input is irrelevant, you can enter the component first or the
reference number first, for example, an “AX1” or a “X1A” could be entered for a normal open contact whose
reference number is X1. If only the reference number is entered, then the component of the previous
operation will be assumed and used, if you simultaneously press “SHIFT” when you are entering the
component, then you will enter a component with an unspecified reference number, in this case you can

specify the reference number later.
Continuing the introduction of operation procedures of Section 2.3.1 Step 10:
Step 11: Press the “Esc” key, and the icon that was previously by the cursor will disappear, then move the

cursor to the network labeled NOO2 and click on the location of the first component.

Step 12: Enter “T” using your keyboard, and the following window will be displayed, then key in “0” and press

“Enter”.

Element Edit = T0
1+ =T »

The input of application functions can be divided into two categories: the first is the category of frequently
used functions, such as timing, counting, set, and reset; the rest are categorized as general functions.

Input of frequently used functions:

The same contact components are represented using the same letters, what's different is the “Shift” key
should be pressed simultaneously:

1. Timer function: Shift + T

2. Counter function: Shift + C
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3. Set function: Shift + S
4. Reset function: Shift + R

Inputting general functions:

First enter “F”, and the application function widow should appear, then use the mouse inputting method

previously described.

Step 13:

Step 14:

Step 15:

Step 16:

Step 17:

Step 18:

Step 19:

Step 20:

Enter the counter function, enter “Shift” + “C”, the following window will appear, input [C] and [PV]

using the same method as described in the above timer description.
Function &J

[C 32 Bits{alD) [T Pulse
C | X Cancel

C: |d »
PY: | b0

Use the “B” and “H” keys on your keyboard to sequentially enter the rest of the NOO2 network.

Sequentially enter “AMOQ” + “Enter” and “OY0Q” + “Enter”, enter network NOO3.

Now enter the network NOO4 by using the Copy function, move the cursor to the location of the MO
contact A component, press and hold the left button on your mouse and select the entire NOO3
network, when the entire NOO3 network has been selected, enter “Ctrl” +"C”, and then move the
cursor to network NOO4 and enter “Ctrl” + "V”, now the entire content of network NOO3 will appear in

network NOO4.

Use the above described method to select networks NOO3 and NOO4 and copy them to networks
NOO5 and NOO6.

Use the above method to select networks NOO3~N006 and copy them to networks NOO7~N010

Now we will edit networks NO04~NO010; first move the cursor to the contact A of network N0O4,
directly input “M1” + “Enter”, then use the down arrow to move the cursor to contact A of network
NOO5 and repeat the above steps until the contact A of NO10 has been changed to M7. Now move
the cursor to the coil of network N0OO4, and use the same method as above to edit the coils of

N004~NO10.

Now let's go back to the network that we previously intentionally left out and input it, first move your
cursor to network NOO2 and right click your mouse, a popup menu should appear, select [Insert
Network] -> [Before This Network]; or press the “Shift” + “Ins” hotkey, and an empty NOO2 network

will be inserted.



Step 21: Complete network NOO2 using the above method.

2.4 Annotating the Example Program

Step 1: Select [Project] > [Comments] = [Element Comment] in the functions toolbar; or select the

m-Rn Comment from the expanded menu; or click on the 1, icon in the tool bar, and the following

window will appear:

Element Comment = E

8 = =i 4
All Used Unused Impart Expoart Fefresh ClearAll  Clear Unused

By ®BM Hs B1I ®c YR | TD

Ref. No. Comment Description %
xo |
X1
X2
*3
x4
*b
*b
"7
X8
X4
x10
X1 |
X12 -

UOoFe19l | [shift+SpaceToggle store to Ladder or Project

Click the Used button > s M and then respectively enter the example annotations, as shown
below:
[ Element comment [E= ISR
=] s =i =4 s d
Al Used Unused Impart Export Refresh Clearall  ClearUnused
s e e e s e ]
Ref. N|:|.| Comment | Description &
M0 Internal light 1 | L
M1 Internal light 2
M2 Internal light 3
M3 Internal light 4
M4 Internal light 5
Mb Intermal light 6
Mb Internal light 7
M7 Internal light 8
M8
M9
M10
M11
M12 -
U153F8038 | [shift+SpaceToggle store to Ladder or Project

Click the Used putton > ¥ X and then respectively enter the example annotations, as shown

below:



Step 2:

, Element Comment =TI
i 5| B 58 &
All Used Unused Impart Expart Fefresh ClearAll  Clear Unused
Br Bl ]2s [Bz Bec [fa]ro |
Ref. No. Comment | Description
Y0 Light nurnber 1 |
Y1 Light number 2
Y2 Light number 3
Y3 Light number 4
Y4 Light number 5
Yh Light number &
Y'b Light number 7
Y7
U153 8038 | !Eﬁif-t:-s.pace:Toggle store to Ladder or Préj'gct A

Fill in the annotations using this window respectively according to the previous definitions and
descriptions in the fields of the tables. The [Description] field was not used in this example, and more

detailed component descriptions may be entered into this field in actual applications.

Now we will proceed with [Network Comment], use your mouse to move the cursor to the network that
you wish to annotate, right click on the mouse to call out the popup function menu, then click on
[Network Comment], and then a window for entering network annotations will appear. Once you have

finished entering the annotations, they will immediately appear above the annotated network.

HOO0

[x select

NOO1 TO Contact v P S1P. SHFL
1} output . EN g L L

Function * WE 1
-, Horzontal $hor
o Wertical Short
~ Horizontal long
HOGE M1924 8.

3¢ Delete e = e

I Delote Vertical Short
% Delete Horizontal long o w0

INBA FRR~

ME Insert Metwork .
Network Edit .
Program Unit Comment I —
ik r e

— . PLS]{ €O CUP=
% cut CHi+X
o i Copy CuleC

MO o, paste cul+v
11 LR

Select all culea

(' 10

Clase Wind
LT wo ose Window -
1 ¢ Cantrol * 4}

NOOOD |
I

' Netwark Comment @E‘g‘

[ 70 | [Frogram stan s
i | & WM

rOTB-
1

FERR-

I‘N‘U‘f]‘?‘.- | M1924 _708. MOV
I H ' ’

WMo

Sy X Gancel




NODO |

NOOT |

[Program start.

TUP-

Step 3: Now we will proceed with [Program Unit Comment], use your mouse to move the cursor inside the

program unit that you wish to annotate, right click on your mouse to bring out the popup function

menu and then select [Program Unit Comment]; a window will appear for you to input through. Once

you have finished inputting the program unit annotations, they will immediately appear above the

annotated program unit.

HOOEO

FEEs |

MO

e

TLES

[[Program starc.

[ Seloct

1 cantact v

Cutput
Function
Harizenal Shert
|, Vertical Short
* Horizontal long
™
192,_" 3¢ Delete
3¢ Delote Vertical Shart
) Dolate He:

' vt Pet
raatwark Eeit .

ro
— —  Metworkcommaent

& cn Crle i
mo | Ha Copy crrlec
—1./1— 8 Paste Ctrisy

Select al Ctrl+a

1ang

™ .

MO Close Window

1 Cantrol

T

To 100

S1P. SHFL
1 w0

08 . Mov
o

L 10

LR

TUP=

OTB-

CuP—

vO
{ ¥

NGOG

NOOL ||

NOOZ

Frogram start,

=] comment

F—ron o=

o 100

Test example|
TO

M1924
1

M8
—

|I o OF | X Cancol

——S1F. SHFL
' WD

1

- 08, MoV
: o

WMo

TupP-
oTE

ERR—

HEOE

MOOL

Test ewampie

Frogram Start.

g Lo15 -
EN
o 100

S1P, SHFL —
EN D : WhO

TuP

OTB—

ERR

Step 4: Save the previous input content to project files. Use the [File] > [Save] in the function toolbar; or

press “Ctrl” + “S”. Because this is the first time you have saved a file, a [Save As] dialog box will

appeatr, press “Enter” once you have input the file name and you are finished.

¥ Please refer to Chapter 6 Comment Information for detailed operation procedures.
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2.5 Testing and Debugging

Step 1: First save the previously entered program code to the PLC, select [File] > [Save As] = [To PLC] from
the function toolbar and [PLC] = [On-Line] dialog box will appear, as shown below:

On—Lrge &J

: Auto Check
Connection Name
& |
Adwanced Add Edit | Delete |
Details
Attribiute Data
Station Murnbear 1
Medium Setial line
Faort Mo COm4
Baud Rate 9600
Parity Ewen parity
Diata Bit 7 hits
Stop Bit 1 hit
Ok | Cancel |

[ @) pLc status S |
ftern Status
B station Nu... 1
ElModel FBs-Z 4 Civd 62)

#l PLC Status  Stopped
@ MEMORY_.. Mot Set
o Syntax Che.. OK

Data Receving .. o Password Mot Set
Main Progr... Not Set
Sub-Frogra.. MNotSet

w System Data DataPass.. MotSet
«" System Configuration Program D Mot Set
) PLCID Mot Set
" ROR Fegister i) Calendar Installed
o Ladder Program EAvailable p... 20224Ward
EUsed progr... 0Word
B Comments E)Free progr..  20223%Ward
Labal Address ElMin. 05 wver.. w4.00
Finigh

W OK

Now we can select a previous connection setting from the [Connection Name] and press “OK” to
proceed with connecting to the PLC and bring out the [Data Receiving] window; if the connection is
successful a [PLC Status] window will appear. If there is no applicable connection setting present,
then you can connect through the “Edit” or “Add” processes. If the connections port does not

correspond with the actual operations, you can select “Edit” and make modifications.

Step 2: After the previous step is completed, the content in the PLC will be the same as that in the project file,
so that now you can take advantage of the [PLC] = [Run PLC] in the function toolbar; or enter the
hotkey “F9” to give a command to the PLC to execute the program. You can also select [PLC] = [Stop
PLC] in the function toolbar; or enter the “Ctrl” + “F9” hotkey to give a command to the PLC to stop

execution of the program.

2-11



Step 3: When the PLC executes, the cascaded program window will be under the following condition:

WD
]
" TO
I I
.
NG FERR—
& M1a24 —OBMN——
L1} 4 =
NE
— J
o o
Sy 5 CupP—
=
)
—-t R
\ ] o
—Iml (H)—
RIS w v
—ml (H)—
ROTE uz vz
I I {}
s n3 A
F €
" na 4
k {
o5 i . . . . . . : i
I I { )
L we 5 . . . . . o
— | {
T s s . . . . . s g
— | { —

All components that are represented with solid line boxes are connected and in an active state, and
we can go and control the display of the ladder diagram program, making it possible for the program

annotations and register values to also be displayed on screen.

You can choose whether or not to display the different categories of information by selecting or unselecting

the following items in the ladder diagram window:

Display program unit annotations
Display network annotations
Display component annotations
Display register annotations

Display font sizes

The more information you decide to display, the richer in information your screen will be, but the less program

code you will be able to view in each screen because the additional information is taking up so much room.

To select which items to display, you can click on [View] in the function toolbar and a dropdown menu will

appear; the above listed items will be listed in the dropdown menu, and you will be able to select them by

checking their corresponding boxes. Iltems that have already been selected will show a check mark on the left

side, if you click on it again then the check mark will disappear and the item will be unselected, the illustration

below shows the effect of selecting [Element Comment] and [Register Content]:
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NOOS | TO
B S
MO
I
Internal
Tight 1
NOO4 | Mo YO
- (—
Internal Light
Tight 1 number 1
o = . ) . . . . . . 3 : o
¥ (l)—
Internal Light
Tight 2 number 2
rare) ek : ; : : § : ; E : ; o
= (—
Internal Light
Tight 3 number 3
NOD7 M3 \E
2 1 (m)—
Internal Light
Tight 4 number 4
TR s ; ; : ; : ; ; ; : ; 2
- (—
Internal Light
Tight 5 number S
s o . . . . ’ . . . ] ) o
] (l)—
Internal Light
Tight & number &
TR e : ; : : § : ; E : ; i
(! | l.)_
Internal Light
Tight 7 number 7
fott - ] : : ; : ; 3 E ] : i
- m—
Internal Light
Tight 8 number 8§

Step 4: Coil enable/disable control, move your cursor to the coil location and right click on

your mouse, a menu that looks like the one on the right will appear, using the [Disable]

Close Window

function, you can free the component from the control of the program. For example, | Enabled
Dicabled

when YO0 has been disabled, its state will not be affected by the state of MO, and now ON
OFF

you can use [ON] and [OFF] to control its status, disabled components are displayed

differently, the following are display symbols for [Disable] components:

M7
{5 3

Step 5: Use the [Status Page] for testing, first open an empty status monitoring page by doing the following:
Select [Project] > [Status Page] - [New Page] from the function toolbar; or use your mouse to
double-click on the @ Status Page icon in the project window; or use your mouse to select the
@ * icon in the function toolbar and then select to open a new monitoring page.

Once you have completed the above procedures, a dialog box will appear, please enter

“StatusPage0” in the [Status Page Name] field, then press “OK” and the following window will appear:

(&) Status Monitoring [E=EERSC
Ref. Mo |Status |Data |F|ef. No. |Status |Data | &
il r

' StatuzPagel
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2.6

Step 1:

Now move your cursor to the first blank field in the [Ref. No.] field on the far left and input “YO-Y7” and
then press “OK”, then move the cursor to the second reference number column and input “M0-M8”
and then press “OK”, finally, move the cursor to the third reference number column and input “C0” and
press “OK”, “T0” and press “OK”, “R0” and then press “OK".

You will then see on the screen the reference numbers of YO~Y7 and M0~MS8, their respective
enable/disable statuses and ON/OFF statuses, along with the status and values of timer TO and
counter CO. If you with to enable or disable a node or coil, simply move your cursor to the
corresponding status field and double-click, then the enable/disable option will appear. If you wish to
set their values, you can move your cursor to the corresponding data field and enter 0 or 1, or
double-click your left mouse button to bring up the value input window.

The display format for registers can be controlled using the [Status] field. There are currently six
distinct display formats: base 10, base 10 positive numbers, base 2, base 16, floating, and strings, etc.
To use them, double-click your left mouse button on the status field. The [Ref. No.] field can be
displayed using component reference number or component annotation; this can be done by bringing
out the popup menu by right-clicking in the status monitoring page and selecting [View Element

Comment].

Printing the Example Program

Use your mouse to select [File] = [Print Content Setup] in the function toolbar ; or press “Ctrl” + “P”,

and the [Print] window will appear:

[ Print S5
Print Items | Edit Network | Comment /Description | Table Status Page Systﬂ b
Type Ibern T

Program Unit Font
Type Item [MS Sans Serf - £] n

[ Ladder ... Main_unit]

T adder .. Sub_unitl
1P Ll ek Fritit Itenns

[~ Program Unit Comment,

[~ Metwark Comment

] ] [~ Element Comment
l [~ Step Mumber

] z : ] Select Al | : |

XK Cancel |

Preview | PrinterSetup|

[Edit Network] bookmark: lists all program units in the project in the [Program Unit] field. You can use this

field to select one or more program units that you wish to print, and add them to the [Print Items] field on the

left; or you can select [Font]; and the [Preview] button allows you to preview the print results.

[Comment / Description] bookmark: all annotations options for the project will be listed in the [Data Range]

field. You can use this field to select one or more annotation items that you wish to print, and add them to the

[Print Items] field on the left; or you can select [Font]; and the [Preview] button allows you to preview the print

results.
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[Table] bookmark: lists all the table items in the project in the [Table List] field. You can use this field to select
one or more table items that you wish to print, and add them to the [Print Items] field on the left; or you can

select [Font]; and the [Preview] button allows you to preview the print results.

[Status Page] bookmark: all monitoring page items for the project are listed in the [Status Page List] field.
You can use this field to select one or more monitoring pages that you wish to print, and add them to the [Print

Items] field on the left; or you can select [font]; and the [Preview] button allows you to preview the print results.

[System / Other] bookmark: project information items from the project will be listed in the [Other Item] field.
You can use this field to select one or more project information items that you wish to print, and add them to
the [Print Items] field on the left; or you can select [Font]; and the [Preview] button allows you to preview the

print results.

[Format Setup] bookmark: can set page start/end and margin settings; and the [Format Preview] button lets
you preview your print results. After you have finished entering the data, simply press “Print” and the printing

will begin.

Please refer to Chapter 12 Tabular Output for detailed operation procedures.
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3 Project (File) Management

WinProladder is a project oriented programming software, presenting the content of your application program
development visually using a ladder diagram display method. As shown in the illustration below, this allows
the user’s work status to be viewed in a clear and intuitive fashion. This style of presentation allows program

development and maintenance to be conducted in a very intuitive style and is also convenient for file

management.

Project Tree

| Testexample [FBs-24MC]
2% System Configuration
.38 /0 Configuration
# Mermary Allocation
B3 ROR Register
2B Ladder Diagram
B hain Pragrarm
LT Main_unit
=8 Sub Program
4 Sub_unit]
=& Table Edit
----- % ASCI Takle
----- T Link Takle
----- 8! Servo Parameter Table
----- 8 Servo Program Tahle
----- ¥ 8 General Furpose Link Takle
12 Rengister Takle
----- W bodBus Master Table
-85 Comment
----- S, Program Unit Comment
----- frl Network Na.
Ak, Element Camment

StatusPagel

1% /O Numbering

12 Project /0 Nurnbering
[l 0.FBs-24MC

2 DIx0~K13
Do0™g
-9 PLC /0 Mumbering

3.1 Establish New Project

From the functions toolbar, select [File] > [New Project] using your mouse, or press “Ctrl” + “N” and the

following [Project Information] window will appear as shown below:



[ [ Project Information

FProiect Name  |Test
kModel Name  FBs-24MC Edit

Detachable terminal block RTC14 DC24Y inputs, 10 outputs 2 120KHz + 14
20kHz H3C.2 120KHz + B 20KHz pulse output.1 comm. port{can expand up

Desctiption : [Termperature control setings | -

~Options
W Calendar

o 0K | x Cancell

1. [Project Name]: Please input the name for this project for the convenience of subsequent file
management.

2. [Model Name]: Select the correct model type according to the actual operation machine in the dropdown
menu, the program will automatically display the specification description of the particular model type that
was selected.

[Description]: Descriptive text for this project can be printed out.

4. [Calendar]: If the PLC has been built in the calendar, the RTC will always be able to provide the correct
time and date, regardless of whether or not the PLC is being supplied power. The time and date
information provided includes week, year, month, day, hour, minute, and seconds, a total of 7 pieces of
information. With the installed calendar and clock feature, users can control their systems 24 hours-a-day
all year long, allowing your automatic control system to work in accordance with your daily habits and
routines, not only increasing the level of automated control, but also boosting efficiency. The application of

this field depends on whether the PLC exists this equipment.

The window below will appear after you press “OK”, which means that you have successfully opened a new
project. You can begin setting the various settings for your project and engage in ladder diagram program

design (Described in Section 4). Remember to save your work when finished.
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([E]winProLadder [Test pdw] - [Ladder Diagram - Main_unit1] —|of x|
' File Edit View Project Ladder PLC Tool Window Help -|=| x|
|Ds-4d | BER |(Sem (B -p- | R-T-B-8 -5 -5 BB E
KAt QROQ®R 45— |, BB TEE XX % |

2 No00 | |«
- Test[FBs-24MC] | |
i System Configuration
=] Ladder Diagram ——
- B Tahle Edit et |
= Comment i
B Status Page
=-L2 0 Numbering mj-tj-z---l L
|
NOO3
k|
MOO4
A
NOOS |
i
Main_urit] A5 ub_unit] [4] | ’
B [ | [ Overwite  [NOR1C1 |U:0 F:20223 S:A (Doc U0 F-8191) ' ' [

3.2 Open File

There are two ways to open a file: opening a project and connecting to PLC, which are respectively described
below.

3.2.1 Offline Operation

Select [File] > [Open] = [Open] from the functions toolbar, or click the [Z = icon in the tool bar and
select [Open] from the dropdown menu, or press “Ctrl” + “O”, and an “Open File” dialog window will appear:

Lok _in:] winproladder _'_J & =% Eav

Files of type: | Proladder File [* pdw ] =] Cancel

o

And then select the file that you wish to open and press “Open” button.

3-3



Or you can quickly open the file that you previously opened by selecting one of the four latest files that you
had opened provided in WinProladder. Select [File] = [Open] = from the functions toolbar using your mouse,

as shown in the illustration below:

| E WinProLadder [Test pdw] - [Ladder Diagram - Main_unit1]

@) File Edit View Project Ladder PLC Tool Window Help

[ New Project Ctri+N |
= | [= Open Ctrl+0
| Save Ctrl+5 | [ Connect To PLC Ctrl+L
Save As b

1 CAUsers\Y.C. Wang\Desldop\2\Test pdw
2 CA\Users\y.C. \Wangh\Desktoph, 2\ Test example. pdw

Close |

Select the project name that you wish to open. The above operations will open the selected file and display it

in the ladder diagram window, as shown below:

Bl Yty R BT -Hes B BB
L< L -EROEEXXR

rogras
#1220 Numbaring b T0 o
1 1 TUP:
4 | 100
HOOT 0 1P SHFL.
il EN ¢ wo OTE
: =
Ing ERR:
N, M1924 OB WO
| EN Ll
0
ME
NOO3 T0
— | PLS{ 0 Call
10
MO
i L
WD Mo hi'l
— 1 —
0 1 ¥l
i 1}
00E M2 Y2
! {
T\t urdh [Eb ] | i |

L") Overarite Comemnent 38 20185 SN (Dac U FE191)

When a file is opened under off line operational conditions, all modifications can be saved through the [Save]
operations described in section 3.3, or can also be saved by performing the [Save As] - [To PLC] procedures
described in section 3.4.2, which reconnects the currently opened project contents with the PLC and saves it
to the PLC.

3.2.2 Connection

Select [File] > [Open] = [Connect to PLC] from the functions toolbar using your mouse, or click the tool bar
dropdown icon, and select [Connect to PLC], or press “Ctrl” + “L”, and the confirmation window for whether to

connect and open the corresponding project will appear.



-
\l’) wWant to open the associated project file 7

Yes Mo Cancel ‘

1. Click the “Yes” button: which will open the project file and connect to the PLC.( The contents of this project
must be exactly the same as the content of the PLC program to be connected with, or else the connection

cannot be made. )

Files of twpe: | Proladder File [ pdw, fld] | Cancel

The window for the corresponding project will open, select the project file name that you wish to open,
and press "Open” button, and then you should see the content of the project program code, and the PLC

connection window will also appear:

.

On-Line Lﬁ

) Auto Check]
Connection Name

o

S Advanced |  add Edt | Delete |

Details

Adtribute | Data

Station Mumber 1

hedium Serial line

Fart Mo, ComM1

Baud Rate 9e00

Parity Ewven parity

Diata Bit 7 hits

Stop Bit 1 hit

(0]% | Cancel

(Please refer to section 9.1 Connecting to the PLC, for instructions on setting the connection name)
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When the PLC connection dialog window appears, select the desired connection file name, and press “OK”
button, and the PLC connection operation will proceed:
[ Data Receving ... &J

" Systern Data
" Systern Configuration
+" ROR Register
" Ladder Pragram
I Comments
Label Address
Finish

e

(After the connection has been made, information regarding this connection will be displayed)

[ @& pLc status =X=)

[tem Status

E)Station Mu.. 1

ElmModel FBs-Z2aMO4.B2)

# PLC Status Stopped

0 MEMORY_... Mot Set

o Syntax Che.. OF
Fasgword Mat Set
bain Progr.. Mot Set
Sub-Progra.. Mot Set
Data Pass.. Mot Set
Frogram D Mot Set
FLCID Mot Set

3] Calendar Installed

[E]Available p.. 20224Word

ElUsed progr... 38WwWard

ElFree progr.. 2071 85Word

ElMin. 0S5 ver... w4.00

(Press the “OK” button, and the PLC connection process will be completed)

S

Now, any modifications made to the project content of the opened project will be synchronously made to
the PLC side as well, therefore there will be no need to perform the save to PLC operations described in
Section 3.4.2. All you have to do is execute the Save Project operation described in Section 3.3 and save
modifications to the storage disk, the project content on the storage disk will be exactly the same as the

content on the PLC.

2. If you select “No” button: the corresponding project files will not be opened, and the connection to PLC

dialog window will be displayed:
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On-Line L_“E-
Auto Check
Advanced | Add Edit | Delete |
Details
Adtribute Data
Station Number 1
Medium Serial line
Port No. COMI1
Baud Rate 9600
Farity Ewen parity
Data Bit 7 hits
Stop Bit 1 hit
Cancel

(Please refer to Section 9.1 PLC Connection for the setting of connection names)

After the PLC connection dialog box appears, select the connection name and the connection process will

begin:

Data Receving ... =)

" System Data

«F Systern Configuration

+ ROR Register

B Ladder Program
Comments
Lahel Address
Finish

(After the connection has been established, information on this connection will be displayed)

[ [ pLC status =)
ltern Status
B station Mu... 1
Eltodel FBs-24MC(w4.62)

#l PLC Status  Stopped

G MEMORY_.. Mot Set

o Syntax Che... 0K
Fassword Mot Set
Main Progr... MNot Set
Sub-Progra... Mot Set
Data Pass.. MNotSet
Program ID Mot Set
PLCID Mot Set

3] Calendar Installed

[E available p... 20224wWord

EUsed progr.. 38Word

ElFree progr..  20185Ward

ElMin. 05 wer... w4.00

" OK

A

(Press confirm and the PLC connection will be completed)

The project content now displayed will be the content in the PLC, so if you make any modifications, the
content in the PLC will also be modified. Therefore, you may want to use the [Save] operation described in

Section 3.3 to call out the Save As New File dialog box, and save the PLC contents to a storage disk.



3.3 Save Project

Select [File] © [Save] from the function toolbar using your mouse, or click the icon & in the tool bar, or
press “Ctrl” + “S” to save the project, which will save the project to your storage disk. This function can be

used to save the modified project files to your storage disk.

3.4 Save As

When the content of the opened project has been modified, the modified content can be saved to a new file
on the storage disk with a different file name through the steps described in section 3.4.1; and when opening
a previous file by executing 3.2.1, the modified project can also be saved to the PLC by using the operations

described in Section 3.4.2.

3.4.1 Save to Storage Disk

Select [File] = [Save As] = [Project File] from the function toolbar using your mouse. A save as dialog box will

appear, as shown below:

Save in; |'L winproladder LJ ; £k B~

' Test example. pdw
' Test, pdw

File name: |
Save as type: | Proadder for Win [*.pdw) LJ Cancel

(Enter the new file name and press “Save” button and the save as new file operation will be completed)

3.4.2 Save to PLC

When the content of a project has been modified, the modified project content can be saved to the storage
disk under a different project name using the operations described in Section 3.4.1; when executing 3.2.1 to
open a previously saved file, modified project content can be saved to the PLC using the operations described

in Section 3.4.2.
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4 Program Input and Editing

We use a Windows operating system, and everything is designed in accordance with the Windows
environment and operation style. This makes our software very easy to learn and use, and all users, from
beginners to the very experienced, will all be able to operate our software with absolute efficiency. We also
provide special hotkeys and mouse that are specifically designed to fit the particular characteristics of your
office or working environment, making it easy for the user in all conditions and environments to efficiently
input and test programs. Our flexible ladder diagram program editing feature supports high-efficiency
operations such as network insertion, copying, pasting, and deleting, substantially speeding up the

programming process. The following is a detailed description of each feature.

4.1 On-line and Off-line Editing

If you connect upon opening a new project (refer to Section 3.2.2), then you can use the on-line program
editing function, and you can immediately execute the program after you have finished editing and do not
need to re-download, substantially shortening the time needed for development and modification. On the
other hand, if you open the project off-line (refer to Section 3.2.1), then you are using off line program editing,
and you will have to save to the PLC after you are done editing (refer to Section 3.4.2). It also supports run

time on-line editing feature for allowed non-stop application modification.

4.2 Input via Mouse and Hot Key Operation

When inputting program in the ladder diagram window area, you can use your mouse to select component

types from the component tray, or you can input via hot keys, depending on the preference of the user.

4.2.1 Inputting Via Mouse

When editing, you can use your mouse to click on the component tray, and then select contact A:

E WinProLadder - [Ladder Diagram - Main unitl]
@Fﬂs Edit View Project Ladder PLC Tool Window Help

De -6 |BER (we@|G-p- R -%- -B-8-%-5-W-5/B-EB"
MMM QAReR4 NS L EEDEF XXX

Click on the position on which you would like to input the component in the ladder diagram window:
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CEEER

AlelaEr ]Element Edit

Then you will see a dialog box prompting you to enter the reference number for contact A, enter X0, and now

you have completed the input of a contact component in the ladder diagram window:

4.2.2 Input via Hot Keys

Place the cursor at the location where you wish to input the component in the ladder diagram input window,

press the hot key “A”, and the dialog box prompting you to enter the reference number of contact A will appear.
Enter X0, and now you have completed the inputting of a contact A component in the ladder diagram window.
Or, you can directly input “AX0” or “X0A”, which are also fast inputting methods. Or you can press the “Shift” +

“A” Hot key, and then the following diagram will immediately appear in the ladder diagram program location:

1l

Double-click, and follow the above described procedures.

(MODL

WinProladder provides convenient hotkey operation features; please refer to Section 16.1[Hotkey Table].

4.3 Main Program and Sub Program Unit

Operations

In the WinProladder adder diagram programming window, there are two areas- the main program area and
the sub program area- which makes the programming process even more structured. The operation
procedures in the two areas are identical. The following are instructions for performing operations with

program units.
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4.3.1 Establish a New Program Unit

You can devise a plan for categorizing your programming process into different programming segments,
which will provide an additional degree of structure. Therefore, using the feature for establishing a new
program unit, you can make your program even more easily understandable.

We can select [Project] > [Main Program] = [New Unit] in the function toolbar using our mouse, or select

[New Unit] in the dropdown menu after clicking on the B?p . icon in the tool bar:

ﬂ WinFroLadder - [Ladder Diagram - Main_unitl]
File Edit View | Project Ladder PLC  Tool Window Help
OE-g o 10 Cordiguration

M Allocati "B % -
T | S Memons cation
Ul b 4 5 4 4 |, — & @

E_ Y | EE ROR Register :

=@ Projectd [FB|
-1 Systern B Sub Program ks, Delete Tnit

+ % I—I—ai?erEDd:% LSCTT Table Relocate Unit
E ahle :
: fHha Link Table

#-H Commen

»
b| 375 Main wnit]
Zﬂ_ﬂ Servo Parameter Table 4
»
»

Status Ps
= Eﬂo S EﬁjSewongIamTable
H e O Murnly .
i?% Creneral Purpose Link Table

Or, in the project window, go to [Test example] - [Ladder Diagram] - [Main Program] right-click-> [New

Main-Program Unit]:

= [E Test example [FBs-24MC]
+- 1 Svstem Configuration
- Ladder Diagram
tain Frogram
o it I'Ir::'-.l.-' Main-Frogram Tnit
= B Sub i Delete Mam-Program Unit
#0353 Relosats Main-Program Unit
+ % Table Eomn 1
+ B Comment oo
B Status Page J
- Z2 110 Mumbering

After you select [New Main-Program Unit], a dialog box prompting you to enter the program unit will appear.

As an example, you may enter something like “Channel Control”:

New Program Onit

Proararm Unit Name

Charnnel Contral|

W OK | X Cancelj

After you press “OK”, you will find that a [Channel Control] program unit has been added to the [Main

Program] in your project window:
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= [E] Testexample [FEs-24MC]
-] System Configuration
|- Ladder Diagram
- Main Program
5 hdain_unitl
g Channel Control
--B% Sub Pragram
5 Sub_unit]
+- 18 Tahle Edit
-8 Camment
E} Status Page
+- 102 /0 Mumbeting

The procedures for the sub program area [New Program Unit] operation are the same as for the main

program area; all you need to do is select the sub program operation.

4.3.2 Program Unit Deletion

When an established program unit is no longer needed, you can use the program unit deletion function to
delete it. We can use our mouse to select [Project] > [Main Program] > [Delete Unit] in the function toolbar;

or by clicking m}b . the icon in the tool bar and selecting [Delete Unit]:

ﬂ WinProladder [Test example pdw] - [Ladder Diagram - Channel Conirol]
File Edit Wiew | Project Ladder PLC Tool Window Help

MM R B I
|, BB @CE

3 [, New Unit

Dielete Unit |

Eelocate it

OE - ST [0 Comfiguration

T M Allocatio
h*t“;‘“t*ﬂemry cation

ROR Register

=-[E Test exampl'lﬁ?t Main Progrs
w51 Systern B Sub Program '

= B Ladder Dap yocr Taie

»
= @*‘E?EF% Link Table b4 Main, umit]
; ChE Q; Servo Parameter Table » | #° Chamnel Control
e o "L/ Servo Program Table ’
-1 B Sub P'i# )
Loy A, Genersl Forpose Link Table  »

Or select [Test example] > [Ladder Diagram] = [Main Program] right-click [Delete Main-Program Unit] from

the project window:

] Testexample [FEs-24hC]
#-Y System Configuration
=[5 Ladder Diagra MoOL |

e M| [ New Main-Program Tnit

7= C E[:u:—. i
=B Sub Relocate MainProgram Unit
o SuE T

+ B Table Edi G

=K Comrent ; J
B} Status Page

+- L2 |10 Nurmbering Moo |
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After you select [Delete Main-Program Unit], a delete program unit dialog box will appear. Select “Channel

Control™:

Delete Frogram Onit [zl

tdain_unitl " OK
Channe| Contral |_'|
X Cancel

After pressing “OK”, you will be prompted again to confirm whether or not to delete the selected program unit:

ete Program Unit

%

“_?/ Are you sure ko delete Channel Control program unik |

o | ]

Click “Yes” and then you will find that the previous [Channel Control] program unit in the [Main Program] of

the project window has been deleted:

=-[E] Testexample [FEs-24MC]
+-91 Swstem Configuration
- Ladder Diagram
=& tain Program
-4 bain_unit
=B Sub Pragram
I Sub_unit]
+ 1B Table Edit
+- K5 Comment
E} Status Page
R 0 Numbering

The procedure for [Delete Program Unit] for the sub program area is the same as for the main program area,

with the exception of having to select the sub program operation.

4.3.3 Adjust the Order of the Program Units

If, after you have established many program units, you wish to adjust the order in which they reside in
execution sequence, you can use the program unit order adjustment feature. We can use our mouse to select
[Project] = [Main Program] - [Relocate Unit] from the function toolbar, or select the [Relocate Unit] option in

the B}F A\ dropdown menu by clicking on the icon in the tool bar:
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ﬁ WinProLadder [Test example pdw] - [Ladder Diagram - Sub_unitl]
. L) File Edit View | Prl:n]ect Ladder PLC  Tool Wm::lnw Help

D@vﬂ .z"u"I."OConﬁg'umhnn 'EH::'-%%*%E
| 9 Memory Lllocation
T —
[} i’ 2 ROR Register 3 l, 5l Bl T
Test exampl lﬂﬁ r &. Mew Unit
-] System (B Sub Program b s Delets Tnit
i E Ladde”:'%? ASCII Table _
-8 Main B, o Table b4 Main_umit!
HE ME e 0 . R L

Or select [Test example] = [Ladder Diagram] - [Main Program Unit] right-click [Relocate Main-Program Unit]

from the project window:

=[] Testexample [FBs-24MC]
%] Systerm Configuration

= Ladder Diagram Noo1 |

#0 h [ Wew Main-Program Mnit
- O

=

=B Tahble Ed|t
B Camrment
B} Status Page

& 22 170 Mumbering

After selecting [Relocate Main-Program Unit], a dialog box for adjusting the order of program units will appear.

Select “Channel Control”, and if you wish to paosition it after “Change Control”, Press “Move Down”:

Program Unit Relocation [5__(|

& OK

Change Cantrol X Cancel

Maowe Up

Mawe Diown

Then you will find that “Channel Control” has already been positioned behind “Change Control”:

Program Unit Relocation [5_(|

kdain_unitl o OK
Change Control

‘Channel Control X Cancel

hove Up




After you press “OK”, the order of the program units in the project window will also be different:

=l =l
= [E] Testexample [FBs-24MC] = [F] Test example [FBs-24MC]
+-7f System Configuration +- %] System Configuration
—-B Ladder Diagram —-B Ladder Diagram
=-IR Main Program = Main Praogram
#23 Main_unitl 5 Main_unitl
i Channel Control i Change Control
#; Change Control ::> v Channel Control
=B Sub Program =B Sub Program
2 Sub_unitl 2 Sub_unitl
+ B Tahle Edit + B Tahle Edit
+- K5 Comment +- K5 Comment
S Status Page B Status Page

19 10 Mumbering

+

+- 22 170 Numbering

The [Relocate Program Unit] for the sub program area has the same procedures as that of the main program
area, except you choose the sub program operation. Please notice that the program unit location of sub

program area doesn’t matter with the execution sequence.

4.3.4 Modify Program Unit Name

After the name of a program unit has been established, it can subsequently be modified by using your mouse
to select [Test example] = [Ladder Diagram] = [Main Program] = [Channel Control] right-click [Rename]

from the project window:

- [E] Test example [FBs-24MC)
+-%] System Configuration
=[] Ladder Diagram

=B Wain Program
#52 Main_unit]
-5 Change Caontro

i annel C O

=B Sub Program
s Sub_unit]
+- 8 Table Edit
+- 80 Comment
B} Status Page
+- 122 /O Mumbering

After choosing [Rename], you can change the name of this program unit to [Control Channel]:

|

=-[F] Test example [FEs-24MC)
+-7f1 System Configuration
- Ladder Diagram
=B Main Program
5 Main_unitl

> Change Cantrol

i
ta Control Channe
=B Sub Program
72 Sub_unitl
+-[5) Table Edit
+-F Comment
B Status Page
+1-12 /0 Mumbering
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When you have completed the name modification, you will find that the name of the program unit in the

project window and the page name in the cascaded graphical program window have changed.

4.3.5 Enter Program Unit Annotations

When there are a lot of program units, we will need to add annotations to the program units, so that future

lookups and modifications can be performed more easily.

4.3.5.1 How to Input Annotations from the Dedicated Annotations Area

Use your mouse to select [Project] > [Comment] = [Program Unit Comment] from the function toolbar, or

select =, the icon from the tool bar; or go to [Test example] > [Comment] = [Program

Unit Comment] from the project window and double-click on [Program Unit Comment] input area will appear:

3

in Insertion Col
IChange Contro
Channel Contro
Sub_unitl

| Program Unit Comment

Program Unit
Main_unitl

W OK

You will see a list of all program unit names. Double-click on the empty annotations area on the right-hand

side of the “Coin Insertion Count” program unit:

Program Unit Comment

Main_unitl
llin Insertion Co
Change Contro|Count the Accurnulated Nurnber of Coin Insertions |
Channel Contro
Sub_unitl

|
 OK | X CanceIJ

Enter the annotation “Count the Accumulated Number of Coin Insertions”, press “OK”, and the entered
annotation will first appear at the [Coin Insertion Count] top of the ladder diagram program area of this page,
as shown in the following illustration. If you confirm it to be correct then you can press “OK” in the program
unit annotations dialog box. Now you have completed the annotation input for the [Coin Insertion Counting

Program].
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Count the Accumulated Number of Coin Insertions

¥ Program Unit Comment |§|
NOOL : ==
| | Program Unit Comment

Main_unitl

oo llin Insertion Cofe:NisiE] ulated Mumber of Cain Insertion:
| i Change Contro

Channel Contro
NOO3 | 3 Sub_unitl
;Nﬁﬁii'l

4.3.5.2 Method for Selecting a Single Program Unit and Directly Inputting

an Annotation

In the label page [Coin Insertion Count] in the ladder diagram program area, you can also choose to

right-click on your mouse, and then select [Program Unit Comment] in the functions menu that appears:

BB [Ty Select

. | Contact 3
' Output »
Function 4

|~ Horizontal Short
|, Vertical Short
CEEEM] ’ i ) | ™ Horizontsl long

3 Delete
3¢ Delete Tertical Short
I | 3¢ Delete Hovizontal long

] ; : Tnseit Netwark 4
(Noas | Wetwork Edit 4

Pro Wit Comument

(NDOE ’ i ‘ Wetwork Comment

& Cut Ctl+E
i 3 ) . | By Copy Ctl+C
el | B, Paste Cel+ ¥

\Main_unit'l ;{Sub_unit'l Jn{ChanneI EUntroIlCoin Inzertion Countr Select AL Cel4 i

Or, from the function toolbar [Edit] = [Program Unit Comment]; then a program unit annotations input area

representing [Coin Insertion Counting Program Unit] will appear:

¥ Comment

Count the Accumulated Number of Coin Ingerions,

X Cancel
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After pressing “OK” you will have completed the annotations input for the program unit:

Count the Accumulated Number

of <aoin Insertions.

:'Nﬁo'"o"
iNool'
INODZ
CHEEN
:'N60"4"

INOOE

mooe |

T Main_unit] f5ub_uniti i Channel Contraly Coin Insertion Count «] »

4.4 Contact Components Operations

In the function toolbar [Ladder] > A Contact to vertical component item, and the various contact components

listed in the component tray, as shown in the below illustration:

“|E4 E A AtE ) ) o ot e — |
A E u ] [} - I F N H W

By simply selecting the contact component you wish to input, it will be expressed in the ladder diagram

program area. The following are the procedures for doing this.

4.4.1 Input Contact Component

Use your mouse to select [Ladder] = [A Contact]; or select the icon 1L which represents the A
Contact in the components tray; or right-click on your mouse in the ladder diagram program area and the

following popup functions menu will appear (as shown below), then select [Contact] = [A Contact]:

Nooo
: [+ Select
Woat | A
[ Contact A Contact
: . Output » B B Contact
e Function ¥ | h TI Contact
g
— Horizontal Short " TD Cantet
CoGER |, Vertical Short - Tnvers
| — Horizontal long 17 TU Power Flow
{4
x Delets # TD Power Flow
(AL 3¢ Delste Vertical Short
5 Delsts Hoizontsl long
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Then click on the location in the ladder diagram program area that you wish to perform the input at, and the

reference number input dialog box will appear:

: IElement Edit

Enter “X0” and then press "ENTER", and the following screen will appear:

Or place the cursor at the location in the ladder diagram program area in which you would like to perform the
input and directly input “AX0” or “X0A”, and the above screen will also appear; or press “Shift”+“A”, and only
the A contact component will appear in the ladder diagram program area, and there will be no need to input

the reference number for the component, as shown below:

Moo

]
——

(NOOL |

4.4.2 Change the Type or Reference Number of the Contact

Component

When you need to change the component type of a previously inputted contact component, first select the
contact type that you wish to change to (its selection method is the same as that described in Section 4.4.1) ,
then select it from the component tray, and click the contact component that you wish to make the
modification for in the ladder diagram program area, and then the dialog box for inputting the contact
component and reference number will appear. Or you could place the cursor on the component which you
wish to modify, and directly enter “B”, representing contact B, and the dialog box for inputting the reference
number for the contact B component will also appear. If you only wish to modify the component reference
number, use your cursor to select the component that you wish to modify in the program area, and directly
enter the new reference number or press “SPACE” to bring up the editing window for entering the new

reference number, as shown below:
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MOoL |

You can re-enter the reference number for contact B in the dialog box, for example X1, and the previous X0

for contact A will be changed to X1 of contact B.

4.4.3 Deleting Contact Components

You can select X the icon from the component tray, or right-click your mouse in the ladder
diagram program area and select [Delete] from the popup menu, and the cursor will represent the delete
operation; or directly click on the X1 component at contact B, and then press the “Delete” key, this will also

delete the component:

h S LT ERTEE XX ¥

Moo

*o xa
I —t—

gt

MR LT ERMTEE X X %
wooo || @ i

X2
| +—

4.5 Usage of Function Block Instructions

WinProladder also provides a convenient set of function block instructions. We can go to the function toolbar
[Ladder] = [Setting] [Reset] [Timer] [Counter] or [Function], and select any of the above functions that are
needed; or we can also click on the following icon in the component tray, which also represents the function

options:

Sl B [@ [ [E
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4.5.1 Input Function Block Instructions

For example, if you wish to set a timer with fixed time duration, you will need to control when the timer starts,
when it stops, and the accumulative value that it uses for its timing purposes etc., which are all described

below.

Between the X1 contact A and YO output, to set a fixed period timer, you can perform the setting procedures

by entering timer function:

You can select [Ladder] = [Timer] from the function toolbar; or you can select the timer icon from
the component tray; or use the hotkey “Shift”+“T”; Now the cursor has been set to the timer function, click
once between X1 and YO in the ladder diagram program area, and the [Timer] function settings dialog box will

appear:

T(0.015) X Cancel

LES T »
PV: (1000 W

Enter “TO” into the [T] field; enter “1000” into the [PV] field, and you have completed the settings for a set

period timer:

CEEER

- 015— R
1} EN~‘ ’:rup—{
TO 1000

4.5.2 Editing Function Block Instruction

When you wish to modify existing function block instruction, if the cursor is not in the “Selection Cursor” state,
then you should first set the cursor to the “Selection Cursor” state. You can select the icon [ from
the component tray, right-click on your mouse in the ladder diagram program area and select “Selection
Cursor” from the popup menu, and then double-click on the existing function block that you wish to modify,

and the editing window will appear:
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[Nooo | X1
I I
(NOOL
J Funchion ks

r T Pulaelst

(NOD2 ' ' ’ ' ' ’

| ], T (0.015) X CanceIJ
T:

s : : _ : . : i »

| PY: 1000 »

Or select the function block that you wish to modify with the cursor, press “SPACE” and the dialog box for

entering the new reference number will appear.

And now you can proceed with the editing of the function block. For detailed descriptions of the types and

usage methods of the function blocks, please refer to FATEK Programmable Controller User Manual | & II.

4.5.3 Delete Function Block Component

Function block components are deleted in the same way contact components were deleted in Section 4.4.3.

4.6 Usage of Step Ladder Instructions

To give your program a higher degree of readability, to facilitate easy maintenance and updating, and to
substantially increase the quality and reliability of your software, we place particular emphasis on the
sequential control of mechanical operations, combining a wide range of existing ladder diagram programming

languages with the support of step ladder instructions.
Select [Ladder] > [Function] from the function toolbar; or click on the [E] icon in the component tray;

or right-click your mouse in the ladder diagram program area and select [Function] = [Function] from the
popup menu, then click on the location in the ladder diagram program area where you wish to input the step
ladder instructions, and all function categories will appear, then select [SFC] under the category item, and
then four step ladder instructions, which are [STP] [FROM] [TO] and [STPEND] respectively, will appear at

the right hand side of the function name, as shown in the illustration below:

@ Function Lookop (MCY:PLC OS Yer[v4 x]

Function Mame: |STP | JDK |

D escription: STEP instuction x C |
ancel

Class

Basic ~| (S

Timer/Counter 3
Output Operation
Set/Reset

Avrithretic
Logic Operation
Compare

D ata Movement
Chifk /B Ababa

The procedures are described below.
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4.6.1 Input Step Ladder Stages (STP Instruction)

To set an initial step ladder stage SO to serve as the initial stage after a system start, follow the instruction

described below:

Select the contact A component in the component tray, click once on the ladder diagram network and input

“M1924" into the reference number input field:

4k - |19z

Click on the [E] icon inthe component tray, click once behind the “M1924” contact instruction, and then
the [Function Lookup] window should appear, select “SFC” under the [Class] option, select “TO” for the

[Name], press the “OK” button, and the following window will appear:

(Mooo M1924
s

Noo1L | ﬁ]

t+Dy T Pulse(altB) IIIIIEHIIl

CEEEN

: ! TO X Cancel
S

ioos | =t i 2 Help |

Enter “S0”, press the “OK” button, repeat the “SFC”, this time choose "STP” for [Name] and the following

illustration will appear:

(Wooo—

NOOL |

NOOZ =
I ] Function

a3 |
a STP X Cancel

=R
50 » 2 Help |

(NOO4

Enter “S0”, press the “OK” button, and you have completed the setting of the SO initial step ladder stage to

serve as the initial stage after each system starts.

(Wooo - M1924
]
- - I

(NOOT | i
' STRI S0
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You can also add step shifting criteria to the initial step ladder stage. First select [Vertical Short] component
from the component tray using your mouse, then click on "STPI S0”; or place the cursor on top of "STPI S0”,

and press the “V" hotkey.

WooD M1934
L

(WOOL |

After the branching line appears, add shift conditions, for example, we can add two shifting conditions "X0"
and "Y0”".

(Wooo M1924
| O S0

(Woo1 |

STFI =0

and then add the step that you wish to shift to when the shifting conditions are met, in our example, when
the "X0” and "YQ” conditions are met (ON), we shift the step to "S21". Bring out the [SFC] categories, select
[TO] for the function name; or press the “>" hotkey, and after the dialog box appears, enter "S21”, and the

following example is completed:

[Wooo M1924
| O S0

(NOOL |

STHRE so

4.6.2 Input Convergence (From Instruction)

This instruction describes the source step from which the current stage was entered from, and also requires

the meeting of conditions from stage Sxxx to continue to the next step ladder stage.

For detailed examples and an explanation of underlying principles, please refer to Chapter 8 Hardware &
Basic Functions or User Manual I. Here, we only illustrate the steps and procedures for using the

Winproladder ladder diagram program as an example:
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4.6.2.1 Selective Convergence

| FROM 521 | | ] 1| TO 523
. ; re : : 3 y :
FROM S22

If we wish to produce the above results, we could follow the instructions below:

We first bring out the [SFC] category according to the procedures described in Section 4.6, select [FROM] for

the function name, press “OK”, or place the cursor in the program area, and press the “<” hotkey, and the

following window will appear:

Function
FROM h 4 Cancel‘
= |sz1| » 2 Help ‘
Enter “S21", press the “OK” button, move your cursor to the [A Contact] component in the
1k
component 2 tray and click on behind it, and the following window will appear:

Element Edit
A b =[] o

Input “X5”, and press “ENTER?”, use the function block again, bring [FROM] for the function name, press “OK”;

or press the “<” hotkey, and the following window will appear:
woos |
[REEE:

(NOOS | "
I jl] Fuooction

o | CTeA) T PuleAE

I FROM X Cancel
Noo7 | - B 2 ? Help |

Enter “S22”, press the “OK” button, move your cursor to the [A Contact] component in the component tray

and click on 4 ||; behind it, and the following window will appear:

CEEEM| X5

FROM Szl —

CEEEH
| FROM 522

] Element Edit
[BER T » &
Enter “X6”, press “ENTER”, and then move the cursor to the component tray and select |.J [Vertical

Short] component, and then single-click behind the X5 contact; or place the cursor on X5 and press the “V”
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hotkey, and a vertical line will appear, as shown in the following illustration:

CEEEN %5
| FROM z21

FROM 522

Now enter "X7”, as shown in the following illustration:

[MOO3 | X5
| FROM szl

xB
FROM sz

Use the function block again, bring out the [SFC] category, choose the function name [TO] and press “OK”, or

place the cursor in the program area, and press the “>" hotkey, and the following window will also appear:

CEEN

FROM 522

Wooa |

TO . x Canceli
. . . i
o 529 = 7 Help |

Enter “S23”, press “OK”, and you have completed the procedures for this selective convergence example.

4.6.2.2 Simultaneous Convergence

| FROM szl | | ™ 23

FROM 522

When we wish to produce the above results, we could follow the following procedures:
We first refer to the procedures in Section 4.6 and bring out the [SFC] category, choose the function [FROM],
press “OK”, or place the cursor in the program area, and press the “<” hotkey, and the following window will

also appear:

Waas |

NOO&

Function

a7 B :

FROM | X Cancal
e | R 2 ? Help |

Enter “S21”, press “OK”, bring out the [SFC] category again, choose [FROM] for the function name, press
“OK”, or place the cursor in the program area, and press the “<” hotkey, and the following window will also

appear:
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e
NODE

NoO7 |

e | I AR

I FROM X Cancal
CEEEN 50 sz s ? Help ‘

Enter “S22”, press “OK”, move the cursor over to the component tray and select | [Vertical
Short] component, and then single-click behind [FEIH___ST >~ or press the “V” hotkey, and you have

completed the procedure for expressing simultaneous convergence in a ladder diagram program:

[NOOS |

Select the A E [A Contact] component in the component tray using your cursor, and then single-click
behind

NOoE |

E_l_ement Edit

Enter “X3”, and press “ENTER”. Use the function block again, bring up the [SFC] category, choose [TO] for

the function name and press “OK”, or place the cursor in the program area, press the “>" hotkey, and the

following window will also appear:

CEEEE| %3
L i | FROM 521 | |

FROM 522

TO X Cancel
5
o . ) . 527 » 2 Help ‘

Enter “S23”, press “OK”, and you have completed this example for simultaneous convergence.

It should be especially noted that to complete a simultaneous convergence operation, |2 [Vertical Short]
component must be adjacent to the , if there is any space between the two, it will become
a selective convergence operation, as shown in the following illustration:

[Woos | 3
f ]

| FR.OM 521 | |

FR.OM 522
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4.6.3 Input Divergence (TO Instruction)

This function describes the step ladder stage to be shifted to. For detailed examples and explanations of the
underlying principles, please refer to Chapter 8 Hardware & Basic Functions in User Manual |, here we only

describe the steps and procedures for using the WinProladder ladder diagram program with an example.

4.6.3.1 Selective Divergence

| FROM 530 | | ] 1| TO 531
: ! i : ; . y :
| TO s3z

When we wish to produce the above results we could follow the following procedures:

Place the cursor at the location where you wish to input in the program area, bring out the [SFC] category,

select [FROM] for the function name; or press the “<” hotkey , and the following window will appear:

o7 |

NOOS

Function

Fios | LB :

FROM | X Cancel
| ° 15 2 ? Help |

Enter “S30”, press “OK”, and the S30 component of the FROM function will appear in the program area.
Single-click behind the contact A component, enter the reference number “X3"; or immediately input “AX3”, as

shown in the window below:

a7 |

e Element Edit

Now enter X0 right after X3:
Woo7 | *3
| FR.OM S2i

:

L Element Edit

SR »

After X0, place the cursor at the location where you wish to make the input in the program area, and then
bring up the [SFC] category, choose [TO] for the function name; or press the hotkey “>", and the following

window will appear:
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[Woo7 | %3
[ FROM S30 | |

CLEES

TO X Cancel
S
T . . . 531| » 2 Help J

CELEN

Enter “S31", press “OK”, place the cursor at the X0 location, enter “V”, add a vertical line, as shown below:

[Woo7 | %3

L FROM 30 O 531
Now place the cursor under X0, enter “X1” or “X1A":

[Woo7 | %3

L t FROM =20 | | TO 31

Element Edit

After inputting component X1, bring out the [SFC] category again, choose [TO] for the function name; or

press the “>" hotkey, and the following window will appear:

[Noo7 | %3 X0
L : FROM 530 | 1| | | T 531

Woos |
oo | s
X Canc:el|
St s3] » 2 Help |

(Wo1a |

Enter “S32”, press “OK”, and you have completed this selective divergence example.
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4.6.3.2 Simultaneous Divergence

‘ FROM s30 ] | TO 531

If we wish to produce the above results, we could follow the following procedures:
Place the cursor in the program area and at the location where you would like to make the input, bring up the
[SFC] category, choose [FROM] for the function name; or press the “<” hotkey, and the following window will

appear:

Haos |

NOLO

o || e R L

. FROM X Cancel
real B 2 ? Help |

Enter “S30”, press “OK”, and the FROM function will appear. Use the cursor to select the contact A and
single-click the point right behind it, enter the reference number “X3"; or directly enter “AX3” behind it, as

shown in the following window:

Waos |

HO10

Place the cursor in the program area and at the location where you wish to make the input, bring out the [SFC]
category again, choose [TO] for the function name; or press the “>" hotkey, and the following window will

appear:

CEEN %3
| | FROM s20 | |

NO1O

(NO11

TO X Cancel
. . . S
o1z a4 2 ? Help |

Enter “S31", press “OK”, and the TO function will appear. Under the S31 location of the completed TO
function, bring up the [SFC] category again, and choose [TO] for the function name; or press the “>" hotkey,

and the following window will appear:
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CERER %3
| | FROM 530 ] | O 531

NO1O

MO11 |

Function

= T0 | X Cancel
i
P . : : 537 » 2 Help J

Enter “S32” and press “OK". Select vertical line component with your mouse, and click on the

= - icon in the program area; or press the “V” hotkey, and the following will appear:

[HOo3 |
! | FROM s20 | |

Now you have completed an example of a simultaneous divergence operation.

4.7 Editing Mode

In the cascaded graphical program editor, we provide functions similar to the [Replace] and [Insert] modes of

general word processors for your convenience, and below are their descriptions.

4.7.1 Replace Mode

When the status bar shows that the system is under [Replace] mode, the cursor display mode in the

cascaded graphical program area will be as follows:

£ WinProLadder - [Ladder Diagram - Main_unitl] =1
.| File Edit View Project Ladder PLC Tool Window Help - 8 x

Dz -d ||EEn
WM B [R-F-Q-8Q - WS BB R,
RN QRYR4 L4~ |, "EEDLEXIX X

: 1 [nooo | L —
= [B Praojectd [FBs-24MC] = ]
#-1 System Configuration
# B Ladder Diagram sl
=B Table Edit |t I
+ B Cormment

-} Status Page Mooz |
- X69 10 Nurnbering T

NOOZ |
CEoE
Main_uritl A5ub_unit 7 4] [ ]
E[ | | [Cverwne] WiR1C2 4 F:20219 §:H (Doc 1.0 FA191) I
uE G vorsio
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Place the cursor at the location X1, directly input “X2”, then the following will appear:

£ WinProLadder - [Ladder Diagram - Main unitl]

File Edit View Project Ladder PLC Tool Window Help -8 x
BsS-d B B
e lEm e MR- oy s oW B S
it MM Q@R 1w — [, "ERMOCE X Ix ®
= 2l [nooo | i
- ] Projectd [FBs-24MC] =
4§ System Configuration
+ B Ladder Diagram Moo %0 s : :
+ B Table Edit L — | | e
+ K Comment
i @ Status Page ooz | : .
+ X2 110 Numbering 0]
CEEEM!
(Wods |
i Main_unitl £5ub_unit1 7 4] [ ]
L ES NIR1C:3 U4 F20219 8N (Doc 0 FE191)

X2 has replaced X1. This is the replacement mode of operation. If you press the “Insert” key again, you will

switch back to the insertion mode.

4.7.2 Insertion Mode

When the cascaded graphical program is in replacement mode, press the “Insert” hotkey, and you will switch
the system into insertion mode, where the status bar will display [Insert] mode, and the cursor in the program

area will become square shaped, as shown in the following.

8 WinProLadder - [Ladder Diagram - Main_unitl]

=) File Edit View Project Ladder PLC Tool Window Help
DS-0 ||[BE5
peeEm B 8 -8 -5 W5 (BR-ER
RAbMM M QRO R- LT~ [, ~[SRTEFE XX %
'l [Nooa | =
=[] Projectd [FBs-24MC] -
+ -] Systam Configuration
=B Ladder Diagram noo1 | o] WL
+- 18 Tahle Edit = | | — [
-85 Comment
B} Status Page o0z |
#4210 Numbering P
CEEER
CECES
~yMain_unit] £Sub_unit! 7 4] [ ¥
G = | WiR1C2Z U4 F-20210 8N (Doc U0 Fa191)

Now place the cursor on the X1 component, and directly enter “X2”, and you have inserted a reference

number X1 component between X0 and X1, as shown below:
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ES WinFroLadder - [Ladder Diagram - Main_unitl]
Fde Edit View Project Ladder PLC Tool Window Help

IDs-'d |BEER
R R R R R B R R R N

B -| & i
il e e e s e (S RUIMECEEL il

E T ;
=1-[E] Projectl [FBs-24MC) = |
®=-%1 System Canfiguration
i+ Ladder Diagram F7 T

(o1 | po]
+-f& Table Edit |
+-M Comment

I

B Status Page

Nz |
-2 /0 Numbering -

COCEm

Moo

Main_unit] ASub_urit] /

4 I

&= [N1R1C3

U5 F:20218 80 (Do U0 FE191)

This is the insertion mode, and if you press “Insert” again you will switch to the replacement mode.

4.8 Changing of Components and Reference Numbers

You will often need to perform changing operations during component editing in the program area, in addition

to the replacement mode described in Section 4.7.1, this can also be accomplished using the [change]

function provided in the function toolbar, as described in the following:

Example: The procedures for changing X2 into X3 are described below:

0

%1
— — —  —

xa
—— —

x1

First, in the program area, select the network number that the contact instruction you want to change resides

in, as shown below:

Execute [Edit] > [Replace] in the function toolbar; or press the “Ctrl” +“R” hotkey, and the following changing

dialog will appear:

i

Replace

Find Fef: |><2

Length: 11

Replace Ref: 1x3|

Range

(Nooz | + Select
i " Current Unit

Fooe C Al
Options
;'Nﬁﬁ's' v "Also replace the comment and dest

' OK | x Cancel‘
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[Find Ref] is the reference number for the component that you wish to change, in this example, it is X2.

[Length] is the total length of the component which you wish to replace, in this example, it would be 1. If you
were to enter 10, it would mean that X2~X11 would be changed, and the changing also proceeded in
accordance with the reference number sequence, for example, if you were to enter X0 in "Find Ref”, 10
in "Length”, MO in "Replace Ref”, then X0~X10 would be changed into MO~M10.

[Replace Ref] is the reference number of the component which you wish to replace.

If [Range] is the “Select”, then only all X2s will be changed into X3s in the selected network.
If [Range] is the “Current Unit”, then every X2 in the program unit will be changed into X3.

If [Range] is the “All”, then every X2 in all units of the project will be changed into X3.

For [Options] check “Also replace the comment and descriptions”, and the annotations and descriptions for
X2 are replaced by those for X3 as well, and after you press “OK”, the total number of replacements will be

displayed. In this example, we have completed the replacement of 1 reference number.

(NOoD

=0 X1
— —— ——

Replace

(NOOL |

‘E) Total 1 replacementi(s) were made

MO0z

4.9 Searching for Components

Because of the structural design of the WinProladder software, there are also two ways to search for

components, which are described in the following.

4.9.1 Search One at a Time in the Current Program Unit

If you want to search for an X3 component in the current program unit, please execute [Edit] = [Find...] from

the function toolbar; or press the hotkey “Ctrl”+“F”, and the dialog box for setting up search criteria will

appear:
Find X
Find I Find In Prnjecﬂ
Find Ref. [
Type
™ Contact I~ Output ™ Function
I¥ A Contact v Cail ¥ Function Name
v B Contact W Inverse Coil W Label
v TLJ Contact ¥ Explicit Fun. Parameter
v TD Contact ™ Implicit Fun. Parameter
[™ OnlyVolatile Parameter
Range Starting address Direction
Al " Inger Network = Up
 Mark Araa & Curgor Position & Daown
X Cancel
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Enter “X3" into the reference number field, you can also check the category of the component that you wish to
search for in [Type], and set the search range in [Range], and set the start point for the component search in
[Starting address], and specify to either search upwards or downwards in [Direction]. Press “OK”, when the
program finds the first X3, the cursor will be placed at its location; if there are other X3 components in the

program unit, a dialog box asking whether or not to continue searching will appear:

Moos |
TO 523
(MOOE
Noo7 | . oo oxo
L 4 FROM 530 | | ] | T 31
- ) . . ) .
| TO s3z2

When you press the “Next” button, the program will search for the next X3, until the end of the program unit.

When there are no more X3 components, a dialog box saying “Search not found” will appear:

j) Search not found

If you press the “Cancel” button, the program will not search for the next X3, and the cursor will stop on the
last X3 location. If you want to continue searching for the next X3, you can press the “F3" hotkey, which
stands for [Find Next]. If you continue to press “F3”, the program will continue to search for subsequent X3
components, all the way to the end of the program unit. When there are no more X3 components, you will see

a “Search not found” notification dialog box.

4.9.2 Batch Searching in Projects

To perform a batch search for component X3, please execute [Edit] = [Find in Project] from the function

toolbar; or press the hotkey “CtrlI” +“F3”, and the search criteria dialog box will appear:

Find g‘

Find Findt In Project }

Find Ref  [x3]

Type

[ Contact [ Output I Function

¥ A Contact v Cail W Function Name

¥ B Contact v Imverse Coil W Lakel

v TU Contact W Explicit Fun. Parameter

v TD Contact W Implicit Fun. Parameter
I~ Only %olatile Farameter

Range

& Al

 Opened Program Unit

 Program Unit on cursor

X Cancel
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The [Find Ref] and [Type] are set in the same way as described in Section 4.9.1.

Set [Range] to “All”, which specifies to search the entire project. If the [Range] is set to “Opened Program
Unit”, then only the currently opened program units will be searched. Press “OK” and all

the search results will be displayed in a new window in the program area, as shown
below:

4 WinProLadder [Test example-2_pdw] - [Ladder Diagram - Main_unitl]

FﬂB Edit View Project Ladder PLC Tool Window Help =| &k
|los-a ||EEs8 |
e G- R -B-Q - -W-5 R EBEN

FUEMM M G999 44— [ "EEMOE XX R

= [ Projectl [FBs-24MC] 19 =0 j
-1 System Configuration
+1-f Laclcer Diagram NooL | ’ ' ' ' ) )
B Table Edit | I R
+-80 Comment
B} Stetus Page | w0 ¥
+ 152 140 Murnbering | | | | O i
Mooz |
inoo3 | ) x5 X7
L FROM szl ] | 1 | l ™o 523 -
Mair,_uritl 45 ub_uritl K I 2

()0
[Search Resul] Main_unit! (9)[0:2]:  x3  "«<3"

A Overwrite  |[NOR1C: [11:58 F:20165 S (Do U:0 FA191)
—

Double-click on one of the search results in the [Search Result], and the cursor will move to the selected X3:

R WinProLadder [Test exomple-2.pdw] - [Ladder Diagram - Mam_unitl]

File Edit View Project Ladder FLC Tool Window Help

—_ %
|pz-a |28 |
|sp@ |- - % % B8 -%-5 W5 B-[EE
[BHEMMMRRRY 4T | " EEANEOEXXR
= 4]
=-[E] Project] [FEs-24MC] |
%1 Systern Configuration :”005 R

| FROM Szl ] |

+- B Ladder Diagram

+ B Table Edit _ . . . . . . J
+-B Comment

B} Stetus Page
+ 152 140 Murnbering

FROM 522

fdain_unitl 4 5ub_unitl 4 1
w3 el

[Search Besuli] Main_unit! (7[0
Fesult] Main_unit] {4

1. Double-click.

Overwrite  NTRIC3 1158 F20165 & (Do U0 F2191)

I#:

4.10 Network Operations

Networks are an important element for the ladder diagram program area, and there are many ways to

4-28



perform operations on them. The following is an introduction to methods for performing network operations.

4.10.1 Copy Single Network

Select the network that you wish to copy using your cursor, for example, network number N009, as shown

below:

FROM

Right-click to bring up the popup menu, select [copy]; or press the “Ctrl"+“C” hotkey, and execute the copy
operation, and right-click again to bring up the function menu, select [Paste]; or press the “Ctrl"+“V" hotkey,

and execute the paste operation. Now you have completed the copying of a single network:

REEEN w3
| FROM 530 | | T 531
TO s3z

%3
FROM 5300 3 | | TQ 531
O 53z

4.10.2 Copy Multiple Networks

To copy networks with adjacent numbers NOOO through N00O2, you can select NOOO through NOO2 via
click-and-drag, or press and hold “Shift” while selecting NOOO through N002, as shown below:

ooo | M15924

NOOL I

—|;|

NOOZ |
- FROM

FROM

Then use the same copy and paste procedures as described in Section 4.10.1, and you have completed the

procedures for copying multiple networks with adjacent numbers.
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If you wish to copy networks NOO1 and NOO3, whose numbers are not adjacent to one another, first click and
select network NOO1 with your mouse, then select networks NOO3 while holding down the “Ctrl” key, and you

will obtain the following result:

FROM

FROM

Now you can perform the same copy and paste procedures as described in Section 4.10.1,and you will have

completed the operation of copying multiple networks whose numbers are not adjacent.

4.10.3 Copying Networks from Different Projects

First, executing the WinProladder application software, and then open the first project file; now execute the
WinProladder software again, and then open the second project file, so that you now have two WinProladder
application software windows opened. Select network NOO1 in project one, and then right-click on your
mouse to bring up the popup menu and select “Copy”, or, press the hotkey “Ctrl”+“C” to copy it. Then place
the cursor in Project 2 where you would like to paste it, and then right-click your mouse to bring up the popup
menu and select “Paste”, or, press the hotkey “Ctrl”+“V” to paste it on. And now you have completed the

procedure for copying networks between projects.

4.10.4 Deleting Networks

Select the number of the network that you wish to delete, and execute [Edit] = [Delete] from the function
toolbar; or press the hotkey “Delete”, and a dialog box asking you whether or not to [Delete Network] will

appear:

FROM

Press “Yes” button, and the network will be deleted.
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4.10.5 Network Row and Column Editing

Ladder diagram program area is composed of many network with numbers, numbering the rows and columns
of a network can make your program very organized and easy to maintain. The rows and columns of a
network can also provide many functions, which can help make your programming process even more

convenient and fast. The following is a description of how to use these features.

4.10.5.1 Expand to 22 Columns

When there are many contact components, the original 11 columns of a network may not be enough, and you
can expand the network to 22 columns. Place the cursor on the network that you wish to expand to 22
columns, execute [Edit] = [Network Edit] = [Expand to 22 Column] from the function toolbar; or right-click on

your mouse to bring up the popup menu and execute [Network Edit] = [Expand to 22 Column].

I WinProLadder [Test example-2.pdw] - [Ladder Diagram - Main_onitl]

EEX
Fxle Edit View Project Ladder PLC  Tool Window Help -8 %
DE-d || BEE &
e B Rt B8 -T--H5 BB
G e e i B RIMIEEEEX X%
2 h92g -
= [ Project [FBs-24MC) ; o 50
#-%1 System Canfiguration
# B Ladder Diagram i .
C % Table Edit o =
B Comment
B3 Status Page w0 v
1 %2 1J0 Mumbering | — I 0 s21
X5 X7
FROM 521 [} TO 523
3 . 2 s
FROM 522
Main_unit] £5ub_unit] El e | 3
= Querwrit O RA§C 1L |52 F:20165 3. (Doc U0 FA191)

I

‘E WinProLadder [Test example-2.pdw] - [Ladder Diagram - Main_unitl]

Fx]e Edit View Project Ladder FLC Tool Window Help

- 8 X
OE-H BB W
Weem B[R B -8-Va-h WS BE R
G e et [ BIBITNICHEEX X %
- El .
= &) Projectl [FEs-24MC] o S0
= “T% System Configuration
= [ Ladder Diagram
= BB Tahle Edit
= By Comment
B Status Page
= %2 /O Numbering
-
Main_uniti £Gub_uni] [« »
BE | Overwrite  |NOR: 1150 F-30164 S0 (Doc U0 FA191)
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4.10.5.2 Shrink to 11 Columns

Place the cursor on the network that you wish to shrink from 22 columns to 11 columns, execute [Edit] >
[Network Edit] = [Compress to 11 Column] from the function toolbar; or right-click on your mouse to bring up

the popup menu and execute [Network Edit] > [Compress to 11 Column].

4.10.5.3 Vertical Expansion

If you wish to increase the vertical space between upper and lower rows X1and X3, as shown in the following

illustration: woo Wl
_I Ii
%o Wl
A — -
w3 |
._I . . : :

Then select X3 with your cursor :

w0 ¥l
) }_hl—
Execute [Edit] > [Network Edit] = [Vertical Expand] from the function toolbar; or right-click on your mouse to

bring up the popup menu and execute [Network Edit] - [Vertical Expand] and you will have completed your

vertical expansion.

4.10.5.4 Vertical Compression

If you wish to save the vertical space between the upper row X1 and the lower row X3, as illustrated below:

_|><|:| Cowl ) .
— 50 wl
-
w3 T
—

Then use your mouse to select the blank space between X1and X3 that you wish to compress:

wno Wl

_l |7
]
.
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Execute [Edit] = [Network Edit] = [Vertical Compress] from the function toolbar; or right-click on your mouse
to bring up the popup menu and execute [Network Edit] = [Vertical Compress] and you will have completed

the vertical compression.

4.10.5.5 Horizontal Expansion
If you wish to increase the space between X0 and X3:
0 X1 =0 = I

Execute [Edit] = [Network Edit] = [Horizontal Expand] from the function toolbar; right-click on your mouse to
bring up the popup menu and execute [Network Edit] = [Horizontal Expand] and you will have completed the

horizontal expansion.

4.10.5.6 Horizontal Compression

If you wish to shrink the space between X0 and X3:

w0 e A w0 Wl
— —— > — — -

Execute [Edit] > [Network Edit] > [Horizontal Compress] from the function toolbar; or right-click on your

mouse to bring up the popup menu and execute [Network Edit] = [Horizontal Compress] and you will have

completed the horizontal shrinkage.

4.10.6 Insert Blank Network

If you wish to insert a blank network above network number NO12, you can proceed as follows:

Right-click on your mouse on any component in the NO12 network in the cascaded program area and bring
up the popup menu. Then execute [Insert Network] - [Before This Network]; or right-click on the network
number NO12 and bring up the popup menu. Then execute [Insert Network] - [Before This Network]; or
press the hotkey “Shift”+“Insert”, and then network NO12 will be a blank network, and the network content

that was previously numbered N0O12 will become network NO13.

oLz | =0 3 pul
I | | ] | o s20

T 521
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HOLS ®n Cowz

TO S2L

4.10.7 Insert Network Annotations

For example, if you wish to input annotations for network N012, you could place the cursor on the number
NO12 or any component in it, and execute [Edit] > [Network Comment] from the function menu; or you can

right-click to bring up the popup menu and execute [Network Comment], and the network annotations

inputting area will appear:

¥ Network Comment E @ gl

Annotations for Salution Metwark MO0

o 0K | x Cancel‘

Enter “Annotations for Solution Network N005”, press “OK”, and you will see the annotation in the row above

network serial number NOO5:

EHHDE3E1 Ofs Tor So0lUC10n NEENDI"K MO )

HOOS

‘ FROM S21 | | TO 523

FROM S22

Or you can double-click on [Test Example] = [Comments] = [Network Comment] in the project window, and
all the network serial numbers will appear. Find network NOO5 and double-click in the blank annotations area,

and the blank network annotations input area will appear:
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W Network Comment

kain_unitl ]Sub_uniﬂ

Ladder No.

Comment

NO003
NOOD4
NO005

NODO6 Annotations for Solution Network HO0E|

_ W OK |x Cancel.]";

Enter “Annotations for Solution Network N0O05”, press “OK” button:

i Network Comment

kain_unitl jSub_uniﬂ l

x]

Ladder No.

Comment

NODD3

NOD04

NOD05
NODDB

W OK

Press the “OK” button again, and you will have completed the network annotations inputting procedure.

4.10.8 Network Searching

If you wish to search for network NOO1 in the [Coin Insertion Count] program unit, you can execute [Edit] >

[Goto...] from the function toolbar; or press the hotkey “Ctrl”+“G”, and the following window will appear:

Goto ...

Frogram Units

kdain_unit
Cain Insertion Count

Channel Caontrol
Change Control
Sub_unitl

MNetwark Numbet I2|

" 0K | x Cancel‘

X
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Select “Coin Insertion Count” in the [Program Units], and enter "2” to represent N0O2 in the [Network Number].

Press “Confirm” button, and the cursor will move to the position of the network you are looking for:

g WinProLadder [Test example-3.pdw] - [Ladder Diagram - Coin Insertion Count]
File Edit ¥iew Project Ladder PLC  Tool Window Help | [

Ds-d |[BEE®
wem o8-8 -5 BREB
BUEAMMQQeR, 14— [ "EENOEXX®

[»

=B Test example [FBs-24MC] (Mool )<2I \Ifl} W12 W13 W15 11P. (4]

i System Configuratian : LR I It It gl e ERa

&

=[] Ladder Diagram shbr R4
= hiain Program

> bain_unitl

. Cain Insertion Caunt ] ] ; y

. Change Cantrol LR

» Channel Control

=B Sub Program — . 3 - e
i Nanz
s b Jni L i ) ) N ) o sa o Re Lasd
+- I8y Tahle Edit
=B Corment . . ) ) sk RO

X6 X
B Status Page 1 —u/s fazb-{

+- %2 [0 Numbering

—u/s{ D Rd Cv—

1% 1% 1%

ach
GEEE mo T Mzg M1g
i M a4 | | 1/ i
% Main_urit] 45 ub_urit] b Cain Insertion Caunt 4] | ]
B E Overyrite NZR:1C:d 1:37 F:20186 SN (Doc .0 F:3191)

4.11 Ladder Program Syntax Check

4.11.1 Execute Syntax Check

After you have completed the input of your application program, you can run a syntax check, which will help
you find errors in the program. We can execute [Tool] = [Syntax Check] from the function toolbar; or press

the “F8” hotkey, and the statistical syntax error table will appear:

Syntax Check 5 J

Error Count 11

Warnihg Count: 5

After you press the “OK” button, if there are errors, the errors will be listed under the program area, and if you
double-click on one of the error items, then the erroneous component segment will be displayed in the

program area, as shown below:
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E WinProLadder [Test example.pdw] - [Ladder Diagram - Main unitl]

File Edit View Project Ladder PLC Tool Wmdow Help
ODE-d B i W
e o R R TR WS BB R
el e e e e e e (SN e e
= [naza ¥E K7 j
=[] Test example [FBs-24MC] FROM s21 I
=i System Configuration
= Ladder Diagram %6
+- By Takle Edit FROM s22
= B4 Comment
B3} Status Page [Ho1s . 1
+ ¥2 10 Nurnbaring _ = =2 2. The cursor will move to the erroneous component segment.
FROM s22
[NOT6 : *oa Fo]
i | FROM 530 ] | | | l TO 5321 -
Main unitl ASub_ unit [l ] il
A[Stepernar) E75 STF S0 76.The STP( 20- 57) and STPEND does not match A

Step erar] EBE TO 521 GE.TO# without a corresponding STP#
Step error] EBE TO = B6.TO# without a carresponding STP#
[Step error] EEY FROM a1 B9 Duplicated FROM Sxxinstruction
[Step error] EBS FROM 522 B4 Duplicated FROM Sxx instruction
[Step error] EBG TO 523 66 TO# without a corresponding STP#
[Step error] EGE TO 53 GE.TO# without a corresponding STP#

S ~ ~an e T L

1. Double-click.

=1 Overwrite  |N14R:1CH 1194 F-20129 §:4 (Doc U0 FA151)

Please refer to User Manual | —Hardware & Basic Functions description for the syntax rules of the FBs

series PLC, and also refer to the syntax error codes table. The display segment of the error list contains two

types of messages: one is the syntax inspection results error table; the other is the results for the project

contact component reference number search; right-click on your mouse and three options will appear in a

popup menu:

1.

Clear results for syntax check: the execution of this item will clear error messages resulting from the
[Syntax Check].

Clear results for data search: the execution of this item will clear results from the [Search in Project]

command.

Save Messages: this will save the error messages from the error table in the display area to a text file.

4.11.2 Syntax Check Setting Options

In addition to the user being able to perform a syntax check at any stage of program editing, before executing

(RUN), the system will also automatically perform a syntax check to ensure safety. The user can specify the

items to be checked for both the user initiated syntax check and the automatic system initiated syntax check.

Execute "Project” - "Options” or press the Ctrl+F8 hotkey, and the following screen will appear:
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Options

|gnored Meszages

[ Dwplicated Coil [~ MCE Before Matched MC
[ Duplicted SET/RST [~ SKPE Before Matched SKP
[ Duplicated Timer [~ CALLJMP Target Mot Exist
[~ Duplicated Counter [T Subrouting ‘Without BTS
[ D5W Function Multiple Usage [ Subrouting Without RTI

[ PL50 Function Multiple Usage [T Contact without Fieference Mumber
[ PwM Function Multiple Usage [~ Open Contact

[T Can't Find Matched MC Function [ Function Incompelated

[ Can' Find Matched MCE Function [~ STEPw arming]

[ Can't Find Matched SKP Function [~ Others

[~ Can't Find Matched SKPE Function

lanored Syntax

r

STEP

Stop Conditior

Stop Error Message Counts

|25— [ .. 50
|25— [1..50]

gf oK | x Cancel |

Stop “Waming Meszage Counts :

In this options page, the user can specify the item that they do or do not want to check, and when the
conditions for stopping the check have been met (when the number of error or warning messages has

reached the specified limit), the system will cease the syntax check.
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5 Table Entry and Editing

To give users a familiar interface for producing tables, communications parameters, and command table
settings, the Winproladder application provides tabular entry features. The following is an introduction to the

various tabular operations.

5.1 ASCII Table

For text table usage and internal representative meanings, please refer to Chapter 14 Advanced Functions in

User manual Il:  Application of ASCII output files.

5.1.1 New ASCII Table:

Select[Project]>[ASCII Table]>[New ASCII Table]from the function toolbar ; or select [New ASCII Table]from
the dropdown menu by clicking on the '3% = icon in the tool bar; or, in the project window,
right-click and select [New ASCII Table]from [Test Example]>[Table Edit]>[ASCII Table]:

=-[&) Test Example [FBs-40rC)
+ %3 System Configuration
+- B Ladder Diagram
--5& Tahle Edit
% .i'k!:i[_:iH Tahle % New ASCII Table
% Link Table M
8 Servo Pararm .
& Servo Program Takle
R, General Purpose Link Takle
2 Register Table
W% ModBus Master Takle
+-B Caorrment
B} Status Page
+- X2 110 Numbering

and the table edit window will appear:

Table Properties
Tahle Type: [ =]
Table Name |5ubstrate Division Production Ste

Table statting address: [RD

Table Capacity: ™ Dynamic Allocation
" Fixed Length

r
r

Description
Subgtrate Division Production Statistics Taklg|

X Cancel

Input “Substrate Division Production Statistics Table” in the [Table Name] field, and define “R0” as the [Table

Starting address], choose “Dynamic Allocation” for the [Table Capacity], and input any descriptive text that
you would like to specify in the [Description] field :
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Z-ASCIMable = [Substrate Division Production Statistics lable|

k= =) = et B
Import Textll ExportText(E) CalculatorC) Setup(S) Dutput Prenview
ASCI Editor
Allow: 3540 words{fuka) Used: 0 wards Cursaor position: RO[L]:

Output Presiew

W COK | X Cancel|

The text for the table that you would like to output can be input in the [ASCII Editor] field, and when you are

inputting, you can preview your output in the [Output Preview] field below. Or you can click the

lmpm:‘?'rmw Button, and select a text file that you would like to import, cutting down on the time needed for
input:
Gpen o)
Look in: | B winproladder j = =5 B
R Y0701 bt

B best txt

File: name: |D?D1 bt
Files of type: |Te:-:t Filz [* txt] ﬂ Cancel

A

B
After you finish inputting, you may also click the ExportTextiE) icon and save to a new text file, so
that you will be able to open and reuse the file at a later time.

When you click the “id icon, you will enter the same window as when you select [New Table] and
Setup(3)

enter the [Table Name] initial settings windows..., where you can perform additional renaming and description

modifications. After you have finished editing the text table, press the “OK” button, and you will have

completed the creation of the new text table, and you will see that a new item called [Substrate Division

Production Statistics Table] has appeared in the [Project Window], as shown below:
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I

TestExample [FBs-40MC]
+-41 System Configuration
+-p Ladder Diagram

--[& Tahble Edit

I A2 Substrate Division Production Statistics Tablel

T Link Table
B! Sero Parameter Tahle
8 Serso Program Takle
R General Purpose Link Tahle
‘2, Register Tahle
iﬁé ModBus Master Table
+-F5 Comment
B Status Page
+- L2 170 Numbering

Also, under [Project]>[ASCII Table] in the function menu, the new item [Substrate Division Production

Statistics Table]will have also been created, as shown below:

£ WinProLadder - [Ladder Diagram - Main_unitl] HEEH
Fil: Edit ¥iew  Pmject Ladder FLC Tool Window Help e x|
OEs-E 2 110 Confignration
@ Memony Allocation
RCE Register

gﬁvggn'%’é' @' E?EH‘“?
|, " E B @E E X X %

i Sub P
Test Exampl ¥ Sub Program

+-51 Shstern O % 1 Tahle
+-F Ladder D P Link Tsbls
--By Tahle Ed ﬁ_ﬂ Servo Parameter Table »
—-B2 ASCI 8 Servo Program Tabls 4
%7 Su Py Genersl Puposs Link Table  »
W, Link T 2 Register Table ’
8 Servo B ModBus Master Table v

8, Seno & 1ak Configmation

W8 Genet
‘2, Regis Status Page 3
Wi ModB  Comments 3
+ H Cammen Project Setup 4
§ StatusPe b et Register Allocation
+ e {0 MUk .
Program conversion 4

Froject Information

Ciptiomns Ctl+Fa
< ¥ WMain_unit] f 4] [ ol
By Chveruite NOR:1C:1 U0 F:20223 3:C (Doc T0 F2191)

5.1.2 Modify ASCII Table Name

In the project window, select the text table with the name [Basic Section Group], right-click on your mouse and

select [Rename] from the popup menu that appears, and then you will be able to modify the name:
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Project] [FBs-24MC]
+-%] Swstem Configuration
+-f Ladder Diagram
--[& Tahle Edit
=82 ASCH Table
G 74 Eiasic Section Group
A2 Substrate Division F el cz Table
fw Link Table
& Seorvo Parameter Table
8 Servo Program Table
%n, General Purpose Link Table
2 Register Tahle
Wi todBus Master Table
+-B5 Comment
B Status Page
+- 120 ;0 Mumbering

Or, you can double-click on the name of the [Basic Section Group] ASCII table, and select [Setup] in the

ASCII table input window that appears, and you will also be able to modify the name.

=5 Table Edit 1
e

Tahle Properties

Tahle Type: | =]
Tahle Name: ]

Table starting address: |R1
Edit Length: |

Tahle Capacity: ™ Dynamic Allocation
" Fixed Length

E
-

Description

W OK | X Cancel|

5.1.3 Delete ASCII Table

Select [Project]>[ASCIl Table]>[Delete Table] from the function toolbar; or click on the %% o icon
in the tool bar and select [Delete Table] from the dropdown menu; or, in the project window, in [ Text
Example]>[Table Edit]>[ASCII Table] right-click and select [Delete Table]:
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est Example [FBs-40rC]
+-] System Configuration
+-f Ladder Diagram

-- I Table Edit

= Dms B2 Wew ASCII Table
U

74 :
Delete Table
S Link T 2

! Servo Parameter Table
8 Serso Program Table
¥a General Purpose Link Tahle
2 Rengister Tahle
®i ModBus Master Table

+-B0 Carnrment

B Status Page
-2 /0 Numbering

and the deleted text table window will appear:

Delete ASCIT Table ]

Basic Section Group
Substrate Division Production Statistics Tahble

W 0K X Cann::el|

Use your cursor to select the “Substrate Division” ASCII table item, and press “OK”, and you will see a

deletion confirmation window:

Delete" ASCII Table

\:‘p Are you sure to delete the Basic Section Group table

Press “Yes”, and the “Substrate Division” item under [ASCII Table] will have disappeared.
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- [E] Projectl [FBs-24MC]
+-%] System Configuration
+ [ Ladder Diagram

A2 Substrate Division Production Statistics Tahle

B Link Table
B! Servo Parameter Table
8 Serso Program Table
R, General Purpose Link Table
‘2 Register Table
Wi ModBus Master Table

+-K Carmrment

B} Status Pags
+- 22 |10 Mumbering

5.2 Link Table

5.2.1 General CPU LINK Communication Table

5.2.1.1 Create a New General CPU LINK Communication Table:

If you wish to create a new “General CPU LINK Communications Table”, please execute [Project)]>
[Link Table]=>[New Link Table] from the function toolbar; or click the iﬁ% ~ icon in the tool bar and select
[New Link Table] from the dropdown menu; or select [Test Example]>[Table Edit]>[Link Table]-=>[New Link

Table] from the project window, as shown below:

=-[F] TestExample [FBs-40MC)
+ -] System Configuration
+-f Ladder Diagram
- B8y Tahle Edit

+- B2 ASCI Tahle
Wy
8 Senvo P Wy New Link Table

8 Seno Pro T Delete Table

¥, General Purpose Link Takble
‘2] Register Tahle
#i todBus Master Takle
+-K Comrment
B} Status Page
- 120140 Numbering

An [Table Edit] window will appear, select “Normal Link Table” from the dropdown menu in [Table Type], input
“General CPU LINK Communications Table” in [Table Name], and then set the [Table start address] and enter

the necessary descriptive text:



= Table Edit

- Table Propertie

Tahle Type: Normal Link T able g
Tahble Name: General CPU LINK Communicatic
Tahle starting address: |RD

Tahle Capacity: ™ Dyhamic Allocation
" Fixed Length

[T Load Takle Fram PLC
[T Load Takle Fram ROF:

Description
General CPU LINK Comrrunications Taklg|

W OK I %X Cancell J

The [Table Capacity] allows the user to choose whether to allow the system to automatically and dynamically

set the editable length and size of the table, or to manually set a fixed length range and not let the table

exceed this length. For example, if the user chooses a fixed table content length of 30:

- Table Propertie
Tahle Type: |Mormal Link T able Bl

Table Name: General CPU LINK Comrunicatic
Tahle starting address: |RO

Table Capacity " Drywnamic Allocation
™ Fixed Length |37

(Unit\WORD)

[T Load Takle From FLC
[T Load Takle From ROR

Description
General CRLU LIME Communications Takle

W DK I x Canc:ell

When adding a new communications item, the total length must not exceed 30.

|
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| " Normal Llink Table - [General CPUTINK Communications Table]

= i &
Calculator(C) Setup(S) hdmnitorhd)
Link Cormmand

Sen. | Command | Slave | haster... | | Slave ... | Diat... | Addl |

1] Fead 1 R200 <- R200 20
1 Fead 1 R100 « R100 20 M

¢ Whrite 1 01an -» oan 20 )
3 Write 1 oo > oo 2 | Ed |
Delete |
If the length of the next item will exceed 30, ’

ou will not be able to create a new communications item. Ml
7y [ 0= Du:uwnl

Allow: 30 words k |Llsed: 29 wards ) |Positiu:un: RO-R23

o DK X Canc:ell

4

After you have finished specifying the settings, press “OK”, and you will be able to begin editing the necessary

[Link Command]:

7 ‘Normal Link Table = [General CPUTLCINK Commumnications Table]

= ]
Calculator(Ch Setupl(3) hdanitar(hd)

Link Cormmand
Seq. | Command | Slawve | kaster... | | Slave ... | Dat... | Add

Insert
Edit |
Delete |

fiowe Up |
hl e DDwnl

Allow: 30 words |Used: 1 wards |Position: RO-RO

o OK I x Cancell

4

[Calculator] field: brings up the simple calculator included in Windows, as shown below:

| i Calculator

Edit Wiew Help
| 0]
O Hex & Dec O 0t O Bin (%) Degees () R adians () Grads

Om  Owe | [ [Backspace|| e |[ & ]

(] (o) (o e e ) e e
- DEW E PO
)
e & COEOEE
Dat A B [ o] E F

[Setup] field: brings up the edit table window. The user can rename the editable window, or modify the

initialization point, as shown below:
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E;i Table"Edit

Takle Fropeties Can rename

Tahble Type: |
Tahle Mame: |Gbneral CPU LINEK Cummum
Table starting address: |Ro o
Edit Length: |

Tahle Capacity: ™ Dynamic Allocation
" Fixed Length

-
-

Description

Can modify Start address

Genetal CPU LMK Communications Tahle

o DK | % Canc:el|

[Monitor] field: can randomly monitor whether communication commands are successful or not, but you

must be careful of one thing: the monitor feature can only be used with the “Z” hotkey (refer to

Section 5.7 for details), which calls up the table, and cannot be executed from the

communication commands table in the project management window.

% _ Normal Link

=
Calculator(C)

Link Command

Table - [General CFU LINE Communications Table]

Setup(3) Maonitor(hd)

Seq. | Command Slave Master. . Slawe . | Dat...
| Wme 1 RS o
i

Result

Twpe Yalue Description Q

gs;-zgr?sedﬁa 22: Transaction Sucess

gf:ua:rlw?':aNnngT.r 52: Block write slave discrete status Q
Allow: 3840 words(iato) Used: 15 words Posihion: RO-R14

W 0K ‘ X Cancel |

If you wish to create a new communication command item, first press the “Add” button, and the following

window will appear:
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Slawve Station:

Command ;
Data Length

Master Data Start Address: X0

Slawve Data Start Address |XI]

o 0K X Cancel |

fill the relative master and slave communications settings, press “OK” and the newly specified data item will

be created in [Normal Link Table]:

COX

7 _ Normal Link Table - [General CPI LINK Communications Table]

o ol
Calculatar(C) Setup(3)
Link Cormmand
Seq. | Command Slawe Master... Slawve .. | Dat...
n Fead 1 *0 <- =0 1
Ao 2840 word (A uta) Teed: 8 words Position: RO-E7
W DK | X Canc:e||

On the right side of the “Add” function button, there is also:

1. Insert:

2. Edit:

3. Delete:

inserts an item between 0 and 1 of the original items list, choose item 1, and then press the
“Insert” button, and the same settings screen that appears when you press the “Add” button
will appear, and now you can insert a data item, as shown below:

select the item that you would like to edit and press the “Edit” button, and the same settings
screen as when you press the “Add” button will appear, and you can proceed the modification
of the original data settings.

select the item that you would like to delete, press the “Delete” button, and it will be deleted.

4. Move up: select item number 1, and press the “Move up” button, and you will move up one item number.

5. Move down: exactly the opposite as the move up button.

After the necessary [Link Command]have all been set, press the “OK” button, and you will have completed the

creation of a [Link Table], and you will find a newly created table under the [Link Table]category in the [Project

Window], as shown below:
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=-[&] Test Example [FBs-40MC]
+-%] System Configuration
+-f Ladder Diagram
--[8 Tahle Edit
w82 ASCI Table
= Link Table
=" General CRU LINE Communications Tahkle
& Servo Pararmneter Table
8 Serso Program Table
Wa, General Purpose Link Table
2_ Register Tahle
WL tocBus Master Table
+-K Comrment
B Status Page
+- 242 140 Numbering

5.2.1.2 Modify General CPU LINK Communication Table Names:

Follow the procedures described in [Modify ASCII Table Name] of Section 5.1.2, or, in the table edit window,

click the "Settings” button.

5.2.1.3 Delete General CPU LINK Communication Table:

Follow the procedures described in [Delete ASCII Tablelin Section 5.1.3.

5.2.2 High-speed CPU LINK Communication Table

5.2.2.1 Create New High-Speed CPU LINK Communication Table:

Follow the same procedures as in [create new general CPU LINK communication table] in Section 5.2.1. The
only difference is, in the [Table Edit] window that is brought up, you must select “High Speed Link Table” from

the dropdown menu in [Table Type], as shown below, the rest is exactly the same:

=. Table Edit 3
Table Properies
Tahle Type: |High Speed Link Table |
Tahle Name: |general CPU LINK communicati

Tahle starting address: [Rol

Tahle Capacity: * Dynamic Allocation
™ Fixed Length

[~ Load Table From FLC
-

Description
general CPU LINK communication tahle

W OK | X Cancel|

After you press the “OK” button, a [High Speed Link Table] window will appear, press “Add” and a

[Link Command] window will appear, as shown below:
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i —— :
Calculatorn(C) & 7. Link Command [High Speed] @

Link Command 1
Broadcaster Station: =T

Seq. | Command L Add

Command :I

Data Length : ’1[]7
Data Start Address: R100

Hdd

Allow: 3340 words{Autn v 0K | XK Cancel ‘

o 0K | X Cancel‘

Enter “1” into the [Broadcaster Station] field, set the [Data Length] and [Data Start Address], press the “OK”

button, and you have completed a high speed Link communication command, as shown below:

% High Speed Link Table - [zeneral P LINK communication fable] =13
= il
Calculator() Setupls)
Link Cornmand
Seq. | Command Broad... | Data All Stat.. | Dat..
0 H_Link 1 R100 -» R100 10
Allow: 3840 words(Auto) Teed: 8 words Poztion: RO-E7
o CK | X Cancel|

You can also use the “Insert” button to insert a communication command; or select the communication
command that you would like to modify, and press the “Edit” button, and you will be able to modify it; press the
“Delete” button and you will be able to delete the communication command. Use the “Move Upward” and

“Move Downward” buttons to change the order and sequence of the various communication commands.

5.2.2.2 Modify the High-Speed CPU LINK Communication Table Name:

Follow the same procedures and in [Modify ASCII Table Name]in Section 5.1.2, or, click the “Setup” button

during table editing.

5.2.2.3 Delete a High-Speed CPU LINK Communication Table:

Follow the same procedures as described in [Delete ASCII Table] of Section 5.1.3.

5.2.3 General Purpose Link Table (Model,?2)

5.2.3.1 Create New General purpose Link Table (Model,2) :

Execute [Project]>[General Purpose Link Table]>[Add General Purpose Link Table] from the
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function toolbar; or, click the l?'E: T icon and select [New General Purpose Link Table]
from the dropdown menu; or, in the project window, select [Text Example]>[Table Edit]>[ General Purpose

Link Table] right-click and select [Add General Purpose Link Table], as shown below:

e

| Project? [FEs-40kC]
+-51 System Configuration
+-[ Ladder Diagram
-1 Tahble Edit
B2 ASCI Table
fha Link Tahle
8 Servo Parameter Table
ﬁa Servo Frogram Table
‘?% General Purpose
2_ Register Table
Wﬁ tModBus Master Table
+-B Cornment
B, Status Page
- L2 /0 Mumbering
+ L% Praject YO Mumbering
L2 PLC IO MNumbering

Add General Purpose Link Table
g, Delets General Purpose Link Table

Use the same settings as in [Create New ASCII Table] to specify the settings for the name and other items in

[General Purpose Link Table] below:

B, Table Edit x]
Tahle Froperties
Tahle Type: | =
Table Name: |Create Mew Generic Communic

Tahle starting address: [RQ|

Table Capacity: & Dywnamic Allocation
" Fixed Length

-
=

Description

Create New Generic Communication Takle

o OK | x Cancel|

Press the “OK” button, and you will enter the [Communication Parameter Settings] screen:

T General Purpose Link Table - [Create New Generic Communication Table]

= i
CalculatorC) Setup(S)

Comm. Parameters Setting

y Or B
1:Transmit then rece

w2 of Beceive then transmit

[Communication Mode] 0: only transmit messages/only receive messages.
1: receive message after transmission of message/transmit message after
receiving of message.
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[Start Code]: set Start code of receiving.

[End Code]: set End code of receiving.

T General Purpoze Link Table - [Create New Generic Communication Table] E|@|gl

= 5l
Calculator(C) Setup(S)

Comm. Parameters Setting

|D:Transmit0n|y or Receive anly j start Code: |0
End Code: |D
I Command Edit |

ao, anh, "AE' ' C'

A llow: 3840 words(Auta) Teed: 9 words Position: E0-R8
Data Presvigw

Ref Decimal Hexadecimal | String

R0 0 nonoH !

FE1 0 nonoH v

Rz 5 no0sH !

R

R R
2
Rk

R7 39 noz27H t

Ra 99 0063H =

Length: 4 | |Checksnm BY TE) = 90 CRCIG=8E21 |

" OK | x Cancel|

[Command Edit]: when in the middle of editing, you can preview in the [Data Preview] section below.

[Data Preview]: you can use your mouse to drag and drop ranges, and the calculated checksum and CRC16
values will be displayed below in the status bar. Press the “OK” button, and you will have

completed the creation of a new General Purpose Link Table.

5.2.3.2 Modify General Purpose Link Table (Model,2)Name:
You can follow the procedures described in [Modify ASCIlI Table Namelin Section 5.1.2, or, during table

editing, click on the "Setup” button.

5.2.3.3 Delete General Purpose Link Table (Model,2):

Follow the procedures described in [Delete ASCII Table] in Section 5.1.3.

5.2.4 ModBus Master Communication Table

5.2.4.1 Create ModBus Master Communication Table:

Execute [Project]>[ModBus Master Table ]>[Add ModBus Master Table] from the function toolbar; or, click

on the ‘?n"g = icon in the tool bar and select [Add ModBus Master Table] from the dropdown menu; or, in

the project window, select [Text Example]>[Table Edit]>[ModBus Master Table] right-click and select [Add

ModBus Master Table] as shown below:
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Test Example [FBs-40MC)
+-%] System Configuration
+-F Ladder Diagram
--[& Tahle Edit
w B2 ASCI Table
s Link Table
B! Sero Parameter Takle
B SeroProgram Takle
W, General Purpose Link Takle
2 Reqister Tahle
L4 hiodBus
+- M (%L Add ModBus Master Table ‘

R %% Delste ModBus Master Tsble
+ E;OR (FLER W fagial =)l

As before, in the [Table Edit] window that appears, enter the [Table Name] and whatever other additional
items:

%, Table Edit X

Table Properties
Tahble Type: | =]

Tahle Mame: |MDdEIuS Master Table
Tahle stariing address: |Ro

Tahle Capacity: * Dynamic Allocation
" Fixed Length

-
-

Description
tModBus Master Tahle

W 0K | X Canc:el‘

press the “OK” button and the following will appear:

7 _ ModBus Master Table - [ModBus Master Tahle]

] i
Calculator(C) Setup(s)
Cormrmand
Seq. Cormrmand Slave taster Data | | Slawve Data | Data S.. Add
Allow: 28340 words{futo) Taed: 2 words Position: RO-E2
W 0K | X Cancel|
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The following procedures are the same as in [Create General CPU LINK Communication Table] in 5.2.1, with
features such as “Add”, “Insert”, “Edit", “Delete”, “Move Up”, “Move Down”, etc. Create three new

communication commands, as shown below:

W . ModBus Master Table - [ModBus Master Table]

= !

Calculator(Z) Setup(S)

Cormmand

Sed. Caommand Slawve tdaster Data Slawve Data | Data 5 Add
0 Fead 1 hAl < [ooom 10

1 Fead 1 RO < 4000m 2

2 W'rite 1 R100 -> 400m 1

< ¥

Allov: 2840 weond (Ao Taed: 24 words Position: EO-R23

o DK | x Cancel|

Press the “OK” button, and you will have completed the creation of the new ModBus master table.

5.2.4.2 Modify ModBus Master Table Name:

You can follow the procedures described in [Modify ASCII Table Name] of Section 5.1.2, or, during table

editing, click the "Setup” button.

5.2.4.3 Delete ModBus Master Table:

Follow the same procedures as in [Delete ASCII Table] in Section 5.1.3.

5.3 Servo Parameter Table

5.3.1 Create New Servo Parameter Table

Execute [Project]>[Servo Parameter Table]>[New Table] from the function toolbar; or, click on the ﬂn -
icon in the tool bar and select [New Table]from the dropdown menu; or, in the project window, select [Test
Example]>[Edit Table]>[Servo Parameter Table] right-click on your mouse and select [New Table], as

shown below:

=-[E Test Example [FBs-40MC]
+-%F1 System Configuration
+ [ Ladder Diagram
-- 18 Tahle Edit
w2 ASCl Takle
- Link Table

m Sersio P

8, Se @ wew Table
P8 GE@ Delete Table Tahle
= Re

Wi ModBus Master Table
+-H5 Comment
B Status Page
+ L2 /O Mumbering

ararmeter Table
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As before, enter the [Table Name] items in the [Table Edit] window that appears:

B, Table Edit X
Tahle Properties
Table Type: | =l
Tahle Name: |Create Mew Server Parameter”

Tahle starting address: [R5200

Tahle Capacity:* Dynamic Allocation

C Fedlength [T woRD

-
-

Description

Create New Server Parameter Table

0K | X Cancel‘

After you press the “OK” button, the following window will appear, enter the appropriate values according to

the proper order and item fields:

] i
Calculator(C) SetuplS)
R5200 0.Unit ; 1-Pulse - R5213 10.+ Movement Compenzation ; Iui Py
R5201 1 Pulse/Riex (16Bit): F5214  11.-Movement Compensation : (T
DRE20Z2  2DistancesRev. : R5215 12.Dec. Time o
RE204 AMin. Unit : RE216 13 Interpalation Time Constant: 00 s
DR5205 4 Mar, Speed : DR5217 14.Pulze/Rev.[32Bit): lgi
DRE207 5 .Start/End Speed : R5219 LB 15 000G Input; W
R5209 B.Creep Speed: R5219 HE 15 1.5toke Input: W
R&210 T Backlash Compensation RE220 LB 15 2 PGO Input: W
RE211 gAcc./Dec. Time: R5220 HE 15 3.CLR Output: W
R5212_LE  9_0.Direction Contral : TUp - DR5221 16.Machine Zera Paint: Iui pe
RE212_HE 9 1.Zero Returm Direction: IW' R5223 17.PGO Count: |17

Allaw: 2872 word s(Auta) Teed: 24 words Poszition: R5200-R52232
Reset To Default & 0K | X Cancel ‘

[Unit]: you can choose either “Mechanical”, “Pulse”, or “Hybrid” in the dropdown menu.

[Direction Control]: you can select either “UP” or “DOWN?” in the dropdown menu.

Press the “OK” button, and you have completed the creation of a new Servo parameter table.

5.3.2 Modify Servo Parameter Table Name:

You can follow the procedures described in [Modify ASCIl Table Name] in Section 5.1.2, or, during table
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editing, you can click the "Setup” button.

5.3.3 Delete Servo Parameter Table:

Follow the procedures described in [Delete ASCII Table] in Section 5.1.3.

5.4 Servo Program Table

5.4.1 Create New Servo Program Table:

Execute [Project]>[Servo Program Table]>[New Table] from the function toolbar; or, click on the

& -

icon and select [New Table] from the dropdown menu; or, in the project window, select [Test

Example]>[Table Edit]>[Servo Program Table] right-click and select [New Table], as shown below:

=-[F] Test Example [FBs-40MC]
+ %1 System Configuration
+-[ Ladder Diagram
-- [y Table Edit
B2 ASCI Takle
¥ Link Takle
8 Servo Parameter Table

=ervo Fraogram Tahle

Wil MaodBus Master Tahble
+-K5 Cormment
B} Status Page
+- 12 10 Murnbering

%8 G = e &, New Table
eneral Purpose Lin

. Delete Table

=, Reqgister Table 2 D ’

As before, enter the [Table Name] items in the [Table Edit] window that appears:

= Table Edit
Tahle Properies

Tahle Type:

| Servo Program T able

[

Tahkle Narme:

|Create Mew Server Command ™

Table starting address: |R155

Table Capacity:  Dynamic Allocation
" Fixed Length

~
~

Description

X]

Create MNew Server Command Table

o OK | %X Cancel‘

press the “OK” button and the following will appear:
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" Servo Program Table - [Create New Server Command Table] |Z||E|E|

] il
Calculator(C) Setup(S)

Servo Command

Step. | Speed kMovement Action YW ait GoTo Add

Allow: 2685 words{fota) Teed: 2 words Position: R155-R156

o COK | X Canu:el‘

FEEL

press the “Add” button, and select the required items and values in the proper order:

Motion Command Item &|

Speed:  |R1000

Movement:[ory— <[[ADR <]+ <] o ]
WWait: WATTIME — ~|[100

GoTo: |NE><T j

W OK | x Cancel|

The [Operation] field: the “DRV” command is used to operate the motor, while the “ABS” setting uses the

absolute coordinates to represent distance of movement, and the “ADR” setting represents
the distance of movement in relative coordinates. For example, if the current location was
100mm, and you wish to move to 300mm, then you would want to set the positioning

commands to the following:
1. Expressing the movement distance using absolute coordinates:

Motion Command Item &

Speed: |H1I]I]I]

Movement:[pRy  ~[[aps ~|  ~|[300] Ut =]

Wait WATTIME =100
GoTo: |NE><T j

o DK | X Cann:el|

2. Expressing the movement distance in relative coordinates:
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Motion Command Iiem

Speed:  |R1000

Mwement:|D|:W j|ADRj|+ j|2l]l]| |Ut j
Wait [WAIT TIME ~|j100

GoTo; |NE><T j

0K | X Canc:e||

After you press the “OK” button, the following window will appear, and as before, you can select the [Servo

Program] that you have already created, and click on the “Insert”, “Edit”, “Delete”, “Move Up”, and “Move

Down” functions on the right:

& Servo Program Table - [Create New Server Command Table]

=] o
CalculatorC) Setup(s)

Servo Command

Step. | Speed Mowement Action Wit GoTo Add
SPORI10.. DRBEY ADRE.+ 200Ut SWAIT Tl GOTO MNEXT
Insen
Edit
Delete
Aoy 3685 words{huto) Teed: 11 words Position: R155-E165 |

o OK | X Cancel|

Press the “OK” button, and you have completed the created new Servo command table operation.

5.4.2 Modify Servo Program Table Name

Follow the procedures described in [Modify Text Table Name] in Section 5.1.2, or, during table editing, click

on the "Setup” button.

5.4.3 Delete Servo Program Table:

Follow the procedures described in [Delete Text Table] in Section 5.1.3.

5.5 Register Table

5.5.1 Create New Register Table:

Execute [Project]>[Register Table]>[Add Register Table] from the function toolbar; or, click on the

_, ~ iconin the tool bar and select [Add Register Table] from the dropdown menu; or, in the project window,
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select [Text Example]>[ Table Edit]>[Register Table] right-click and select [Add Register Table], as shown

below:

Test Example [FEs-40MC]
+-5] System Configuration
+-f=] Ladder Diagram
--[8 Tahle Edit
B2 ASCH Tahle
o Link Table
8! Serso Parameter Table
8 sSersoProgram Table
¥a, General Purpose Link Tahle

‘2, 144 Register Table ‘

BE

Wi ModBus Master ;= Delete Register Table

+-B5 Comment -
B} Status Page

- L2 ;0 Numbering

As before, in the [Table Edit] window that appears, enter the [Table Name] items:
5, Table Edit 3
Tahle Properties

Table Type: | =]

Tahle MName: |New Fegister Tahla
Tahle starting address: RO

Table Capacity: * Dynamic Allocation
" Fixed Length

-
-

Description

MNew Register Table

W OK | x Cancel‘

After you press the “OK” button, the following will appear:

~_ Register Table - [New Register Tahle]

] kL
Calculator(C) Setup(S)

Register Data

Fef Diata Type  [Data Description Add

Insernt

Edit

Delete

Allowe: 2840 words(duto) Teed: 0 words

" 0K | X Cancel‘

After you press the “Add” button, the following window will appear:
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Data width: you will have a choice of either a “Word (16-bit)” or “Double Word (32-bit)".

Fief.: ||:m

Data Type: [vyORD( 6Bits) =

Data: ||]

Description:

o OK | X Canc:el‘

After you press the “OK” button, the following window will appear:

As before, you can also select the [Servo Program] that you have already created, and select the “Insert(”,

“Edit”, “Delete”, “Move Up”, and “Move Down” functions on the right:

- . Begizter Table - [New Begister Table]

B i
Calculatar(C) Setup(3)

FRegister Data

Fef Cata Tvpe  |Diata, _|Descrimi0n Add
(=11 WORD BBits!)
Insert
Edit
Delete
A low: 3840 words(Auta) Teed: 1 words Pozition: RO-R0

' OK | x Cancel|

Press the “OK” button, and you have completed the operation for creating a new register table.

5.5.2 Modify Register Table Name:

Follow the procedures described in [Modify Text Table Name] in Section 5.1.2, or, during table editing, click

the "Settings” button.

5.5.3 Delete Register Table:

Follow the procedures described in[Delete Text Table]in Section 5.1.3.

5.6 Table Configuration

Execute [ Project]>[Table Configuration]from the function toolbar; or, click the [Table Configuration]

icon from the tool bar, and the following settings window will appear:
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g3 Table Setup

Tahkle List

MNarme StartAd.. | EndAd.. | Allocated...
& mation_0 RE000 RARO001 Dynamic ...
i New Connecti.. R100 R100 Dynamic ...

pdate to PL

R

Range Check

You can first click on any table name under the [Table List], and then select one of the following buttons on

the right-hand side:

1.

2
3.
4

[Settings]: re-set the [Table Name], [Start Address], or descriptions settings for the chosen table.

[Edit]: re-modify the content and commands in the chosen table.

[Delete]: deletes the chosen table.

[Update to PLC]: when there has been an adjustment of settings or modification of contents, you can
press this button to update the changes to the PLC.

[Range Check]: the system will automatically check the table settings, and will list the results under

[Message] item, as shown below:

#d Table Setap E|
Tahle List
MName StatAd.. | EndAd.. | Allocated... Setting
82 [Mew Text Ta.. [R106 R112 |  Dynamic... _
& motion_D EEOO0  EBAO0T Dynamic ... Edit
% New Connecti. |R100 R107 | Dynamic .
Delete
|
|Cpriatz o rLl
tessage
ahle [New Connections Table] and [[Mew Text Table] Dverlapl
W OK

Therefore, when you are setting and adjusting your tables, you can directly click the “Range Check” button,

and you will be able to modify the various tables according to the messages listed under the [Message] item.
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5.7 Creating and Bringing Up Tables in the
Ladder Diagram Using Hotkeys

Zooming: rapidly create or bring up tables stored in the PLC with the hotkey “Z”, which can be applied to
any function instruction that has table contents, such as communication instruction (FUN151),
the high-speed pulse output instruction (FUN140) for NC position control, the parameter setting

instruction (FUN141) for NC positioning...etc

Bring Up Table:

With the procedures described in Sections 5.1 through 5.6, we can create and modify tables, and we can also
obtain information on all tables in a project via the project window, but there is no way of knowing where
tables are used in the ladder diagram program, therefore, if a instruction in the ladder diagram program area
uses a table output, we could select this function instruction using our mouse, and press the “Z” button, and
the settings window for this table will appear, to provide you with a quick and convenient channel for

modification and editing.

Create New Table:

If, when opening the existing file, you opened the program data in the PLC by executing [File]>[Open]>
[Connect to PLC] and choosing not to open the corresponding program, then the project program in the PLC
will be brought up and displayed on the screen, and there will be function instruction in the ladder diagram

program area, as shown below:

‘E WinProLadder - [Ladder Diagram - Main unitl]
F)le Edit ¥Wiew Project Ledder PLC Tool Window Help

ODs-B | BE&

MR (B K-8 -TE S B[R E
UMMM QQYR 4TS |, - B EDEOE XX R

£l -

=-[E Project? [FBs-40MC]
+-%1 System Configuration
+ [ Ladder Diagram
- Tahle Edit

A2 ASCI Table

e Link Table

Fr

Furpose Link Tahle

2 Register Table
W ModBus Master Table
+-#h Camment
B Status Page
= 22 1/0 Mumbering
=172 Project /O Mumbering
K2 PLC IO Murnbering

Main_unitl #5ub_unitl K| 3

B = 0% Overwrite NZR:1CSB U:15 F.20208 8:N (Doc U0 F:8191)

Place the cursor on the above location, and press “Z”, then the following confirmation dialog box will appear:
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Table Edit

2) ?
\_,./ Wo matched table were found, create a new one?

Yes Mo |

Because Zooming reflects the table content in the PLC program, and not the table content stored in the
project in the PC therefore, select “Yes” in this confirmation dialog box, and the following window will appear,

and you can create a new Servo command table for the project displayed on the screen:

=, Table Edit X

Tahle Properties

Table Type: | =l
Table Mame: |thiDn_D|

Table starting address: [R5000

Takle Capacity:® Dynamic Allocation
" Fixed Length

v Load Table From FLC
-

Description

" OK | %X Cancel|

The frame in the above window is checked and unchecked here, and the created new Servo command table

in Section 5.4 cannot select this. Therefore, whenever you enter “Motion_0" into the [Table Name] and press
the “OK” button, the following confirmation dialog box will appear, confirming whether or not to load the table

data from the PLC. It should be noted that only when connected to the PLC can you load data from the PLC.

Tahble Edit

2) 2
\‘:/ Bre wwou sure to get the data table from PLC %

(0] I Cancel

Press the “OK” button, and the function instruction table selected on the screen will be copied from the table in
the project in the PLC and displayed in the project on the screen, and after you have completed the creation
process, you will find that a “motino_0" item has been added to the [Servo Program Table] in the [Project

Window] in the project on the screen, as shown below:
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lﬁ WinProLadder - [Ladder Diagram - Main_unitl]

File Edit ¥iew Project Ladder PLC Tool Window Help E -
OE-B BES
R B[R B-8, -5, - -4 B R
UMMM QRYRAL L [ "ERBITECEXIX X
E B
Project! [FBs-40MC]
+-%1 System Configuration . .
+-B Ladder Diagram en | e O HERER _ACT—(MN)CI—
--[& Tahle Edit @
2 ASCI Tahle : : =R i o1
W Link Table | o .- | crR {
o o Do oy T2l | 1 1
I» 8 Servo Program Table . . " hios
ﬁ rotion_{ e - DN——{ }|
W General Purpose Link T
‘2 Register Tahle
W ModBus Master Tahle
+-H0 Comrment
B} Status Page
= L2 /0 Numbering
#1722 Praject /O Numbering
+- L2 PLC /D Numbering . . . . .
< * | NMain_unitl f ﬂ i
iy | @ Owverwrite NI1ZR:1C3 W15 F20208 3N (Doc 1.0 F:3191)

And now you have completed the procedure for creating a new table in the project displayed on the screen by
using the contents of a table stored in a project in the PLC.
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6 Comments Information

Like other program editors, WinProladder provides an annotations feature. Annotations can be made for
components, networks, or program units. Annotations can be hidden or displayed, allowing easy maintenance,

and increasing program readability.

6.1 Program Unit Comment

When there are many program units, we will need to add annotations for the program units, so that future

checking and modifications can be performed with more convenience.

Enter Program Unit Comment:

Please refer to the procedures described in [Enter Program Unit Comment] in Section 4.3.5.

Modify Program Unit Comment:
You can modify annotations by using the same method that you used in inputting the original annotations, or,
you can double-click on the annotations display area in the cascaded graphical program area, and you will be

able to modify the annotations:

g File Edit View Prc
De-H |BEER e | G-w-|R-%-8-8-F-5-W-5B-|EHN
B e mer Lo o v (S R] T [CIEL X X M

B8 WinProLadder [Test exam pﬂr]_—[Ladder Diagram - Main_unit1]

=-[E Test example [FBs-24MC]
-5 System Configuration
-] Ladder Diagram

#-fF Table Edit i = T 52 |
e G Program Unit Comment L
=K Camment & Prog =
B} Status Page Program Unit Comment
Y /0 Nurnbering csoo-| H [Main_unitt e e
Sub_unitl
NOOL
NOD2 M1924 X Cancel
| mos [0 ] X omen] |

Delete Program Unit Comment:
You can take advantage of the program unit description annotations modification procedures to clear all
descriptive text; or, click on the annotations in the ladder diagram program area with your mouse, and press

the “Delete” hotkey, which will delete directly.
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6.2 Network Comment

In a program unit, there will have many networks of program, and each has its unique function, therefore, if we
can annotate each network according to its function, future maintenance of the program can be performed

much more conveniently.

6.2.1 Enter Network Comment Mode of Operation

With your mouse, select [Project] > [Comment] - [Network Comment] from the function toolbar, or click the
il icon in the tool bar; or in the project window, select [Text example] = [Comment] = [Network Comment]

and double-click, and the [Network Comment] inputting area will appear:
[ 7 Network comment (e

| Sub_unitt |

Ladder No. Comment -
NDO0D I
NOoo1
Nooo2
NODD3 5

' OK

.

The annotations input procedures are as described in [Enter Program Unit Comment] in Section 4.3.5. After

you finish inputting:

, MNetwork Comment |
hdain_unitl lSub_uniﬂ

Ladder No. Comment o
NO0D0 L
NO0D1
NO0D2
NOOD3 L

o OK

e

Press the “OK” button, and you will have completed the annotations for the solution network:

File Edit View Project Ladder PLC Tool Window Help
De-B ||BE® |e= G -w- R - -8 -8 -F-5-W-5 (BB
Eevnusqgeeass%S " EEMNOEXXR

]

=-E) Test example [FBs-24MC]
- System Configuration
- Ladder Diagram

=y Table Edit Program start.
=85 Comment

&, Program Unit Comment

EE:E Metaark MNa. o 10
-4k Element Comment [ %
@ Status Page |
#8110 Numbering
NOOL TO
el
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6.2.2 Choose Single Network Comment Mode of Operation

You can also click the network labeled NOOO or its components in the ladder diagram program area, and then
right-click and select [Network Comment] from the popup menu that appears, then the input area for [Network

Comment] will appear:

Netwark Comment o D )

Program start. »

W« OK | x Cancel‘

-

Press the “OK” button, and you will have completed the network annotation procedures.
Modifying Network Comment:

Please refer to the procedures described in [Modify Program Unit Comment] in Section 6.1.

Delete Network Comment:

Please refer to the procedures described in [Delete Program Unit Comment] in Section 6.1.

6.3 Element Comment

A program unit is composed of many networks of program, while the networks are composed of various
components, therefore, considering the vast number of components in a program unit, there is even greater

need to provide annotations for the various components.

Enter Element Comment Mode of Operation:
With your mouse, select [Project] > [Comment] - [Element Comment] from the function toolbar, or click on
the 4k, icon in the tool bar; or in the project window, double-click on [Test example] - [Comment] >

[Element Comment] and the [Element Comment] input area will appear:

Element Comment ===
8 B =i
All Used Unused Import Export Refrash ClearAl  Clear Unused
B> &y |[&w | %s | BT [ BC [®E [ =D |
Ref. No. Comment Description %
X0
X1
X2
X3
X4
x5
X6
X7
X8
X9
X0
X1
x12 -
U.0F8191 [ éhift+.§p.ate T.dggle.store to Ladder or Pfo.ject.
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Select [All] combined with option [Y], and the total amount of used and unused Y coil components will be

listed in the annotations input area, and there will be a check mark beside the used coil reference numbers:

Element Comment ui=)
=) B i
All Used Unuged Import Export Refresh ClearAll  Clear Unused

|#s |#®1 |#c |[wR |%®D

Ref. No. Comment Descriplion

[»

AR AR ASRSAS

UDFELL ‘shift+Space Toggle store to Ladder or Project

A |

gl Used

e

Y Unused

Select [Used] combined with option [Y], and then all used Y coil components will be listed in the annotations

input area:

Element Comment =HECE X
=] b= =i 4
All Unused Import Export Refresh ClearaAll  Clear Unused

#x |#s |#1 |®8cCc TR | %D

Ref. No. Comment Description
Y0

U0 3101 [ ﬁshif‘t+'Spa'cé ngrglre store to Ladder or'Project' A

e

Select [Unused] combined with option [Y], and all unused Y coil components will be listed in the annotations

area; select [Export], and the following screen will appear:

Element Comment |ﬂr
2 = g &
All Used | Unused Impart Export Fefresh Clearall  Clear Unused
#ix (B | Comment Import [
Ref. No. Con | File: o
v8 i i
Y9 I Filz Name: | =
Y10 111
:1]2 i Field | Range
Y13 ¥ Comments ¥ % [Input Faints] ¥ T [Timer]
Y14 : ¥ Description W % [Output Relays] W C[Counter]
Y15 ] ¥ M[Intemal Relays] W F[Register]
i} g ¥ S [Step Relays] ¥ D [Data Register]
n 4 L i !
¥1g i % Cancal
Y20 -
U0 Fa191 |shift+SpaceToggle store to Ladder or Project ;

Set the export file name, select the items and data ranges that you wish to export, and then press the “OK”
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button. The exported file will be a text file. You can use this file if you decide to import it one day by selecting
the [Import] option, where its settings are the same as the [Export] option. Component annotations can be

integrated with other software applications via the export and input functions.

The [Refresh] button:

When you open the component annotations window, and, at the same time, create a new unused X5
component in the cascaded graphical program area, then the original X5 in the component annotations
window will be an unused component, but if you press the [Refresh] button, the status of X5 will be changed

to a used component.

Element Comment

B m 8 B E k4

Al Used Unused Import Export Refresh Clear All Clear Unused
Bx | Wy |®M Bs [BI Bc Wa VD

Ref. No. Comment Description i
X0 [

i; [%] Element Comment e e

X3 =] =] =3 & o E

=4 All Used Unused Import Export Refresh Clear All Clear Unused

x5 [Fz 50 56 = ams 2 | == 5o

is Ref. No. Comment Description &
X0 7] [

X8
X9
X10
X1
X1z
U:0F8191 ||[xp
——| %7

X9

X10
X11
X12 -

U0 F8191 Shift+ Space-Toggle store to Ladder or Project

The [Clear All] button:

It can clear all [Comment] and [Description], as shown below:

Delete All'Comment

\_‘.:/ Confirm to delete all elements comment ?

Delete All'Comment

\:.':‘j Delete the element description also ¥

After you confirm the clear all operation, all descriptions and annotations in the project files will be deleted
from the storage disk, and if you are connected to the PLC, then the following screen will appear, which

represents that the annotations and descriptions in the PLC will also be deleted:
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1
Data Receving .. l@

Swstern Data,
Swstern Configquration
FOR Register
Ladder Program
Comments

Label Address
Finish

¥4&4 449

The [Relocation] button:
Because component annotation and descriptive texts are stored dynamically, therefore the [Relocation] button

can re-organize memory allocation and release even more comment space.

Enter Description Mode of Operation:
Double-click on the blank space in the [Comment] area on the right of X0 and enter the annotation “Switch”,

double-click on the [Description] field and enter “Contact A”™:

Element Comment =A==
a B El & 4 . &
All Used Unused Import Export Refresh ClearAll  ClearUnused Relocation
[ fon &= Zs 5T | = 2 |2t
Ref. No. Comment Description &
SO Swich o el
X1
x2
X3
X4
x5
X6
X7
Batil
X9
X10
X1
X1z T
U5 F:8186 [ "éh\ft{S'pace:Togg\estore to Ladderor Pfoject

After you have completed the component annotations input, click on the upper right-hand corner and close
this window, and you will find that the previously entered annotation text has appeared under the X0
component in program unit one, and that when you place the cursor over X0, a small frame containing the

entered descriptive text will appear:

inProLadder - [Ladder Diagram - Main_unit1]

File Edit View Project Ladder PLC Tool Window Help

Ds-1 HE® |[wem & -p- (R -5 Q-8 - -5 -85 B8
e qeens s |, SEDNOEXXR

“[NODO X0
=) Projectl [FBs-24MC] | I
“{ Syetem Configuration switch
B Ladder Diagram Cuntac‘tA|
- Table Edit NOO1
K Cormment

And now you have completed the input of component description annotations.

Modify Element Comment:

Please refer to the procedures described in [Modify Program Unit Comment] in Section 6.1.

Delete Element Comment:
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Please refer to the procedures described in [Delete Program Unit Comment] in Section 6.1.

6.4 Show Comments

Please refer to the procedures described in [Control of Ladder Diagram Display] in Section 7.2.
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/7 Manipulating the Display of the Ladder

Diagram

The most important aspect of this application is that of cascaded program input, therefore, we naturally

provide a complete display of information in display windows. The procedure for operation of this display is

described in the following.

7.1 Usage of the Windows

We provide multiple window displays for ladder programs, where the user can simultaneously display different

segments of the program, and perform convenient operations such as comparing, copying, and editing.

7.1.1 Create Multiple Ladder Diagram Display Windows

A project is divided into the main program area and sub program areas, and they can each create new

program pages, as shown in the illustration below. The user can switch between various program areas by

clicking the various “Page Label” buttons:

Represents that the current window opened is ladder diagram
display 1 — M,ain_unit 1

-
(&) WinProLadder [Test example. pdw] {[Ladder Diagram - Main_uniti]| e 5 ]
G| File Edit View Project Ladder PLC Tool Window Help e
ODE-E ||HER
EET ST R 24 08 58 Re. 20 1101 120
(I ferd G ibeiatl g a0 ot e 5 [SIIRLTIE] [ELSE [ 3
“x1[NDOD | | «]
=& Projectd [FBs-24MC]
=58 System Configuration
=+ Ladder Diagram ]
=& bain Program (NOO1
> bdain_unit1
> Switch Control
> Channel Control NOOZ |
» Change Caontrol |
=8 Sub Program =
LT Sub_unit] -
m-B Tahle Edit INOOD3
-85 Comment
[} Status Page
= 10 e
e WO Mumbering No0O4 -
NOOS |
_NOOG l
| 'iMain_unit! £5ub_unit! Switch Control / Channel Control {Change Control / | K | ] na
ﬁ Overwrite MNOR1C1 U0 F20223 S A (DocUDF: | | /|

Click on the different page labels
71 to switch between pages




We first place the cursor on the program window “Main_unitl”, then execute [View]>[New Window] from the
function toolbar, and the system will open a ladder diagram display 2 window, which includes the program

label page for “Main_unitl”, whose content is the same as the content in the “Main_unitl” label page for the
original ladder diagram display 1, as shown in the illustration below:

Represents that the current

opened window is that of ladder

diagram display 2 — Main_unit 1
////\\\‘

r b
E WinProLadder -I[Ladder Diagram: 2 - Main_dnit1] ﬂlﬁ
File Edit WView Project Ladder PLC Tool Window Help _ &=
Ds-a |58 |
e R e e e il ey e =l
Ik MO gR- 4= |, "EBRITLCE XIx %

121[NOOD | =
= B Project] [FBs-24MC] '

=-%§ System Configuration
=B Ladder Diagram "
& B Table Edit !
= Comment
B} Status Page
=232 /0 Mumbering N0OZ

NOO3

NOOZ

INOOS

NOOG |

b ain_unit1: 1 |
By | [ Overwrite [NOR1C1 ——a£30223 S:C (Doc U0 FB191) il ' il

Thereisonlya “Main_unit1” page label

The advantage of this operation is that the ladder programs for “Main_unitl” and “Coin Insertion Count” can

be displayed on the screen simultaneously, so that comparisons and copy operations can be performed
conveniently between the different sections of the ladder diagram program areas.

7.1.2 The Order of Display for Ladder Diagram Display Windows

Displaying Order for Multiple Ladder Diagram Displays:

Execute [Window]>[Cascade] from the function toolbar:



(&) winProLadder (= B [
File Edit View Project Ladder PLC Tool Window Help
Ds-d |[BEH |
Lem | B R - -8 -Fa-5-B-5B-EHEH
Lt et e ety | (SR TINE] [E] e |36 % |
AF =
rojectd [FBs-24MC] _E."'-.aJLadtigrDiagramfl-Main_unitll [=1Er==]
Systern Configuration NDOO | [ e —_— - - =
Ladder Di 2 - Main_unit1]
Ladder Diagram |—| %'(;0 ef cheslielils - il
-8 Main Program | |
> bdain_unit NOOT
% Sub Pragram | |
3T Sub_unit] N_o'o_j:_|
By Table Edit N
K5 Comment N 02_|
Status Page [
22 {0 Mumbering |N A |
'N_03_|
[
PT@T|
b ain_u |————— I
Mait1_urnit] 4 | I _ﬂ_|
B [ | [ Overwrite  [NORIC1 [U:0 F:20233 S:C (Doc U F:8191) [ [ 7

Displaying Method for Windows that are displayed Side by Side Horizontally:

Execute [Window]->[Tile Horizontal] from the function toolbar:

( (&) winProLadder (2B
File Edit View Project Ladder PLC Tool Window Help
Ds-d |28 |
R N A e R R Tl e i =T
IR OQQRYRLY-w— [, "ERTEE XIX R |
E@ Project] [FBs-24MC] de! Diagram: 2 - Mafn_unﬁl] @
&% System Configuration NOOD | ] 1 &
=-F Ladder Diagram l
ﬁa dain Program
H ----- # Main_unitl NOOT
8% Sub Program |
: L3S Sub_unit]
-8 Table Edit
7K Comment N 02_|
B Status Page | M|
L2 10 Numbering Main_unit1 il I _I _L|_|
Lz dLadder Diagram: 1 - Main_unit1] = (=R
NOOO | A
_0_1_|
| J
NOOZ |
J -|
Main_unit! 1 Sub_unit] [] | I
& [ ] [ Overwrite  [NOR1C1 [U-0 F20223 5:C (Doc U-0 F8191) | A

Simultaneous Display of Multiple Windows Ordered Vertically:
Execute [Window]->[ Tile Vertical] :
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[E] WinProLadder ==
File Edit Wiew Project Ladder PLC Tool Window Help
=E-d || B5E S
e m (B | B-B Py W (R R
b e R e st s | 5 S1IRITC]ED 315
e l__ —_—
=B Project) [FBs-24MC) lz/|Ladder Diagram: 2 - Main_unit1} = |[-=-E] | fElLadder Diagram: 1 - Main_uniti] (==
E‘:‘?ﬁ Systern Configuration _NUOO +| | [nooo
£ B Ladder Diagram '
¢ =B Main Program
: e » s
e NOOL NOOL |
¢ i Sub Program |
: #2 Sub_unitl
'E.! % Table Edit
&R Comment NOO2 INOD2
- Status Page |
oo MNumbering
NOO3 INOD3
NOO4 INOD4
NOOS INODS
bain_unit] 4 il P ain_unit] A Sub_unitl 4 1l
« i v
By Overwrite NOR1C1 U:0 F:20223 S:C (Doc U:0 F.8191)

7.2 Manipulation of the Annotations Display in

Ladder Diagram Display Windows

The ladder diagram program area provides unit annotations, network annotations, and component

annotations. The following describes how to display or hide these annotations.

7.2.1 Manipulation of Program Unit Annotations Displays

Execute [View]>[Program Unit Comment] from the function toolbar. If the option on the left of the text is not
checked, then the annotations will not be displayed at the top of the ladder diagram program area. After you

perform this operation, there will be a check mark in the option on the left of the text:

¥ WinProLadder - [Ladder Diagram - Main_unit1]

E® WinProLadder - [Ladder Diagram - Main_unit1

[Z] File Edit | view Project Ladder PLC T [Z] File Edit | view Project Ladder PLC T

O = -~ g [ Project Tree O = - g [ Project Tree
e — || 2] Ladder Diagram || 22 - | [E] Ladder Diagram
% T " || ome pMnemonic = = =1 3% Mnemonic
|} PR |} 1t 4t A
A E A E

Pragram Unit Comment
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v |Program Unit Comment

INetwork Comment

Metwork Comment B oo ool v
B rc:]ect Element Comment Bl ® O v [Element Comment
I ﬁﬁ Stystg . -] Syst -
Register Content F11 [ Register Content F11
m-E Lads m-E Lads
@B Tabl]  Tool Bar » - Tabl  Tool Bar
Eirﬂ: Com|  Font ’ Eirﬂ: Com  Font
ﬁ S e —" ﬁ S e —"
w10 o N ew Window w1 o N ew Window




and this represents that the annotations text will be displayed above the cascaded graphical program area:

r WinProLadder [Test example.pdw] - [Ladder Diagram - Main_unitl] lﬂl&]
= File Edit View Project Ladder PLC Tool Window Help _ =l
Dmvﬂ_ﬂ@%
B By (Y e BB YTy S W @v'goyﬂ-
kﬂ%mur{){/)@{m/-T;'-w'—|a@'@.@@xm? )
T ] Test example =
=[5 Testexample [FBs-24MC]
: "1 Svystem C.aniguration NOOO | 015
E LadderD!agram | | rr\<r TUP—
%f Tahle Edit NOGL | T0 ] . : : e =
&K Comment | | 1 EN-| D : WMo L =
i L I | EN OTB
=R ﬁatatus Page : ] ] ] e 1 :
------ StatusPagel | | 3
B E-¥2 170 Numbering 2 o ; ; ; ; INE : : I ]
(NOO2 M1924 08. MoV
I | ENH S5 &
M8 d d d B WMo
—APJ
SOGT h . . . . - -
| i S PLS{ <O FCuP-
MO . . . . PV: 10 .
—/1 CLR+ =
'\ W ain_unit1 £ Sub_unit] / B H
By | Overwrite  |NOR1C1 [U:38 F:20185 5:A (Doc U144 F2047) il il [ >

7.2.2 Manipulation of the Network Annotations Display

Execute [View]>[Network Comment] from the function toolbar, and a check mark will appear to the left of the
text option, which means that the annotations text will be displayed above the network of ladder diagram area:

Dl@&1

‘WinProLadder [Test example.pdw] - [Ladder Diagram - Main_unit1]
Gzl File Edit View Project Ladder PLC Tool Window Help =

DmvajE@%

| H @ ;:v' ﬁa ﬁnvi#%vé;vmv_..;:, @vu :,J-u-
[}-H—-I/I—-Iﬂ--M—()(/){S){R)/-T;-Jr-—|—>|E||E|.|E||E|X|x?
] Test examp'le . - _A_

=-[E) Test example [FBs-24MC]
B9 Systern Configuration e
B Ladder Diagram

-8 Table Edit < =
@A Comment i | Er\_r _,—\:mp_
B @ Status Page o 0 | . :
- L.E StatusPagel g i

L I =

m-ke L2 140 Mumbering

NGOZ | M19I24
- | I
M8
—
wooz || 1o ' ' ' - '
(S  m— ,"‘LS~| o |~CUF’— =
' Main_unitl 4 Sub_unit] / 1 J |

Ty | Overwrite  [NORI1C1 [U:38 F:20185 S:A (Doc U144 F:8047)

7.2.3 Manipulation of Element Annotations Displays

Execute [View]>[Element Comment] from the functions toolbar, and a check mark will appear on the left of

the options text, and the annotations will be displayed below the component in the ladder diagram program
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area. If you place your cursor on top of the component, a small frame containing the description
component will appear:

of the

i E WinProLadder [Test example.pdw] - [Ladder Diagram - Main_unit1]

= [ B[S

FiIe Edit View Project Ladder PLC Tool Window Help

o -4 |[@EE
_::AHAQ(iﬁavgguvia@v%vﬁévﬁav?gvz%vwﬁv@i@v'g?mﬂ-?!
Rk MMM QQeg,4— |, BETEE XIX % |

ORG |
ano |

A Test example

=-[E] Test example [FBs-24MC]
%1 System Configuration
] Ladder Diagram

I

Program start.

StatusPagel

2 140 Mumbering 1

FTUP-

FOTB—

FERR—

b air_urit] £ 5ub_urit] /

!41 ]

R [ [

Overwrite  [NORILC1 [U38F20185SA (DocU153F8038) [

7.3 Manipulation of the Display of Register Data

Execute [View]>[ Register Content] from the function toolbar; or press the “F11” hotkey, and the register data

will be displayed in the program area:

[ E WinProLadder [Test example.pdw] - [Ladder Diagram - Main_unitl] ﬂ@
File Edit View Project Ladder PLC Tool Window Help L_ & [ x|
DE-8 | BE®
|zem B - R -Pa-B-0-Fa-a-W-5 B8
[EHUS MM RReR 4SS [, "ERTDCOEXIX® |

E] Test example =)
=] Test example [FBs-24MC]
- Systerm Configurstion
= Ladder Diagram e
=By Table Edit Program sSTart.
=M Comment
=] @ Status Page
- StatusPagel NOOO
=52 170 Numbering | ‘ LTup-
NOOL ‘ TO
[ | rOTB-
Timer 0
FERR-
Main_urit] {Sub_unit | B
el | | Overwite [NOR1C1 |U:38 F20185 5°A (Doc U153 F-8038)

Before the F11 hotkey has been pressed, the register data is not displayed
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@ WinProLadder [Test example.pdw] - [Ladder Diagrarn - Main_unitl] ;‘_J':' [ E] S
File Edit View Project Ladder PLC Tool Window Help
DeE-d  HE&E
W ey R @R Ve WS BB
RGN L L EROCE XX ® | ) _ ) ) .
E| Test example B
B-[E] Test example [FBs-24MC]
B Systerm Configurstion
E Ladder Diagram -
=B Table Edit Program sSTart.
- Comment
=] @ Status Page

)

B StatusPagel NOOO
B2 /0 Numbering /] 7—TUF‘—
48 Project /0 Mumbering
=42 PLC IO Mumbering
NOOL T0
I LoTB-
Timer 0
FERR-
b ain_unit] £ Sub_unit] ] ]
% E Eo | Overwrite NOR1C1 U:38 F:20185 S:A (Doc U:153 F-8038)

After the F11 hotkey is pressed, the register content values are displayed

If the [View]>[Element Comment] option had already been selected, then after executing [Register Content],
the element comment will be hidden, and the register data will be displayed. If [View]>[Register Content] had
originally been selected, then after executing [Element Comment], the register data will disappear, and the

component annotations will be displayed.

7.4 Direct Display of Specific Program Points

The ladder diagram area is composed of program unit categories, and the various program units are
composed of many components, therefore we provide a cascaded method of display in the project window, so
that the relative program units, program labels, and steps can all be displayed, allowing the user to be able to

quickly display specific program points through the positioning scheme.

7.4.1 Locating Elements through Program Units

In the project window, in the [Main Program Area] and [Sub Program Area] under [Test Examples]->[Ladder
Diagram] in the project window, there is a list of the respective program units, as shown in the illustration
below:



= B Projectd [FBs-24MC]
L+‘_|‘ﬁ System Configuration
=B Ladder Diagram
- @ R
T hain_unit]
% Coin Insertion Count
-5 Channel Control
- ¥ Change Contral
-8 Sub Program

&8 Table Edit
-H Comment

----- B Status Page
&-EE 170 Mumbering

Double-click on “Main_unitl”, and the program for this unit will immediately be displayed, and the cursor will

point to the first line in the ladder diagram program area of “Main_unit1”.

7.4.2 Locating via Program Labels

The various [Label] names are listed under the program units of the [Main Program Area] and [Sub Program

Area] under [Text Examples]->[Ladder Diagram] in the project window, as shown below:

|

=-[E] Projectd [FBs-24bC]
L+‘_|‘ﬁ Systemn Configuration
=B Ladder Diagram
Elﬂﬁ bain Fragram
-4 Main_unit!
.3 s0
L1523
40 Coin Inserion Count
----- % Channel Contral
-3 Change Control
=B Sub Program
LT Sub_unit]
-6 Table Edit
&MY Comment
) Status Page
-9 170 Numbering

Double-click on “TEST”, then the program segment of that particular Label will immediately be displayed, and
the cursor will point to that Label.
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7.4.3 Locating via Steps

In the [Main Program Area] and [Sub Program Area] under [Test Examples]>[Ladder Diagram] in the project
window, there are the respective lists of program units. Double-click on “Main_unitl”, and the steps in this

program unit will appear, as illustrated in the following illustration:
A

=& Frojectd [FEs-24hC]
'1‘_. a1 System Configuration
=B Ladder Diagram
f—‘lﬂ}F bain Frogram

SR iain_unitl

E Cain Insertion Count
. Channel Contral
. Change Contral
=B Sub Program

LT Sub_unitt
=8 Tahle Edit
=-B5 Comment

----- Status Page
E5) o

-9 110 Numbering

Double-click on “S0”, and the corresponding step program will be immediately displayed, and the cursor will

point to the “S0” step.

7.5 Select Display fonts

Execute [View]>[Fonts] from the function toolbar, and there will be five options: “Largest”, “Large”, “Medium”,

“Small”, and “Smallest”.

7.6 Mnemonic Code Display Control

Place the cursor at the location of the program that you would like to see the mnemonic code for, execute
[View]>[Mnemonic Code] from the function toolbar; or, select the icon from the tool bar, ao and  the

mnemonic code window for the solution network at the location of the cursor will be displayed:
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Mnemanic [ESHTER X

ORG  NOT TO
0oo0iM  TO .01 100

Independent mnemonic code windows can at any time display the network mnemonic code programs for the
network corresponding to the location of the cursor, and can be used for educational and debugging purposes,
where “00000M” represents the place of order in which the instruction is located; “ORG” is a simplified
instruction; “X1" is the reference number of the component.

Click the close }CI icon on the upper right corner to close the mnemonic window.

Convert the NOOOO network area where the cursor is located to mnemonic code:

( ] X0 X1 X3 %5 11P, {+)
et | | | | | | End 2 1 D=0-
' sh: ;L3 !
uss| o R foy-
M1 ' MO
FER— ]
X1 MO ¥l ¥yiz Y13 Yid ' 1P, {+)— '
— I | | | | | | EN{ Sa: : b=0-
. . . . . . . . , .
uss| o Ré lev-
_ER—
I X2 i1 Y12 ¥13 Y15 1P, (+)— '
— | | | | | | | | | EN{ 5a: 0 |p=0-
) ) sh: 23 !
uss| o R loy-
_ER_

7-10



8 Testing of Application Programs

Prior to the completion of program’s development, the final application program must be downloaded to the
PLC and tested. Through the resultant component conduction status, register value display, and status

display of status monitoring page, we can judge whether the application program is complete or not.

8.1 On-Line Testing

If you open the file via the off-line method in Section 3.2.1, then execute [PLC] = [On-Line] from the function
toolbar; or connect via the “F12" hotkey. After you connect, you can execute [PLC] = [Run PLC] from the
function toolbar; or test the program results using the “F9” hotkey. If you open the file on-line via the method

described in Section 3.2.2, and you connect successfully, then you can execute [PLC] = [Run PLC] from the

function toolbar; or test the program results online by pressing the “F9” hotkey.

8.2 Run Time Status Display

When using on-line PLC testing to test the application program, we can use the bright display of conductive

components, register value displays, and component enable/disable displays to check the correctness of the

program.

8.2.1 Bright Display of Conductive Components

During on-line testing, conductive components are displayed in bright red color:
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+-E] Ladder Diagram

= E - Overvite

PC Tool Wirk
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T
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4] |
38 30185 SA (Doc U0 FALOD) G

8-1




8.2.2 Current Register Value Display

When on-line, execute [View] = [Register Content] from the function toolbar; or press the “F11” hotkey, and
the result will be:
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8.2.3 Component Enable/Disable Status Display

When on-line, the display of components that are enabled and ON as shown in the illustration below:

- [Ladder Dlagram - Main_unitl]

=0l x|
E] Fle Edit View Project Ladder PLC Tool Window Help =l x]
DS-8 HES #Ned R-p-R-Yy-0-8-Tg-0,-F -5 0B- L =
It Qeaqg4 LS L, " BEDODE X xR
- doeo [[ x0 x1 | | J d . g g 4 ~ vo |4
= Frojectd [FBs-24MC] [ 1] [ i I8
# i System Conbguration
= ] Ladder Diagram
= G Table Edit KL
w1 B Commmarn
B} Sretus Page
CLLE
i |
il — T =
TE - s F20219 SA (Do UD F5191) -

In the function toolbar, [Ladder] = [Control] = [Disable]; or select the X2 component and right-click and select

“Disable”, and the following window will be produced:

E\Mnﬁpl.addéq—nadﬁé( Diagram - Main_unit1] _of x|
File Edit View Project Ladder PLC Tool Window Help -2 x|
DE-B |EER (2es G -F- R-%-8-0-f-o-%-5 B[R =
[ 4 QReR4 G5 L "ERMCOEXXR |
————————ino00 X0 X1 o |4
-] Projectd [FBs-24MC] - ——a— N (-
-5 System Configuration
[ Ladder Disgram

B Table Edi oL
=-# Comment | 5
[, Status Page
=29 110 Numbering

i NODZ
-ty Project fO Numbering L
#-4 PLC IO Numbering
NOO3
Main_unit! /Sub_unitt / il w |
& B b | Ovewite |NOR1C3 |4 F:20218 SA (Doc U:0 F:8191) s =

Then select the “OFF” option and you will see the following illustration:
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(E)winProLadder - [Ladder Diagram - Main_unit1] _[o]x|

File Edit View Project Ladder PLC Tool Window Help ==l x|
DE-d [|[HER |[2es [G-w- R-%-0-8 -5 -B-5|8-|5 5 =
i i D L BB EE XX ®

———————————— 1[N0 X0 x1 Y0 |~

=@ Projectd [FEs-24MC] I T Py
4 System Configuration
& Ladder Diagram
B Table Edit fReias
B Comment

B}, Status Page

%2 /O Mumbering 553
& 52 Project §O Numbering
= 5§ PLC /0 Numbering

NOO3

Main_urit1 fSub_unitl <
% B e Overwrite  [MOR1C:3 U4 F:20218 S:A (Doc U:0 F.8191) P77 -

8.3 Usage of the Status Monitor Page

The status monitor page can be used to monitor and configure PLC contact statuses and register data. If the
monitor point is a contact component, the conduction status and its enable/disable status will also be
displayed. You can control the enable/disable status of the contact component and force the contact status to
ON or OFF. If the monitor point is a register, then its content value will be displayed and you can modify its
value according to your needs. The status monitor page combined with the ladder diagram program display

screen is the best tool and companion for your program testing and debugging needs.

8.3.1 Status Monitor Page Management

Status monitor page management operations include creating new status monitor pages, deleting unneeded
status monitor pages, and renaming status monitor pages and calling them up. Their operation procedures

are described as follows.

8.3.1.1 Creating a New Status Monitoring Page

Execute [Project] - [Status Page] - [New Page] from the function toolbar; or from the project window [Text

example] = [Status Page] right-click and select [New Page]; or click the @_ = icon in the tool bar and select
[New Page] from the dropdown menu and the following window will appear:

Mew Status Page &J

Status Paoe Name

B
o QK | x Canu:eIJ

After entering the name for the newly created monitor page, press the “OK” button, and the status monitor

table will appear:
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' -
[ Status Monitoring =B S
Ref. Mo, |Status |Data Ref. Mo, Statug |Data | -

]
< [ b
' StatusPagel /
e

8.3.1.2 Deleting Status Monitor Pages

Execute [Project] - [Status Page] = [Delete Page] from the function toolbar; or in the project window [Text

example] = [Status Page] right-click and select [Delete Page]; or click the @_ * icon in the tool bar and

select [Delete Page] from the dropdown menu and the following window will appear:

S5

X Cancel

Delete Status Page

Use your cursor to select “StatusPage0”, and it will be deleted.

8.3.1.3 Rename Status Monitor Pages

Select the status page that you wish to rename from the project window, right-click and select [Rename], and

the following will appear:

@ WinProLadder [Test example.pdw] - [Ladder
File Edit View Project Ladder PLC
D2 -H B E &

|3 e B~ v |9~ P - @

[ AL 44 4 @ ®) - 1 -
14 A E u o o @ E R I F

=-E Test example [FBs-24MC]
ﬁ Systern Configuration
- Ladder Diagram

7B Table Edit

@ Comment
-, Status P

And you can proceed with the renaming.



8.3.1.4 Call out Specific Status Monitor Pages

From the function toolbar [Project] > [Status Page] - and all status page name will be listed, and then you
can simply select the monitor page that you wish to open; or in the project window, all page hame will be listed
under [Test example] - [Status Page], and you can double-click on the status page name that you wish to

open; or click on the @_ - icon in the tool bar, and all status page name will be listed, and you can simply
select the monitor page that you wish to open.

8.3.2 Defining and Deletion of Monitor Points

Defining Monitor Points:
You can enter a reference number for the monitor point, for example R1000, meaning that the monitor point is

R1000; or enter a range, for example D0-D4, meaning that the ranges of DO through D4 are to be monitored.

Status Monitoring (=)= 5= |
Fef Mo |Status ‘Data Ref. Mo Status ‘Data | -
Status monitoring lihj
Please inout reference number or ranoe (Ex. #X0.RE.01
[Pt 000]
X Cancel
! »
StatusPagel

Deletion of Monitor Points:
Using your cursor, select the reference number of the monitor point that you wish to delete and press the
“Delete” button, and only the specific reference number will be deleted. If you wish to delete all of them, you

can right-click in the status monitor page and select [Clear All] from the popup menu.

8.3.3 Monitor Point Status Display Format Control

Right-click in the monitor page and a popup menu will appear, and shown in the illustration below:

[%) Status Monitoring b B |
Ref. Mo, | |Stalus |Data |F|el. Mo, |Status |Data | &

R1000 Decimal 1234

Unsigned Decimal Number
View Reference Number
View Element Comment
Refresh

All Binary Ctrl+B
All Decimal Ctrl+D =
< | All Unsigned Decimal Mumber Display Ctri+u s
| \Stash All Hexdecimal Ctrl+H
"__
Clear all
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Select “View Element Comment”, then the monitor page display status will shift into the “Comment” display
mode, as shown below:

sty The Ref. No. has changed into Comment. | b=l =) jmes]

Comme e [Commert ELEDE [Oata | -
[R1000] TDecimal 1234 [ i

4

StatuzPagel

Select “All Binary” then all [Status] fields in the monitor page will be displayed binary:

Status Monitoring = |
Ref. Mo Status |Data |F|ef. No. Status |Data | -
B0 Decitel ] e E
RE500 Decimal 55 =

Binary

Decimal

Unsigned Decimal Number
Hexdecimal
String

View Reference Mumber

FR Yiew Element Comment
StatuzPagel Refresh
All Binary Ctrl+B
All Decimal Ctrl+D
All Unsigned Decimal Number Display Ctrl+U
All Hexdecimal Ctri+H
Clear All

I

Status Monitaring =|:E]

Ref. Mo Status |Data |Hef. Mo |Status |Data |:_

R1000 Binary 000007 0011070071 0B B

R&00 Binany 0000001 00010710118

4 |:| 3
StatuzFagel

Select “All Hexadecimal”, then all [Status] fields in the monitor page will be displayed hexadecimal:
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Status Monitoring =&

Ref. Mo. Status |Data |F|ef. Mo, |Status |Data |_A_
R1000 Hexdecimal  0402H L#
RE500 Hexdecimal  022BH

< [
StatuzPaged

Select “All Unsigned Decimal Number”, then all “Status” fields in the monitor page will be changed to
unsigned decimal number:

Status Monitoring [E=REER =5
Ref. No. Status |Data Ref. No. Status |Data | -
R1000 Ungzigned Decimal number | 1234 L&
R500 Ungigned Decimal number | 555

< [l »
StatusPagel

Data Modification:

If you wish to modify the data in reference number R1000, you can double-click on the “1234” data field, and
then enter “6789":

Status monitoring

S

Flease inaut walug

|67

o OK | X Canceli

And you will see the data in reference number R1000 has been changed to “6789”:

Status Monitoring [E=STEER
Ref. Mo |Status Drata Ref. Ho. |Status |Data | -
R1000 Decimal lezsa) L4
RE00 | Decirnal (555

< [l b
StatusPagel

Double-click on the status field “Enable” of reference number X0, and you will be able to choose either
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“Enable” or “Disable”:

Status Monitoring l=/=] % |
Ref. Mo |Status |Data Ref. No. Statug |Data | -
R1000 | Decimal (E783 | | [
R500 | Decimal (555 | |
=<0 Enable (0N

Disakle

Enable
< [ b

StatuzPagel

I

#
Status Monitoring (BN
Ref. Mo |Status |Data |Hef. Mo Status |Data | -
R1000 | Decimal (6789 | | L
RE00 | Decimal hiali]
=0 Disable |
< [ b

StatusPagel

Or, right-click to bring up the popup menu shown below, and you will be able to perform the “ON” and “OFF”
modification for the X0 status:

Status Monitaring [ESRHEE 5

Ref. Mo |Statu$ |Data |Hef. o, |Status |Data | -~
R1000 | Decimal (6783 | | [
RE00 | Decimal /555

40

Enabled
Disabled
O
OFF
Unsigned Decimal Mumber

< [
StatuzPa el e .

lew Element Lommen
—

Refresh

View Reference Mumber :

All Binary Cirl+8
All Decimal Ctrl+D

All Unsigned Decimal Murnber Display Ctrl+U
All Hexdecimal Crl+H

Clear all
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8.3.4 Entering the Monitor Point Status

Status Monitaring = | B S
Ref. Na. |Status |Data Ref. Na. Status |Data |L
E
< r
StatusPagel

Double-click on the blank space in the [Status Monitoring] window, and the status monitor input window will

appear, and you can input desired monitor reference numbers:

Status Monitoring l=|=3] & |

Fef. Mo

|Hef. Mo |Status |Data | -

|Status |Data

1| Status monitoring

1 Please inout reference number or ranoe (Ex. x0.RE.01

[F0o0]

W Ok | X Canc:ell

|

'.,StatusF'ageD,J

Press the “OK” button:

#
Status Monitoring [E=SEERTSC
Ref. Mo. [Status [Data Ref. Mo Status |Dala | -
F1000 Decimal 0 _ _ [H
< [ ’

StatusPagel

And you will have completed status monitor point input.
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9 Operation of the PLC

Our goal is to operate the PLC through the WinProladder programming software, therefore we describe
connection to the PLC, disconnection, activation, and stop execution of PLC’s operation procedures in the

following.

9.1 PLC On-Line

When connecting to the PLC, the following connection settings will appear:

( on-Line (e |

. Auta Check,
Connection MName
Advanced Add Edit I Delete I
Details
Adtribiute Ciata
Station Mumber 1
redium Serial line
Fart Mo, Ci0kAd
Baud Rate 9600
Parity Ewen parity
Diata Bit 7 hits
Stop Bit 1 bit
O, | Cancel I

Including the Advanced, Add, Edit and Delete settings for the Connection Name, and detailed display settings
for the connection name. PLC connection can be facilitated through Serial line (RS232/485), Modem, or the
Internet, and communications settings files can be established through each of these three connection

methods, and then used for subsequent connection operations.

9.1.1 Direct Usage of Existing Connection Settings Files

Select the file that you would like to use for your connection from the [Connection Name] dropdown menu and

proceed with the connection operation.

9.1.2 Modify Existing Connection Settings Files

Select the connections settings filename that you would like to modify from the [Connection Name] dropdown

menu, then press the “Edit” button and the following settings window will appear:



[ ™
Connection Setup |

On-Ling [ = .|w
Station Mumber: |1 e
FortMNo. i l—L|
Baud Rate:  [gg0p0 = felit | Delete

Parity: Ewven parity *
Diata Bit 7 bits - :
Stop Bit 1 kit -

' Ok x Cancel| ié Cancel

|

9.1.3 Create a New Connection Settings File

In the [Connection] window, press the “Add” button:

( On-Line [-'E_E-J‘
. Auta Check
Connection Narme
|Rs232 -]
Advanced Edit ‘ Delete ‘
Details
Aftribute Data
Station Mumber 1
tedium Serial line
FortMa. COm4
Baud Rate 9600
Farity Ewen parity
Data Bit 7 hits
Stop Bit 1 it
oK Cancel

Step 1: Enter the desired name “Connection 1” for the connections settings file » and press the “Next” button:
Connection \Wizard I&J ]

Pleaze Input The Connection Mame :

‘ 3> Nest

Step 2: Select the hardware to perform the connection through. There are three option types: Serial line

%

(RS232/485), Modem, or the Internet. For [Connection Hardware] settings, please refer to User Manual 11—
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Advanced Applications Chapter 11 FBs-PLC Communications, where FBs-PLC communications related
hardware are described in detail.

Connection Wizard &J

Please chose a medium

" Modem

" Intemet

<< Back ‘ »» Next |

e

1. Serial line (RS232/485):

Press the “Next” button, and the communications parameter settings window will appear:

.
Connection \Wizard &J

Station Murnber 1

Port Mo, : | COMT | |k« Advanced Setun
Baud Rate : 9500 -
Parity: Even parity -
[rata Bit : 7 bits -
Stop Bit 1 bit -

<+ Back ‘ Finish |

\

For details on settings editing, refer to User Manual 1l —Advanced Applications Chapter 11 Communications
Parameter Settings.

2. Modem:

Press the “Next” button:

5
Connection Wizard &J

Please choze a medium :

" Serial line [R5232/485)
@ A

" Intemnet

<< Back | »r Nest

\

Set the PLC station number and select the modem model, set three dial modes, which are described in the
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following:

Using the active dial-up mode:

Enter “035314991" into the [Phone number] field, and try to connect to the modem of the remote party through
the telecommunication system, as shown below:

Connection Wizard &J

Statiorn Number : 1

Modem Maodal Parameters Setting
I El

RAS FPPGE Lined000
R4S YPN Line 0
il Miniport (L2TF)
S5TP

[T Using the passive receive mode

™ Using the call back mode

Phone number 0353145591 |

<< Back ‘ Finizh

Using the passive listening mode:

Check the [Using the passive receive mode] option, then the modem will be set to listening mode, and will
wait for the remote modem to dial in, as shown below:

o
Connection Wizard lﬂiﬂJ

Station Number : 1

Maodern Modal Parameters Setting
I =

FiAS PPPCE Line0000
RAS WP Line 0
AN Miniport (L2TP)
SSTR

I Iv¥ Using the passive receive mode

<< Back ‘ Finish

Using the call back mode:
Check the [Using the call back mode], input the call out telephone number in the [Phone number] field, and
enter the call back telephone number in the [Call back number] field. This means that the WinProladder will

dial up the telephone number “035314991" first, and then the remote party will call back the telephone number

“035457385" if it has successful connection before. The settings shown as below:
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Connection Wizard &J

Station Mumber : 1

Modern Madal Parameters Setting

FAS FPFE Line0000
RAS VPN Line 0
WAN Minipart [LZTP)
S53TP

[ Using the passive receive mode

v Using the call back mode

Phone number:  [035314331
Call back number |035457385

<< Back ‘ Finish

For a further description of the above three MODEM dialing modes , please refer to FATEK programmable
controller User Manual 11— Advanced Applications Chapter 11.

3. Internet:

%
Connection Wizard &J

Flease chose a medium :

7 Serial line (R5232/485)

" Modem

<< Back ‘ »r Nest |

e

Press the “Next” button:

%
Connection Wizard &J

Protocal
&+ UDP

iR

Station Mumber: 4

IF:

Port Nurnber : [}

<< Back ‘ Finish |

For [Protocol], select UDP or TCP, set the [Station Number], [IP] and [Port Number].

Step 3: Press the “Finish” button, and you will have completed the procedure for creating a new connection

settings file.
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Select a connection name and press “Delete”, and you can delete the selected connection name.

On-Line |.i.|

Auto Check

Connection Mame

|Connection1 j
Advanced Add Edit ‘
Connection Wizard ﬁ ]

| e 1 Please confirm if want to delete the [Connectionl] connection
¥ setup

0K J Cancel |

oK Cancel I

9.2 PLC Off-Line

When connected to the PLC, simply execute [PLC] - [Off-Line] from the function toolbar.

9.3 Run PLC

When connected to the PLC, simply execute [PLC] = [Run PLC] from the function toolbar; or press the “F9”
hotkey.

9.4 Stop PLC

When the PLC is in operation, you can execute [PLC] = [Stop PLC] from the function toolbar; or press the
“Ctrl”+“F9” hotkey to stop PLC operation.

9.5 Clear PLC

When connected, execute [PLC] = [Clear PLC] from the function toolbar, and the following data clearing

options will appear:
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Clear PLC Data lﬁj

Clear Operations

& Claar All (Initialization}

 Only Ladder Program
 Only Fegisters
 Only Cails

o OK | X Canu:el‘

Select one of the four options- Clear all (Initialization), Only Ladder Program, Only Register and Only

\,

Coil according to the portion of the program that needs to be cleared, and press the “OK” button.

9.6 PLC Setting

When connected with the PLC, you can set the PLC ID, station humber, communications parameters, and

communications protocol settings for the PLC. The procedures are described as follows:

9.6.1 Setting-PLC ID

Execute [PLC] - [Setting] = [PLC ID] from the functions toolbar, and the following illustration will appear,
enter the PLC ID which is identical to the program ID:

[ Change PLCID (i |

Old Password :
New Password @ |>¢¢<
Confirm Password : |>¢¢4

o OK x CanceIJ

9.6.2 Setting-Station Number

When connected, execute [PLC] - [Setting] = [Station Number] from the function toolbar, and the following

settings window will appear:
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Station Number ﬁ
Station Mumber ]

[~ Sawve To Program

[~ Before writing into, Check the station number

o 0K | X Cancel‘

9.6.3 Setting-Port Parameters

When connected, execute [PLC] - [Setting] = [Port0 Parameters] from the function toolbar, and the following

[Comm. Parameters Setting - Port0] settings window will appear:

Comm. Parameters Setting - Port0 ﬁ

Baud Rate: igggu vi
Farity: iEven parity

Data Bit 7 bits

|4

I

Stop Bit: 1 hit

¥ This portis used for current programming.

Reply delay time: 13 me

Transmission Delay: x10mS

Feceive Time-aut intersal time:
x10m3

[~ “Without checking of station number

Protocal:

X Cancell

It can set the communication parameters for needs: PortO ~ Port4.

9.6.4 Setting-Protocol

When on-line, execute [PLC] = [Setting] = [Protocol] from the function toolbar, and the following settings

window will appear:

Protocol &J Protocol &J
Port: JFatek Communication Pru'_'_] | Partt: ]Fatek Communication PI’D'L]
Fa ] Ci
Port?: ]Fatek Communication Pro"'_| FortZ: | |ModBus RTU(Slave)
ModBus ASCI(Slave)
Part3: ]Fatek Communication Proi:ﬂ] Port3: ]Fatek Caomrmunication Proij
Fortd: ]Fatek Communication Proi__v___] Fortd: ]Fatek Communication Proi.;l

" OK ‘ X Cancel " OK | X Cancel ]
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9.6.5 Setting-Calendar

When the PLC is in [On-Line] status and is in [Run PLC], execute [PLC] = [Setting] = [Calendar], and the

following window will appear, and you can set the time for the PLC'’s built-in calendar:

FPLC current tirme-

Date: | = ] J

Time:| BT | e

& Update PLCtme |
X Cancel

[PLC current time] is the current time taken from the PLC under connected conditions, in the [Setup] field,

check “Apply PC time”, then the PC time will be displayed in the next field, then click the “Update PLC time”
button, and the [PLC current time] will be changed to the current time in the PC; if the “Apply PC time” is
unchecked, then the [Date] and [Time] settings in the next fields can be modified, then press the “Update PLC

time” button, and the [PLC current time] will be changed to the currently set time.

9.6.6 Setting-Phone Number

When connected, execute [PLC] - [Setting] = [Phone Number] from the function toolbar, and the following

settings window will appear:

[ "Setup the dial out phone number® @J‘

Setup the PLC's phone #: ‘

Setup the phone # ].,021 234567 4174

Description:
Example:
021234567 #12*
Description ;
Wait 4 seconds then dail the phone number
02021234567

" OK | x Cancel]
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9.7 Quick Control

WinProladder versions 2.0 and earlier had to wait long periods of time (in large programs) before being able
to obtain any information from the PLC. This became a large and unnecessary overhead if all you wanted to
do was obtain the status of the PLC or initialize the PLC. Therefore, in versions 2.0 and later, we added “Quick

Control” feature, allowing users to quickly read the status of the “PLC” and initialize the PLC without having to
connect to the PLC:

inProLadder - [Ladder Diagram - Main_unit1]

%) File Edit View Project Ladder | PLC Tool Window Help
- | BEm 8" "B -V E - R

o &
NI 4; Vt 4 ) ) (82.02_'/5' he !X -

=) Projectd [FBs-24MC)
-] System Configuration
E Ladder Diagram
=& Tahle Edit
=M Comment Qu:lne £
B} Status Page
=162 140 Numbering

o) =
e Project /0 Mumbering Setting ;

K2 PLC /O Numbering
Project Status
[ Initialize PLC
= Run PLC
RO # StopPLC

MEMORY_PACK operations ..

9.7.1 Get System Status of PLC

When off-line, select [PLC] = [Quick Control] > [Get System Status of PLC] from the function toolbar and you

will be able to read PLC information.

on-Line e |

Auta Check
Advanced Add Edit I Delete J
Details
Aftribute Diata
Station Mumber 1
Mediurm Serial ling
Port Mo COhdq
Baud Rate 3600
Parity Ewen parity
Data Bit 7 hits
Stop Bt 1 hit

And Press “OK” button.

[ PLC Status =

Status
ation Mu.. 1
ElModel FBs-24MC(w4.62)
i PLC Status  Stopped
< MEMORY_.. MotSet
Syntax Che... Check error or not check yet
Password Mot Set
Main Progr... Mot Set
Sub-Progra... Mot Set
Data Pass..  NotSet
Frogram D Not Set
FLCID Mot Set
9 Calendar Installed
[EAvailable p.. 20224vard
OWord
20223Word
~4.00

' OK
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9.7.2 Initialize PLC

When off-line, select [PLC] = [Quick Control] = [Initialize PLC] from the function toolbar, and you will be able

to initialize the PLC if successful connection:

[ On-Line &-J"

. Auto Check
Connection Mame
Advanced Add Edit I Delete I
Details
Adtribiute | Data
Station Murmber 1
tedium Seralline
Fart Ma. CokA4
Baud Rate 600
Farity Ewen parity
Data Bit 7 hitg
Stop Bit 1 hit
CIE, | Cancel

L

And Press “OK” button.

PLC Initialization [

l' . Are you sure clear ladder program + data ?

e "

Then Press “YES” button.

Connect Ta PLC ﬁ

10] System Initialization OK!
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10 Ladder Program Simulation

10.1. Features

B Can simulate the FATEK PLC ladder program execution without PLC connection.

W With providing single/multiple/continuous scan mode, the execution result at each scan end can be
easily checked.

B With providing program address breakpoint and data breakpoint, it is convenient to check any

intermediate execution result and to identify any data changed.

Provides communication interface allows external program or device (For example, graphic panel

or HMI) to modify or monitor the variable value during the simulation.

With run time editing feature, during the simulation process the program can be modified without

stop the execution.

10.2. Limitation of Program Simulation

Besides the I/O operation, most of the instructions can be simulated. When the ladder program
contains the unsupported instruction, the operation of unsupported instruction will be ignored and will

be shown with yellow background color as following.

56D.G->E
EN— 5 RO

100

71

150P.M-BUS——
H 2 FACT—

2

RO
100

R10 FERR—
0

—DH—
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10.3. Operation of Program Simulation

The following is an example of “ssi.pdw” project. With this project to explain the related operations for

program simulation.

10.3.1 Open Ladder Program

Follow the following main menu operation to open the “ ssi.pdw” project file.
File > Open project > Open file > select ssi.pdw. After select the project, the screen will display

as below:

el

GO TRM ARV ME)

O R S e e RN =P
RALH S L "EEDNOE XX R
[~ :

10.3.2 Enter Simulation Mode

Main Menu: PLC > Simulation

It will enter into the simulation mode after execution.

10.3.3 Start Execution of Program Simulation
Main Menu: PLC > Run

After execution, the color of power line of ladder program will become to red color as the screen

shown as below:
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W) PLCD TAM BEM) WE0T

LAE 52 S SANE SO0 S8 A8
RS L - EEODEX*R

iR
5 IERE S

|
|
== g e
|
|
|
¢

Ewn /B T I

@ wn WE nzRica

During the execution, there is a blinking red dot at the left side of status bar. On the right of the red
dot has SC:xx, xx means the number of time have been scanned. During simulation, can use the

status page to monitor or modify the value of register or discrete point.

10.3.4 Pause of Program Simulation

Main Menu: PLC > Pause Simulation or the easiest way is to click the space bar

At this point, the blinking red dot stop blinking and it will become pink color.

10.3.5 Proceed to Program Simulation

Main Menu: PLC > Resume Simulation or the easiest way is to click the space bar

At this point, the dot becomes blinking again and the program continues the operation.

10.3.6 Control Scanning

The above pause/Resume program simulation is operated by manual way of controlling the program
execution, which will pause the program execution at the next scan end point right after you issue the
command. But if you would like to control the exact times of scan execution after pause, you can use

set scan mode to control.

10.3.6.1 Single Scan

Main Menu: PLC > Setup Simulation choose "single scan”
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Simulation Setup | B

Scan | Communication
[T Cold Start

Scan Mode:

After set this mode, you can use space bar or

Main menu: PLC >Resume Simulation to start a new scanning work.

10.3.6.2 Multiple Scan

Main menu: PLC > Setup Simulation choose “multiple scan”

After selecting the mode, you can set number of scans to be performed in the number of scanning

field.

Scan Mode:

Scan Times: |2

" OK

After that, press space bar or

Main menu: PLC > Resume Simulation to start up next scanning work.

reached the set number, it will pause the scanning.

10.3.6.3 Continuous Scan

Main menu: PLC > Setup Simulation choose “continuous scan”

This is the default scan mode after enter the simulation.
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10.3.7 Set Address Breakpoint of Program Execution

In addition to the above methods to make the program paused at the scan end point, can also using
the following method to pause the program at the point before a specific network number.

Please first select the network to be set break point and then execute the

main menu: PLC > Add/Remove address breakpoint

or in the ladder program window, on the “Network Display” region click the right button of the mouse
and popup the menu.

Popup Menu: Add/Remove address breakpoint

The network with breakpoint set will display a red dot, which is as shown in the picture below:

NOOO

08D . MOV
51 D407

2

100
D RO
100

NOO1

08D . MOV
51 D407 2

100
D R2
100

The above picture indicates NOO1 has been set to an address breakpoint. When every time right
before execution of this network, it will pause the program execution. The user can press space bar
for continuing the program execution. The address breakpoint can be set up to 16 points at same

time.

10.3.8 View Address Breakpoint List

When there are many address breakpoints have been set, can use this feature to quickly remove,
pause or enable the setting of address breakpoints.
Main menu: PLC > view address breakpoints

After execution, it will display the following window:

) Address Breakpoint List (= | B s
Mo. Frogram Unit Met Mo, |Enabled =+

This window will show all the existed address breakpoints. The checked mark in the enabled field
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means corresponding address breakpoints are in effective. You may use right click to call the pop-up

menu shown in below:

Enabled
Dizabled
Erase

Erase All

@ Enabled: Activate the breakpoint.

® Disabled: Inactivate the breakpoint. When disabled, the red dot of the corresponding network will
become a gray dot.

® Removed: clear the breakpoint.

® Removed all: remove all breakpoints.

If you double click the breakpoint in the list, it will display the corresponding breakpoint in the ladder

program window.

10.3.9 Setup Data Breakpoint

Use this feature will make the program pause when the value of a specific contact or register changed
or change into a certain values.

Main menu: PLC > Setup Data Breakpoint

After operation, it will display the window as shown in below

The left screen will be shown when the “Enable” field is not checked while the right screen is checked.

Data Break Setup = B [ = | B [

[ Enahbled

Ref. Mo:
Data:

Condition
f* Change to
" Change notto

" Change to any

¥ Cancel | o 0K | * Cancel |

e

When check the “Enabled” checkbox, the setup fields will appear. Description is as follows:
»  Ref. No.: Register (Word or Double word) or contact reference number.
»  Data: Conditions of match value

»  Condition: three options
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® Change to — When value of Ref. No. (Monitoring variable) is changed to the “Data” value, the

execution will be paused.

® Change not to -When value of Ref. No. (Monitoring variable) is changed to a value not equal to

“Data” value, the execution will be paused.

® Changed —Whenever the value of Ref. No. (Monitoring variable) is changed , the execution will

be paused.

This feature can easily be used to identify the source of any changes of monitored variables.

10.3.10 Stop Simulation

Simulate the PLC “stop” operation, when next time execution (RUN), it will simulate the initial

operation.

Main menu: PLC > Stop

10.3.11 End Simulation

Exit the simulation mode.

Main menu: PLC > End simulation

10.4. Communicate with Simulation Program

When perform the simulation, besides “Winproladder” software, other devices or software can also
monitor or modify the status of variables, though serial port or TCP/IP network interface by using the
Fatek communication protocol. The most common practice is to combine the HMI and ladder

simulation to perform the integrated test.
There should be noted that, this feature only provides Fatek PLC slave communication capability. The

function block FUN 150, 151 and real I/O related functions are not supported in simulation.

10.4.1 Communication Function Setup

You may choose serial ports or TCP network. The setup method is as follow:
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Main menu: PLC > Setup Simulation After that please select “communication Setup” tab.

In this page, please check “Enabled” checkbox and then it will display the following window.
"[E) simulation Setup = | B S |

Scan  Communication l
& Serial Adtribute Data -
Station Murnber 1 =
lﬂ- =
Tee Medium Serial line
FortMo. COm1
Baud Rate 9600
. Erarite Fuvian navih: S
Edit I m b
o 0K

10.4.1.1 Serial Port Communication Setup

After select 232, press “Edit”. Fill in the simulated communication parameters.

In addition, the “Port Number” means the port number on PC.

Connection Setup ﬁ
Station Number :
PartMNo. : COM1 -
Baud Rate:  |gpnp -
Parity. Ewven parity, =
Data Bit 7 bits -
Stop Bit 1 kit -

X Cancel

10.4.1.2 Internet Communication Setup

After select TCP, press “Edit”. Fill in the simulated communication parameters as desire.

Connecticn Setup (o
Station Number: |1

Frotocol

& TCP

Port Numbe|snp




11 Constructing Projects

When constructing a project, to ensure that the project has been well designed with intellectual protection and
for long term maintenance and easy maodification, it needs to provide detailed information regarding project
information, program security settings, and system configurations. The following is a description of the

settings related to construct a project.

11.1 Modifying Project Information

Execute [Project] = [Project Information] from the function toolbar, and the project information window will

appear, and you can proceed with the modifications:

Project Information 54

Proiect Mame | FEEEREn I
Model Mame  FBs-24MC Edit

Detachable terminal black RTC. 14 DC24Y inputs(2 120KHz + 14 20KHz),10
outputs(2 120KHz + B 20KHz).1 comm. port{can expand up to &)

Description :

4 ]

Options
[v Calendar

X Cancel

Please refer to [Create New Project] in Section 3.1 for a description of how to conduct the settings process.

11.2 Program Security Settings

Most systems adopt a password approach for intellectual property protection. With FBs-PLC, in addition to
passwords, we also provide security measures such as program ID and PLC ID, providing an additional layer

of security to help protect the results produced through the user’s painstaking research and development.

11.2.1 Set the Program Password

Execute [Project] > [Project Setup] = [Password] from the function toolbar, and the following window will

appear:
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Change Password X

Old Password :
MNew Passwaord : S
Canfirm Password : [5044

[ Pratect Sub-Program Only

V' OK | X Cancel|

After you have entered the password, all subsequent access to the project will require inputting this password

to protect the program.

When the program designer only wishes to open the main program area for public access, and does not wish
to allow public access to the sub program area, then the "Protect Sub-Program Only” option can be selected,

and the sub program area will be protected.
[ Change Password & )

Old Passwaord :
MNew Password OGO
Confirm Password © s

I|7 Protect Sub-Program Oni |

W OK | X Cancel|

11.2.2 Set the Program ID

The program password can prevent illegal copying of the program, which can provide a certain degree of
protection, but it cannot help against preventing program hardcopies (If ROM Pack being used, it is easy to
take out and install on some other PLC main unit for working), in these circumstances, the password will not
be able to protect the program. In this situation, setting a program ID that must be identical to the PLC ID can

prevent hardcopies, thereby providing a further degree of security.

Execute [Project] > [Project Setup] = [Program ID] from the function toolbar, and the following window will

appear:

Change Program ID e G

Old Password :
MNew Passward : e
Confirm Password © |50

W OK X Cancel |

Now you can set the program ID; if a program has the program ID setting, then the PLC that wishes to
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execute this program must have a PLC ID set to be same with program ID, otherwise the PLC will not be able

to operate.

11.3 Program Conversion

Execute [Project] = [Program Conversion] = [8K->13K] from the function toolbar, and you can expand the
program conversion from 8K to 13K; or, execute [Project] = [Program Conversion] - [13K->8K] from the
function toolbar, and you can shrink the program conversion from 13K to 8K. In addition, in versions 2.00 and
newer, we have also added FBe(8K/13K) - FBs(20K).

11.4 Set System Configurations

System configurations include 1/O settings, memory allocation, and read-only register settings.

11.4.1 Set I/O Configuration

Ban
=t

Execute [Project] - [I/O Configuration] from the function toolbar; or click the icon in the tool bar; or in the
project window, click [Text example] = [System Configuration]>[l/O Configuration] twice, and the 1/0

configuration window will appear:

5
[ /O Configuration MC v4.x ]
“Utiization 1 | Timer/Counter | IntemuptSetup | OutputSetup | InputSetup | Temp. Configuiation 4 | »

140 Mo | Function | -

w0 Undefined HSCO HSC1 HSC2 HSC3 HSC4 HSCh HSCE HSC?

X1 Undefined Timer Configuration HSC Polarity

bl Undefined _

3 Undefined Counter Type: | ask signak ’m
et Undefined it = 2

bl Undefined ounting kode: ot use - : ’—_|
B Undsfined Clear signal: Marmal -
B Undefined i i

xa Undzfined Counter signal Mormal -
x4 Undefined

®ia Undefined

=11 Undefined |= i

%12 Undefined H5C's Data Length

A3 chdefined 32-Bit Hardware Counter j

X4 Undefined
®18 Undefined

Y0 Undsfined

! Undefined
Y2 Undefined
Y3 Undefined
) Undefined
A& Undefined
A Undefined

At Undefined b

x Cancel

11.4.1.1 Configure the Counter/Timer Settings

As shown in the illustration below, configure the [Counter] page, the FB-PLC has 4 HHSC(Hardware
High-Speed Counter), and 4 SHSC(Software High-Speed Counter) in which the 4 HHSC(HSCO0~HSC3) have
8 counting modes, which can be selected in the [Counting Mode] dropdown menu in the illustration below;
and the 4 SHSC(HSC4~HSC7) have 3 counting modes, which can be selected in the [Counting Mode]
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dropdown menu shown in the illustration below.

5
1/0 Configuration MC v4.x |
“Utiization | | Timer/Counter | IntemuptSetup | OutputSetup | InputSetup | Temp. Configuiation 4 | »

140 Mo | Function | -
w0 Undefined I H5CO HSC1 HSC2 | HSC3 HSC4 HSCh HSCE HSC?

®1 Undefined Timer Configuration 7 HSC Polarity
bl Undefined

®3 Undefined Counter Type: Hardware Counter = Mask signak Marmal -

=4 Undefined 5 b m
ig Hzg:;:z:g ounting Mocke: o ?SB = Clear signal: Mormal -
bl Undefined :

xa Undzfined Counter signal Mormal -
®9 Undefined
»10 Undsfined
bl Undefined
w12 Undefined
®13 Undefined
®14 Undefined
®15 Undefined

m

H5C's Data Lenath

32-Bit Hardware Counter j

gl Undefined
! Undefined
Y2 Undefined
3 Undefined
r4 Undefined
b Undefined
A Undefined

At Undefined b

x Cancel

For the HHSC, because A/B inputs must be used in pairs, if you select the “A/B” [Counting Mode], and select

“X0” for the [A-Phase] field, then “X1” will automatically be chosen for the [B-Phase] field, and you will not be

allowed to modify this. As shown below:

5
1/0 Configuration MC v4.x |
“Utiization | | Timer/Counter | IntemuptSetup | OutputSetup | InputSetup | Temp. Configuiation 4 | »

140 Mo | Function | -

w0 HSCOAPH.. | HSCO H5C1 HSC2 HSC3 HSC4 HSCH HSCE HSC?

=1 HSCOE Ph... Timer Configuratior -1 HSLC Polarity

bl Undefined

®3 Undefined Counter Type: Hardware Counter = Mask signak Marmal -

et Undefined

ig Hzg:;:z:g Sailiobicc A/ hd Clear signal: Mormal -
bl Undefined ;
Counter signal: Mormal -

xa HSC2.4 Ph..
X3 HSCZE Ph..
®ia Undefined

m

bl Undefined | 3 .
®12 Undsfined AcPhase: H5C's Data Length

i Undef!ned ke |32-Bit Hardware Counter j
X4 Undefined !

#15 Undefined M askMEE]:

o \Undefined ClearlCLR):

1 Undsfined

2 Undsfined

T3 Undefined

4 Undefined

5 Undefined

A Undefined

At Undefined b

x Cancel

If “K/R” or “U/D” is chosen for the [Counting Mode], then the inputs can be entered separately. To achieve

optimal results, the input point distribution is as follows:

HHSCO HHSC1 HHSC2 HHSC3
Clk Dir Clk Dir Clk Dir Clk Dir
Up Down | Up Down | Up Down | Up Down
X0 X1 X1 X5 X4 X9 X5 X13
X4 X5 X12
X8

The meaning of the points that appear repeatedly is, for example, you can just set one point for HHSCO, and
save X1 for HHSCL1 to use, therefore, the 1/0 point settings for FBs will be more flexible than those for the

previous FBe series, and if you use the distribution method described below, a 14-point main unit will be able
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to complete 4 sets of hardware high-speed counters (without considering the directions):

HHSCO HHSC1 HHSC2 HHSC3
Clk Dir Clk Dir Clk Dir Clk Dir
Up Down | Up Down | Up Down | Up Down
X0 X1 X4 X5

The 8 counter modes for the HHSC are: U/D » U/D*2 » KIR » K/IR*2 » A/B » A/B*2 » A/B*3 > A/IB*4.
The 3 counter modes for the SHSC are: U/D » K/R » A/B.

(For descriptions of the above counter modes, please refer to Chapter 10 Advanced Applications of User

Manual Il.)
5
1/O Configuration MC vdx =5
Utilizatior | Timer/Counter | Interupt Setup Output Setup Input Setup Temp. Configuration FEIS
|/0 Mo, | Function o f
20 HSCO.UP 3 HSCO HSC1 HSC2 HSC3 HSC4 HSCH HSCE HSC?
1 H5SCO.DM é Timer Configuratior 7| HSLC Polarity T
22 HSCOMSK
3 HSCOCLR Counter Type: Hardware Counter Mask signak Marmal -
4 Undetined IC e |Uf’D _JI
=5 Undefined Rl TiElE = - =
s Uincisfined | Clear signal: Mormal
=7 Undsfined i SR :
wa HSC2 A Ph.. U|_+—I_FL| | Counter signal: Mormal >
®g HSC2E Ph.. P i = W
=10 Undefined
w11 Undefined | " = .
i I e LUp(UP) |%0 |l | FHSC's DataLength
#13 Undsfined D own(DM): x1 = |32-Bit Hardware Counter j
w14 Undefined ST
®15  Undefined ask(MSK] #2 =
0 Undfined LlcalCle),
1 Undefined
2 Undefined
Y3 Undefined
4 Undefined
b Undsfined
Y& Undefined
7 Undefined Iy

x Cancel

Select the [HSCO] counter setting, choose “Hardware Counter” for [Counter Type], select “U/D” for [Counting

Mode], representing that single-phase independent upward/downward high-speed counters have two
independent upward (U) and downward (D) pulse inputs, and these two are independent and unrelated.

Therefore, the following will appear after you have chosen “U/D”:

[Up (UP)]: if “X0" is chosen for this field, then the current counting value will increment

by 1 at the rising-edge of the X0 pulse input.

[Down (DN)]: if “X1" is chosen for this field, then the current counting value will decrease

by 1 at the rising-edge of the X1 pulse input.

[Mask (MSK)]: if “X2" is chosen for this field, then when the X2 signal is a 1, the HSC
counter pulse will be masked and will not count, while the internal states of
the HSC will be fully preserved. When X2 goes back to 0, HSC will go back

to normal operation.

[Clear (CLR)]: if “X3" is chosen for this field, then when the X3 signal is a 1, the internal CV
register of the HSC will be cleared to a 0, and cannot count, and only when
X3 goes back to 0, will HSC begin counting from 0. After completing the

settings, the “not specified” content of the X0~X3 status in the [Interface
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Usage Status] window on the left will be changed to the settings contents.

[Mask signal] field: can choose to reverse or non-reverse the Mask input signal.
[Clear signal] field: can choose to reverse or non-reverse the Clear input signal.
[Counter signal] field: can choose to reverse or non-reverse the Count input signal.

[HSC’s Data Length] field: Function reserved.

11.4.1.2 Configure the Interrupt Signal Settings

Select the [Interrupt Setup] page:

(& /O Configuration MC vdx S5
Utilization Timer/Counter | Interupt Setup | Output Setup | Input Setup | Temp. Caonfiguration Pl
1#0 Na. | Function s

o HSCOUP Interupt Setup

<1 HSCO.0N UseNTORD)  [Fosivetdge =] iiE atetee E
e HECOMSE [ Use [0 Positive Edge [ Use (8] Posithve Edge

o5 HSCO.LLR ™ UseINT1(<1]  [Posiive Edge [~ Use INTA <) Positive Edae

wa INT4.Pos. ..

#5 Undzfined [T UseINT2(42)  |Positive Edae [~ UseINTI0[x10)  [Pasitive Edoe

§§ HESZ:EZ: [ UseNT3[3)  [Fosiive Edoe [~ UseINTIT(11) [Fositive Edge

#a HSC2A Ph.. [ Use INT4 [=4) Pozitive Edge | T UseINT12(12)  [Positve Edos
%3 H5CZE Ph.. B z
®10 Undsfined 7 Use INTS [<5) o [T UseINT13(<13]  |Positve Edge

m

bl Undefined
®12 Undefined [ Use INTE [<6)

®13 Undefined Usze INT? (=7,
=14 Undefined a e
#15 Undefined

Al Undefined

[~ Use INT14 [x14) Posgitive Edge
[~ Use INT15 [%15) Poszitve Edge

Puositive Edge

1 Undefined
e Undefined
3 Undefined
4 Undefined
e Undefined
Yh Undefined
Y7 Undefined iy

XK Cancel

Interrupt refers to a signal sent to the CPU requesting immediate service, during the routine sequential

execution of cycles and scanning; when the CPU receives an interrupt request, it immediately discontinues
the scanning operation that it is executing, and proceeds with the “Service Requested by Interrupt” first; and
the CPU will return to the interrupted scanning operation after the service is complete.

The service specified by the interrupt request, i.e. the “Interrupt Service Program”, must have a one and only
“Interrupt Label Name”. For the interrupt label names and interrupt priorities of the 49 FBs-PLC interrupts,
please refer to Section 9.3 [interrupt components for FBs-PLC, and label names and order of priority] in
Chapter 9 Advanced Applications in User Manual Il.

The rising and falling edge settings for X0~X15 in the [Input Setup] represent the interrupt occurrence

conditions for the interrupt priority 18 ~ 49 “Interrupt label names”.

11.4.1.3 Configure the Output Signal Settings

Select the [Output Setup] page:
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5
1/0 Configuration MC v4.x [_5_3..]
Utilizatiory Timer/Counter | Interupt Setup | ] Output Setup | Input Setup | Temp. Configuiation | 4 | »

140 Mo | Function . . ! 8
o HSCO.UF Retentive Output Coit HSPS0
1 HSCO.DN [ ET . PSO0 (YO
%2 HSCOMSK v £ ok
%3 HSCO.CLR ¥2 L PSOT (Y23
w4 INT4.Pos. ... Y3
=5 Undefined 14 PS02 [v4-+75]):
B Undefined LIvs :
%7 Undfined 6 o e
b H5C2A Ph.. I
%3 HSCZ.B Ph.. E Output Polarity
»10 Undzfined
#1 Undefined 3 $:II1D Y0471 Output: Mormal -
w12 Undefined r
=13 Undefined m% Y273 Output: Mormal -
X4 Undefined v ; ) ’—_‘
w15 Undsfined V15 Y475 Output: Mormal hd
"""""" T 116 YEYT Qulput Momd =]
gl Undefined Y17
1 Undefined bk =
v2 Undefined =R
3 Undefined
r4 Undefined
b Undefined
A Undefined
At Undefined b
X oo

[Retentive Output Coil]: when Yn is selected, the Yn output will be preserved in the case of a power-off.

[HSPSOQ]: FBs-PLCs can provide 20KHz~920KHz high-speed pulse output depending on model
type. With regard to the pulse frequency, three series of model types are provided: the
(FBs-xxMA-T) series can provide 20KHz (single-end) output, the (FBs-xxMC-T) series
can provide 20KHz ~200KHz (single-end) output, and the (FBs-xxMN) series can
provide up to 920KHz high-speed differential output.

High-speed pulse output circuits share the FBs-PLC external output points YO~Y7. When the HSPSO function
is not utilized (the PSO function has not been configured), the YO~Y7 external output points of the FB-PLC
are mapped to the internal statuses YO~Y7 of the PLC. But when the HSPSO has been configured, then the
external output points YO~Y7 will directly switch to the HSPSO output circuits internal to the ASIC, and will
have nothing to do with the YO~Y7 status in the PLC.

The following is a table showing the signal descriptions of the output points of the various axles of the main
unit and the selectable output modes, the [High-Speed Pulse Output] settings can be set according to the

following table:

Output mode
External i i
Axle output u/D CK/DIR A/B Single-point
number point output output output CK output
PSOO0 YO YO=U YO0=CLK YO0=A YO0=CLK
Y1 Y1=D Y1=DIR Y1=B
Y2 Y2=U Y2=CLK Y2=A
POl Y3 Y3=D Y3=DIR Y3=B Y2=CLK
PSO2 Y4 Y4=U Y4=CLK Y4=A Y4=CLK
Y5 Y5=D Y5=DIR Y5=B
PSO3 Y6 Y6=U Y6=CLK Y6=A Y6=CLK
Y7 Y7=D Y7=DIRR Y7=B

In the table, the “Single-Point CK Output)” mode provides users with a mono-direction high-speed pulse
output, and can therefore save output points for designers that only need one high-speed output point, which
can be very useful.

[Output Polarity] field: select inverted or non-inverted for pulse output.
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11.4.1.4 Configure the Input Signal Settings

Select the [Input Setup] page:

1/O Configuration MC vA.x [&
Utilizatior Timer/Counter | Intermupt Setup | Dutput Setup ]\npulﬁetup Temp. Configuiation | 4 | p
1/0 No. | Function | = )
w0 HECO.UP 2 Captured Input Configuration
w2 HECO.ON [~ Setall I~ Resetal
w3 HSCOMSEK [~ X0 [~ 4 [~ g 12 [T %16 [T =20 |7 24 [T X2e [ X322
%3 HSCO.CLR (R T R T 4 A -1 R T i M
%4 INT#4Pos, e.. CWz [Cx6 (X100 xia [T K18 [T x22 | %26 [0 %30 [ %34
%5 Undefined Mx3 M%7 TR [CRIs [T X18 [T =3 [T &7 [7X31 M 35
B Undefined _
7 Undefined Drigital Filker Configuration
8 HSC24Fh... -
g HSC2.B Fh... ®Ow3 O Time: x0.1mS H129018 O Time 1+, TmS
%10 Undefined
i e |d @ Freq [T & Freq:  [480K ]
%12 Urdefined
%13 U:d;:::d Ka~p O Time: x0.1mS HIE™H23: Time: 3 e
%14 Urdefined
GE  Undefined oy BR x| e
Y0 Undefired XBK11: € Time: 1S WK Time: 3 s
v Undefined
¥2 Undefined ol B x|
73 Undefined
4 Undefined
5 Undsfined
& U:dzf:::d Froce Fun [nput: Mot used -
Y7 Undefined %
X o
Captured Input Configuration:
[Set All]: set all X0~X35 inputs to captured Input.
[Reset All]: cancel all X0~X35 captured Inputs.
[Digital Filter Configuration]: divide X0~X35 into 6 groups.
1 X0~X3 4 X12~X15
2 X4~X7 5 X16~X23
3 X8~X11 6 X24~X35

% For descriptions of captured Inputs and digital filtering, please refer to Section 9.7 of FBs User Manual

— Advanced Applications

11.4.1.5 Configure Temperature Module Settings

If the PLC system exists the temperature expansion module, it will automatically detect and distribute the 1/0

reference address to it. For details, please refer to Section 13.6 (I/O Reference Number Allocation statuses).

&8 winProLadder - [Ladder Diagram - Main_unit1]
[ File Edit View Project Ladder PLC Tool Window Help

i A,

Os~-B HEHER
weewm B %ot B -8 V- H B E
R[S E R e [0 (SIRI T [CITET X R
[Nooo
= [ RS232 [FBs-24MC]
- %1 System Configuration
&[] Ladder Diagram
= B Table Edit NOOL
- Comment
% Status Page
2% 110 Numbering D2
#-42% Project ¥ Numbering
=152 PLC O Numbering
= [ 0FBs-2aMC(v4.62)
LB DRI NOO3
DO:Y0™YE
Be-TCh
DONY10™Y17 TG0
 IRR3040
= M 2FBs-RTD6
3% DOY18™Y2E
Cam IRR3B4T NOOS
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The example in the above illustration shows the FBs-24MC main unit has two expanded temperature modules

TC6 and RTD6. To configure the expansion modules, click [Temp. Configuration] and shown as below:

Y
[Z) /O Configuration MC va.x [
Utilization Timer/Counter | Interupt Setup | Output Setup Input Setup | | Temp. Configuration | 4 | »

140 Mo. | Function -

w0 i Und f.' q Temperature Configuration -

o U'; deIEZ d Starting Address of Configuration T able: R1000 [R1000~F1005)

H2 Undsfined Starting Address of Temperature Register: RO [RO~R11)

®3 Undefined

w4 Undefined Starting Address of Warking Register: R&00 [RE00~R511)

»5 Undefined

%6 Undefined Addiess  Module Name  Sensor Type Urit of Temp.: Cebsivs
RT Undefined #1: R3840  FBs-TCE K. el [

wB Undefined Times of Average: Nao -
9 Undefined #2 R3gd FBs-RTDE PT1000-DIN =

Scan Rate: Nomal -

®in Undefined

w1 Undefined uE

m

w2 Undefined Hi-
®13 Undefined

w14 Undefined HE:
G |
o Undefined #7:
1 Undefined

Y2 Undefined He:
Y3 Undefined

r4 Undefined

5 Undzfined

A Undefined

A\ Undefined E

x Cancel

[Starting Address of Configuration Table]: the registers of table store configuration information regarding
the temperature modules. For detailed descriptions, please refer to FBs User
Manual Il (Chapter 21 FBs-PLC Temperature Measurement and Temperature PID

Control).

[Starting Address of Temperature Register]: sets the beginning register address for the current reading
values of temperature measurement; each channel is mapped to a register. In the
example, one TC6 module and one RTD6 module, adds up to a total of 12

channels, and therefore needs 12 registers.

[Starting Address of Working Register]: these registers are needed for the internal operation of the PLC
system for temperature module’s working. For detailed descriptions, please refer
to FBs User Manual Il (Chapter 21 FBs-PLC Temperature Measurement and

Temperature PID Control).

[Sensor Type]: FBs temperature module comes in two main categories: TCXX and RTDXX. The types and

ranges of selectable temperature sensors are listed in the following table:

J(-200 ~ 1200°C) E(-190 ~ 1000°C)

K(-190 ~ 1300°C) T(-190 ~ 380°C)
(1). TCXX

R(0 ~ 1800°C) B(350 ~ 1800°C)

S(0 ~ 1700°C) N(-200 ~ 1000°C)

Triple-wire type JIS or DIN
(2). RTDXX Pt-100(-200 ~ 850°C)
Pt-1000(-200 ~ 600°C)
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[Unit of Temp.]: the user can select either Celsius or Fahrenheit temperature representations.

[Times of Average]: you can calculate the averaged value of the measured temperatures. The selectable
options are: "No”, "2", "4”, and "8".

[Scan Rate]: select the “Normal” (With 0.1° resolution) or the “Fast” (With 1° resolution) refresh rate for

temperature measurement.

11.4.1.6 Configure the Al Module Settings

If the PLC system exists the analog input expansion modules, it will detect and distribute the 1/O reference
address for access. For detailed descriptions, please refer to Section 13.6 (/O Reference Number Allocation

Statuses).

@ winProLadder - [Ladder Diagram - Main_unit1]

% File Edit View Project Ladder PLC Tool Window Help
DES-d ||BER
Hen | Bow- BB -G-8, -% -5 B8 B |EE
[t #QRQR4 S L "EETEEXIX %
N

=B R5232 [FBs-24MC]
-1 System Configuration
¢ 38 110 Configuration
& Memary Allocation NOOL
: ROR Register
=] Ladder Diagram

=B Table Edit s
- Comment
B} Status Page
=58 10 Numbering
145 Project /O Numbering NOD3
52 PLC IO Murbering
el 0FBs-24MC w4 62) -

NOO4

Lom IPER3840™R3845
NOOS

The above illustrated example shows a FBs-24MC main unit has a 6AD expansion module, and this module
occupies six analog input registers R3840~R3845 as the reference address for access. To configure this

module, click [Al Configuration], it will show the screen:

%) 1/O Configuration MC v4.x S5
Utilizatior Intemupt Setup | Output Setup | Input Setup Temp. Configuration Al Configuration | 4 | »
140 Mo | Function | = i
bl Undefined |
1 Undefined Al Data Format " 14-bit Format
n Undefined :

%3 Undefined Al Modules Al Setup
=4 Undefined Position | Module Name | Start Address | fddiess  Validbit  Times of Average
%5 Hrdchined 1 FBs-EAD R3840
bt Undefined
ne Undefined
bt Undefined

x3 Undefined
pali} Undefined
bl Undefined
w2 Undefined
x13 Undefined
K14 Undefined
w15 Undefined

m

v0 Undsfined

1 Undefined
e Undefined
Y3 Undefined
) Undefined
he] Undefined
Y& Undefined

At Undefined %

x Cancel

[Al Data Format]: It can be 12-bit or 14-bit format for representation
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/O Configuration MC v4.x [

~Ltilizatior Interrupt Setup Output Setup | Input Setup Temp. Configuration Al Configuration | « | »

I#0Mo. | Function | = !
0 Undefired | ]

1 Undefined Al Data Farmat : (¥ 12-bit Format " 14-bit Format

®2 Undefined S . .

w3 Undefined Al Modules Al Setupr

»4 Undefined Pogition | Module Name | Start Address At VAt Tiesofsveios

®a Undefined i 5D

B Undefined - ch R3540 12-hit 1

HF Undefined S

o Undsfined chl R3841 12-bit 1

2 Hndoined chz R3gdz  [1zbe ][t

®10 Undefined

X1 Undefned |5 ch3 R3se3  [1zbi -1
w12 Undefined

#13 Undefined chd R3544 12-bit 1
R i che R3a4s  [12br [T
b Undefined

hal Undefined

T2 Undefined

w3 Undefined

rd Undefined

A1 Undefined L5

B Undefined

i Undefined i

X Cancel

[Valid Bits]: if the analog input format is set to 12-bit, then the effective number of bits will be set at 12 and
cannot be changed. If the analog input format is set at 14-bit, then the effective bits setting can

be set to either 12-bit or 14-bit, and the Al reading values are all in 14-bit representation.

= b
1/O Configuration MC vé.x =5
~Utilizatior | Intemupt Setup | Output Setup | Input Setup | Temp. Configuration ]AI Configuration | 4 | »

I#0MNa. | Function | T

Undefined 1l
Undefined Al Data Format : " 12-bit Format v 14-hit Format | se—
Undefined S . E |
Undefined Al Modules Al Setup
H:g:g::zg Position ] Module Name ] Start Address 1 Addiess  Validbit  Times o Average
Undefined ! FBs8AD Fi3g4 chil B3840 126t =1
Undefined 7 —
Undefined el (R '
Undefined

h2 R3842 .
Undefined | | :
Undefined 1= ch3 R3843 126t =1
Undefined
Undefined chd R3844 124t = |1

Undefined
Undefi

chS R3845 126t =1

Undefine:
Undefined
Undefined
Undefined
Undefined
Undefined LE
Undefined
Undefined i

x Cancel

[Times of Average]: it can give the number of average for reading value calculation, which can be at least 1
time (No average), and at most 16 times. But it should note that the higher the average value,

the more times it will take to refresh the reading value.

11.4.2 Configure the Memory Allocation Settings

Execute [Project] & [Memory Allocation] from the function toolbar; or click onthe & icon in the tool bar;
or in the project window, select [Test example] > [System Configuration] - [Memory Allocation] and

double-click, and the memory allocation settings window will appear:
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Allocable range

values for internal

Enter values that

you wish to allocate

to retentive types Memory allocation

ranges for retentive

Memory Allocation

-/ =)

1 Sec Timer Tatals

\

Retentive Coill Totalsf[ 0. 1400 ]

Fietentive Step Relap Totals [0 .. 980 ]
0.070 Sec Timer Totals [0 .. 256 ]
0.1 Sec Timer Totals [0 .. 256 ]

Retentive 16 Bit Counter Totals [ 0. 200 ]
Retentive 32 Bit Counter Tatals [ 0. 56 |
Retentive Data Register Totalz [0 .. 3840 ]
ROR Register Tatal: [0 3072 ]

Reset To Default

o 0K | X Cancel ‘

[r4200-441339]

[foo  (55005339)
[0 (10749

[Bo  (T50T139)
e (m2007255)
[0 (coC1g)

[ (czo0cz)
[000  (ROR299)
[

When the PLC main units are manufactured (They are set to factory defaults), the system construction

settings, such as for (Retentive) and (Non Retentive) coils, or for the specified allocation of registers,

read-only register ranges, have all been planned and set to appropriate values. We refer to this configuration

as the Default Configuration. Under most circumstances, the user does not need to change the default

configurations. Only in various more complex or specialized applications, does the user need to modify the

default configurations, and this feature is meant to provide a means to do so with the FBs series PLCs. By

pressing the “Reset to Default” button, you can set the system settings back to the initial default settings. After

pressing the “OK” button, you will have completed the memory allocations setting procedure:

m Discrete & Register Allocation @
Type Item Fange | Amount
B Input Contact 0 - X255 256
ey Output Relay - 255 256
B M Fetent Internal Relay  M800-M1399 00
A Internal Pelay b0 - 14794 a0
B M Intermal Relay hA1400 - M1811 512
B M Spacical Relay 141812 - b42001 a0
] Fetent. Step Relay SE00 - 5949 500
L) Step Relay S0-5499 500
:—%T 0.01 Sec Timer TO-T49 50
T 0.1 Sec Timer TRO-T199 150
Tl 1 SecTimer T200-T255 5k
by e Fetent. 16 hit Counter C0-C139 140
i 16 hit Counter C140-2194 60
i Fietent. 32 hit Counter C200-C239 40
c 32 bit Counter C240-C25h 16
v R Fetent Data Register  R0-R2999 3000
b= Data Register F3000 - R3g39 340
R Input Register F3g40 - R3903 G4
o B Output Register F3904 - R3967 G4
(=] Special Register F3965 - R4167 200
rim P ROR Register 0
R Data Register REOO0 - RB071 3072
D Retent Data Register  D0-D4095 4095
F File Register F0-Fao a0vz

o OK

The value of non-retentive type relays and registers will be cleared to 0 after a power-up or a PLC STOP >
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RUN operation, while the retentive types will still be set to the value prior to the power-down or STOP. The

following is a description of their various characteristics.

11.4.2.1 Set the Number of Internal Coils in the Retentive-Type

The settable range for the internal coil quantity of retentive-types is 0~1400. If you enter “600”, you will
distribute a quantity of 600 to the internal coil of retentive-types, and therefore you will first allocate range
MO0~M799 (a total of 800 in quantity) to non-retentive type internal coils, thereby setting the range for
retentive-type internal coils to M800~M1399 (a total of 600 in quantity). Internal coils can be modified, please

refer to the description in Section 2.2 of User Manual | —Hardware & Basic Functions.

11.4.2.2 Set Retentive-Type Step Coil Quantities

The settings range for retentive-type step coil quantities is 0~980. If you enter “500”, you will allocate 500 in
guantity to retentive-type step coils, while steps S0~S19 will always be non-retentive and cannot be changed,
therefore the step coil range is 0~999, therefore the system will first allocate the range S0~S499 (a total of
500 in quantity) to the non-retentive type step coils, and therefore the step coil allocation range for
retentive-type will be S500~S999 (a total of 500 in quantity). The step coils can be modified, please refer to

the description in Section 2.2 of User Manual | —Hardware & Basic Functions.

11.4.2.3 Set Timer Time Base Amount Allocation

The settings range for timer quantities is 0~256, and timer timing bases are divided into 0.01 second, 0.1
second, and 1 second timing methods. Therefore, if you enter “50” in the 0.01 second field, you will allocate
50 quantities to the 0.01 second timer, and therefore the TO~T49 (a total of 50 quantities) range will first be
allocated to the 0.01 second timer; and then enter “150” in the 0.1 second field, which represents that 150
guantities will be allocated to the 0.1 second timer. Therefore range T50~T199 (a total of 150 quantities) will
be allocated to the 0.1 second timer; and therefore the remaining 56 quantities will be allocated to the 1
second timer, and the range of allocation will be T200~T255 (a total of 56 quantities). Timers can be modified,

please refer to the description in Section 2.2 of User Manual | —Hardware & Basic Functions.

11.4.2.4 Set the Quantity of Retentive-Type 16-bit Counters

Retentive 16-bit counter quantities have range settings of 0~200. If you enter “140”, you will have set the
guantity of retentive 16-bit counters to 140, therefore retentive 16-bit counters have allocation ranges of
C0~C139 (a total of 140). Retentive-type 16-bit counters can be modified, please refer to the description in

Section 2.2 of User Manual | —Hardware & Basic Functions.
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11.4.2.5 Set the Quantity of Retentive-Type 32-bit Counters

Retentive 32-bit counter quantities have range settings of 0~56. If you enter “40”, you will have set the
guantity of retentive 32-bit counters to 40, therefore retentive 32-bit counters will have allocation ranges of
C200~C239 (a total of 40). Retentive-type 32-bit counters can be modified, please refer to the description in

Section 2.2 of User Manual | —Hardware & Basic Functions.

11.4.2.6 Set the Quantity of Retentive-Type Data Registers

The quantity settings range for retentive-type data registers is 0~3840. If you enter “3000", you will have
allocated 3000 retentive-type data registers, and therefore the allocation range of retentive-type data registers
will be R0O~R2999 (for a total of 3000). Retentive-type data registers can be modified, please refer to the

description in Section 2.2 of User Manual | —Hardware & Basic Functions.

11.4.2.7 Set the Amount of Read-Only Registers

The settings range for read-only registers is 0~3072. If you enter “0”, you will have allocated 0 to read-only
registers, and therefore read-only registers will not have an allocation range. Read-only registers can be
modified, for a description of settings ranges, please refer to User Manual | —Hardware & Basic Functions

page 2-2.

11.4.3 Configure Read-Only Register Content

Execute [Project] » [ROR Register] from the function toolbar; or click the icon from the tool bar; or in
the project window, select [Test example] = [System Configuration] 2 [ROR Register] and double-click.
Continuing with the un-configured read-only register range in Section 11.4.2, the following window will first

appear:

ROR Register =5

! ROR register has not configured yet!, want to configure it ?

h

The allocable range for read-only registers is R5000~R8071 (a total of 3072 quantities), and if no range is
allocated to read-only registers, then R5000~R8071 can be used as general registers of the retentive type.

Press the “Yes” button, and re-set the quantity of read-only registers, enter “200", and the allocation range for
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read-only registers will be R5000~R5199 (for a total of 200):
Memory Allocation Lg

Retentive Col Tatals [0 .. 1400 | W [MB00-k1339)
Retentive Step Relay Totals [0.. 980 ] IW' [5500-5339)
0.01 Sec Timer Tatals [0 .. 256 ] 150—' [TO-T49)
0.1 Sec Timer Totals [0 .. 256 ] W [T50-T139)
1 Sec Timer Totals 155—' [T200-T255)
Fietentive 16 Bit Counter Totals [ 0., 200 ] W [CO-C139)
Fietentive 32 Bit Counter Totals [0.. 56 ] 140—' [C200-C239)
Fietentive Data Fegister Tatals [ 0.. 3840 ] 2000 [RO-R2339]

| ROR Fiegister Totals [ 0.. 3072 ] 20l [RE000-R5193) |

Reset To Default v 0K X Cancel ‘

Press the “OK” button, and the read-only memory data, annotations, and description input areas for
R5000~R5199 will be listed:

Discrete & Register Allocation &J
Type Itern Range | Amount
B Input Contact %0 - %255 256
Ty Qutput Relay Y0 -255 256
i) Fetent. Internal Relay hAB00 - hA1399 G00
i) Intermal Relay kA0 - b4739 &00
il Intemal Relay 11400 - k41911 B12
il Spacical Relay w1312 - h2001 a0
= Fetent. Step Relay S500- 5999 500
S Step Relay 50-5499 500
LG 0.01 Sec Timer T0-T48 50
Ltag 0.1 Sec Timer TRO-T189 160
T 1 SecTimer T200-T255 56
brlies Retent. 16 hit Counter C0-C139 140
el 16 hit Courter C140- 199 1]
Jlle Retent. 32 bit Counter Cc200-c239 40
A 32 hit Counter C240- C2h5 16
on R Retent Data Register  R0-R2999 3000
an P Data Register R3000 - R3639 840
R Input Register R3840 - R3903 ]
oe R Output Register R3904 - R3967 ]
eaiR Special Register R3968 - R4167 200
ral ROR Register R5000 - RA199 200
R Data Registar RE200 - RAO71 2872
i) Fetent Data Register D0-D4095 4096
e File Register F0-F8071 8072
W OK
ROR =
= 3]
Import Export Festore ead ROR<-Reg.
Ref. Mo. Status Data |Enmment |Descriplinn Reqg Value -
R5000 1 i |
|RE001 Decimal -1 i}
RS5002 Decimal -1 0
RE003 Decimal -1 1}
RE004 Decimal | o
R5005 Decimal -1 o
RE006 Decimal - 0
| RE007 Deciral 1 0
RS008 Decimal -1 il
|R5009 Decimal -1 1}
REOT0 Decimal -1 a
RE011 Decirnal -1 1]
RENZ2 Decirnal | o
RE013 Decimal -1 a
R5014 Decimal -1 o
| rB01S Decimal 4 i
RE016 Decimal -1 i} -

The advantage of setting read-only registers is that the content of the registers will be saved along with the
project files, therefore, when you save the project to the PLC, if you have specified read-only registers in the
project, then these read-only registers will carry the values that you specified even at the very beginning of

system initialization.
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12 Tabular Outputs

After the program is completed, naturally you would want to print some relative descriptions of the program or
annotations, but before you do, you will need to configure the printer, or select the settings for the items to be

printed. The operation procedures are described in the following:

12.1 Printer Settings

Execute [File] = [Printer Setup] from the function toolbar, and perform the printer configuration:

Frinter
Mame: Froperties...
Status: Feady
Type: HF Lazerlet 2100 PCLE
Wwhere:  LPTT:
Caommerit:
Paper Orientation
Size: |Letter j (+ Partrait
b,
Source: |Aut0matically Select j " Landscape
Metwark... Cancel

12.2 Printing Settings

Execute [File] > [Print Content Setup] from the function toolbar; or use the hotkey “Ctrl"+“P”. Perform the

print settings for the program content, as described below:

12.2.1 Select the Ladder Program thatyou would like to Print

In the [Print] window, select the [Edit Network] page:

Print ==
Print Iterms- Edit Network | Comment /Description Table | StatusPage | Spst 4 >1
Tupe 1 ltem |

—Program Unit 1 Font
Tupe Item | | [M5 Sans Serf - 6] 1]
addei .. Main_unit]
gy Ladder ...  Change Control Print It
[#s Ladder .. Charnel Contral ol
[ Ladder .. Sub_unit] [~ Pragram Unit Camment
I~ Matwork Comment

‘ - ‘ [~ Element Comment

- : [~ Step Mumber
- ‘ tMave ‘ Select Al I Append ‘l

D e ————S

Preview } PlinterSetup] & Frint X Cancel ]
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For the [Program Unit] field, select the first program unit item “Main_unitl”, and then press the “Append”
button, then the program unit “Main_unit1” will be listed under [Print Items] to the left; the “Select All” button
can be used to select all of the program units listed under [Program Unit], press the “Append” button again,
and all the program units will be listed under [Print Items] on the left to be prepared for printing. If you check

“Network Comment” for [Print Items], then the network annotations for the program unit will be printed:

Frint Items | Edit Network | Comment /Description | Table | Status Page | Swst 4 | »
| Type Item
[efs Ladder ... Main_unit1 Program Unit Font
e e [MS Sans Seif - 2] n

[@s Ladder ... Change Control
[@s Ladder ... Channel Contral

B Ladder .. Sub_unit] Frint ltems

[~ Program Urit Cornment
‘ I~ Element Comment
[~ Step Murmber

Select &l ‘

‘ 2 : I Select Al | . |

Presiew | PrinterSetup| « Frint | XK Cancel |

If you press the “Print Setup” button, you will go to the [Printer Settings] screen in Section 12.1, and will be
able to re-configure the printer; if you press the “Preview” button, you will be able to preview the screen that

you wish to print:

Print Items : Main_unitl

‘ Network Comment
| Prirted ltem: Ladder Diagram - Main_unit1 |
Roganstat
[ 5
] i} enl 0 | o
i —— SESH ——
o] —1 | ENq Dt WMl tOTR
M: 1
IMEA ERR
p1924 o ——
— | e s 0
M D WD
—
0
— I PLs{ O CUP-
M0 P 10
/1 TR
MO 0
no] —1 | {
M1 1
— I {
M2 v2
Nooe] 1 { —
M3 v3
N7 — | { —
4 v
— | {
M5 Y5
o] 1 {
ME Y6
womo] — | £
M7 v7
— | {
N2
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Press the “Print Setup” button and you will go to the [Printer Settings] screen in Section 12.1, and you will be
able to re-configure your printer; press the “Print” button and printing will begin; if there is more than one page,
you can press the up and down buttons; press the “Magnify” and “De-Magnify” buttons to adjust the preview

image; use the “Close” button to go back to the print window.

12.2.2 Select the Descriptions and Annotations that you wish to

Print
In the [Print] window, select the [Comment / Description] page:
Print @
Frint Iterms E dit Metwork | Comment /Description | Tabls | Status Page | Syst 4| »
Tupe | Item
[ Ladder .. Main_unitl Data Range —Fant

»

[M5 Sans Serif - 8] w

[ |

[ Frint ltems

EE‘E Corment  Change Contral
EE‘I Comment  Channel Cantral [v Element Description

:{Eomment Sub_urit? [w Fegister Data

Ak, Comment  Input Contact
I Ak ceee

[ Y P

Select Al J o I o

J Fd e Do I Select Al JI Append |
Preview | PrinterSetup] & Fiint | x Eance||

[Data Range] will list the following three categories: program unit annotations, network annotations, and

e

component annotations. For example, if you select the annotations for the first program unit, and press the

“Append” button, then you will also list this item under the print items on the left:

S |
Print Items | Edit Metwork ] Comment /Descripion | Table | Status Page | SPStL]L
Type | Item :
Ladder .. Main_unit Data Range Font-
&, Comment  Comment Type | Item * || M5 Sans Serif- 8] 17]
firs Comment  Main_unitl |
FrT Comment  Change Contral (W —
EE‘I Comment  Channel Control ke
EH Comment  Sub_umit] v Element Description
Ak, Comment  Input Contact 7 Flesistes Dok
'"'f, Comment  Output Relay
L P S Py N I
Select Al ] ‘ 4 [Tl | »
] b e Doy ‘ Select &l ‘ ‘
Preview ‘ Printer Setup ‘ o Frint | x Cancel ‘

Press the [Preview] button and all of the program unit annotations will be printed on the second page in the

preview screen, as illustrated below:
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Prirted lker: Program UnitComment

@REE BEIEEEE

Blue frames represent program unit names.

Pragram Unit Comment

L@@@@@ (EEEEE BEE

Main Pragram Unit Commer‘t-

Testesample

EE @iEE]

Red frames represent program unit annotations.

eiealaalaaaaaaaaaalalalaaaleicled

If you select the “Coin Insertion Count” item under [Data Range], then the [Network Comment] for the “Coin

Insertion Count” program unit will be printed; if you press the “Append” button, and add the [Print Items] listed

on the left, then the " network annotations in coin insertion count program unit ” will be printed.

File(F) Pages(P) View(¥)
SPrirter Setup SyPiint | 41 4 3 9 Zoom & Reduce |100% | Cloze

Prirked kem: Metwork Comment - [Coinlnzetion Count]

T o ({0 o (il 30 (5
Metwork Comment- 3

(R(EE ((E(E(E () (2 G (EEEE (F(EE EGS

Blue frames represent program unit names.

INDEI]D Coinlnserion Count's nebwark comme

jclaialaaaaaalaaaaaaiaaaiaaiolaes

Red frames represent network annotations
for the coin insertion count program unit.

If you select the “Input Contact” item in [Data Range], and check the “Element Comment” option in the [Print

Options] on the right, then the text of the [Comment / Description] will be printed; if you check the “Register

Data” option in [Print Options] then the data or values in the registers of the component will be printed; press

the “Append” button, and add the [Print Iltems] listed on the left, and the following will be printed: the

component description of the input connection point, descriptions, and register data and values. The following

is the preview screen for an “Input Contact” item:

M Preview

File(F) Pages®) View(V)
aPlinterSetup EpFint | 4] 4 ¥ Zoom £ Reduce [100% * | Cloze

Input contacts X0 and X1.

Prirted lkem: Element Cammert - [Input Contact]

The status of input contact “X0”.

GEEEEEEEAEEEAEEEEREEEEFT  erTE O EEE

EIementComment-[lmqurtaVl
The description for input contacts X0 and X1.

[OTFEnabepe Loniac
jelelaleicialalalalele el
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12.2.3 Select the Table that you wish to Print

In the [Print] window, select the [Table] page:

¥ Print L]
Pririt Iterms Edit Metwork | Comment /Description | | Table | Status Page | Spst ¢ | p

Type tem
Table List Font
AT iz MS Sans Sert - £
General CFU LI L ] w
W Table General Purpose...
|72 T able ModBus Master ... Filens
£ T able MNew Servo Prog... I~ DataorValue

& Table Servo Program

J | Select Al ‘ Append ‘

Preview I F'nnlelSstupI \/F'nnt | XCancs\I

All of the tables you created will be listed under [Tables List]. For example, if you select “General CPU LINK

Communication Table”, and press “Preview”, the settings content for the table will be printed. There are three
data items in the following table:

File(F) PageslP) View(¥)

SEFiner Setup SyPint | @ 4 b B | @Zoom £ Reduce [100% ~|| Close

Prirted ltem: Mormal Link Table -[General CPU LINK Commuricaton T able]

Mormal Lirk Table - [General CPU LINK Commuricaion Table] Start Pos:RE00D Stop Pos.REDZ Allocate Size:Dynamic allo cation

Seq. Commard  Slave MaskerData  Slave Data Data Siz

0 Fead TR O T |
1 FRead 1 ®0 <« W0 A
2 FRead 3K o« K01

If you check the “Data or Values” option in [Print Options], then the data and values for R6000~R6021 will be
printed during print preview.

12.2.4 Select the Status Monitoring Page that you wish to Print

In the [Print] window, select the [Status Page] page:

X

Print [bems Edit Metwark Comment /Description Table Statuz Page | Syst 4 | »
Type tem
Statuz Page List Faont
A [M5 Sans Serit - 8] v
'8
@Status P... StatuzPagel Frint e
@StatusP... StatuzPage2 s
{+ Print Reference number
" Print Comment
‘ v Do | Select All | Append |
Preview ‘ PrinterSetup‘ o Fiirt | X Cancel ‘
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Under the [Status Page List] category, you will find a list of all the monitoring pages that you created, choose

the first item “Status Page 07, and add it to the print item on the left; check the “Printing Reference number”

option under [Print Options], then the print preview screen will be as follows, displayed according to “No.” :

Bile) Pages®) View(V)
gPrinteISelup & Print

## Zoom & Reduce |100% v || Close

Prirted ltem: Stabus Page - [StalusPagen]

Statuz Page - [StatusPagel]

Mo Status Data
) Enable  OFF
#l Enable  OFF
RO Dedmal 0
R1 Decimal 0
R2 Decimal 0

Check “Print Comment” in [Print Options], and the preview screen will be as follows, displayed according to

“Comment”:

¥ Preview
File(F) Pages®) View(¥)

&5 Printer Setup Sy Print @@ Zoom & Reduce |100% | Close

Prirted ltem: Status Page - [Status Pagel]

Stahus Page - (5 tatusPageld]

Commert Status Data

A Contact
B Contact
[0
IRl
[Ra]

Enable
Enable
Decimal 0

OFF
OFF

Decimal 0

Decimal 0

12.2.5 Select the Project Information or Configuration that you

wish to Print

In the [Print] window, select the [System / Other] page:

¥ Print
“Print Iterns-
Type

Item
1 Other lter

Comment /Description

Table

| Statuz Page | Spstem/Other

Type

=

Q, Project ...

Project ...

Cross RL..

Cross RL..

Cross RL..

‘ 7 ‘ Cross AL

Select Al ‘

Item

. |/0 Configuration

Memary Allocation
ROR Register
Contact[Metwork]
ContactMa]
FunctionMetwork]
Function[Ma]

Append ‘

Preview | F'nnlelSelup|

« Fiint XK Cancel I

1 Fort

[MS Sans Seiif - 8]

W

Falr

3

The following three system configurations of project will be listed under [Other Items]:
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1. [I/O Configuration] :
10.4.1.

will be printed according to the [Set I/O Configuration] settings made in Section

2. [Memory Allocation] : will be printed according to the [Set Memory Allocation] settings made in

Section 10.4.2.

3. [ROR Registers] : will be printed according to the [Set Read-Only Register Content] settings made in

Section 10.4.3.

12.2.6 Set Print

Format

In the [Print] window, select the [Format Setup] page:

Prirt [bemns

Type

Item
~Format Preview 1

| {BzE Loy | Page Heading /Page Tail Setup |

Previgw | F'rinterSetup| /Print | x Cancel ‘

Table Statuz Page Systern/Other Format Setup

4]k
~Paper Size
210.0rnmm * 237, Orm
1 Print margin Setup
Upper margin: E jt' mm

=

[¥]
=
a1

Lowser margin:

=
=]

Left margin: g jt' mm
Right margin: 8 jt' mm

[Printing margin Setup]: set the upper, lower, left, and right margins in units of mm. The status and changes

in the margin settings will immediately be shown in [Preview].

[Paper Size]: the width and height of the paper will be displayed according to the paper size settings specified

in th

e printing settings.

[Page Heading / Page Tail Setup]: press this button and the following settings page for the title at the top of

the page and the page number at the end of the page will appear, as shown below:

H Page Heading / Page Tail Setnp

Fage Heading

W PrintHeader |Print Test

Fant

v Printed File Name
v Date of Frint
Page Tail
¥ Frint Fage Muml

Alignment: Center -
Page Number Format: [T -

Format Description: '# Current Page, '$'Tatal Page

« 0K | X Cancel|
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Page Heading

[Print Header]: enter the “Print Test” title into the text area, you can also make changes to the font type using
the “Font” button, and then check print title, and then this title will be printed.

[Print File Name]: if selected, the project file path will be printed.

[Date of Print]: if selected, the print date will be printed.

Page Tail

[Print Page Number]: if selected, page humbers will be printed. The following settings will only have meaning
when this setting is selected.

[Alignment]: you can choose to position the page number by either aligning to the left, aligning to the right, or
placing in the center.

[Page Number Format]: page number format settings, # represents the current page number, $ represents

the total number of pages.

12.3 Print Preview

You can preview the result of all of your settings in the printing settings window via the “Preview” button. Only
when you are satisfied with the settings should you “Print”. We have already shown the [Preview] screens for
the settings in Sections 12.2.1 through 12.2.5, the following is the [Preview] screen for the settings described
in Section 12.2.6:

b_"ﬂl’review
File(F) Pages(F) View(V)
aPrinterSetup EpPrint | < BB & Zoom £ Reduce [100% *|| Close

Set title at the top of the page.

Set file name at the top of the page for printing.

Frirk Test
—=
File Mame: C:*Documerts and S etings'us erwirproladder ENU-OKI[041 30N est example pdw

Frirt Date: 2011/41 —
Y —— Set date at the top of the page for printing.

0 m
I E N TUP-
i1 & g
e —— S ——
o) — ENA D: Wi HOTE-
M: 1
Mg ERR-

12.4 Printing

After you have completed the settings in the [Print] window, you can press the “Print” button to print; or in the
print preview screen, you can execute [File] - [Print Content Setup], and click the “Print” button in the tool bar
to print.
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13 Auxiliary Functions

The WinProladder software also provides auxiliary functions, like the CRC16/Checksum calculator which
allows the user to enter data for calculation and produce values for checking; the contact and register usage
information features provide overall usage tables for the various contact components and registers; also
provided are register content backup, register content backup recovery, and four different ROM Pack

operation modes, which are described in detail below.

13.1 CRC16/Checksum Calculator

Execute [Tool] > [CRC16 Generator] from the function toolbar, and the following window will appear:
=)

8 CRC16 Generator

0O E B B
Mew Open Save Close
11 12 44 50 66 21 44

Example: 00 0A DB FA

Len = 7 BYTE (BYTE) CheckSum = 82 CRC16 = 0000 |

Enter the code that you wish to check; this function will display the number of bytes (Len) currently entered;
the checksum is automatically calculated; and the CRC16 value is automatically calculated. After you have
finished inputting you can press the “Save” button, and save it as a text file of the txt type file extension, and
can call out the file next time by pressing the “Open” button, and will not have to input it again. The “New”
button will clear the input area, and allow you to begin inputting from scratch. Click the X icon on the upper

right-hand corner or the “Close” button, and you can close the CRC16 calculator window.

13.2 Contact and Register Usage Information

Execute [Tool] > [Element Statistics] from the function toolbar, and the [Element Statistics] window will

appear:

[# Element Statistics

= | B [

Al

Used

Urnused Doubious  Refrash

s BI

=0

s B

T D

.| Eonlact‘ Coil DuplicFunction W FuncFunctiTable startincT able 11/0 Configuil /0 Implie =

LIRRLRINERY
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The main intention for this feature is to allow the user to view the usage statuses of the various components in

the project: used or unused. Select the “All” button, and then select the “X” component button, and all X

components will be displayed, and all used components will have a check mark on the right-hand side of their

reference numbers, as shown in the red frame in the illustration above. When this X component only appears

in contact instruction, the “Contact” field on the right will display a check icon in it, as shown in the blue frame

in the above illustrations. If you select the “Y” button, and the Y component appears in contact and coil

instructions, then a check icon will

appear under the “Contact” and “Coil” fields on the right. Therefore, the

“Contact”, “Coil", and “Function” fields are used to show whether the selected component reference number

appears in the relative instructions; the “Duplicate” field shows whether or not the selected component is

repeatedly used; the “Function Implied” field shows whether this component is used in function block

instruction, as shown below:

Element Statistics ==

All

nx

=) s &
Used Unused Doubious Refresh
By (MM Bs (81 ®c |vr [[To

Ref. No.

Do

D1

D2

D3

D4

D&

D6

D10

Di1

&

Cnnlacll Coil ‘Duplicale| Function Write | Function | Function Implied ‘ -
L F
L e
o v
v o
L L
v v
v v
L bl L
o v i
t

13.3 System Backup

This feature can backup or recover the content of the PLC system in a very fast manner. This operation

resembles that of saving the PLC contents to a file and therefore can be used as a PLC copy application. To

use this feature, execute [Tool] = [System Backup] from the function toolbar when connected to the PLC:

When the above window appears,

[ Backup Itam Setup = D |

System and Frogram Area
W Swstem Status

v Ladder Program

Data Memany Area
v Discrete Status
¥ Special Discrete Status
W Diata Register
W Special Registar
W Timer/Counter Register

¥ File Register

v ok [

the user can choose the items they wish to backup. After pressing the “OK”
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button, if the project has a password, then the user will be prompted to enter the password.

Input Program Password lg

Fassword : ]>0¢¢<

o OK | X Cancel‘

*

After the password has been confirmed, the system will request the protective options for backup and

recovery, as shown below :

Protection Setup (==

Protection Type-

" Mode Locked Frotection

T Password Frotection

o OK | X Cancel‘

A\

1. No Protection: When using this file for recovery, you will not need to enter a password.

2. Node Locked Protection: If this type of protection is chosen, when the user wishes to recover using this
file, they will not need to enter a password, but will only be allowed to recover
the current computer, and will not be allowed to recovery other computers. This
feature is usually used in factory production conditions.

3. Password Protection: A password will be required to perform a recovery using this file.
[ Protection Setup @I&J‘

Frotection Type-

Mo Protection

 MNode Locked Protection

* Password Frotection:

o 0K | X Cancel]

.

After you have chosen the recovery protection options, press the "OK” button and the following dialogue box

will appear :
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Save System HackipFile .
Save I B winpraladder j & £ EF-

File: name: | Save I
Save astype: | System File [Fst] =] Cancel |
|

After you enter the file name, press the "Save” button, and the following dialogue box will appear, and you can

add notes to your backup file.

[ ) comment Edting b LB )

File Description:

XK Cancel |

2|
Press the “OK” button and the backup will begin.
rm Under Data Transfer ... =) ]
PLC System D ata
Ladder
Discrete Status S0~55999

Special Discrete Status M19127M2001

v & & 4 K

D ata Register RO~R3839
Special Register

Timer/Counter R egister

File Register
Systern Backup M
@ Backup Complete !

 OK
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13.4 System Restore

When the PLC is connected, execute [Tool] = [System Restore] from the function toolbar.

Upen system Hackup kile T W

Laok in: “;. winproladder j - A=
File name: |
Files of type: | System File [* fsb.” frd] ~| e

Choose the files with the fsb or frd file extensions and you can perform system recovery, and the following

illustration will appear.

Comment Edting =HEE]

File Description:

X Cancel I

If you have added notes to your backup file, this file description can be used for verification, and after you
decide to use this backup file for recovery, press the "OK” button, and a password confirmation dialogue box

will appear.

Password Authentication [E=HEER S

rFPassword Type

" Encrypted Password

Password : I

Encryption Kew: I OTI =0

o 0K I X Cancel |
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1. Ladder Password: enter the program password for the original protected program and you will be
able to recover, but if the designer is unwilling to provide this password, you
can choose to use an encryption password for user recoveries.

2. Encrypted Passwords: the encryption password randomly produces an encryption key, and
Winproladder will produce an encryption password according to this random
value and the program password. Because Winproladder produces a different
encryption key each time, therefore only those who know the program
password can calculate an encryption password and perform file recovery. The
advantage of this scheme is that backup file recovery can be performed
without having to let the user know the program password, and because the
random encryption key is different each time, each recovery encryption
password is also used only once, which provides a further degree of protection

for the intellectual property rights of the program designer.

Password Authentication o] L5

rPassword Type
" Ladder Paszward

* Encrpted Password

Pazzword : |

E hcryption Key: BFEQES

X Cancel |

If an encryption password is used, then the user that wishes to perform the recovery must give the encryption
key shown in the window to a protector who knows the program password. The protector have to open a new

WinProladder, then executes [Tools] = [Encrypted Password Generation] :

File Edit Wiew Project Ladder PLC | Tool Window Help
D - '

Encrypted Password Generation

CRC16 Generator
Check power supply capacity

Enter the program password and the randomly produced encryption key into the dialogue box shown below :
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Encrypted Password Generation E@ﬁ

Ladder Password : iw

Encryption Key: 1BFE9EE‘

o 0K I x Canc:eli

Press the “OK” button to produce the encryption password.
i Single Pass Passw... ﬁ

W 0K

The protector will then give this encryption password to the user that wishes to perform the recovery to enter
into the password confirmation dialogue box, and the recovery operation can be proceeded with. The user
must not close the password confirmation dialogue box before inputting has been completed or the encryption

key will be different the next time it is opened.

Password Authentication [E=SREER

rFassword Type
" Ladder Password

% Enciypted Password

Password ; |UDA453|

Encryption Key: EFEQER

o OK | X Carcel |

=4
Press the "OK" button and the restore will begin.
[ ) under Data Transfer .. | ) )
o PLC Syztem Data
o Ladder WVector Address
o Dizcrete Status MO~M1911
¥ 4 Special Discrete Status— M1312~M2007
o Data Register D3072~04035
o Special Register R3840~R41E67
|

Timer/Counter Register  TO~T255

File Register
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[S5c)

System Restoration

[0'1 Restore Complete !

o OK

13.5 ROM Pack Operation

When connected with the PLC, execute [Tool] > [MEMORY_PACK operations] from the function toolbar, and

the following window will appear:

MEMORY_PACK operations ...

[

Please select an operation

&+ ‘Write program and data to MEMORY_PACK

" Erase MEMORY_PACK

" Disable FLASH content loading when power on
" Enable FLASH content loading when power an

XK Exit I

I >> Mext I

1. Write program and data to MEMORY_PACK: to execute the writing of program and data to ROM Pack.

2. Erase MEMORY_PACK:

3. Disable FLASH content loading when power on:

clears all program and data originally being written to the ROM Pack.

if you select this setting, then the program and data

stored in ROM Pack will not be read during power-up.

4. Enable FLASH content loading when power on:

if you select the normal mode settings, the program

and data stored in ROM Pack will be read during power-up.

Four Operation Modes:

1. Write the program and registers to the ROM Pack, press next and the following screen will appear:

MEMORY_PACK operations

=5

& Register Data
" System Backup with PLC D
" System Backup without PLC 1D

Agsign the data to be read back when power up

Starting .. | Ending ... | Datalen.

% it |

<< Back ‘

i

Press the “Next” button. If you need to retrieve the register data from the ROM Pack during each power-up,

then you will need to define the initial and termination addresses. Press the “Add” button:
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MEMORY_PACK operations —_—

@« Register Data.
" System Backup with PLC D
" Systemn Backup without PLC D

Assign the data to be read back when power up

J Staring ... | Ending ... | Datalen... Add
Data assigment &J |

Starting address: |mioo0 - [R1199 Q
Diata Lenith : ’mmi Q

<< Back | Execute | XK Exit |

After creation, you may also click the “Edit” button to modify, or you can also “Clear All” and then define a new

one. After defining, press the “Execute” button and the writing will begin.

MEMORY_PACK operations ... 5|

* Register Data
Ny  Systern Backup with PLCID

@ ¢ System Backup without FLC 1D

Assign the data to be read back when power up

Staring ... | Ending ... | Datalen..
R1000 R1194 200

[ oo |
Clear All

 After Initinal Systern.Read back the data one time
& Mhen power on Read back the data every time

<< Back I Execute |I XK Exit |

The Data Read Back Setting

MEMORY_PACK operations .. (el

& Register Data
 Systern Backup with PLC D
" Systern Backup without FLC 1D

=5

I
Program MEMORY_PACK

hen power up

Adel

|
Do |
Clear All

g
i System Fead hack the data one time
& When power onRead back the data eveny time

<< Back J Execute X Exit I

lol MEMORY_PACKwrite OKI

13.6 I/O Reference Number Allocation Statuses

WinProladder takes an automatic 1/0 address calculation for PLC main unit and expansion modules. After
WinProladder connects with the PLC main unit, it will read the I/O installation status of the PLC main unit and
the expansion modules, at the same time automatically allocating the 1/O reference address for access. The

user can view how many expansion modules are connected to the PLC main unit, and what the I/O addresses
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are used by the expansion modules in the project management window.

WinProLadder - [Ladder Diagram - Main_unit1]
le Edit View Project Ladder PLC Tool Window

ODs~-d || BHEE

AND

me = (B ow R80T

o

DALV AL ) Q@ ® ;b — [
] E u o o @ E R 1 ! L} H o =

|
Projectd [FBs-24MC]
751 Bystern Configuration
BB Ladder Diagram
&3 Table Edit
-8 Comment
B Status Page
Bl 10 Nurmbering
12 Project [0 Mumbering

@39 PLC /O Numbefing

After you expand it, you will see the information for the expansion modules being installed:

& WinProLadder - [Ladder Diagram - Main_unit1]

File Edit View Project Ladder PLC Tool Window
OsS~-d |8 EE

AND

P oER B vy v (B2 W -8 -8 W -

3B
SH ]

%1FM11‘F%F()(/){SJ{R)'/"T"V— | ==
A B U D A @ E R I P N H lu

el
=-[E] Projectd [FBe-24MC]
E“'ﬁ System Configuration
- Ladder Diagram
- Table Edit
w-F5 Cormment
-} Status Page
-5 170 Numbering
59 Project 110 Mumbering
=42 PLC IO Numbeing
= Bs-24mClwd 62)
DIEAD™X13
DO:Y0~Ys
1.FBs-TCE:
DON10™17
e [FoR3840
2 FBs-RTDE:
5 DONY18™YER
" RR3641

The Iillustration above shows a FBs-24MC main unit has two expansion modules, which are TC6, RTDS6,

respectively, in which the 1/0 addresses used by TC6, RTD6 are as shown in the following table:

Used system resources
DO IR
Expansion device model
TC6 Y10~Y17 R3840
RTD6 Y18~Y25 R3841

Besides obtaining the I/O address of expansion modules through the on-line method, WinProladder also

provides users with a method of editing expansion module information off-line, which is described in the
illustration below:
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WinProLadder - [Ladder Diagram - Main_unit1]

File Edit View Project Ladder PLC Tool Window
D~ || HE

""‘H Iil;pF g::rvj% vin v @) 8 v~

I TEAE ) ) @ W) b — | =

=& Projectd [FBs-24MC]
&1 System Configuration

] Ladder Diagram

B Table Edit

R Cornment

@ Status Page

=] ped I,:’O Mumbering

mbering. «
Add Module

- p:? PLC O N

Load form PLC

Right-click on [I/O Numbering], and select the "Add Module” option:

[ ) Add Module [ESNIEn)
Paosition:
Select Module:
FBs-B2DA
]
FBs-16EA
S - GEY
FBs-1LC
FBs-20E=
FBs-24EA

Location 1 represents that the connected expansion module is module number 1, which also means it is the
first expansion module, and location 2 represents the second expansion module, and so on.... Now, select the
model types of the modules that you wish to install, add 7SG1S, 2DA and VOM for example. Using this

method, you can pre-edit the expansion modules that you wish to install during off-line.

=] inProLadder - [Ladder Diagram - Main_unit1]
.Flle Edit View Project Ladder PLC Tool Window

ps-&8 B8
|smem |l - Y-8 -8 -
%-H—-I/‘I--HI--M-{)(/)(S)'OQ/'T"¢'—‘—>E

=] @ Projectl [FBs-24mMC)
] System Configurstion
- Ladder Diagram
=& Tahle Edit
K Cormment
@ Status Page
X0 110 Numbering
=52 Project IO Mumbering
-0l 0.FBs-24MC:
=58 1 FBs-78G1S:
Loe OFCR3904~R3906
10 2 FBe-2DA
-on ORCR3807~R34906
a0 3 FBs-vOhd
% DIX14™%21
L8R DONT0™Y7
Bt PLC IO Mumbering

The WinProladder software also displays the real installed expansion modules and manual edited modules.
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14 Import and Export Project Contents

Project contents that can be imported and exported include four types: [Comment], [Import Table], [Ladder

Diagram], and [Status Page].

E® WinProLadder - [Ladder Diagram - Main_unit1]

ile Edit View Project Ladder PLC Tool Window

ED Mew Project Ctrl+M
!..".._.ﬁ OpE.‘I"I » ;
3 h 7 i
|1 save Ctrl+S ¥ ﬁ’ = ﬁ’ TR
|| saveas v e E
—  Close _><_j",.
Export 3 Import Table
&5 Printer Setup .. Laves Dingiam
Status Page

&j Print Content Setup  Ctrl+P
Exit

Annotations descriptions: execute [File]2>[Export]|2>[Comment] from the function toolbar, and the

[Comment Export] window will appear. The exported file will be a text file, with txt file extension.

File

u

File MName: |C:‘-,Documents and Setings\DIGIMDeskioph0707 b B

Field Fange
W Cormrments v = [Input Points] [ T[Timer]
v Description W [Output Relaws] W C[Counter]

W M [Intermal Relays] W B[Register]
W S [Step Relays] v D [Data Register]

UserDefine|

...... ¢OK, x Cance||

For the exported annotations text files you can further execute [File]=>[Import]>[Comment] from the function

toolbar, and the [Comment Import] window will appear; select a text file and proceed with the import operation:

File

File Mame: |C:‘,Documents and Setings\DIGIM\Desktopy0701 ¢ 2

Field Range
W Comments v 7 [Input Paints] W T [Timer]
v Description v ' [Output Relays] v C[Counter]

v M [Internal Relays] W B [Register]
v 3 [Step Relays) v D [Data Register]

v o |[X
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Please refer to Section 6.3 [Element Comment], where there is also a detailed description of these

procedures.

Export Table: execute [File]>[Export]>[Export Table] from the function toolbar, and the [Table Export]

window will appear:

[ g |
( Table Export | W
Table Lizt
M ame Start Addr... | EndAddr.. | Allocated Size
. modbus RO RO Dynarnic all...

J E wport |_x Cancel |

Under the [Table List] option, select the table that you wish to export (for example, you may select “modbus )

and then press the “Export” button, and save it as a file with a tab file extension, and you will have completed

the table export procedure.

Execute [File]=>[Import]>[Import Table] from the function toolbar, and the [Table Import] window will appear:

( Table Import

File

Tahkle List

e of

==

File Mame: |k3:"-,DD|:ument5 and Settings\DIGITYDeski =

Mame
e modbus

StartAd..
(]

v Impn:urtl x Cancel|

Allocated...
Cwnamic ...

End Ad...
(]

Select the filename that you wish to import, and press the “Import” button, and you will have completed the

import operation.

Ladder diagram:

if we wanted to copy network NOO1 from project one and paste it into project two, we

could proceed as follows.
First, open project one, and select network NOO1l, as shown in the following
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illustration:

Execute [File]>[Export]>[Ladder Diagram] from the function toolbar, and a save as... dialogue box will be
produced:

Save As E 1
Save |l Desktop ﬂ £ Ef-

I.DMV Documents
!__ My Computer
B9 M1y Metwark Places

File hamne: |sam|:|le
Save as bype: |Ladder Resource [*1dr] j Cancel

Enter the file name [sample] and then press “Save”, and an “Export Complete!” message will appear:

1 ;' Export Complete !

After you press the “OK” button, execute [File]>[Close Project] from the function toolbar, and close project
one; then, open project two (to open the project, refer to the description on how to open existing files in
Section 3.2), move your cursor to the position where you would like insert the network, and execute

[File]=>[Import]>[Ladder Diagram]from the function toolbar:

| Oper TR
Look in: |l Deskiop j fj( El-

BMv Docurnents

!_. My Computer
QM';-' Metwork Places
v g =ample. dr

File name: |sam|:|le.ll:|l
Files of type: |LadderF|esnurc:e [%.1dr] ﬂ %
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In the open file dialogue box, select the [sample.ldr] filename that you previously entered, and then press
“Open”, and an “Import Completed!” message window will appear, and you have now completed a copy

network operation between two different projects:

. | ) Import Complete |

Status Page: execute [File]>[Export]>[Status Page] from the function toolbar, and the [Status Page
Export] window will appear. Select “StatusPage0” in [Status Page List], and then press the
“Export” button, and it will be saved as a file with the spf file extension, and now you have

completed the status page export operations.

( Status Page Export rmfim W
Status Page List

Mame [tern Count

atusFagel

vy Expurtl x Cancel‘

execute [File]>[Import]>[Status Page] from the function toolbar, and the [Status Page Import] window will

appear:

( Status Page Import =l 1

==
File

File Mame: |C:\,Ducuments and Setings\DIGIT Desk 2

Tahle List
Mame [termn co...
B StatusPagel 1

" Import | x Canu:el‘

Select the status page filename that you would like to import, and then select the status page with new

filename under the table list, press the “Import” button, and you will have completed the import operation.
Open the [Status Page] window of this project, and you will find that this status page has been created.
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15 Managing the Desktop

The Winproladder programming software has an easy-to-use Window interface, and there is an easy way to
manage every aspect of the software, including the tool bar, project window, status monitor, and ladder

diagram windows, etc., allowing even easier operations, and even neater displays.

15.1 Tool Bar Management

Execute [View] = [Tool Bar] > [File] from the function toolbar, and the file toolbar icons will be displayed. If

you execute this again, the file tool bar will be hidden:

IDhE-d

Execute [View] = [Tool Bar] = [View] from the function toolbar, and the view toolbar will be displayed;

execute it again and the view tool bar will be hidden:
| = e o

Execute [View] > [Tool Bar] = [Project] from the function toolbar, and the project toolbar icons will be

displayed; execute this again and they will be hidden:

[speem B - R -8 -8 V-5 -%-&(B - B

Execute [View] = [Tool Bar] - [Ladder] from the function toolbar, and the component tray toolbar icon will be

displayed; execute this again and it will be hidden.

“IE-II—-L«’I—-ITI--MI-{J{/J/-TP--% |, BB @ E E X Ix

Use your cursor to drag open the portion of the tool bar encircled in red below and the toolbar icons will be
brought out in an independent window, you can close this window by clicking on the X icon in the upper

right-hand corner:

Wiews @

lBEx - — |[(mE=

Similarly, if you drag the front portion of the tool bar, you can re-arrange all of the displayed tool bar icons:
'Eji WinProLadder - [Ladder Diagram - Main_unit1] _

i~ =] E% > [ L -
[}-II—-VI--ITI- HE L3 L 5
E

bt e Tk Tl Tt T =L S0 i
S L TERTEE X Ix %

g
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B8 WinProLadder - [Ladder Diagram - Main_unit1] .
] File Edit View Project Ladder PLC Tool Window Help

OE -

"Hnﬁ;" B%vEH}ﬂv %v%v%vﬁ]v?%v%ﬂv%v 2 @.v E.’EH‘"‘,’
el el e s e BB E X

15.2 Management of the Project Window

Execute [View]>[Project Tree] from the project window, and [Project Tree] will be displayed in the left-hand
window in the WinProladder programming software, as shown in the illustration below. You can close this

project management window by pressing the X icon in the upper right-hand corner:

=]

=] Projectl [FEs-24M0C)
"ﬁﬁ System Canfiguration
&-F Ladder Diagram

@& Table Edit

7Ky Comment

@ Status Page

=58 110 Numbering

Similarly, by dragging on the portion marked in red in the above illustration, you can also create an
independent project window, as shown in the illustration below, and you can close this window by clicking on

the X icon in the upper right-hand corner:

Project Tree @

=B Projectd [FBs-24MC]
-5 System Configuration
- Ladder Diagram

15.3 Management of the Status Monitor Page

Execute [Project]>[Status Page] from the function toolbar, and select the already existing monitor page name
“StatusPage0”; or, in the project window [Test example] > [ Status Page] and select the already existing
status page name “StatusPage0”, and the [Status Monitoring] window will appear, and all existing status page
names will be listed in the monitoring window. You can bring out page contents by clicking on the various page
labels, and you can close the [Status Monitoring] window by clicking on the X icon in the upper right-hand

corner.
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Status Monitoring — | [O] -
Fef. ND._[Status Diata, Fief. ND._[Status Diata, Fef. ND._[Status Diata,

Fs
T0 OFF 0 b0 Enahle OFF %0 Enahle  |OFF =
b1 Enahle OFF 1 Enahble  OFF =
h1824 Enable  OFF b2 Enahle OFF 2 Enakle  OFF
b3 Enahle OFF w3 Enshle  OFF
b4 Enahle OFF v Enakle  |OFF
b5 Enahle OFF 5 Enahle  OFF
hG Enahle OFF B Enakle  OFF
b7 Enakle OFF 7 Enakle  |OFF
(T Enable OFF

<« [ p

'\ StatuzPagel /

15.4 Management of Ladder Diagram Windows

Please refer to [Order of Ladder Diagram Windows] in Section 7.1.2 for detailed operation procedures.
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16 Common Q&A’s (FAQ)

Question one: Why can’t | connect with the PLC?

ANS: Please make sure that the set station number and communication parameters are correct, an error in
any of them will result in failure to connect. If you are not sure whether or not the station number is
correct, you can try the universal station number "255", and then change it back to the station number

you wish to use after you have successfully connected.

On-Line = ]
Auto Check
Cannection Name
|Rs232 |
petvanced|  add [ Eai Delete |
Connection Setup - petells
Adtribute | Data
Station Murrber:  [285] Station Mumber 255'
hedium Serial ling
PortMNa.: COM4 = PaortNa. COM4
Baud Rate 9600
Pari Ewven pari
SaudRete: [ogo) -] ate it To
Parity: Even parity, v Stop Bit 1 it
Data Bit: 7 bits -
Btop Bt 15t - __ok [ concel |

m X Cancel

Question two: Why is it that even though | have finished writing the program, | cannot perform
on-line operations with the PLC, and a “Project Information Does Not Match” warning window
keeps appearing?

ANS: When the PLC is manufactured, its internal program areas are empty. If you try to open a project
under this condition and execute connection items, WinProladder will compare your project program
with the PLC internal program, and will only connect if the two programs are identical. Of course, if
your PLC just came out of the factory, its contents must be empty, and no project will be able to
connect to it, therefore, you should execute the "Save As” = “To PLC” option, instead of executing

the "On-Line” option.
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Question three:

[ WinProLadder - [Ladder Diagram - Main_unit1]

File Edit View Project Ladder PLC Tool Window Help

[ [.[2 gew Project Ci+N bogp E2 By o~ o~ [ v P -
-1 & Open 3
S =T ek — —
|l | & save Chiths, gr PN W |"'. Ll @
— I o 7 oiec Fie
B Close | ;
Import 4 il it e
Evport . NOOL
&5 Printer Setup ...
&) Print Content Setup  Ctrl+P il
. NOO2 |
Exit |

Why can’t | send an interrupt event inside the program, and how come when
there is an interrupt, the interrupt service routine is not executed?

ANS:  The reason for this is that although the interrupt label has been entered into the ladder program area,

the interrupt input signal has not been defined in the 1/O configuration settings page in the system

configurations. Therefore, the way to solve this problem is to go to the 1/O configuration settings page

and define it, as shown below:

NODO

=D

RTI

’ 150P — - )
EN OWF-
1 Do

o _
| RTT

’ :LEI:I':‘— _ .
EN UDF-
(-13 Do

1. Enter the interrupt label and service routine in the sub ladder program area (the LBL frame will be

highlighted in bold).
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1/0 Configuration MC va.x

=5

~Utilization

]
=1
e
a3
x4

1#0 No. |_Function

INTO.Pos. e...
INT1,Meg. ...
Undefined
Undefined
Undefined
Undefined
Undefined
Undefined
Undefined
Undefined
Undefined
Undefined =
Undefined
Undefined
Undefined
Undefined
Undefined
Undefined
Undefined
Undefined
Undefined
Undefined g |
Undefined

Undefined |

Timer/Counter ] Inkerrupt Setup

[ Intermupt Setup

Output Setup [

v Use INTT [<1) Hegat

™ UseNT2%2  [PosiiveEdge =] [ Use INTIDIX1D)
[~ UseINT3p3  [PosiiveEdoe =] [ UseINTI1¢11)
[~ UseNT4(44)  [FostiveFdo= ~| [ UseINT12[x12)
[~ UseINTSpS]  [PosiiveEdge =] [ UseINT13p<13)
[~ UseINTE (<] [Fostivebdge <] [ UseINTT4[x14)
[ UseINT7[<7)  [PosiiveEdge =] [ UseINTIS[X15)

v Use INTO(=0) Positive Edge
|

W Ok | X Cancel I

[~ Use INTS [<8)
|~ || T oUseINTaX)

Input Setup Temp. Configuration 4 ;]

2. You will need to define the interrupt input in the 1/O cofiguration page.

Question four:  How come | used a high-speed pulse output function (FUN140) in the program,
but there is no high-speed pulse output?

ANS:  Some instructions in the FATEK PLC main unit must be executed through FATEK self-developed

ASIC, and therefore you need to tell the ASIC which jobs you want it to execute for you through the

system configuration settings. So, please enter the 1/O configuration setting page and make the

required definitions, as shown below:

I/O Configuration MC va x

S

“Utilizatior

140 No. | Function
»o Undefined
w1 Undefined
n Undefined
®3 Undefined
~d Undefined
®a Undefined
¥E Undefined
wi Undefined
bt Undefined
®9 Undefined
»io Undefined
bl Undefined
w2 Undefined
®13 Undefined
w14 Undefined
»15 Undefined
¥ PSO0PLS
1 FSO0.DIR
Y2 PSO1.UP
Y3 PSO1.0M
4 FSO2A
i) PSOZ2ER
Y& PSO3PLS
A\ Undefined

Timer/Counter | Interupt Setup iDutputSetup

Input Setup Temp. Configuration

1

x Cancel

Fietentive Dutput Coil “H5SF50

- PSO0 [0 |vO=PLSX1=DIR =]

'—‘ RSO (Y23 [v2-Pwaon =]
PS02 [145):
PS03 [YBY7):

Output Palarity-

YO1 Ouput |Nomal ¥
Y23 Ouput  |Noma ¥
VNS Ouput |Nomal =)
YENTOuput |Nomal <]
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Question five: Why do the LED indicators light on immediately after the PLC executes, even when
the corresponding output status should be 0?

ANS: You have probably accidentally set the output to an inverted state, making output coil that originally
should not have conducted to invert, and therefore making the output indicators light up. Therefore,

you should go to the I/O configuration setting page and select the correct output polarity.

[ /0 Configuration MC v4.x S
Utilizatiors Timer/Counter | Interupt Setup | ] Output Setup | Input Setup | Temp. Configuration | 4 | »
i Retentive Dutput Col | HSPSO
®1 Undefined 0 PSO0 [P0 Mat used
¥2 Undefined 1 e Al e =
) Undefined e ¥ PSOT [v2+3): Mot used -
w4 Undefined 3
w5 Undefined 144 PSO2 [v4-v5): Mot uzed hd
®E Undefined Llvs :

o Undefined Y6 PS03 [vVE-~7): Mot uzed
%3 Undsfined E
=9 Undefined w9 Output Polarity
bl Undefined A w10
*11 Undefined = 8 i
wiz Undefined T m 12
%13 Undefined i3 r2-r'3 Output: Normal hd
%14 Undefined Clvia : : [foma . 15]
Wis Undefined 15 475 Output: MNarmal -
"""""" Y16 B Output: Normal -
Yo Undefined w17
¥ Undefined 18 =)
Y2 Undefined —
Y3 Undefined
Y4 Undefined
G Undefined
N Undefined
Y7 Undefined x
X e

Question six: In the I/O configuration setting page, | defined a high-speed hardware counter
(HHSCO~HHSC3), but cannot see the corresponding registers (DR4096~DR4110) beginning to
count?

ANS: If you want to use the hardware high-speed counter, besides doing the I/O configuration, you must
also use the function instructions (FUN92, FUN93) to read and write the internal data from/to the
ASIC. For details, please refer to Chapter 10 FBs-PLC High-Speed Counter and Timer of User

Manual Il - Advanced Application.

Question seven: Can previous FBe series programs be executed on FBs series?

ANS: Yes! But it must go through code conversion. There are two methods for code converting, please
refer to the following description:
(1). Modify Program Capacity: through the modification of program capacity, FBe series programs

can be converted and saved to FBs series.

“Project” - “Program conversion” = “FBe” to “FBs”".

(2). Modify Project Information: or you can perform code conversion by directly modifying project

information.

In addition, after the program has undergone code conversion, some function instruction icons will also
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change. For example, +, -, *, / ..., will all have signed/unsigned input options, and the original

communication instructions (FUN96, FUN97) will convert to the new communication instruction

FUN151. As for the FBe instructions that the FBs does not support, an error message dialogue box will

appear after the code conversion has been completed. After code conversion, previous files cannot be

changed by means of overwriting, please use the save as new file method. The following is the FBs

and FBe function instructions comparison table, which can serve as a reference for code conversion:

FBs New Instructions

111 FUNS5 ( B->G ): Binary code to Gray code

1.1.2 FUN56 ( G>B ): Gray code to Binary code

1.1.3 FUN114 ( Zone Write ): Zone write

1.14 FUN139 ( HSPWM ): Hardware High-Speed PWM Output
1.15 FUN160 ( RW—FR): File register Read/Write

FBs Canceled Instructions

1.2.1 FUN96 (LINK2): Port 2 communication convenient instruction

1.2.2 FUN97 (LINK1): Port 1 communication convenient instruction

1.2.4 FUN72 (TP4): Multiplexing temperature module FB-2AJ(K/H/T)4 temperature
measurement instruction

1.25 FUN73 (TSTC): Temperature module FB-2AJ(K/H/T)4 temperature measurement--
PID temperature control

1.2.6 FUN85 (TPSNS): Multiplexing temperature module FB-4AJ(K)XX temperature

measurement instruction

FBs Modified Instructions

1.3.1 FUN11 (+) : Addition operation, with signed ~unsigned calculation option
1.3.2 FUN12 (—) : Subtraction operation, with signed,”unsigned calculation option
1.3.3 FUN13 (x) : Multiplication operation, with signed,”unsigned calculation option
1.3.4 FUN14 (+) : Division operation, with signed ~unsigned calculation option
1.35 FUN17 (CMP) : Comparison, with signed ~unsigned calculation option

1.3.6 FUN23 (DIV48): 48-bit division operation, with signed,”unsigned calculation option
1.3.7 FUN77 (HKEY): 16 key multiplexing input, increase working register

1.3.8 FUN78 (DSW) : Thumb wheel switch input, increase working register

1.3.9 FUN79 (7SGDL): 7-segment display scan output, increase working register
1.3.10 FUNB8O (MUXI): multiplexing contact input, increase working register

1.3.11 FUNB84 (TDSP): 7-segment and alphanumeric display convenient instruction
1.3.12 FUNS86 (TPCTL): PID temperature control instruction

1.3.13 FUNS87 (T.01S) : 0.01 second accumulative timer, can be up to 32 bits

1.3.14 FUNS8S8 (T.1S) : 0.1 second accumulative timer, can be up to 32 bits
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1.3.15 FUNB89 (T1S) : 1 second accumulative timer, can be up to 32 bits

1.3.16 FUN93 (HSCTW): Hardware High-Speed Counter,/Timer settings or writing of current

value and preset value

1.3.17 FUN141 (MPARA): NC positioning parameter settings instruction, adjustment of

parameter item

Question eight: How do | download projects into the PLC?

ANS: Please follow the following steps.

Step 1:  Use your mouse to select [File] > [Open] = [Open] or click the = - dropdown icon in the

tool bar, and select [Open], or press the “Ctrl"+“O” key, and the “Open” dialogue box will appear:

Loak. jn: | b winproladder ﬂ ek B

'™ Test examples . pdw
' Test,pdw

Files af ype: |F'ru:u|au:|u:|er File: [* pde, *Fld] j Cancel

Then choose the file that you wish to open and press the “Open” button.
Or, select one of the four recently opened files provided by WinProladder, and you can quickly open one of
the files you last opened. Use your mouse to select [File] > [Open] from the function toolbar (as shown in the

illustration below:)

[ WinProl adder - [Ladder Diagram - Main_unit1]

Fle Edit View Project Ladder PLC Tool Window Help

[ New Project cul+nN | i
e . o o |
|1 save Ctrl+5 | [ Connect To PLC Ctrl+L

Save As 3
Close

1 C:\Users\y.c. Wang\op\Z\Test examp_p
e 2 CA\Users\Y.C. Wang\Desktop\pdw3Z 38\ My-servermotor. pdw
Import 3 3 CA\Users\Y.C. Wang'\Desktop\pdwzl & \example (2).pdw

Export »| 4 ChUsers\Y.C. Wang'\Desktophpdw3# 5\station03.pdw
&5 Printer Setup ... NOOT |

Print Content Setup  Ctrl+P

Exit

NOMD |
Select the project that you wish to open. Follow the above steps to open existing file and display it in the

ladder diagram window, as shown below:
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(The program in the current ladder diagram window is only the program in the PC disk, and is not connected
with the PLC)

Step 2: We can first save the program to the project files in the PC disk, please execute [File] = [Save] from

the function toolbar, which means that the original project files will be saved; or, execute [File]>[Save

As] = [Project File] from the function toolbar, and save the modified project program to a new project

file. You can keep the original project.

Step 3:

Since, in the beginning, an opened existing file is not connected to the PLC, therefore we need to

connect to the PLC, and save the test program to the PLC, to be able to proceed with program testing.

First execute [File]>[Save As] - [To PLC] from the function toolbar, and the [On-Line] window will

appear:
On-Line =)
. Auto Check
Connection Mame
Advanced Add Edit I Delete ‘
Details
Adtribute Data
Station Nurnber 1
Medium Serial line
PaortMo COk1
Baud Rate 4600
Parity Ewen parity
Diata Bit 7 hits
Stop Bit 1 bit
Cencel

(Select the desired [Connection Name], and then press the “OK” button, and the connection process will

begin)
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Data Receving ... ﬁ

System Data
Systerm Configuration
ROR Register
Ladder Pragram

¥4 4

Comments
Label Address
Finish

(After the connection has been established, the following illustration will appear)

PLC Status =)
tem Stetus

Elstation Mu... 1

ElModel FBs-24MCHA 62)

# PLC Status  Stopped

@ MEMORY_.. MNotSet

«F Syntax Che... OK
Fassword Mot Set
Wain Progr... Mot Set
Sub-Progra... Mot Set
Data Pass.. Mot Set
Program D Mot Set
PLCID Mot Set

i Calendar Installed

ElAvailable p.. 2022440rd

EUsed pragr.. 38wWard

ElFreeprogr..  20185%ord

EMin. 05 ver.. v4.00

' OK

(And now you can proceed with PLC connected tests)
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17 Appendix

This appendix contains the hotkey table and import/export format descriptions.

17.1 Hotkey Table

Component input

Input component

Keys and descriptions

A or Shift + A, if you simultaneously press the shift button you will only

Contact A need to enter the component and will not need to enter the reference
number
B or Shift + B, if you simultaneously press the shift button you will only
Contact B need to enter the component and will not need to enter the reference

number

Transition Up Contact

U or Shift + U, if you simultaneously press the shift button you will
only need to enter the component and will not need to enter the
reference number

Transition Down Contact

D or Shift + D, if you simultaneously press the shift button you will
only need to enter the component and will not need to enter the
reference number

Output Coil

O or Shift + O, if you simultaneously press the shift button you will
only need to enter the component and will not need to enter the
reference number

Inverted Output Coil

Q or Shift + Q, if you simultaneously press the shift button you will
only need to enter the component and will not need to enter the
reference number

E or Shift + E, if you simultaneously press the shift button you will only

Set Coil need to enter the component and will not need to enter the reference
number

R or Shift + R, if you simultaneously press the shift button you will

Reset Coill only need to enter the component and will not need to enter the

reference number

Note: When entering the above components, you can first enter the reference numbers (X,Y,M,S,T,C)
and then enter the component keys (A,B,U,D,0,Q,E,R), or you can first enter the component
keys and then enter the reference number.

Inversion of node status

Transition Up of node status |P
Transition Down of node status |N
Horizontal Short H

Continuous Horizontal Short | Shift + H
Vertical Short \%
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Function Block F
SET Function Shift + S
RESET Function Shift + R
Timer Function Shift + T
Counter Function Shift + C
Label Input Shift + L
Repeat Last Input Shift + F

Component Editing

Function

Keys and Descriptions

Modify contact reference number

Directly input new reference number, or press the “SPACE” key to

bring up the editing window and then enter the new number.

Modify reference number in the

function instruction

Press the “SPACE” key to bring up the editing window and then

enter the new reference number.

Delete component or function

instruction

Press the Delete key or the Backspace key.

Network Editing

Function

Keys and descriptions

Insert blank network

Insert above — Shift + Insert

Insert below — Ctrl + Insert

Delete single network Ctrl + Delete
Select networks in all program units |Ctrl + A
Copy network Ctrl+ C
Paste network Ctrl +V
Delete network Delete
Cut network Ctrl + X

Note: Before performing the above four operations, you must first mark the network with your mouse.

Cursor Movement

Function

Keys and description

Up, down, right, left movement

The up, down, right, and left keys

Jump to first column

Home
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Jump to last column End
Jump to next row Shift + Enter
Jump to next network Enter
Jump to first network Ctrl + Home
Jump to last network Ctrl + End
Jump to a specific network Ctrl+ G
Project Operations
Function Keys and descriptions
Open new project Ctrl + N
Open project file Ctrl+ O
Connect and open project |Ctrl + L
Save project Ctrl+S
Print Ctrl+ P
PLC Operation
Function Keys and descriptions
Stop PLC Operation Ctrl + F9
PLC execution F9
Component Search
Function Keys and descriptions
Search for component  |Ctrl +F
Search for next component |F3
Miscellaneous Operations
Function Keys and descriptions
Set project options Ctrl + F8
Syntax check F8
Display register data F11
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Step Ladder
Function Keys and descriptions
STP ? (irrelevant to Caps Lock)
FROM < (irrelevant to Caps Lock)
TO > (irrelevant to Caps Lock)
STPEND Shift + Z

17.2 Export/Import File Format

There are four types of project contents that can be exported and imported: [Comment], [Import Table],

[Ladder Diagram], and [Status Page].

1. [Comment] The import/export file format is a text file with a txt file extension.

2. [Import Table] Import and export operations are performed in tab file extension format.
3. [Ladder Diagram] Import and export operations are performed in Idr file extension format.
4. [Status Page] Import and export operations are performed in spf file extension format.

( test.txt - Notepac g@

File Edit Format Miew Help
REF COMMERT DESCRIPTION
o] start

=1 L=l

e Ls2

w3 L3

=4 L=4

B0 TURM OpR

v At

¥l A—

e B+

Y3 E-

=21 PROGRAML

S22 PROGRAMS

The following is a description of the text file contents:
“REF": list component name fields.
“COMMENT": text annotations for the corresponding components.

“DESCRIPTION": text descriptions for corresponding components.
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