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Manual for the FATEK M-Series PLC Software Interface 

Preface 

This Manual provides important information related to the use of the FATEK M-Series PLC CPU Module.  

Before using the product, be sure to read this Manual carefully in order to get familiar with and understand 

its content. Should you have any questions or comments, please contact the FATEK distributor for detailed 

warranty services and responsibility limit.  

Warranty Service 

The warranty period provided by FATEK for its product shall last for one year (or other period as 

otherwise agreed) starting from the date when the product is sold and it will be offered under the pre-

conditions that there are no defects in product use.  

Please contact FATEK or the local distributor in the event failure occurs on any of the FATEK products for 

reasons not caused by man-made factors during the aforesaid warranty period. However, the failure due 

to any of the following reasons shall not be covered by the warranty services:  

1. The malfunction is due to the user’s failure in following the conditions, environment, operations, 

installation and correct wiring method specified in this Manual.  

2. The malfunction is due to the user’s failure in following the operating method originally designed.  

3. The malfunction is not due to the reasons of the product.  

4. The malfunction is not caused by the modification and the maintenance executed by FATEK.  

5. The malfunction is caused by other types of force majeure factors such as natural disasters or man-

made negligence.  

In the meantime, the aforesaid warranty services shall be limited to the FATEK product only and the 

losses resulting from the product failure will not be covered in the warranty scope.  

 

Limit of responsibilities 

Unless it has been confirmed that the product is properly used, stored, installed and serviced and that it 

has not been contaminated, abused, misused or improperly modified or repaired as being analyzed by 

FATEK; otherwise, FATEK shall not be liable for any product-related particular damage, consequential 

damage or derivative damage or even revenue loss or commercial loss that resulted from whatever 

means.  
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Precautions on Using the Product 

Compliance with the application-related conditions 

The user shall evaluate the suitability of FATEK product and shall install the product in the well-designed 

equipment or system.  

The user needs to check if the system, machinery or device currently used is compatible with the FATEK 

product. If the user fails to confirm the compatibility or the suitability, then FATEK shall not be liable for 

the suitability of the product.  

When required by the customer, FATEK shall provide correlated third party certification to define the 

value rating and the application restrictions that will be applicable for the product. However, the 

aforesaid certification message shall not be considered as sufficient to determine the suitability of the 

FATEK product, the final product, the machine, the system and other applications or relevant 

combinations. Described below are certain applications that should be cautiously treated by the user. In 

spite of this, the content described below shall neither be considered as having included all of the 

intended product purposes nor suggesting that all of the following purposes shall be entirely suitable 

for the product. For example, outdoors use, use in an area subjected to potential chemical 

contamination or electrical interference or used under conditions or functions not mentioned in this 

Manual or used with the system, machine and equipment that may create risks to life or properties.  

Before working with the product, the user will be required to check if the entire system is marked with a 

hazard sign and shall select the design that can ensure the safety such as the backup design, etc. 

Otherwise, the user shall not be allowed to use the product in the application that will present personnel 

and the property safety concerns. In no event shall FATEK be liable for the specifications, statutory 

regulations or restrictions that will be used by the customer in the product combination or the product 

operations.  

When using the product, FATEK shall not be liable for the programs edited by the user or the resulting 

consequences. 
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Disclaimers 

Dimensions and weight 

The dimensions and the weight specified in the manual are nominal values only. Even if provided with 

the tolerance, they cannot be used in the manufacturing purposes.  

 

Performance data 

The data specified in this Manual mean that the performance data obtained under FATEK’s test 

conditions are provided for the user to confirm its compliance only. Therefore, the user is also required 

to consider the actual application conditions. Therefore, actual performance shall be defined according 

to the content of the guarantee and the limit of responsibilities established by FATEK.  

 

Errors and negligence 

The content of this Manual is provided through careful checking process and is considered as correct. 

However, FATEK shall not be liable for the errors or the negligence that may be found in the text, printing 

content and proofreading.  

 

Change of specifications 

The product specifications and accessories may be subject to change along with the technical 

improvement or other reasons. In the event that the published specifications or performance need to 

be changed or where significant structural change is required, FATEK will change the model number of 

the product accordingly. If certain specifications of the product have changed, then FATEK will not give 

the notice under the following situation: when it is required to use a special model number or create 

particular specifications in order to support the customer’s application according to the instructions 

given by the customer. To confirm actual specifications of the product to be purchased, please contact 

the local FATEK distributor.  
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Precautions for Safety  

Signs and meaning of safety precautions 

The following signs will be used in this Manual in order to provide precautions that will be required for 

using the M-Series PLC safely. These precautions are extremely important for using the product safely. 

Please read the safety precautions carefully in order to get familiar with and understand the content and 

the meaning of the aforesaid instructions.  

 

 Warning 

Means a potentially dangerous situation that will result in death or serious 

injury if not avoided. In the meantime, it may also lead to serious property 

losses.  

 

 
Caution 

Means a potentially dangerous situation that may result in minor or 

medium level injury or property losses if not avoided. 

 

 

Means operations that must not be executed. 

 

Means operations that must be executed. 

 

Means general precautions. 

 

Means the precautions relating to hot surfaces. 

 

Means the precautions related to the wiring, grounding and electrocution of the electrical 

system.  
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Warning 

Do not attempt to dismantle any module or touch the internal side of the module when 

it is under energized status or it may lead to electrocution injury.   

Do not attempt to touch any terminal or terminal board when the module is under 

energized status, or it may lead to electrocution injury.  

To ensure the system safety in order to avoid abnormal actions that may be caused by 

man-made external factors or false actions resulting from the faulty PLC, it is required to 

install the following safety measures in the external circuit (not within the PLC 

procedure); otherwise, it may lead to serious accident. 

The externally controlled circuit must be provided with emergency stop switch, 

interlocking circuit, limit switch and similar safety measures. The PLC will stop outputting 

the signals when encountering major failure alarm during the operations. However, the 

errors in the I/O controller and the I/O register as well as other undetectable errors will 

still trigger unexpected actions. To deal with the aforesaid errors, you are required to 

install external safety measures to protect the system safety. If the output relay is 

jammed, burnt or if the output transistor is damaged, then the PLC may still maintain its 

output at the ON or OFF status.  

To solve the aforesaid issues, it is required to install external safety measures to protect 

the system safety. By installing the corresponding safety measures in the system and the 

equipment, it allows you to maintain the safety of the entire system in spite of the fact 

that communication errors or false actions have occurred during the operating process.  

 

The user must take corresponding failure preventive measures in order to ensure safety 

when the signal line is damaged or when the power is instantly disconnected or when 

the signal is wrong, missing or abnormal as may be caused by other reasons. If failing to 

taking the appropriate measures, it may lead to improper operations that may result in 

serious accidents. 
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Precautions 

Do not touch the power module when the PLC is under energized status or when the 

power source is disconnected. At this time, the power module might still present 

extremely high temperature that can cause a scorching injury.  

 

When connecting with the terminal board of the power module, the cable should be 

secured with the appropriately sized Ferrule. If the cable is loose, it may lead to 

burning or the failure of the power module.  

 

The online editing shall be allowed only after confirming that the extended PLC cycle 

duration will not result in any adverse impact or the system may not be able to read 

the input signal.  

 

After confirming that the I/O terminal is safe, you may transmit the required 

parameters to other terminals such as PLC setting, I/O table and I/O register data, 

etc. Otherwise, it may lead to unexpected actions if transmitting or modifying the 

aforesaid data before that.  
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Precautions for Use 

When using the M-Series PLC, please observe the precautions provided below.  

Using the power 
⚫ Please use the voltage specified in the Manual. Incorrect voltage will lead to false action or burning 

damage to the equipment. 

⚫ If the number of the module being connected exceeds the current rating of the power module, you 

may not be able to start the CPU module or other modules.  

⚫ Please use the designated power source and then supply the power according to the specified voltage 

and frequency rating. Special attention should also be given to the location subjected to unsteady 

power supply, as incorrect power supply may result in false action.  

⚫ Before starting any of the following operations, be sure to disconnect the PLC power; or it may lead 

to false action or electrocution injury.  

(1) When installing or dismantling power module, I/O module, CPU module or any other type of 

module. 

(2) When connecting cables or executing the system wiring. 

(3) When connecting or disconnecting the connector.  

⚫ When using the power module, be sure to observe following precautions. 

(1) The voltage applied at the equipment output point or the connected load shall not be higher than 

the rated specifications established for the power module.  

(2) If it is required to put aside the power module for over 3 months, it shall be stored in a cool and 

dry location in order to maintain its function at normal status.  

(3) If the power module is improperly installed, it will result in the accumulation of heat as to cause the 

aging or the damage of the component within. Therefore, it shall be properly connected and you are 

also required to use the standard installation method. 

Installation 

⚫ Do not install the PLC at the location near a high frequency noise interfering source.  

⚫ Confirm that the terminal board, the connector, the memory card, the peripheral communication wires 

and other buckle-mounted devices are latched in position. Improper latching will result in false action.  

⚫ After connecting to the adjacent module, the buckle at the top or the bottom must be securely locked 

(i.e., properly latched). If failing to lock the buckle tightly, the module may not be able to achieve the 

intended function.  
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Wiring 
⚫ Please follow the instructions provided in the Manual in order to execute the wiring operations 

correctly.  

⚫ Before connecting the power, please check the setting status of all wires and switches. Incorrect wiring 

may result in burning damage to the equipment. 

⚫ After checking the installation position, you may start installing the terminal board and the connector.  

⚫ During the wiring process, the label should be tagged on the module. If you tear off the label, foreign 

mattes may get into the module as to cause a false action.  

⚫ To ensure normal heat dissipating function, please tear off the label after completing the wiring 

operations. If retaining the label, it may lead to false action.  

⚫ Please use an EU-standard terminal to execute the wiring operations. Do not connect the terminal 

with bare stranded wires. The aging or the breaking of wires may result in burning damage to the 

equipment.  

⚫ The voltage applied to the input module shall not be higher than the input voltage rating or it may 

result in burning damage to the equipment. 

⚫ The voltage or the load applied to the output module shall not be higher than the maximum switch 

capacity. The over-voltage or the overload may result in burning damage of the equipment. 

⚫ Do not drag or bend the cable excessively. Such action may cause the breaking of the cable.  

⚫ Do not place any objects on the cable or other type of wires or it may cause the breaking of the cable. 

⚫ Please set the grounding wire correctly for the power module and communication port to avoid 

communication error and equipment malfunction caused by noise interference. 

⚫ It is recommended to use M series dedicated AC power modules to supply power to MPLC related 

modules. 

⚫ It is recommended to use twisted-pair shielded cables for communication cables and ground them 

properly. 

Operating 
⚫ Before supplying power to the MPLC to start the operations, ensure that the setting of the data 

register is correct without any mistakes.  

⚫ Before executing any of the following tasks, confirm that it will not bring about any adverse impact 

on the system; otherwise, it may result in unexpected action.  

(1) When changing the operating mode of the PLC (RUN Mode/STOP Mode). 

(2) When executing compulsory enable/ compulsory disable for any of the data retained in the 

register. 
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(3) When changing the present value of any bit or setting that has been logged in the register.  

⚫ Do not attempt to dismantle, repair or modify any module; or it may result in false action, fire or 

electrocution.  

⚫ It is required to protect the PLC from falling or from excessive vibration or impact.  

⚫ If the I/O is located at the “ON” position, when switching the “RUN Mode” to the “STOP 

Mode,” the system will set the PLC output at the “OFF” position and then all output actions will 

be disabled. Please ensure that the external load will not generate hazardous factors during the 

aforesaid process.  

⚫ If the CPU module stops running due to catastrophic error, please set all of the output points on the 

output module at the “OFF” position. The output status will be retained after being set as the 

holding-type memory configuration parameters.  

⚫ If the status monitoring pages or the parameters are improperly set, it may result in unexpected 

action. Even though the status monitoring pages or the parameters are correct, it is also required to 

confirm that the controlled system will not be subject to adverse impact before starting.  

⚫ When applying maximum level of voltage or when the power supplied to the operating switch is 

interrupted suddenly during the Insulation Strength Test, it may result in the damage of the CPU 

module. In this case, please use the variable resistor to increase or reduce the voltage level gradually.  

⚫ Before conducting the Withstand Voltage Test or the Insulation Resistance Test, please separate the 

wire grounding terminal of the power module from the functional grounding terminal. Otherwise, it 

may result in burning damage to the equipment. 
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Precautions for the Application Environment 

⚫ Please follow the instructions described in this Manual for carrying out the 

installation activities correctly.  

⚫ Do not operate the control system in any of the following locations: 

(1) The location exposed to direct sunlight.  

(2) The location with temperature or humidity exceeding the specified range. 

(3) The location vulnerable to dewing effect due to abrupt temperature changes.  

(4) The location exposed to corrosive or combustible gases.  

(5) The location exposed to dust (especially iron chips) or smoke. 

(6) The location exposed to water, oil or chemicals. 

(7) The location vulnerable to impact or vibration.  

⚫ When installing the system in any of the following locations, appropriate and 

effective preventive measures should be taken:  

(1) The location exposed to electrostatic or other type of noise. 

(2) The location exposed to strong electromagnetic field. 

(3) The location that may be exposed to radioactive pollution.  

(4) The location near the power supply source.  
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    Danger 

1. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

2. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

3. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 

malfunction. 
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UperLogic is a professional PLC software, which is mainly used to design and configure the new 

generation of M-series PLC. It runs on Windows operating system and is completely designed according 

to the operating habits of Windows environment. The window interface is presented in the style that is 

commonly used by the general public today. Easy to learn and use, both beginners and experienced users 

can operate in a very efficient way. The software adopts the project concept and presents the 

development content of the program in a hierarchical manner in a visual way, so that the relevant work 

content can be presented to the user at a glance. Both program development and maintenance can be 

carried out in a very intuitive way. In addition, it provides convenient keyboard and mouse shortcut 

operation methods, which can complete program editing and testing in a very efficient manner. It also 

provides a Multiple Document Interface (MDI) editing program screen, which can simultaneously display 

and compare, copy and edit programs in different sections. 

 

Main Functions and Features: 

• Full support for global tags, regional tags and system tags, which facilitates programmers to 

configure and manage registers in a more intuitive way. 

• Supports Ladder Diagram (LD), Structured Text (ST), mainstream PLC language editing, and 

supports custom Function Module (FCM), can be aimed at repetitive logic program packaging 

and release for use. 

• Provides three modes: Offline Editing/Online Monitoring/Online Editing, making it safer and 

more convenient to design programs and test machines. 

• In addition to the monitoring table function to monitor the registers online in real time, it also 

provides a Data chart tool, which can more intuitively present register data from different 

sources on the graph at the same time, and can also facilitate comparisons. 

• Brand new Device View function, more intuitive to set PLC and IO module system parameters 

and configuration. And you can know the device size, power consumption, module resources 

and other information in advance. In the On-line Monitor mode, you can directly monitor and 

modify IO data and understand the status of the PLC system. 

• Users can divide the entire development work into several program units according to different 

functions or other classification methods, and can perform independent input annotations and 

tests, which is of great help to program development and subsequent maintenance work. 

• Diversified program searching functions, in addition to basic search functions, also supports 

memory configuration and cross query functions. Help users understand the usage of the 

memory more quickly, and quickly find and open the relevant functions or program window 

screens of the register used, and modify the parameters. 
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• Provides program syntax checking function, the execution of this function can be proposed by 

the user, or the system will automatically execute when the user issues an operation command. 

After execution, a syntax check report window will be generated, and various errors will be 

listed in columns. If you click the error item directly with the mouse, the program 

corresponding to the error will be called out directly, and the cursor will be placed on the 

wrong location, this judgment on the error is helpful for the subsequent correction. 

• Perfect protection of intellectual property rights. In addition to project passwords, program 

passwords, data passwords, and download passwords, protection measures for program IDs 

and PLC IDs are also provided, allowing users’ projects and systems to be assigned according 

to the different roles of designers and operators. Different password permissions, thereby 

protecting the security of the system and intellectual property. 

• Supports complete motion control functions, such as servo trial run, motion monitoring 

diagram, motion trajectory preview, and motion flow block. It can easily set the servo and cam 

related configuration (E-CAM), and plan the motion control process conveniently and 

systematically. 
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2 
Installation Instructions 
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    Danger 

1. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

2. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

3. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 

malfunction. 
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This section introduces the installation requests and process of UperLogic. 

 Operating Environment 

It supports the following operation systems: 

Windows 7 (32&64 bits) 

Windows 8 (32&64 bits) 

Windows 10 (32&64 bits) 

Windows 11 (32&64 bits) 

 

  Connection Configuration 

Through the USB/Type C or by connecting network to PC and PLC, it allows the user to upload and 

download the ladder diagram, control the PLC operation and monitor the PLC Register, etc.  

 

  Installation Process 

 

This section describes how to install UperLogic. 

 

1. After downloading the UperLogic Installation file from the official website, double click [Install] file to 

begin the installation. The system will ask if the user want to install the UperLogic to the PC. If yes, 

please click [Next].  

 

 

Fig. 1: Installation interface_1 
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2. The system will ask the user about the type to be installed. It is recommended that [Complete] be 

selected to prevent from missing out the corresponding drive software. After being confirmed, click 

[Next]. 

 

 

Fig. 2: Installation interface_2 

 

3. After confirming that the executed installation as correct, click [Install] to being the installation. To 

modify the previous setting, click [Back] and you may return to the previous page to perform the 

required setting.  

 

 

Fig. 3: Installation interface_3 
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4. During the system installation process, the FATEK Program Drive Install will appear in the webpage. 

Click [Next] to begin the drive program installation.  

 

Fig. 4: Drive program installation interface 

 

5. After installing the drive program, the system will display following information. Click [Finish] to 

complete the drive program installation.  

 

Fig. 5: Drive program installation finished 
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6. After installing the drive program, the system will show that the UperLogic has been successfully 

installed. Click [Finish] to complete the installation. 

 

 

Fig. 6: Installation finished 

 

7. After completing the installation of UperLogic, the user will find the corresponding software shortcut 

 on the desktop. 

 

8. Double click  shortcut to open UperLogic.  

 

Fig. 7: Open software
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    Danger 

4. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

5. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

6. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 
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This section describes the functions that will be displayed in the UperLogic software interface.  

 

Displayed in the webpage below are the UperLogic working window and the status of the respective 

connection window.  

 

Fig. 8: Webpage configuration

malfunction. 
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3-1 File 

Such function allows the user to perform project operations such as opening a new project, saving a 

project, saving a new file, importing and exporting, and printing. 

 

Fig. 9: File 

Function Description Detailed introduction 

Open new project Create a new project for executing the editing.  Please refer to 

Section 4.1. 

Open project Open previously written project for executing the 

editing. 

Please refer to 

Section 4.8. 

Save project Save currently edited project to disk.  Please refer to 

Section 4.4. 

Save project as Save currently edited project as another project name 

in the disk.  

Please refer to 

Section 4.5. 

Close project Close currently edited project.   

Import Import previously saved information to project.  Please refer to 

Section 4.6. 

Export Export the information from project to disk.  Please refer to 

Section 4.6. 

Exit Close UperLogic.  

Table 1: Detailed file function introduction
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3-2 Quick Toolbar 

The Quick Toolbar allows users to select frequently used functions for quick selection. 

 

Fig. 10: Quick Toolbar 

Quick key will display the function that can be used under current status.  

Status Quick Toolbar display status 

Offline editing, and project not 

opened. 

 

Offline editing, and project 

opened. 

 

Online monitoring, and PLC is 

running  

 

Online monitoring, and PLC 

stops running 

 

Table 2: Quick Toolbar display status 

 

Function Description Detailed Introduction 

Open new project Create a new project for executing the 

editing. 

Please refer to Section 4.1 

Open project Open previously written project for 

executing the editing. 

Please refer to Section 4.8 

Save project Save currently edited project to disk. Please refer to Section 4.4 

Run (F9) Run PLC Please refer to Section 11.5 
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Stop Run 

(Shift+F9) 

Stops running PLC Please refer to Section 11.5 

Upload Upload project from PLC to software Please refer to Section 11.3 

Download Download currently edited project to 

PLC 

Please refer to Section 11.4 

Clear data Clear PLC data Please refer to Section 1.6 

PLC status Display current PLC status Please refer to Section 11.7 

Self-defined quick 

toolbar 

The user may define its own quick 

toolbar 

 

Table 3: Quick toolbar function introduction 

 

3-3 Interface Outlook Setting 

This function provides a number of software outlook interfaces for users to execute the adjustment 

according to their own demand.  

 

Fig. 11: Interface outlook setting options 
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Format Preview 

Office color 

 

Fatek dark 

color 
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Fatek light 

color 

 

Table 4: Interface outlook format preview 

 

3-4 Ribbon Tag Page 

This function is designed to organize the created commands in a “tag” group, and each group 

comprises the required commands. Each application program corresponds to the related tag group in 

order to demonstrate the functions that will be provided by the program. Its purpose is allowing the user 

to search and use the functions of the application program more easily, as per the tag categorization 

indicated in the figure below.  

3-4-1 Project 

This tag page is mainly used to set the overall information of the project such as memory configuration 

and security. 

 

Fig. 12: Project tag page 

Type Function Description 
Detailed 

Introduction 

System 

configuration 

Device View The equipment required for 

planning and checking current 

status of PLC. 

Please refer to 

Section 10 
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I/O Configuration Set the I/O status Please refer to 

Section 5.1 

Memory Allocation Check current memory 

configuration 

Please refer to 

Section 5.2 

ROR Register Check and edit the read-only 

Register.  

Please refer to 

Section 5.3 

Server Configuration Set the connection between PLC 

and server 

 

Modbus Device 

Allocation 

Check and edit the settings of 

PLC Register and Modbus 

address. 

Please refer to 

Section 5.4 

Ladder 

diagram 

Main Program Add or revise Master Program Please refer to 

Section 6.1 

Sub Program Add or revise main sub-program Please refer to 

Section 6.1 

Data Table 
Table Edit Set required tables Please refer to 

Section 7 

Status Page 
Status Page Check current status of PLC 

Register 

Please refer to 

Section 12.3 

Comment 

Description 

Comments Set and edit the comment Please refer to 

Section 8 

Project 

Security Edit PLC security related setting. Please refer to 

Section 13 

Project Setup Edit the project attribute related 

setting. 

Please refer to 

Section 4.7 

Discrete Register 

Allocation 

Check contact and register 

related information 

Please refer to 

Section 5.3 

Project information Set project name and 

information 

Please refer to 

Section 4.2 

Option Set project automatic backup Please refer to 

Section 4.3 

Motion 

control 

Motion Network Edit motion network related 

setting 

Please refer to 

Section 9.1 
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Motion Axis Edit motion axis related setting Please refer to 

Section 9.2 

Motion Point Edit the motion point related 

setting 

Please refer to 

Section 9.3 

Motion Flow Edit the motion process related 

setting 

Please refer to 

Section 9.4 

Motion Sync Control Edit the motion synchronization 

related setting 

Please refer to 

Section 9.5 

Motion Param 

Mapping 

Edit the motion network related 

setting 

Please refer to 

Section 9.6 

Table 5: Setting project tag page  

Type 
Function Description Detailed 

Introduction 

System 

Configuration 

Device View The equipment required for 

planning and checking current 

status of PLC. 

Please refer to 

Section 10 

I/O Configuration Set the I/O status Please refer to 

Section 5.1 

Memory Allocation Check current memory 

configuration 

Please refer to 

Section 5.2 

ROR Register Check and edit the read-only 

Register.  

Please refer to 

Section 5.3 

Server Setting Set the connection between 

PLC and server 

Please refer to 

Section 5.4 

Communication Setting Check and edit PLC 

communication-related 

settings 

Please refer to 

Section 5.5 

Information of contacts 

and registers 

Check the information of 

contacts and registers 

Please refer to 

Section 5.3 

Program Unit 

Main Program Add or revise Main Program Please refer to 

Section 6.1 

Sub-program Add or revise Sub-program Please refer to 

Section 6.1 
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Type 
Function Description Detailed 

Introduction 

Interrupt Sub-program Add or revise Interrupt Sub-

program 

Please refer to 

Section 6.6 

Function Module 

Program 

Add or revise Function Module 

Program 

Please refer to 

Section 6.7 

Data Table 
Data Table Set required tables Please refer to 

Section 7 

Status Page 
Status Page Check current status of PLC 

Register 

Please refer to 

Section 12.3 

Comment 

Description 

Comments Set and edit the comment Please refer to 

Section 8 

Project 

Security Edit PLC security related 

setting. 

Please refer to 

Section 13 

Project Setup Edit the project attribute 

related setting. 

Please refer to 

Section 4.2 

Motion 

Control 

Motion Network Edit motion network related 

setting 

Please refer to 

Section 9.1 

Motion Axis Edit motion axis related 

setting 

Please refer to 

Section 9.2 

Motion Point Edit the motion point related 

setting 

Please refer to 

Section 9.3 

Motion Flow Edit the motion process 

related setting 

Please refer to 

Section 9.4 

Motion 

Synchronization 

Edit the motion 

synchronization related 

setting 

Please refer to 

Section 9.5 

Motion Parameter 

Table 

Edit the motion parameter 

related setting 

Please refer to 

Section 9.6 

Motoin Recipe Edit the motion recipe related 

setting 

Please refer to 

Section 9.7 
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3-4-2 Design 

This tab page is mainly used to edit the related design of the ladder diagram and the motion flow block 

program. 

Fig. 13: Designing tag page 

Type Function Description 

Clip book Paste Paste the copied or clipped object 

Cut Cut the selected object 

Copy Copy the selected object 

Edit Delete Delete the selected object 

Undo Restore to previous status 

Redo Cancel the restore 

Select All Select all objects 

Find/Replace Find Search object in Ladder Diagram 

Replace Search and replace corresponding object 

Goto To specific ladder program network bar 

Ladder Block Block Close Close ladder block 

Block Open Open ladder block 

Network Insert Insert network in upper or lower side 

Expand  Compress or expand the network 

Ladder 

Diagram 

Cursor Arrow Return to the mouse status where object is not 

being selected 

A contact Constant open contact 

B contact Constant close contact 

TU contact Create a pulse wave when contact is energized 

(0→1). 

TD contact Create a pulse wave when contact is closed (1→0). 

Coil Send computation result to the coil.  

Inverse Coil Send computation result back to coil 

Set Coil Set the coil. 
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Reset Coil Clear the coil. 

Inverse Execute reverse phase for node status. 

TU Power Flow Retrieve upper differential for node status 

TD Power Flow Retrieve lower differential for node status 

Horizontal Short Add horizontal line in Ladder Diagram 

Vertical Short Add vertical line in Ladder Diagram 

Horizontal Long Add long horizontal line in Ladder Diagram 

Set Set all bits for each point or Register (set as 1). 

Reset Clear all bits from each point or Register (set as 0). 

Timer General Timer command 

Counter General Counter command 

Function Set corresponding Function command 

Cursor Delete Delete object from Ladder Diagram 

Delete Vertical 

Short 

Delete vertical line from Ladder Diagram 

Delete Horizontal 

Long 

Delete horizontal line from Ladder Diagram 

Zooming Open the table setting corresponding to application 

command 

Motion Process Finish Finish motion control 

Branch Selection Select the corresponding branch 

Horizontal Branch Simultaneous branching 

Coverage Make motion process branches converge 

Point Reset Set the reset process 

Position Control Set the positioning control process 

Speed Control Set speed control process 

Torque Control Set torque control process 

Standby Set standby process 

Sub-process Set up Sub-process 

Page Skipping Skip to other process 

Synchronizing 

Control 

Set synchronizing control process 

Computation Execute computing 

Table 6: Setting tag design page 
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3-4-3 PLC 

This tag page is mainly used for editing the Ladder Diagram related design.  

 

Fig. 14: PLC tag page 

Type Function Description Detailed introduction 

PLC Run PLC Run PLC Please refer to Section 11.5 

Stop PLC Stop running PLC Please refer to Section 11.5 

Trial Run Test project while editing online Please refer to Section 

11.10 

Discard 

Change 

Abandon the action of online editing Please refer to Section 

11.10 

Operation Upload Upload project from PLC to software Please refer to Section 11.3 

Download Download currently edited project to PLC. Please refer to Section 11.4 

Syntax Check Syntax Check Check if syntax error exists in Ladder 

Diagram 

Please refer to Section 6.4 

Mode Offline Edit Edit when not connected with PLC.  Please refer to Section 11.1 

Online 

Monitor 

Edit when connected with PLC. Please refer to Section 11.2 

Monitor Status Page Check current status of PLC Register Please refer to Section 12.3 

Data Chart The Trend Curve used for checking the 

change of each Register.  

 

Motion Chart Check current status of motion control Please refer to Section 9.1 

Connect Connection 

Parameter 

Set up PLC connection method and relevant 

parameters 

Please refer to Section 11.1 

Others Quick Control Set up PLC-related operation in quicker way  

PLC Setting Set up PLC-related setting Please refer to Section 11.8 

Clear PLC Clear PLC data Please refer to Section 11.6 

PLC Status Display current PLC status Please refer to Section 11.7 

Table 7: Setting PLC tag page 
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3-4-4 Inspection 

This tag page is mainly used for editing the Ladder Diagram related design. 

 

Fig. 15: Inspection tag page 

Type Function Description Detailed introduction 

Project Window Project 

Management 

Display or hide project 

management window. 

Please refer to Section 3.5 

Tool Box Display or hide toolkit Please refer to Section 3.6 

Module List Display or hide module list Please refer to Section 10.2 

Memory Position Display or hide the position of 

memory 

Please refer to Section 3.5 

Crosstab Searching Display or hide crosstab 

searching 

Please refer to Section 3.5 

Comment Program Comment Display or hide program 

comment 

Please refer to Section 6.1.5 

Network Comment Display or hide network 

comment 

Please refer to Section 6.2.5 

Component 

Comment 

Display or hide component 

comment 

Please refer to Section 8.3 

Register Value Display or hide Register data  

Font Font size Set font size for Ladder 

Diagram 

 

Window Cascade Display window overlapping Please refer to Section 6.2.1 

Tile Horizontal Display entire window array Please refer to Section 6.2.1 

Switch Window Quick switch to corresponding 

window 

Please refer to Section 6.2.1 

Close All Close all windows Please refer to Section 6.2.1 

Table 8: Setting inspection tag page  
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3-4-5 Tools 

This tag page is mainly used for editing the Ladder Diagram related design. 

 

Fig. 16: Tool tag page 

 

Type Function Description 
Detailed 

introduction 

Tools System Backup Set up and save system project 

related backup  

Please refer to 

Section 14.2 

System Restore Read originally saved system 

backup data 

Please refer to 

Section 14.2 

Memory Card 

Operations 

Execute memory cartridge related 

operation 

Please refer to 

Section 14.3 

CRC16 Generator System will calculate and produce 

the checking value automatically 

Please refer to 

Section 14.4 

Table 9: Setting tool tag page  
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3-5 Project Window 

3-5-1 Project Management 

Such function allows the user to organize regularly used functions into a tree diagram and then display it 

in the left-hand side Project Management window. By clicking the respective function setting tag under 

the Project Management, it also allows the user to open the required window in quicker way. For example, 

click the “IO Configuration” and the relevant setting window will pop up.   

 

 

Fig. 17: Project management window 

 

Type Description Detailed 

introduction 

System 

Configuration 

Check Register related setting  Please refer to 

Section 5 

Program Unit Check Main Program and sub-

program 

Please refer to 

Section 6.2 

Comment 

Description 

Manage the comment deployed in 

the Ladder Diagram 

Please refer to 

Section 8 

Status Page Monitor current status of Register Please refer to 

Section 12.3 
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Run Chart Monitor the trend graph of 

individual register changes 

Please refer to 

Section 6.2.1 

Motion Control Set the motion control related 

parameters.  

Please refer to 

Section 9 

Data Table Set up various tables Please refer to 

Section 7 

Table 10: Setting project management window 

3-5-2 Tool Box 

For easier operation by users, normal commands are categorized for organizing in the toolkit. By clicking 

[View]→ [Tool Box] in the function toolbar, the user will be allowed to open the Tool Box command 

window. 

 

Fig. 18: Tool Box window 

For the introduction of the functions in the tool box, please refer to the relevant manuals. 

 

3-5-3 Module List 

Click [View]→ [Module List] in the function toolbar, the following module management webpage appears, 

as shown in the figure below: 
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Fig. 19: Module List 

Please refer to Section 10-2 for detailed description. 

3-5-4 Position of Memory 

When there are too many components used in the project, it is impossible for the user to fully remember 

which components or functions use which resources, but through this function, the user can clearly see 

which registers are used and the corresponding registers; therefore, users can plan the resources in the 

project more efficiently. 

As shown in the figure below, red represents the used registers, and green represents the unused 

registers. Double-click the list item with the left mouse button to open the corresponding function 

window. 

 

Fig. 20: Position of memory 
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3-5-5 Crosstab Searching 

Through this function, users can quickly query the location, characteristics, functions and other 

information of registers or tags, and use the filtering function to further search for registers or tags with 

specific conditions. Double-click the list item with the left mouse button to open the corresponding 

function window. 

 

Fig. 21: Crosstab Searching 
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3-6 Webpage Configuration Management 

In addition to displaying the window list currently opened, the user may also open the designated 

window or execute the arraying. When opening several windows, the user may arrange the display 

windows according to personal operating habitude.  

 

Fig. 22: Webpage management 

For example, the user may drag the window of the opened monitoring page to the desired position, 

release the mouse and then the user will be allowed to change the window arraying pattern.  

 

Fig. 23: Changing window arraying pattern 
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3-7 Quick key 

Click [Project] →[Project] → [Quick Key] to view the shortcut keys provided, and also allow users to define 

familiar quick keys. 

 

Fig. 24: Quick Key 

 

Type Function Quick key 

Project Function Manual “F1” 

Special Manual “F2” 

File New Ctrl+N 

Open Ctrl+O 

Save Ctrl+S 

Print Ctrl+P 

Design Find Ctrl+F 

Replace Ctrl+R 

Goto Ctrl+G 

PLC Run F9 

Stop Ctrl+F9 
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Trial Run F10 

Discard Change Shift+F10 

Upload F11 

Download Ctrl+F11 

Offline Editing Ctrl+F12 

Online Monitoring F12 

Online Editing Shift+F12 

Other Syntax Check F8 

Register Content F7 

Options Ctrl+F8 

Ribbon Collapse Ctrl+F1 

 Table 11: Quick key list
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This section describes how to open and save the project as well as certain relevant setting in order that 

the user may quickly control over the method in using the required functions.  

4-1 Open a New Project 

Create a new project to edit the controller program. 

First, click the upper-left [File]  and then click [New], or click the [New] in Quick toolbar, or you may 

press [Ctrl+N] to open a new project directly.  

 

 

Fig. 25: Open new project 

After that, the [Project Information] window appears as per the figure below. After completing the setting, 

click [OK] key to open the new project.  

 

Fig. 26: Creating new project 
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Function Description 

Project 

Name 

Please define the project name for the convenience of file management 

in the future.  

Description The lists the descriptive text relating to the project.  

Series  Based on the series that will be actually needed, select a corresponding 

series with the scroll-down menu.  

Model No. Based on the model that will be actually needed, select a corresponding 

model with the scroll-down menu. After that, the program will display the 

specifications and the description of such model at the lower side 

automatically.  

Perpetual 

Calendar 

If the PLC is provided with a perpetual calendar, then RTC will be able to 

count the time correctly under PLC energizing or shutdown condition. 

The time figures provided by such calendar shall comprise the following 

seven time-value data: week, year, month, day, hour, minute and second.  

With the perpetual calendar clock, it allows the system to carry out 24-

hour control continuously. It not only helps the control system coordinate 

with people’s daily life automatically but also elevates the level of 

automatic control and the efficiency is therefore intensified. When using 

this column, please check if the PLC is provided with such perpetual 

calendar function. 

Program 

Language 

To change the language of the editing project, or can choose to edit 

through Ladder or ST. 

Table 12: New project opening related setting 
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4-2 Project Setup 

The project can modify and view project information, model, history and capacity by clicking [Project 

Setup] → [Project Information] on the function bar as shown below: 

 

Fig. 27: Project Setup 

Function Description 

Project Information Please define the project name to facilitate future file management. 

Change Module Optionally list the explanatory text for this project. 

Project Resume According to the drop-down list, select a corresponding series 

according to the series actually used. 

Project Capacity Display the current project program and data usage. 

4-2-1 Project Information 

Click [Project Information] and then the below window appears. Users can edit project name and 

description through project information. 

 

Fig. 28: Project Information 
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4-2-2 Change Module 

Click [Change Model] to see the following screen. Users can select the series and model of the project. 

 

Fig. 29: Change PLC Module 

4-2-3 Project History 

Click [Project History] and you will see the following screen. Users can log in the history and write 

comments, and then restore the project to the original version when necessary. 

 

Fig. 30: History List 
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4-2-4 Project Capacity 

Click [Project Capacity] and you will see the following screen. Users can clearly know the usage 

distribution of each part of the project through the bar graph. 
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4-3 Automatic Project Backup 

To protect the newly edited project from losing due to unexpected contingencies, it allows the user to 

execute the automatic backup related setting action by clicking the [Project] → [Options] → [File] in the 

tag page.  

 

Fig. 31: File Processing 

Function Description 

Backup Interval Automatically back up projects based on set intervals. The time 

interval of automatic backup can be set from 1 to 999 minutes, 

and automatic backup will be enabled when checked. 

Backup file limit Set the upper limit of automatic backup files for the same project, 

and the setting range is 1 to 99. 

For example, if the project file name is “Untitled”, and the file 

limit is 5, it will be automatically backed up 

“($autosaved_0) Untitled”, 

“($autosaved_1) Untitled”, 

“($autosaved_2) Untitled”, 

“($autosaved_3) Untitled”, 

“($autosaved_4) Untitled”, it will be overwritten from 

“($autosaved_0) Untitled” in the future. 
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Backup file if I close 

file wothour saving 

When the user has edited the project but closes the file without 

saving, checking this option will automatically back up the current 

project. 

For example, if the project file name is “untitled”,  

“($unsaved) untitled” will be automatically backed up. 

Backup files during 

trial running 

When the user uses the trial run function during online editing, 

checking this option will automatically back up the current project.  

For example, if the project file name is “untitled”,  

“($unsaved) untitled” will be automatically backed up. 

Backup Directory The location of the above backup files can be set. 

Advanced Backup When the file version is updated, use the new version program to 

start the file, and the program will automatically back up the old 

version of the file to the backup location. 

For example, the current project file name is “untitled”, the file 

version is 1009, and the new version of the program is 1011, and 

“($1)untitled” will be automatically backed up when the project 

is opened. 

This function is always enabled, there is no off setting. 

4-4 Save the Project 

Click the upper-left [File]  and then click [Save Project] or click [Save project] in Quick toolbar, or 

you may press [Ctrl+S] key to save the project directly and it is intended to save the project on the disk. 

You may use such function to save the revised project content on the disk.  
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4-5 Save a New Project 

Click the upper-left “File”  and then click “Save project as.” If change will be required for the 

content of the opened project, you may save the revised project content as another project name in order 

to save it on the disk.  

You may also point the cursor at [Save As] in the [File] and then the window will show detailed items of 

the project being newly saved. In the meantime, the [Save As] also comprises the following two modes 

and they are [Save As] and [Save As to PLC]. Described below is the difference between both.  

 

Fig. 32: Saving a new project (Save As) 

Mode Description 

Save As You may save the revised project content as another project 

name and then store it on the disk.  

Save As To 

PLC 

Same as [Download], you may download the project to PLC 

directly after setting up the [Online Parameter]. 

Table 13: Two modes of “Save As” 
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4-6 Project Content Import and Export 

The project content import and export function shall include [Comment], [Ladder Diagram], [Status Page], 

[Table] and [Motion]. Click [File] → [Export] or [Import] in function toolbar and the desired function will be 

displayed. Described below are relevant details: 

 

Fig. 33: Project Import 

1. Comment: 

⚫ Export: Click [File] → [Export] → [Comment] in function toolbar and the [Comment Export] window 

will appear. The exported file is presented in text file format and its sub-file title is coded as “txt.” 

 

Fig. 34: Comment Export 

⚫ Import: If the text file contains the export comment, click [File] → [Import] → [Comment] in function 

toolbar and the [Comment Import] window will appear. Select text file and then execute the 

importing procedure: 
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Fig. 35: Comment Import 

2. Ladder Diagram 

⚫ Export: If you need to copy Network N001 of Project-1 to Project-2, execute according to the 

following step. First, open Project-1 and then highlight Network N001, as per the figure below: 

 

Fig. 36: Highlighting N001 

Next, click [ File] → [Export] → [Ladder Diagram] in function toolbar and the [Save As] 

dialog box will be created. After inputting the file name, press [Save] to complete the exporting 

procedure.  

 

Fig. 37: Exporting Ladder Diagram 
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⚫ Import: Open the project. Move the cursor to the position where the network will be inserted and 

then click [File] → [Import] → [Ladder Diagram] in function toolbar: 

Select the file to be inserted and then press [Start] to complete the importing procedure.  

 

Fig. 38: Importing Ladder Diagram 

 

3. Status Page: 

⚫ Export: Click [File] → [Export] → [Status Page] in function toolbar and the [Status Page Export] 

window will appear. In [Status Page List], select “Status Page 1” and then press [Export] button for 

saving it as “spf” sub-file to complete the Status Page exporting procedure.  

 

Fig. 39: Status Page Export 
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⚫ Import: Click [File] → [Import] → [Status Page] in function toolbar and the [Status Page Import] 

window will appear. Select the file name of the Status Page that will be imported. Click [Status Page] 

in the list and then press [Import] button to complete the importing procedure. Open the [Status 

Monitor] window of this project and you will see the newly added Status Page. 

 

Fig. 40: Status Page Import 

 

4. Export Table 

⚫ Export: Click [File] → [Export] → [Table] in function toolbar and the [Table Export] window will appear. 

In [Table List], select the table that will be exported. Press [Export] button and then save it as “tab” 

sub-file to complete the table exporting procedure.  

 

Fig. 41: Table Export 
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⚫ Import: Click [File] → [Import] → [Table] in function toolbar and the [Table Import] window will 

appear. In [Table List], select the table that will be exported and then press [OK] button to complete 

the table importing procedure. 

 

Fig. 42: Table Import 

 

5. Motion 

⚫ Export: Click [File] → [Export] → [Motion] in function toolbar and the [Motion] window will appear. 

Press [Export] button and then save it as “.fmprj” sub-file to complete the Motion Control exporting 

procedure.  

 

Fig. 43: Exporting Motion  
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⚫ Import: Click [File] → [Import] → [Motion] in function toolbar and then select the file that will be 

imported to complete the Motion Control importing procedure. 

 

Fig. 44: Importing Motion 
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4-7 Open Old Projects 

Click the upper-left [File] → [Open] or click [Open] of the quick toolbar and you may open the 

edited project.  

By pointing the cursor at [Open] in [File], the system will display detailed items of the project that will be 

opened. The project opening can be achieved with any of the following three options: [Open], [Import 

WinProladder Project] or [Connect To PLC].  

 

With the [Import WinProladder Project], it allows the user to easily convert the project being edited in 

“WinProladder” to “UperLogic” project for use. By simplifying the complicated rewriting procedure, the 

efficiency of project conversion is therefore enhanced. Attention should be paid to confirming the project 

content after conversion, some register definitions and functions are not fully compatible. 

 

Provided below is the detailed description of the aforesaid three options. 

 

Fig. 45: Open Project 

Mode Description 

Open Project (Ctrl+O) Open the existing project. 

Import WinProladder 

Project 

Open the project (.pdw) being edited in 

WinProladder. After being converted, the user 

needs to confirm the content of the project; 

however, such function is not fully compatible.  



Chapter 4 Project Management 

3-17 

M-Series PLC Software Interface Manual 

Connect to PLC Same as the [Upload] function. After setting up the 

[Online Parameter], the user will be allowed to read 

the project from the PLC.  

Table 14: Three modes of Open Project 
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4-8 Project History 

Provides users with the functions of registering, replying, and deleting project revision records, and the 

project revision records will exist in the project file (*.pdwx). When PLC is in the state of “Offline 

Editing”, select the tab page [Project] → [Project Settings] → [Project History]. 

 

Fig. 46: Project History 

 

模式 說明 

Login After clicking [Login], the log-in window will display the history 

number, login time, program version and provide users with the option 

to edit the notes of the history. After confirming, the history will be 

registered, and the upper limit is 100. If the current project is an 

unsaved project, the user will be prompted to save the current project. 

Restore Select the project history you want to restore, click [Restore], and the 

project will be restored to the state of the history.  

Delete Select the project history to be deleted, and click [Delete] to delete the 

history. 
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4-9 Print 

The function of print includes [Print…], [Print RTF File], [Print Setup]. Click the upper-left [File] → 

[Print]. 

 

Fig. 47: Print 

 

Mode Description 

Print…. Set the format to be printed and the content to be printed 

Print RTF File The selected print file will be converted into RTF format 

Print Setup You can modify the related settings of the printer 

Table 14: The three modes of Print 

4-9-1 Print… 

After clicking [Print…] or press [Ctrl+P], the screen will be shown as below. Users can select the items 

which they want to print. And use [Move UP] or [Move Down] to change the display order. Users can also 

use the right-side function [Preview], [Page Setup], [Printer Setup] for setting. 
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Fig. 48: Print 

[Preview]: 

Users can preview the completed print through “Print Preview”. 

 

Fig. 49: Print Preview 
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[Page Setup]: 

Users can modify related settings such as paper size, orientation, and borders through [Page Setup]. 

 

Fig. 50: Page Setup 

[Printer Setup]: 

Same as 4-9-3 [Printer Setup]. Users can set the printer to be used and related settings here. 

 

Fig. 51: Printer Setup 
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4-9-2 Print RTF File 

Click [Print RTF File] to show a page almost same as [Print….]. Users can select the items which they want 

to print, and use [Move UP] or [Move Down] to change the display order. 

 

Fig. 52: Print RTF File 

4-9-3 Print Setup 

Users can set the printer to be used and related settings are shown below: 

 

Fig. 53: Print RTF File 
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5 
    System Parameters 

 I/O Configuration .............................................................................................. 3-24 

 Setting up the Number of Component Memory ................................................ 3-31 

 Setting up the Content of Read-only Register .................................................. 3-34 

 Server Configuration ......................................................................................... 3-45 

 Communication Configuration .......................................................................... 3-45 

 

 

 

 

 

 

 

 

    Danger 

7. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

8. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

9. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 

malfunction. 
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This section describes the system related parameters that will be required for setting up the content of 

I/O configuration, memory configuration and read-only Register.  

5-1 I/O Configuration 

I/O configuration provides configuration enablement and adjustment of high-speed counters, interrupts, 

outputs and inputs. Execute the function bar [Project] → [I/O Configuration], or click [Test Example] → 

[System Configuration] → [I/O Configuration] in the project management window: High-Speed Counter. 

 

Different modules have different numbers of high-speed counters, HSC0~3 provide 6 counting modes: 

1. Single-phase independent up-counting high-speed counter U 

2. Single-phase independent up-counting high-speed counter U*2 

3. Single-phase relative up/down high-speed counter P/R 

4. Bidirectional correlation high-speed counter A/B 

5. Bidirectional correlation high-speed counter A/B*2 

6. Bidirectional correlation high-speed counter A/B*4 

Some modules of HSC4~7 only provide A/B*4, and all modules provide software masking and clearing. 

 

Fig. 54: High-Speed Counter 

 

Item 說明 

HSC 

Configuration 

Up (UP)/Down (DN) 

Pulse/Direction 

A-Phase / B-Phase 

Sets the selection of the counting input of the high 

counter. 

Mask (MSK) Sets the selection for mask input. 
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When the input signal is 1, the counter will be blocked 

and will not count, and the internal state will remain 

unchanged. When the signal returns to 0, the counter 

will work properly. 

Clear (CLR) Sets the selection to clear the input. 

When the input signal is 1, the current count value 

temporary register inside the counter will be cleared to 

0 and cannot count. The counter will not start counting 

from 0 until the signal returns to 0. 

HSC Polarity Mask Signal Able to set the normal phase or negative phase of the 

mask input. 

Clear Signal Able to set the normal phase or negative phase of the 

clear input. 

Counter Signal The input signal can be set as normal counting or 

reverse counting. 

HSC Data Length Provides two modes “16-bit counter” and “32-bit 

counter” to choose from. 

For example: if the temporary register for HSC0 storing 

the count value is DR35280, if “32-bit counter” is 

selected, DR35280 will be used as the current count 

value register of the high-speed counter; if “16-bit 

counter” is selected, R35280 is still the current count 

value register of the high-speed counter. But R35281 

will be used by the system as a 16-bit loop counter. 

The inputs of the counting mode are interdependent. Except “U”, which only has a single input, they 

must be used in pairs. For example, when “X4” is selected in the “A-Phase” field, “B-Phase” will 

automatically use “X5”. The input selections of “Mask” and “Clear” also need to be paired, but you 

can choose to use only “Mask” or “Clear”. In order to achieve optimal benefits, the input points are 

configured as shown in the table below: 

 Input Point 

Up 

(UP) 

Pulse A-Phase Down 

(DN) 

Direction B-Phase Mask 

(MSK) 

Clear 

(CLR) 

HHSC0 X0 
NA 

X1 X2, X4, 

X6, X8, 

X3, X5, 

X7, X9, HHSC1 X2 X3 
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HHSC2 X4 X5 X10, 

X12, 

X14 

X11, 

X13, 

X15 

HHSC3 X6 X7 

HHSC4 X8 X9 

HHSC5 X10 X11 

HHSC6 X12 X13 

HHSC7 X14 X15 

Table 15 Configuration of input points 

5-1-2 Interrupt Signal Configuration 

The interrupt means that the PLC will send an interrupt request to the CPU immediately when the 

demand for immediate response occurs during the normal sequential execution of the scan cycle. After 

the CPU receives the interrupt request, it immediately stops the scanning work being executed, and 

executes the “interrupt service routine” first. After the task is completed, return to the unfinished 

scanning task. This page is used to set the use and trigger conditions of the input interrupt. 

 

Fig. 55: Interrupt setting 
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Item Description 

Usage Set to enable or disable the interrupt function. 

Edge Trigger Set trigger conditions. 

[Positive Edge] Input from 0 to 1 

[Negative Edge] Input from 1 to 0 

[Positive and negative edges] trigger when input changes 

 

5-1-3 Output Signal Configuration 

It is used to set the pulse form of output signal, output polarity and output power-off hold and other 

configurations. 

 

Fig. 56 Output Setting 
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Item Description 

High-Speed Pulse 

Output 

Set the output mode of high-speed pulse output. Divided into 

four modes 

1. Pulse (PLS) / Direction (DIR) 

2. Up (UP) / Down (DN) 

3. A-Phase / B-Phase 

4. Single Point Pulse. 

Output Polarity Select normal output or reversed output. 

Output Latched When checked, it means that when the power is turned on 

again, the output will keep the original output value. 

 

If not using the HSPSO function, the Y0–Y15 external output points of M-PLC will be corresponding to the 

status of Y0–Y15 output relays in the PLC. If the HSPSO is implemented, then the system will switch the 

Y0–Y15 external output points directly to the HSPSO output circuit in ASIC; therefore, it is irrelevant to Y0–

Y15 relays in PLC.  

 

Listed below are the signal details and the optional output modes of the output points at the respective 

axis of M-PLC. The “high-speed pulse output” can be set according to the method indicated in the 

table below: 

 

Axis No. External 

Output Point 

Output Mode 

PLS/DIR UP/DN A/B-Phase Single Point PLS 

PSO 0 Y0 

Y1 

Y0= PLS 

Y1= DIR 

Y0= UP 

Y1= DN 

Y0=A 

Y1=B 

Y0= PLS 

PSO 1 Y2 

Y3 

Y2= PLS 

Y3= DIR 

Y2= UP 

Y3= DN 

Y2=A 

Y3=B 

Y2= PLS 

PSO 2 Y4 

Y5 

Y4= PLS 

Y5= DIR 

Y4= UP 

Y5= DN 

Y4=A 

Y5=B 

Y4= PLS 

 

PSO 3 Y6 

Y7 

Y6= PLS 

Y7= DIR 

Y6= UP 

Y7= DN 

Y6=A 

Y7=B 

Y6= PLS 

PSO 4 Y8 

Y9 

Y8= PLS 

Y9= DIR 

Y8= UP 

Y9= DN 

Y8=A 

Y9=B 

Y8= PLS 

PSO 5 Y10 

Y11 

Y10= PLS 

Y11= DIR 

Y10= UP 

Y11= DN 

Y10=A 

Y11=B 

Y10= PLS 
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Axis No. External 

Output Point 

Output Mode 

PLS/DIR UP/DN A/B-Phase Single Point PLS 

PSO 6 Y12 

Y13 

Y12= PLS 

Y13= DIR 

Y12= UP 

Y13= DN 

Y12=A 

Y13=B 

Y12= PLS 

PSO 7 Y14 

Y15 

Y14= PLS 

Y15= DIR 

Y14= UP 

Y15= DN 

Y14=A 

Y15=B 

Y14= PLS 

Table 16: Output mode setting table 

 

5-1-4 Input Signal Configuration 

For many high-speed applications, in addition to using the interrupt input method to prevent signal 

omission, the input points included in the host can also be set as capture inputs to capture their fleeting 

signals. This page is used to set its captured input configuration. 

 

Fig. 57: Input Setting 
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Item Description 

Input Filter Value The filter settings are divided into 4 groups (X0~X3), 

(X4~X7), (X8~X11), (X12~X15), and the filter conditions can 

be set to time or frequency: 7 options such as 28KHz to 

1.8MHz can be set when the frequency is used as the 

condition; 3 to 15 milliseconds can be set when the time is 

used as the condition. 

Forced Operation 

Input Point 

Set the point of forced operation input point. 

Captured Input 

Point 

Check to set it as the input point to be captured. 
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5-2 Setting up the Number of Component Memory 

When M-PLC leaves the factory, proper arrangements have been made in advance for the allocation of 

retentive and non-retentive coils or registers, timers, counters, and read-only registers. In most 

applications, the factory settings do not need to be changed, but in order to adapt to various special or 

complex applications, in addition to the factory settings, UperLogic also provides the function so that 

users can set them according to their needs. 

Click [Project] →  [Memory Allocation] in function toolbar or double clicking → [System 

Configuration] → [Memory Allocation] in the project window and then the memory allocation setting 

window will appear: 

 

Fig. 58: Memory Allocation window 

When restarting following the outage or switch PLC from STOP to RUN, the non-retentive relay or the 

Register will be cleared as “0”, but the retentive relay will maintain its original (before outage or under 

STOP status) status. Described below are relevant details: 

Item Description 

Retentive Internal 

Relay 

[Total] Displays the total number that can be set as retentive type 

[Quantity] The quantity to be set as retentive type 

[Range] Displays the range after setting 

Retentive Step 

Relay 

[Total] Displays the total number that can be set as retentive type 

[Quantity] The quantity to be set as retentive type 
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[Range] Displays the range after setting 

Time Base of 

Timer 

The timer is divided into four time bases of 1 ms, 10 ms, 100 ms and 

1 s, and the four time bases share the total number. 

[Total] Displays the total number of timer 

[Quantity] The quantity to be set for each time base 

[Range] Displays the range of each time base setting 

Retentive 16-bit 

Counter 

[Total] Displays the total number that can be set as retentive type 

[Quantity] The quantity to be set as retentive type 

[Range] Displays the range after setting 

Retentive 32-bit 

Counter 

[Total] Displays the total number that can be set as retentive type 

[Quantity] The quantity to be set as retentive type 

[Range] Displays the range after setting 

Retentive Data 

Register 

[Total] Displays the total number that can be set as retentive type 

[Quantity] The quantity to be set as retentive type 

[Range] Displays the range after setting 

Read-Only 

Register 

[Total] Displays the total number that can be set as read-only register 

[Quantity] The quantity to be set as read-only register 

[Range] Displays the range after setting 

Retentive Input 

Register 

Set all output registers as retentive type or non-retentive type 

Default Value Restore to factory settings 

 

After the setting of the memory allocation window is completed, the system will display the [Discrete & 

Register Allocation] window to provide the user with an overview of the complete allocation status, as 

shown in the figure below: 
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Fig. 59: Discrete and register allocation window 
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5-3 Setting up the Content of Read-Only Register 

The configurable range of read-only registers is R43224~R47319 (4096 in total), and the range not 

planned as read-only registers can be used as general registers, which are retentive types. The content set 

as read-only registers will be stored in the project, so when the project is downloaded to the PLC, if there 

are read-only registers specified in the project, these read-only registers will be used when the PLC starts 

content as the initial value. 

Click [Project] →  [ROR Register] in function toolbar or double clicking [Test Example] → [System 

Configuration] → [ROR Register] in the project window. If the ROR range is not set, the following window 

will appear first to prompt the setting. When the setting is confirmed, it will automatically jump to the 

memory allocatoin window in Section 5.2 to provide the user with the set amount. 

 

 

Fig. 60: Setting up read-only Register 

The ROR window provides users with setting ROR data, comments and instructions, and can synchronize 

the Register value and ROR value. 
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Fig. 61: Read-only Register 

Item Description 

Export/Import Notes and description of export/import 

Restore Old Value Restore the data to the one just entered the ROR window 

Register→ROR Synchronize general register value to read-only register 

ROR →Register Synchronize read-only register value to general register 
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5-4 Servo Configuration 

Provides users with the settings related to the server on the PLC. 

Click [Project] → [Servo Configuration]. 

 

 

Fig. 62: Server Configuration 

 

Users can apply the communication settings to configure NTP, SMTP, IoT and MQTT. 

5-4-1 Network Time Protocols (NTP) 

Provides users to set NTP parameters on PLC. 

Click [Project] → [Servo Configuration] → [NTP]. 
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Fig 63: Setting NTP 

5-4-2 IoT 

Provides users with setting the IoT parameters on the PLC. When monitoring or editing online, the HWID 

of the PLC can be viewed and copied. 

Click [Project] → [Servo Configuration] → [IoT] 

 

Fig. 64: Setting IoT 
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5-4-3 MQTT 

MQTT is a communication protocol designed for IoT, characterized by simplicity and lightness. It is 

suitable for applications in environments with limited hardware resources and network bandwidth, and 

can meet the needs of remote monitoring and data exchange. 

The mechanism of message transmission is publish/subscribe model, and each message must be 

identified by a topic name. The client is the publisher and the subscriber, the Publisher publishes a 

message with a topic, and the Subscriber subscribes to a topic; the server side is a Broker, which is 

responsible for receiving the publisher’s message and forwarding it to Subscribers for the 

corresponding topic. 

 

Provides users with setting the MQTT parameters on the PLC 

Click [Project] → [Servo Configuration] → [MQTT] 

 

Fig. 65: Setting MQTT 
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Page Property Description 

MQTT Server 

Configuration 

Enable/Disable 

This is the main switch of the MQTT function. Only after 

enabling it can you set the detailed fields, as well as 

related topic publishing and topic subscription. 

Host 

(IP or URL) 

Set the Broker host address, you can fill in the IP or URL. 

Port No. Set the connecting port of Broker. The default is 1883. 

Client ID Client-specific identification code 

Authentication 

Enable/Disable Enable/Disable authentication 

User Name Input Broker-specified user name. 

Password 
Input the password specified by the Broker, and it will be 

kept secret in cipher text after entering. 

TLS/SSL 

Configuration 

Enable/Disable Enable/Disable TLS/SSL 

Identification Mode One-way and two-way identification are optional. 

Select Server 

Certificate 

Use server authentication. Import the required 

documents. 

Select Client 

Certificate 

Use client authentication. Import the required 

documents. 

Select Private Key Use client authentication. Import the required private key. 

Connection 

Setting 

Reconnection 

Interval (seconds) 

The interval between reconnections if the MQTT 

connection is disconnected, in seconds. 
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Topic Publishing 

 

 

You can click [New] above to add a new theme, click the [Delete] button to delete the selected theme, 

click [Edit] or double-click the item in the theme list to edit the selected theme. If there is an existing 

theme in the theme list project, you can click [Export] to export all theme data into a CSV file in a specific 

format, and click [Import] to import a CSV file in a specific format to directly update the theme table. 
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Page Property Description 

Basic 

Name 
Set the name of the topic, which can be used as a 

description 

Topic 
The topic used by MQTT to send messages. 

(Note: #, + are wild characters and cannot be used) 

Sending Mode 

Cyclic: Send messages periodically, and you can set the 

interval in seconds. 

Value change trigger: A message will be sent only when 

the value of the data item changes. 

Keeping Message 

Determines whether MQTT messages should be kept on 

the server. If checked, the server will save the subject 

message. Afterwards, if there are new subscribers, or 
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previously disconnected subscribers reconnect, they will 

receive the latest reserved message. 

QoS 

Set the Quality of Service of MQTT, which is divided into 

three levels: 

Grade Description 

0: The message is sent only once, delivery is not 

guaranteed, and will not be repeated. 

1: The message delivered at least once, guaranteed 

delivery, may be repeated. 

2: The message is delivered exactly once, and it is 

guaranteed to be delivered and will not be repeated. 

Data Format Raw Data 

Data Item 

Setting 

Number of Data Item Sets the number of data items for this topic. 

Name 

The name of the data item cannot be blank, and each item 

name must be unique, and the item name can be entered 

directly. 

Data Type 

There are [bit], [16-bit BCD number], [16-bit integer], [16-

bit positive integer], [32-bit BCD number], [32-bit integer], 

[32-bit positive integer], [32-bit floating point] and [Ascii] 

can be selected. 

URL 
According to the data type, the user can set the address of 

each data item. 

Length Users can determine the address length of this data item. 

 

  



Chapter 5 System Parameters 

3-43 

M-Series PLC Software Interface User Manual 

Topic Subscription 
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Page Property Description 

Basic 

Name 
Set the name of the topic, which can be used as a 

description 

Topic 
The topic used by MQTT to send messages. 

(Note: #, + are wild characters and cannot be used) 

QoS 

Set the Quality of Service of MQTT, which is divided into 

three levels: 

Grade Description 

0: The message is sent only once, delivery is not 

guaranteed, and will not be repeated. 

1: The message delivered at least once, guaranteed 

delivery, may be repeated. 

2: The message is delivered exactly once, and it is 

guaranteed to be delivered and will not be repeated. 

Data Format Raw Data or JSON 

Data Item 

Setting 

Number of Data 

Item 
Sets the number of data items for this topic. 

Name 

The name of the data item cannot be blank, and each item 

name must be unique, and the item name can be entered 

directly. 

Data Type 

There are [bit], [16-bit BCD number], [16-bit integer], [16-

bit positive integer], [32-bit BCD number], [32-bit integer], 

[32-bit positive integer], [32-bit floating point] and [Ascii] 

can be selected. 

URL 
According to the data type, the user can set the address of 

each data item. 

Length Users can determine the address length of this data item. 
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5-5 Communication Configuration 

It allows the user to configure the corresponding relationship between Register address and Modbud 

address in PLC. 

Click [Project] → [Communication Configuration] 

 

 

Fig. 66: Communication Configuration 

Users can use communication settings to configure Ethernet, serial port and Modbus addresses. 

5-5-1 Ethernet Port 

The parameter allowing users to set up the network port on PLC. 

Click [Project] → [Communication Configuration] → [Ethernet Port Setting] 

 

Fig. 67: Setting network station number 
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Page Property Description 

General 

Enable DHCP Enable/disable dynamic host setting protocol 

IP address Setting network address 

Subnet mask Setting subnet mask 

Preset gate Setting preset gate 

Regular server Setting regular DNS server 

Other Setting other DNS server 

Service 

Main connection port 
Setting regular network connection port for FATEK 

communication protocol 

Other connection port 
Setting fixed network connection port for FATEK 

communication protocol 

Main connection port 
Setting regular network connection port for Modbus 

communication protocol 

Other connection port 
Setting fixed network connection port for Modbus 

communication protocol 

Table 17: Setting Network Station Number Table 

 Serial Port 

Provides users with setting the parameters of the serial port on the PLC. 

Click [Project] → [Communication Configuration] → [Serial Port]  
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Fig. 68: Setting serial port parameter 

頁面 屬性 敘述 

Port1 

Port2 

Basic Settings_Baud Rate Setting Baud Rate 

Basic Settings _ Check bit Setting Check bit 

Basic Settings _Data bit Setting Data bit 

Basic Settings _Stop bit Setting Stop bit 

Basic Settings _ Response 

Delay Time (ms) 
Setting Response Delay Time 

Basic Settings _Sending 

Delay Time (ms) 
Setting Sending Delay Time 

Basic Settings _ Response 

error time out (ms) 
Setting Response error time out 

Advanced Settings _Check 

Station No. 
Whether to check the station number 

Advanced Settings_ 

Communication Protocol 
Setting Communication Protocol 

Station No. Station No. Setting Scope: 0-254 

Table 18: Serial port parameter setting 
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5-5-3 Modbus Device Allocation 

It allows the user to configure the corresponding relationship between Register address and Modbud 

address in PLC.  

Click [Project] → [Communication Configuration] → [Modbus Device Allocation] 

 

Fig. 69: Modbus address preset configuration 

The preset configuration enables all of the Register addresses on PLC to communicate with the Modbus 

address. If the user wishes to reduce the number of Register used for communicating with Modbus 

address or to change the corresponding address, then the user may edit its own configuration type.  

 

Fig. 70: Displaying setting error 
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If the address created by the user is incorrect, then the system will indicate the incorrect portion in red 

letter and will also display the error message.  

Type  Description 

Item Explain the type of the contact that will be listed in this column. 

Home address Create the home address that will correspond to the contact or 

the Register (preset as zero). 

Modbus home 

address 

Create the Modbus home address that will correspond to the 

contact or the Register. 

Sum Create the Modbus sum (preset as maximum value) that will 

correspond to the contact or the Register. 

Servicing status Under normal condition, it displays the Modbus address status 

that will correspond to the contact or the Register. If the setting 

is wrong, then it will display the corresponding error. 

Error message Description 

Is such scope overlapped? Modbus address is overlapping. 

Such scope cannot be 

used! 

The contact or the Register 

address is wrongly created or 

exceeds the scope. 

Such scope cannot be 

used and is overlapped! 

Modbus address is overlapped. 

In the meantime, the contact or 

the Register address is wrongly 

created or exceeds the scope. 

 

 

Table 19: Items required for Modbus address configuration 
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    Danger 

1. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

2. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

3. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 

malfunction. 
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This section describes the program creating procedure that will be required for editing the Ladder 

Diagram. 

6-1 Main Program and Sub-Program Unit Management 

The editing window is divided into Master Program Field and Sub-program Field. It presents orderly 

organized program architecture for users to carry out the editing and the checking more easily. Both units 

are operated in the same way. Described below is the operation procedure of each program unit: 

6-1-1 Creating new program unit 

During the planning, the programs can be categorized for editing in order to present orderly organized 

program architecture. With such kind of program unit adding function, a well-defined architecture will be 

presented when planning the program.  

You may click [Project] → [Ladder Diagram] → [Main Program] → [Right mouse button] → [Main Program 

Add] in project management toolbar, or you may select [Main Program Add] from the scroll-down menu 

in function toolbar icon.  

 

Fig. 71: Add Main Program Unit 
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6-1-2 Deleting program unit 

If the created program unit is no longer required, you may delete it with the program unit deleting 

function. In this case, you may move the cursor to the unit tag and then click the right mouse button → 

[Delete] and then such program unit will be deleted. 

 

Fig. 72: Deleting program unit 

6-1-3 Program unit relocating sequence 

You may click [Project] → [Ladder Diagram] → [Main Program] → [Right mouse button] → [Relocate Main 

Program] in project management toolbar, or you may select [Relocate Main Program] from the scroll-

down menu in the toolbar icon. 

 

Fig. 73: Relocating Master Program Unit 
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Fig. 74: Relocating Master Program Unit_2 

Press [OK], and you may change the array of the program unit in the project window.  

The [Relocate Main Program] of Sub-program can be adjusted in the same way as the Main Program. In 

this case, simply select the function from the Sub-program. 

 

6-1-4 Changing program unit name 

After creating the program unit name, you may change the program unit name. Click [Test Example]→ 

[Ladder Diagram] → [Main Program] → [Main Section] in project management window and then press 

the right mouse button → [Rename]: 

 

Fig. 75: Changing program unit name 



Chapter 6 Creating Program 

4-5 

M-Series PLC Software Interface User Manual 

6-1-5 Inputting program unit comment 

If several program units are to be processed, it will be required to create a comment for the respective 

program unit for the convenience of checking and changing later on.  

 

Inputting comment operation method in dedicated Comment Field 

Click [Project] → [Comment] → “Program section” → “Double-click left mouse button” in function 

toolbar, or you may click toolbar icon and then the [Program Unit Comment] input field will appear. 

 

Fig. 76: Program unit comment 

Input the comment text. Press [OK] and the comment will be displayed at the topmost side of such 

Ladder Diagram.  

 

Fig. 77: Displaying comment at topmost side of Ladder Diagram 
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Operation method for inputting comment by selecting Single Program Unit 

In the Ladder Diagram program field, click the right mouse button and the function menu will appear for 

selecting the desired [Network Comment] function: 

 

Fig. 78: Adding unit network comment 

You may click [Project] → [Comment] → [Network Comment] in function toolbar and the program 

comment input field representing the respective unit will appear.  

 

Fig. 79: Network Comment 
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Press [OK] to complete the inputting of network comment. 

 

Fig. 80: Inputting network comment  

Press [OK] and the comment will be displayed at upper side of the program.  

 

Fig. 81: Displaying comment at upper side of the program 
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6-2 Ladder Diagram (LD) 

The most essential part of such application program is the compilation of the Ladder Diagram related 

program. For this purpose, it also provides the well-organized window in order to display relevant 

messages. Described below is its operation method: 

 

6-2-1 Display elements  

Window operation 

It provides a number of window-based ladder program pictures for showing the programs being created 

for different sections at the same time for users to execute the compare, copy and edit functions. 

 

1. Creating multi-ladder window 

Each project comprises Master Program Section and Sub-program Section in which, each section will be 

allowed for adding the desired program tab, as per the figure below. By clicking “Switch page” in the 

“Tab,” it allows the user to switch between the program section of each page.  

 

Fig. 82: Creating multi-ladder window 
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2. Arraying of ladder window 

⚫ Arraying of cascade display:  

Click [Window] → [Cascade] 

 

Fig. 83: Cascade window 

 

⚫ Arraying of tile horizontal display: 

Click [Window] → [Tile Horizontal] 

 

Fig. 84: Tile Horizontal display 
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6-2-2 Component operation 

Click [Designer] → [Ladder Diagram] in function toolbar, and the component items from A Contact to 

vertical line will be displayed. Indicated in the figure below is the arraying method of the respective 

contact component in the company panel, as below:  

 

Fig. 85: Ladder Diagram component operation  

Select the contact component that will be imported. Drag such component to Ladder Diagram program 

section and it will be displayed. Described below is the operation procedure: 

 

Input contact component 

Click [Designer] → [Component Panel] → [A Contact]  in function toolbar. 

You may also move the cursor to the Ladder Diagram program section and then click the right mouse 

button and the Pop-up Menu will appear as the figure below. After that, select [Contact] → [A Contact]: 



Chapter 6 Creating Program 

4-11 

M-Series PLC Software Interface User Manual 

 

Fig. 86: Inputting contact component 

 

Click the desired input position in the Ladder Diagram program section, and the [Element Edit] box will 

appear:  

 

 

Fig. 87: Inputting component number 
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After inputting “X0”, press “ENTER” key and the picture will be displayed as below:  

 

Fig. 88: Complete component inputting 

 

Next, move the cursor to the input position in the Ladder Diagram program field. After that, click the left 

mouse button once and then input “AX0” or “X0A” with keyboard and the figure above will appear.  

 

In the meantime, press “Shift” + “A” keys to show the webpage where A Contact component will be 

displayed in program section only without inputting the component number, as per the figure below:  

 

Fig. 89: Page without inputting component number 

Changing the type or the number of contact component  

To change the type of the contact component being entered, select the contact type to be changed; for 

example, select B Contact from the component panel, and then click the left button on the contact 

component to be modified in the ladder diagram program section, and the input number box of the B 

contact element will appear. 
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To change the component number, move the cursor to the component to be changed in the program 

section and then enter the new number or press “SPACE” key to show the edit window. After that, input 

the new number as per the figure below.  

 

Fig. 90: Component number changing method 

You may also key the number in the “Element Edit” box at B Contact, such as “X1”. After that, the 

“X0” of the original A Contact will be revised as “X1” of B Contact.  

 

Fig. 91: Component number changing result 

Deleting contact component 

In component panel, you may select deletion icon  or move the cursor to the Ladder Diagram 

program section. Next press the right mouse button to display the Pop-up Menu where you will be 

allowed to select the [Delete] function. At this time, the cursor serves as the deleting function; or you may 
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click [X1] of B Contact component and then press “Delete” key on the keyboard and “X1” will be 

deleted.

 

Fig. 92: Selecting the component to be deleted 

Press “Delete” key on the keyboard, it will be deleted directly. 

 

Fig. 93: Deleting component by clicking Delete 
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6-2-3 Operating by instructions 

The UperLogic also provides convenient function instruction set. You may select the required instruction 

by clicking [Check] → [ToolBox] → [Set/Reset] → [Timer/Counter] → [Function Instruction] in function 

toolbar and drag the module to the configuration position by clicking the left mouse button. In the 

meantime, you may also click the component panel icon which can be used as the 

function instruction option. 

 

Fig. 94: Dragging Function instruction 

After releasing the left mouse button, the function instruction will appear. After inputting the parameter 

setting, press [OK] to complete the configuration. 

 

Fig. 95: Completing component dragging 

 

 

 

 

 



Chapter 6 Creating Program 

4-16 

M-Series PLC Software Interface User Manual 

Input Function instruction  

If users want to use different function instructions, for example, when setting a fixed time timer, it is 

necessary to control the timing start, when the timing ends, and how much value the timing accumulates, 

etc., the operation steps can refer to the following instructions: 

To set up a fixed-time Timer between X1 contact and Y0 output, you may input the Function instruction to 

carry out the setting: 

 

Fig. 96: Setting by inputting Function instruction 

You may click [Designer] → [Ladder Diagram] → select timer function icon from component panel in 

function toolbar. At this time, the cursor is serving as the Timer. In the Ladder Diagram program section, 

click the space between X1 and Y0 and the “Timer” Function instruction setting dialog box will appear.  

 

In the Ladder Diagram program section, you may also click the space between X1 and Y0 and then press 

“Shift” + “T” quick keys and the “Timer” Function instruction setting dialog box will appear: 

 

Fig. 97: “Timer” Function instruction setting dialog box 
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Key “T10” in “T” column and key “1000” in “PV” section to complete the fixed-time setting for 

the Timer: 

 

Fig. 98: Completing the fixed-time setting for Timer 

Deleting functional component 

You can select the delete icon in the component panel, or click the right button in the ladder diagram 

program section to display the Pop-up menu to select the [Delete] function, and the cursor represents the 

delete function; or directly click the function component, and then press the keyboard “Delete” key, 

you can also delete it directly  

 

6-2-4 Network operation 

In the Ladder Diagram program section, the network is an essential element that is designed with a 

variety of operation methods. Described below is the network operation method in the program section. 

Copying single network 

Point the cursor at the network to be copied. For example, network “N009” per the figure below: 

 

Fig. 99: Replicating single network 

Press the right mouse button to show the Pop-up Menu and then select [Copy] or press “Ctrl” + “C” 

quick key and then execute the copy instruction. Next, press the right mouse button to show the menu 

for selecting [Paste]; or press “Ctrl” + “V” quick key to execute the paste command. In this way, it 

allows the user to complete the single network copying: 

 

Fig. 100: Complete the copying of single network 
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Copying multiple networks 

To copy the connected networks coded in N001 to N003, the user may use the mouse to scroll the 

selected N001 to N003 or press “Shift” key and then click Network N001 to N003, as per the figure below: 

 

Fig. 101: Copying multiple networks 

Execute the copying and pasting actions to complete the copying of networks that are connected with 

each other. To copy the non-connected networks such as N001, N003 and N005, highlights Network 

N001 with mouse, press “Ctrl” simultaneously and then highlights N003 and N005 to achieve the 

following result:  

 

Fig. 102: Completing the copying of multiple networks 

Execute the copying and pasting steps to complete the non-connected network copying.  

 

Copying the network between different projects 

First, open the UperLogic application program and then open Project-1 file. Likewise, open the UperLogic 

application program again and then open Project-2 file. In this way, you will be allowed to open two units 

of UperLogic application program windows. In Project-1, highlight Network N001 and press the right 

mouse button to show the Pop-up Menu and then select [Copy] or press “Ctrl” + “C” quick keys to 

copy the desired network. Next, move the cursor to the pasting position in Project-2 and then press the 

right mouse button to show Pop-up Menu. Next, select [Paste] or press “Ctrl” + “V” quick key to 

paste the network. In this way, it allows the user to complete the copying of network between different 

projects.  
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Deleting network 

Highlight the Network Number to be deleted and then click [Designer] → [Delete] in function toolbar, or 

press “Delete” quick key and it will be deleted directly.  

 

Editing network lines and rows 

In the Ladder Diagram, the program section is composed of multiple Network Numbers. Through the 

lines and rows of the Network Number, an orderly configured program is presented that will be easier for 

maintenance. Further, other functions are also designed for the network lines and rows to achieve more 

convenient and quicker program compilation. Described below is the operation method of these 

functions: 

 

Expand network to 22 lines 

If multiple contacts are created that will be insufficient for the original 11 lines in the network, it can be 

expanded to 22 lines. By doing so, move the cursor to the network where 11 lines will be expanded to 22 

lines and then click [Designer] → [Network] → [Expand to 22 lines] in function toolbar; or you may press 

the right mouse button to show Pop-up Menu and then click [Edit Network line/row] → [Expand to 22 

lines].  

 

Fig. 103: Before expanding to 22 lines

 

Fig. 104: After expanding to 22 lines 
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Compressing network to 11 lines 

Move the cursor to the network where 22 lines will be compressed to 11 lines and then click [Designer] → 

[Network] → [Compress to 11 lines] in function toolbar; or you may press the right mouse button to show 

Pop-up Menu and then click [Edit Network line/row] → [Compress to 11 lines]. 

 

Vertical expanding 

To expand the vertical distance between the upper and lower lines of X1 and X3, execute per the figure 

below:  

 

 

Fig. 105: Expanding vertical distance 

Click X3 with cursor:  

Click [Designer] → [Expand Network] → [Vertical Expand]; or press the right mouse button to show Pop-

up Menu and then click [Edit Network line/row] → [Vertical Expand] to complete the vertical expanding. 

 

Vertical compressing 

To compress the vertical distance between the upper and lower lines of X1 and X3, execute per the figure 

below: 

 

Fig. 106: Compressing vertical distance 

Then the cursor clicks the blank row to be compressed between X1 and X3: 

 

Fig. 107: Clicking the empty rows to be compressed 
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Click [Designer] → [Expand Network] → [Vertical Compress]; or press the right mouse button to show 

Pop-up Menu and then click [Edit Network line/row] → [Vertical Compress] to complete the vertical 

compressing. 

 

Horizontal expanding 

To expand the distance between X0 and X3: 

 

 

 

 

 

Fig. 108: Expanding horizontal distance 

Click [Edit] → [Expand Network] → [Horizontal Expand] in function toolbar; or press the right mouse 

button to show Pop-up Menu and then click [Edit Network line/row] → [Horizontal Expand] to complete 

the horizontal expanding. 

 

Horizontal compressing 

To compress the distance between X0 and X3:   

 

 

 

 

 

Fig. 109: Compressing horizontal distance 

Click [Edit] → [Expand Network] → [Horizontal Compress] in function toolbar; or press the right mouse 

button to show Pop-up Menu and then click [Edit Network line/row] → [Horizontal Compress] to 

complete the horizontal compressing. 
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Inserting empty network 

To insert an empty network in the upper side of Network N012, execute the following procedure: 

In the Ladder Diagram program section, move the cursor to any component contact of N012 and then 

press the right mouse button to show Pop-up Menu. Next, click [Insert Empty Network] → [Upper Insert]; 

or you may press the right mouse button of Network N012 to show Pop-up Menu and then click [Insert 

Empty Network] → [Upper Insert]; or click [Designer → [Insert Network] → [Upper Insert]; or press 

“Shift” + “Insert” quick keys and then Network N012 will become an empty network. In the 

meantime, the content of original Network N012 will change to Network N013. 

 

 

 

 

 

Fig. 110: Inserting empty network 

Searching network 

To search Network N001 of the intended program unit, click [Designer] → [Go To]; or press “Ctrl” + 

“G” quick keys to show the following window: 

 

Fig. 111: Searching network 
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Taking the searching of Network N005 in [Main_unit1] for example:  

In [Program Unit List], highlights [Main_Unit-1] and then enter “5” in [Network Number] column to 

represent N005. Next, press [OK] button and the cursor will move to the Network Number position to be 

searched.  

 

Fig. 112: Moving to the Network Number position to be searched 

6-2-5 Editing comment 

To input the network comment for Network N012, move the cursor to N12 or any component and then 

press the right mouse button to show Pop-up Menu. Next, click [Network Comment] and the network 

comment input section will appear:  

 

Fig. 113: Network comment input section 

Input “N012 Network Comment.” Press [OK] button and you will see that the keyed comment is 

displayed in the previous line of the existing Network N012: 
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Fig. 114: Displaying comment in previous line of Network Number 

In the meantime, you may double click [Project] → [Comment] → [Network Comment]; or in project 

window, double clicking → [Comment Description] → [Network Comment] to show all of the Network 

Numbers. Find out N012 by scrolling down the menu and then double clicking on the empty comment 

section and the network comment input empty section will appear:  

 

Fig. 115: Adding network comment 

Input “N012 Network Comment” and then press [OK] button to complete the network comment 

inputting. 
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6-3 Structured Text (ST) 

In addition to the most basic editing of ladder diagram programs, UperLogic also provides a structured 

document programming language (Structured Text), whose syntax is similar to Pascal. Through this 

syntax, it is convenient to perform complex logic and calculations that are more difficult to edit than 

ladder diagrams. Commonly used programs and circuits can also be edited through Function Block (FB) is 

created for repeated use. Its operation method is introduced as follows: 

 

6-3-1 Display Composition 

Window Operation 

Provides a multi-window ladder program page, which can display programs in different sections at the 

same time for comparison, copying and editing.

 

Fig. 116: List of programs in use 
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6-3-2 Commands Operation 

[Commands] on the left side of the ST window will provide users with corresponding commands, which 

are divided into three categories: Script, Toolbox and FCM: 

 

Fig. 117: ST commands operation 

 

Double-click the command you want to use or enter it directly on the screen to use it. The following is the 

operation instruction: 
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Script： 

Users can write programs through the instructions here. For example, after double-clicking the IF, the 

screen will display the corresponding specifications, and use ( ) to prompt the user to fill in the 

information here. If the user already understands, you can also directly enter the corresponding 

command. 

 

Fig. 118: Syntax hints comments 

ToolBox： 

Users can edit the project through the written program, and the function here will be similar to the Ladder 

command. The method of use is the same as that of ToolBox. For example, after double-clicking Timer, 

the corresponding specification will be displayed on the screen, and ( ) will be used to prompt the user to 

fill in the information here. If the user already understands it, he can also directly enter the corresponding 

command. 
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Fig. 119: Function hint comments 

FB： 

Users can use the function blocks written in the function block program to edit the project. 

 

Fig. 120: Using Function Block 

For the interface operation of the function block, please refer to Chapter 6-7.
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6-4 Step Ladder Instruction Description 

6-4-1 Instruction-based operation 

The main purpose is to achieve higher program readability, easier maintainability and updating, as well as 

more reliable software quality. Aiming at the sequential control of mechanical action process, the 

software is designed for combining the widely accepted Ladder Diagram language under the support of 

step-based execution command. To operate, click [Designer] → [Ladder Diagram] → [Function Lookup] or 

press “F” quick key; or in Ladder Diagram program field, press the right mouse button to show Pop-up 

Menu and then click [Function Lookup] → [Function Lookup]. In the Ladder Diagram program section, 

click the position where step instruction will be conveyed and all types of function instructions will appear. 

Under type item, select [SFC instruction] and the right-side Function Name will show the following four 

step instructions, i.e., “STP,” “FROM,” “TO” and “STPEND,” as per the figure below: 

 

 

Fig. 121: SFC instructions 

 

For its operation instructions, please refer to Chapter 8 of the M-PLC instruction application manual:
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6-5 Syntax Check 

After inputting the ladder program, the system will be allowed for executing the syntax check to help you 

find out program errors. To execute, click [PLC] → [Syntax check] in function toolbar to show the error 

statistic list resulting from the syntax check: 

 

 

Fig. 122: Syntax check 

 

The system will list all errors under the program section. In the error section, double clicking any item in 

error section and the program section will show the error component block, as per the figure below:  

 

 

Fig. 123: Error displaying resulting from syntax check 
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6-6 Interrupt Program 

UperLogic classifies related interrupt programs and motion control subroutines here, which is convenient 

for users to use and design. For example, to add an interrupt program, you only need to add and select 

the interrupt type, instead of defining the interrupt program through the command Label 65 and the end 

of RTI like Winproladder. In addition to the ladder LD language, programmers can also write special 

program logic through ST. Each special type of program is unique and cannot be repeated. 

 

6-6-1 Types of Interrupt Program 

No. Interrupt 

Source 

Priority Interrupt 

Label 

Condition Note 

17 Hardware 

Time Tick 

3 STM0I Interval from 

1ms~9ms 

Tick unit 1ms 

18 3 STM1I Interval from 

1ms~9ms 

 

19 3 STM2I Interval from 

1ms~9ms 

 

20 3 STM3I Interval from 

1ms~9ms 

 

21 3 LTM0I Interval from 

10ms~60000ms 

Tick unit 10ms 

22 3 LTM1I Interval from 

10ms~60000ms 

 

23 3 LTM2I Interval from 

10ms~60000ms 

 

24 3 LTM3I Interval from 

10ms~60000ms 

 

33 HSC 2 HSC0I Interval from HSC0 to 

(CV=PV) 
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34 2 HSC1I Interval from HSC1 to 

(CV=PV) 

 

35 2 HSC2I Interval from HSC2 to 

(CV=PV) 

 

36 2 HSC3I Interval from HSC3 to 

(CV=PV) 

 

37 2 HSC4I Interval from HSC4 to 

(CV=PV) 

 

38 2 HSC5I Interval from HSC5 to 

(CV=PV) 

 

39 2 HSC6I Interval from HSC6 to 

(CV=PV) 

 

40 2 HSC7I Interval from HSC7 to 

(CV=PV) 

 

25 HST 1 HST0I Interval from HST0 to 

(CV=PV) 

Tick uint 100us 

26 1 HST1I Interval from HST1 to 

(CV=PV) 

 

27 1 HST2I Interval from HST2 to 

(CV=PV) 

 

28 1 HST3I Interval from HST3 to 

(CV=PV) 

 

29 

 

HST4I Interval from HST4 to 

(CV=PV) 

Not supported yet 

30 

 

HST5I Interval from HST5 to 

(CV=PV) 

Not supported yet 

31 

 

HST6I Interval from HST6 to 

(CV=PV) 

Not supported yet 
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32 

 

HST7I Interval from HST7 to 

(CV=PV) 

Not supported yet 

1 Build-in 

Digital 

Inputs 

2 X0+I 

(INT0+) 

X0 positive edge 

trigger 

The software high speed 

counter HSC4~HSC7 can be 

assigned as the trigger source 

of any interrupt X0~X15. 

Therefore, the 

interrupt priority of the 

software high speed 

counter depends on 

the priority of X0~X15. 

2 2 X0−I 

(INT0-) 

X0 negative edge 

trigger 

3 2 X1+I 

(INT1+) 

X1 positive edge 

trigger 

4 2 X1−I 

(INT1-) 

X1 negative edge 

trigger 

5 2 X2+I 

(INT2+) 

X2 positive edge 

trigger 

6 2 X2−I 

(INT2-) 

X2 negative edge 

trigger 

7 2 X3+I 

(INT3+) 

X3 positive edge 

trigger 

8 2 X3−I 

(INT3-) 

X3 negative edge 

trigger 

9 2 X4+I 

(INT4+) 

X4 positive edge 

trigger 

10 2 X4−I 

(INT4-) 

X4 negative edge 

trigger 

11 2 X5+I 

(INT5+) 

X5 positive edge 

trigger 

12 2 X5−I 

(INT5-) 

X5 negative edge 

trigger 

13 2 X6+I 

(INT6+) 

X6 positive edge 

trigger 



Chapter 6 Creating Program 

4-34 

M-Series PLC Software Interface User Manual 

14 2 X6−I 

(INT6-) 

X6 negative edge 

trigger 

15 2 X7+I 

(INT7+) 

X7 positive edge 

trigger 

16 2 X7−I 

(INT7-) 

X7 negative edge 

trigger 

41 External 

Module 

Event 

 

COCPUI Event from Co-

processor (e.g., 

EtherCAT motion 

controller) 

 

42 

 

LHMI Event form left-side 

high-speed module 

 

43 

 

RHM0I Event form Right-side 

high-speed module 1 

 

44 

 

RHM1I Event form Right-side 

high-speed module 2 

 

45 

 

RHM2I Event form Right-side 

high-speed module 3 

 

46 

 

RHM3I Event form Right-side 

high-speed module 4 

 

47 

 

RHM4I Event form Right-side 

high-speed module 5 

 

48 

 

RHM5I Event form Right-side 

high-speed module 6 
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Fig. 124: Select interrupt program type 

6-6-2 Types of motion program 

No. Motion 

Source 

Priority Motion 

Label 

Condition Note 

49 Motion 

Control 

1 MSR Synchronous Motion 

Parameter Program 

 

 

 

Fig. 125: Select motion program type 

MSR can be regarded as the continuous PLC program flow after the action of the continuation of the 

motion process. It is used as the planning of synchronous motion parameters to avoid the running time 

difference between the PLC program and the motion process. Designers can synchronize motion 

parameters in the MSR program to output to PLC registers or output Y contacts in real time, ensuring that 

the output of motion control will not be affected by the existing PLC program logic. For more details, 

please refer to the chapter on motion control. 
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6-6-3 Add special program 

Click [Project] → [Program Unit] → [Special Program] → [Add Special Program] with the mouse; or 

right-click [Add Special Program] in the project management window [Special Program] to create a new 

special program: 

 

Fig. 126: Add special program unit 

Program Unit Name: 

Will be automatically generated by the system, and will have the same name as the interrupt or motion 

control type. 

 

Language: 

Users can choose whether this special program unit is edited using ladder diagram or ST programming 

language. 

 

Interrupt Type: 

Usera can choose the type of the interrupt program, and each interrupt type can only create one program 

unit, which cannot be created repeatedly. 
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6-6-4 Adjust Interrupt Program 

Click [Project] → [Program Unit] → [Interrupt Program] → [Adjust Interrupt Program]; or right-click 

[Adjust Interrupt Program] in the project management window [Interrupt Program] to adjust the interrupt 

program order of sorting: 

 

Fig. 127: Adjusting Interrupt Program 

6-6-5 Call Interrupt Program 

The calling of the interrupt is not by using software instructions, but by sending an interrupt signal to the 

CPU through the hardware circuit, and the CPU recognizes the name of the interrupt and automatically 

jumps into the interrupt subroutine and marks it with the interrupt name.  
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6-7 Function Module Program 

FCM can package highly repetitive or special application program flow, which can be easily called 

repeatedly during program editing, significantly simplifying and speeding up PLC programming, and 

helping to avoid errors and repetitive editing and debugging. Furthermore, a library of functions 

commonly used by programmers is established to facilitate future reuse in different projects. 

6-7-1 Add Function Module Program 

Click [Project] → [Program Unit] → [Function Module Program] → [Add FCM Program] with the 

mouse; or right-click [Add FCM Program] in the project management window [Function Module 

Program], you can add new function module program: 

 

Fig. 128: Add Function Module Program 

Program Unit Name: 

Users can define the name of the desired program unit at the time of creation, and this name will be used 

when calling this function block program when other program units are programmed. 

 

Language: 

Users can choose whether to use the ladder diagram or ST programming language to edit the interrupt 

program unit. 
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Function Module Description: 

Users can define the required program unit descriptions by themselves. 

 

Input Numbers: 

Users can set the quantity to be input, the minimum is 1 and the maximum is 8. The first group of input 

names is fixed as EN, and the remaining 7 groups of input names can be edited by the user. 

 

Fig. 129: FCM input variables 

 

Output Numbers: 

Usera can set the quantity to be output, the minimum is 0 and the maximum is 8. Users can edit the name 

of the output by themselves. 

 

 Fig. 130: FCM output variables  
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Parameter Numbers: 

The user can set the number of parameters required by the function module, the minimum is 0, and the 

maximum is 12. Users can define the mode, name and data type of parameters by themselves, which will 

be explained one by one below: 

 

Fig. 131: INOUT parameters of function block 

⚫ Mode  

Users can choose the mode of this parameter as input (IN), output (OUT), or output-input (INOUT). 

When IN is selected, the value of the parameter before entering FCM will be inherited, and the 

change in FCM will be ignored after the function block is terminated.  

When selecting OUT, the value of the parameter before entering the FCM will be ignored, and if the 

value is changed, it will be output to the designated register. 

When INOUT is selected, it will have both the characteristics of IN and OUT, inherit the value of the 

parameter before entering FCM, and retain the changes in FCM. 

⚫ Name 

Users can define the name of the parameter by themselves. 

⚫ Data Type 

Users can select the data type of the parameter as 16Bit-Int, 16Bit-UInt, 32Bit-Int, 32Bit-UInt or Float. 

 

Fig. 132: Data type 

⚫ Return Value 

After checking, the return value and the specified register will be output. It is mainly used in ST 

language. 
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6-7-2 Adjust Function Module Program 

Click the function bar [Project] → [Program Unit] → [FCM Program] → [Adjust FCM Program] with the 

mouse; or right click [Adjust FCM Program] in the project management window [FCM Program] to adjust 

the FCM program order of sorting: 

 

Fig. 133: Adjusting FCM Program 
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    Danger 

1. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

2. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

3. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 

malfunction. 
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This section describes how to set up the reports, link parameters and command tables. Through the user-

friendly interface, it minimizes the complicated procedure when operated by the user. Provided below is 

the operation method of the respective table.  

7-1 Table Management 

7-1-1 Adding New Table 

To add a table, please select [Table Edit] → [OOOO Table] → [New OOOO Table] in the project window, 

or select [Project] → [Table Edit] → [New OOOO Table], as shown below: 

 

Fig. 134: Adiing a new table 

After clicking [New OOOO Table], the table editing window will pop up allowing users to create table 

properties. 
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Item Description 

Type The subcategory of the table, which varies from data table to data table. 

Name The name of the table 

Start Address The starting address to use for this table, which can be entered as a 

register or a label. 

Length The length used by the table data; the unit is a word group. 

Table Capacity Choose whether you want to dynamically adjust the table capacity or a 

fixed capacity limit: 

⚫ Dynamic Allocation: Edit length changes with form content 

⚫ Fixed length: Edit length must not exceed configured length 

Load Table From PLC To load corresponding link tables from PLC. 

Load Table From ROR To load corresponding link tables from ROR. 

Description Provides users the description of editing tables 

 

7-1-2 Table Edit 

After adding a table, you will enter the table data window. In addition, you can enter the table editing 

window from [Table Edit] → [OOOO Table] → [Name] in the project window, or click [Project] → [Table 

Edit] → [OOOO Table] → [Name]. 

Users can edit the command details for this form in this window. 
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Function Description 

Toolbar Section Calculator Calling the easy-to-use calculator installed in the 

Windows.  

Setting Calling the table edit window. It allows the user to 

rename the table or change the home address of 

such table.  

Monitor The execution status of form commands can be 

monitored. The monitoring content depends on 

different form types, and the content will be 

described in detail in subsequent chapters. 

This function is only supported online and can be 

used by calling the Zooming function on the ladder 

diagram. 

Table Data Section Table data editing section, the content depends on 

different form types, and will be described in detail 

in subsequent chapters. 

Status Section Allow The display table property is set to dynamic 

allocation or fixed length, and the maximum length 

is marked; the unit is a word group. 

Used Displays the length of the table command currently 

used, and the unit is a word group. 

Position Displays the address range currently used by table 

commands. 

 

7-1-3 Rename 

To change the name of the table, please select the table [Name] to be modified in [Table Edit] → [OOOO 

Table] in the project window, select [Rename] from the right-click menu or use the shortcut key “F2” to 

edit the name. In addition, you can directly enter the form editing window and change the name through 

editing properties. 

7-1-4 Delete Table 

To delete a table, please select [Table Edit] → [OOOO Table] in the project window, and select [Delete 

OOOO Table] from the right-click menu, or [Project] → [Table Edit] → [Delete OOOO Table] in the 

execution function bar, as shown in the figure below: 
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After the delete table window appears, select the table you want to delete and confirm. You can delete 

multiple selections. 

 

 

7-1-5 Table Configuration Adjustment 

Uperlogic provides a table overview function, which can be used to determine whether the addresses 

used in the tables overlap to avoid misuse during program execution. To use this function, please select 

[Table Configuration Adjustment] from the right-click menu in [Table Edit] in the project window, or 

[Project] → [Table Edit] → [Table Setting Adjustment] in the execution function bar. 



Chapter 7 Creating Tables 

5-47 

M-Series PLC Software Interface User Manual 

 

 

Item Description 

Table Display the basic properties of all tables of the current project. 

If the start address is marked with [OOO], it means that the address 

uses a label as the start address. 

Configuration Enter the table editing window to modify the properties of the table. 

Edit Enter the table data window to modify the table data. 

Delete Delete the selected table. 

Write to PLC Write the current project table data to PLC. 

Table Comparison Compare the data in the current project table with the data in the PLC 

register. 

Message Shows whether the addresses currently used between tables have 

overlapping ranges. 
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7-2 Link Table 

The main purpose of the link table is to facilitate users to fill in the data content of the communication 

command FUN151 CLINK. The [General Online Table] category corresponds to MD0. For other 

descriptions of corresponding commands, please refer to the advanced manual. 

7-2-1 Table Value 

The table data section of [General Online Table] is as shown in the figure below. Users can edit individual 

commands of [General Online Table] through simple operations, and the content corresponds to the 

command Start Register (SR) on FUN151. 

 

The operation description is shown as below: 

Item Description 

Operation 

New After clicking, a row of commands will be added in the 

editing section for users to edit. 

Delete After clicking, delete the command currently selected by 

the user, and multiple selections can be deleted. 

Move Up After clicking, move the command currently selected by 

the user up one column. 

Move Down After clicking, move the command currently selected by 

the user down one column. 

Right-

Click 

Menu 

Cut After clicking, cut the command currently selected by the 

user, and multiple selections can be cut. 

Copy After clicking, copy the command currently selected by the 

user, multiple selections can be copied。 
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Paste After clicking, paste the command previously copied or cut 

by the user. 

Insert After clicking, insert a row of commands at the selected 

position in the editor for users to edit. 

Delete After clicking, delete the command currently selected by 

the user, and multiple selections can be deleted. 

Move Up After clicking, move the command currently selected by 

the user up one column. 

Move Down After clicking, move the command currently selected by 

the user down one column. 

 

The command data content is shown as below: 

Item Description 

Data 

No. Display the command information of the Nth. 

Command Edit this command action as [Read] or [Write] 

Slave Edit the station number of the slave station to communicate. 

Master Data Edit the data starting address of the Master station. 

Slave Data Edit the data starting address of the Slave station. 

Data Size The data size of such command 

Operation Display this command as [Bit Operation] or [Word Group Operation] 

 

7-2-2 Table Monitoring 

The monitoring of [General Online Table] is as shown in the figure below. Users need to be online and call 

the Zooming function on FUN151 to use it. The content corresponds to the command operation start 

register (WR) on FUN151. 
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Item Description 

Result Code Shows the operating result. 

00H: Normal 

Other values: Error 

Operation No. Indicates that the Nth transaction is in operation. 

Station No. Indicates the station number of the slave station currently in 

communication. 

Command 

Code 

40H: Read slave PLC system status. 

44H: Read the status of multiple consecutive single points of the slave PLC. 

45H: Write the state of multiple consecutive single points of the slave PLC. 

46H: Read the status of multiple consecutive registers of the slave PLC. 

47H: Write the status of multiple registers in the slave PLC. 
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7-3 Servo Parameter Table 

The main purpose of the servo parameter table is to facilitate the user to fill in the data content of the 

positioning program parameter setting command FUN141 MPARA. For the description of the 

corresponding command, please refer to the advanced manual. 

7-3-1 Table Value 

The table data section of [Servo Parameter Table] is as shown in the figure below, users can edit individual 

parameters of [Servo Parameter Table] through simple operations, and the content corresponds to the 

command start register (SR) on FUN141. 

 

Fig. 135: Editing Servo Parameter Table 

Parameter Item Description 

0 Unit Setting The unit used for the travel and speed settings used 

in the program. 

When the setting value is 0, the unit is mm, Deg, Inch, 

which is called the mechanical unit. 

When the setting value is 1, the unit is Pulse, which is 

called the motor unit. 

When the setting value is 2, the setting value is in 

mm, Deg, Inch, and the speed setting is in Pulse, 

which is called compound unit. 

1 Ps/Rev The number of pulses (A) required for one revolution 

of the motor. 

The range is 1～65535 Ps/Rev (when it is above 

32767, set it with decimal positive number) 

When parameter 14 = 0, take parameter 1 as Ps/Rev. 
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When parameter 14 ≠ 0, take parameter 14 as 

Ps/Rev. 

2 μM/Rev The distance (B) driven by the motor for one 

revolution. 

The range is 1～999999 μM/Rev (mDeg/Rev, 0.1 

mInch/Rev). 

3 Min. Setting Unit Setting 

Value 

Mechanical/Compound 

Unit 

Motor 

Unit 

 mm Deg Inch Ps 

0 x1 x1 x0.1 x1000 

1 x0.1 x0.1 x0.01 x100 

2 x0.01 x0.01 x0.001 x10 

3 x0.001 x0.001 x0.0001 x1 
 

4 Max. Speed Setting Motor and compound unit: 1-921600 Ps/Sec 

Mechanical unit: 1-153000 (cm/Min, x10 Deg/Min, 

Inch/Min), 

but the maximum frequency can not be greater than 

921600 Ps/Sec. 

5 Start/Stop Speed Motor and compound unit: 1-921600 Ps/Sec。  

Mechanical unit: 1-15300 (cm/Min, ×10 Deg/Min, 

Inch/Min), but the maximum frequency can not be 

greater than 921600 Ps/Sec。 

6 Return-to-origin 

Deceleration Speed 

Motor and compound unit: 1-65535 Ps/Sec  

Mechanical unit: 1-15300 (Cm/Min, x10 Deg/Min, 

Inch/Min) 

7 Gear Backlash Correction 

Value 

Setting scope: 0-32767 Ps 

When walking in reverse, the walking distance will 

automatically add this value。 

8 Acceleration and 

Deceleration Time Setting 

Setting scope: 0-30000 ms。 

The time represents the one required to accelerate 

from rest to maximum speed (parameter 4), or 

decelerate from maximum speed to rest. When 

parameter 12=0, this parameter is used as the 

deceleration time. 
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9-0 Direction of Operation When the setting value=0, forward pulse output, the 

current Ps value will increase; the reverse pulse 

output, and the current Ps value will decrease. 

When the set value=1, the forward pulse output and 

the current Ps value will decrease; the reverse pulse 

output and current Ps value will increase. 

9-1 Return-to-origin 

Direction 

When the set value=0, the return-to-origin direction 

is the current Ps value plus the upward direction (the 

origin is on the right). 

When the setting value=1, the return-to-origin 

direction is the current Ps value minus downward 

direction (the origin is on the left). 

10 Forward Revolution 

Movement Correction 

Value 

When outputting forward revolution pulse, this value 

will be automatically added as the moving distance; 

the range is −32768 - 32767 Ps. 

11 Compensation Value of 

Reverse Movement Value 

When switching to pulse wave output, this value will 

be automatically added as the moving distance; the 

range is −32768 - 32767 Ps. 

12 Deceleration Time Setting The range is 0-30000 ms. 

When parameter 12=0, parameter 8 is used as the 

deceleration time. 

When parameter 12≠0, parameter 12 is used as the 

deceleration time. 

13 Interpolation 

Acceleration/Deceleration 

Time Setting 

It is used to set the time required to accelerate from 

stillness (speed = 0) to the working frequency during 

linear interpolation motion; this time is also used for 

deceleration and stop control; the range is 0-30000 

ms. 

14 Ps/Rev The range is 0 to 1999999. 

y as parameter 14 = 0, take parameter 1 as Ps/Rev. 

y as parameter 14 ≠ 0, take parameter 14 as Ps/Rev. 

15-0 Proximity DOG Input 

Contact Setting 

Can set [Normally Open], [Normally Closed] or [Not 

Used] input contact; contact number is X0-X15. 
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15-1 Stroke Limit Input Contact 

Setting 

Can set [Normally Open], [Normally Closed] or [Not 

Used] input contact; contact number is X0-X125. 

15-2 Zero-Point Signal PG0 

Input Contact Setting 

You can set [Upper Edge Count], [Lower Edge Count] 

or [Not Used] input contact; the contact number is 

X0-X15. 

15-3 Zero-Clear Signal CLR 

Output Contact Setting 

You can set [Use] or [Not Used] output contact; the 

contact number is Y0-Y23. 

16 Mechanic Original-Point 

Position Value 

The range is -999999-999999 Ps. 

17 Zero-Point Signal 

Numbers 

The range is 0-255 Count. 

 

7-3-2 Table Monitoring 

No monitoring function is provided to [Servo Parameter Table].
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7-4 Servo Program Table 

The main purpose of [Servo Program Table] is to facilitate the user to fill in the data content of the single-

axis high-speed pulse output command FUN140 HSPSO. For the description of the corresponding 

command, please refer to the advanced manual. 

7-4-1 Table Value 

The table data section of [Servo Program Table] is as shown in the figure below, users can edit individual 

commands of [Servo Program Table] through simple operations, and the content corresponds to the 

command start register (SR) on the FUN140. 

 

Fig. 136: Setting Servo Program Table 

The operation description is shown as below: 

Item Description 

Operation 

New After clicking, a row of commands will be added in the 

editing section for users to edit. 

Delete After clicking, delete the command currently selected by 

the user, and multiple selections can be deleted. 

Move Up After clicking, move the command currently selected by 

the user up one column. 

Move Down After clicking, move the command currently selected by 

the user down one column. 

Right-

Click 

Menu 

Cut After clicking, cut the command currently selected by the 

user, and multiple selections can be cut. 

Copy After clicking, copy the command currently selected by the 

user, multiple selections can be copied。 
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Paste After clicking, paste the command previously copied or cut 

by the user. 

Insert After clicking, insert a row of commands at the selected 

position in the editor for users to edit. 

Delete After clicking, delete the command currently selected by 

the user, and multiple selections can be deleted. 

Move Up After clicking, move the command currently selected by 

the user up one column. 

Move Down After clicking, move the command currently selected by 

the user down one column. 

 

 

Command data description is shown as below: 

Item Description 

Command 

Speed SPD 

The frequency or speed of the pulse output can be 

directly input to a constant or register (R/D). 

When FUN141 parameter 0=0, it is the speed; 

When FUN141 parameter 0=1 or 2, it is the frequency. 

Operation DRV 

Pulse Output amount. 

When FUN141 parameter 0=1, the unit is Ps; 

When FUN141 parameter 0=0 or 2, the unit is mm, Deg, 

Inch. 

There are four instruction operands: 

⚫ Select ADR or ABS for positioning coordinates: 

A. ADR, relative value coordinate positioning. 

B. ABS, absolute value coordinate positioning. 

⚫ Select '+' or '−' for the operating direction: 

A. ' + ', forward revolution or count up. 

B. ' − ', reverse or count down. 
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⚫ The stroke setting value (pulse output value) can be 

directly input to a constant or a temporary register 

(R/D). 

⚫ Stroke setting value resolution Ut or Ps: 

A. For Ut, the resolution is determined by FUN141 

parameter 0, 3. 

B. For Ps, the mandatory resolution is one Ps.  

DRVC The usage is the same as DRV command. 

DRVZ 

As a convenient command for return-to-origin, three 

different methods of return-to-origin, MD0-MD2, are 

provided in total. 

Wait 

WAIT 

TIME 

WAIT TIME (unit is 0.01 second) when the pulse output is 

completed. When the time is up, the number of steps 

indicated by GOTO will be executed; constants or 

registers (R/D) can be input directly. 

WAIT 

WAIT for input contact signal when pulse output is 

completed. When the input contact signal is ON, execute 

the steps indicated by GOTO. 

ACT 

After the action time described by the pulse output ACT, 

immediately execute the number of steps indicated by 

GOTO; the action time (unit: 0.01 second) can be directly 

input into a constant or register (R/D). 

EXT 

External trigger command, when the pulse is being 

output (the number of pulse waves has not been sent), if 

the external trigger signal is activated (ON), it will 

immediately execute the steps indicated by GOTO. 

Go To 
GOTO 

When the condition of WAIT/ACT/EXT instruction is met, 

use GOTO instruction to describe the number of steps to 

be executed. 

• NEXT: To execute the next step. 

• A constant: The number of steps to execute. 

• Register (R/D): The number of steps to be 

executed is stored in the temporary register. 

MEND Positioning program finished. 
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7-4-2 Table Monitoring 

The monitoring of [Servo Program Table] is shown in the figure below. Users need to be online and call 

the Zooming function on FUN140 to use it. The content corresponds to the command operation start 

register (WR) on FUN140. 

 

 

Item Description 

Currently 

Working/Stopping 

Steps 

If the command is being executed, the content value is the number of 

steps being executed (1~N); 

If the instruction is not being executed, the content value represents the 

number of steps currently stopped. 

Total Steps Steps in total 

Working Flag Corresponds to flag of WR+1 

B8 =ON, suspend output. 

B9 =ON, wait for transition condition. 

B10=ON, continuous operation (total output stroke is set to 0). 

B12=ON, pulse output (output indication “ACT”). 

B13=ON, command execution error (output indication “ERR”). 
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B14=ON, one-step positioning is completed (output indication “DN”). 

Error Code Error Codes of PSO 0-4 
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7-5 General Purpose Link Table 

The main purpose of the [General Purpose Link Table] is to facilitate the user to fill in the data content of 

the communication command FUN151 CLINK, which corresponds to MD1/MD2. For the description of 

the corresponding command, please refer to the advanced manual. 

7-5-1 Table Value 

The table data section of [General Purpose Link Table] is as shown in the figure below. Users can edit 

individual commands of [General Purpose Link Table] through simple operations, and the content 

corresponds to the command start register (SR) on FUN151. 

 

The data content description is shown as below: 

Item Description 

Parameter Communication Mode 

[Only sending/receiving messages] 

When MD1 is only sending out messages, the other 

party does not respond; when MD2 is only receiving 

messages, there is no response. 

[Receive message after sending or Send message 

after accepting] 

MD1 is sending out a message, and then waiting to 

receive a response message from the other party; 
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MD2 is receiving a message, and then sending out a 

response message. 

Receive even if a 

communication error 

occurs 

When checked, the receiving action will be 

performed whether there is a communication error 

or not. 

The register uses only one 

bit of data 

When checked, one data occupies one register; 

otherwise, two data temporarily occupy one 

register. 

Start Code Start code describing the message. 

Finish Code Finish code describing the message. 

Command 

Edit the content of the sent or received message. 

The editing content can use decimal, hexadecimal 

and character strings, and the data must be 

separated by commas or blanks. 

Preview Preview the message content to be sent or received. 

 

7-5-2 Table Monitoring 

The monitoring of [General Purpose Link Table] is as shown in the figure below. Users need to be online 

and call the Zooming function on FUN151 to use it. The content corresponds to the command operation 

start register (WR) on FUN151. 
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Item Description 

Result Code Shows the operating result. 

00H: Normal 

Other values: Error 



Chapter 7 Creating Tables 

5-63 

M-Series PLC Software Interface User Manual 

7-6 Register Table 

The register table function is mainly to provide users with fast batch writing of register values. Users can 

pre-plan the register table in the project, write in batches during the download process, or directly write 

in the new register table through online editing. 

7-6-1 Table Value 

The table data section of [Register Table] is as shown in the figure below, users can edit individual 

commands of [Register Table] through simple operations, and plan the register values in advance. 

 

Fig. 137: Setting Register Table 

The operation description is shown as below: 

Item Description 

Operation 

New After clicking, a row of commands will be added in the 

editing section for users to edit. 

Delete After clicking, delete the command currently selected by 

the user, and multiple selections can be deleted. 

Move Up After clicking, move the command currently selected by 

the user up one column. 

Move Down After clicking, move the command currently selected by 

the user down one column. 

Right-

Click 

Menu 

Cut After clicking, cut the command currently selected by the 

user, and multiple selections can be cut. 

Copy After clicking, copy the command currently selected by the 

user, multiple selections can be copied。 

Paste After clicking, paste the command previously copied or cut 

by the user. 
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Insert After clicking, insert a row of commands at the selected 

position in the editor for users to edit. 

Delete After clicking, delete the command currently selected by 

the user, and multiple selections can be deleted. 

Move Up After clicking, move the command currently selected by 

the user up one column. 

Move Down After clicking, move the command currently selected by 

the user down one column. 

 

The command data description is shown as below: 

Item Description 

Command 

No. 

The address of the register to be written in batches. 

Counting from the start address of the table, the No. will be 

automatically adjusted as the data type is word group or double 

word-group. 

Data Type Divided into word group (16Bits) and double word-group (32Bits). 

Data 

The data to be written into the register can be filled in decimal, 

hexadecimal or string. 

In decimal, just fill in the decimal number, EX: 1234. 

For hexadecimal, fill in the hexadecimal number, and fill in 'H' at 

the last character. EX: 1234H. 

String, just fill in ASCII characters in the quotation marks, EX: 'By'. 

Description Optionally fill in a description for the command. 

 

7-6-2 Table Monitoring 

No monitoring function is provided to [Register Table].
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7-7 Modbus Master Table 

The main purpose of the [Modbus Master Table] is to facilitate the user to fill in the data content of the 

communication command FUN150 M-BUS. For the description of the corresponding command, please 

refer to the advanced manual. 

7-7-1 Table Value 

The table data section of [Modbus Master Table] is as shown in the figure below, users can edit individual 

commands of [Modbus Master Table] through simple operations, and the content corresponds to the 

command start register (SR) on the FUN150. 

 

Fig. 138: Setting Modbus Master Table 

The operation description is shown as below: 

Item Description 

Operation 

New After clicking, a row of commands will be added in the 

editing section for users to edit. 

Delete After clicking, delete the command currently selected by 

the user, and multiple selections can be deleted. 

Move Up After clicking, move the command currently selected by 

the user up one column. 

Move Down After clicking, move the command currently selected by 

the user down one column. 

Cut After clicking, cut the command currently selected by the 

user, and multiple selections can be cut. 
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Right-

Click 

Menu 

Copy After clicking, copy the command currently selected by the 

user, multiple selections can be copied。 

Paste After clicking, paste the command previously copied or cut 

by the user. 

Insert After clicking, insert a row of commands at the selected 

position in the editor for users to edit. 

Delete After clicking, delete the command currently selected by 

the user, and multiple selections can be deleted. 

Move Up After clicking, move the command currently selected by 

the user up one column. 

Move Down After clicking, move the command currently selected by 

the user down one column. 

 

The command data content is shown as below: 

Item Description 

Data 

No. Display the command information of the Nth. 

Command Edit this command action as [Read] or [Write] 

Slave Edit the station number of the slave station to communicate. 

Master Data Edit the data starting address of the Master station. 

Slave Data Edit the data starting address of the Slave station. 

Data Size The data size of such command 

Operation Display this command as [Bit Operation] or [Word Group Operation] 

7-7-2 Table Monitoring 

The monitoring of [Modbus Master Table] is as shown in the figure below. Users need to be online and 

call the Zooming function on FUN150 to use it. The content corresponds to the command operation start 

register (WR) on FUN150. 
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Item Description 

Result 

Code 

Shows the operating result. 

00H: Normal 

Other values: Error 

Operation 

No. 

Indicates that the Nth transaction is in operation. 

Station No. Indicates the station number of the slave station currently in communication. 

Command 

Code 

01H: Read the status of multiple consecutive single points 0xxxxx of the slave station. 

02H: Read the status of multiple consecutive single points 1xxxxx of the slave station. 

03H: Read the status of multiple consecutive registers 4xxxxx of the slave station. 

04H: Read the status of multiple consecutive registers 3xxxxx of the slave station. 

05H: Write a single-point 0xxxxx status to the slave. 

06H: Write single register 4xxxxx data to the slave station. 

0FH: Write consecutive multiple single points 0xxxxx status to the slave station 

10H: Write consecutive multiple registers 4xxxxx data 
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    Danger 

1. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

2. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

3. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 

malfunction. 
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This section describes the procedure where the comment function is used to improve the program 

readability and to facilitate maintenance in the future. Such descriptive comment is also available for 

components, network or program unit. In the meantime, this section also explains the function designed 

for hiding or displaying the comment.  

8-1 Program Unit Comment 

When running several program units, the user will be required to set up the comment for the respective 

program unit in order that the checking and modification will be executed more easily in the future. 

   

Input descriptive comment for program unit: For detailed operation method, please refer to the 

description provided in Section 6.1.5: “Input Program Unit Comment.” 

 

Modify descriptive comment for program unit: After being imported, the user will be allowed to change 

the program according to the imported comment or to show the modification field by double clicking the 

comment text field in the Ladder Diagram program field. In this way, the user will be allowed to change 

the comment text.  

 

 

Fig. 139: Program unit comment 
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8-2 Network Comment 

Each program unit comprises several network comments and each of them is designed with the intended 

function. By using such function with the comment, it will be easier for program modification and 

maintenance in the future.  

8-2-1 Operation method for inputting comment in dedicated comment field 

Click [Project] → [Comment] → [Network Comment] in function toolbar, or double clicking [Comment] → 

[Network Comment] in project management window and the [Network Comment] input window will be 

displayed:  

 

Fig. 140: Network Comment 

The comment input method shall be the same as the operation instructions provided in Section 6.1.5: 

“Input Program Unit Comment”. After being imported, press [OK] to complete the comment setting for 

the network comment. 

 

Fig. 141: Inputting network comment 

8-2-2 Operation method for inputting comment by selecting Single Solution Network 

In Ladder Diagram program section, you may click Network N000 or its component and then press the 

right mouse button to show Pop-up Menu in order to select the [Network Comment]. By clicking the right 

mouse button to show the function menu, it allows the user to select [Network Comment] function. At 

this time, the system will show the network comment input section that represents “Network N000.” 
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Fig. 142: Editing network comment  

Press [OK] to complete the editing of comment for network comment.  

 

Modifying network descriptive comment 

For detailed operation method, please refer to Section 10.1: Section 6.1.5: “Input Program Unit 

Comment.” 

Deleting network descriptive comment  

For detailed operation method, please refer to Section 10.1: Section 6.1.5: “Input Program Unit 

Comment.” 
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8-3 Element Comment 

The program unit is composed of several network comments where each component is also serving as a 

single network comment. Under such structure, lots of components exist in each Single Program Unit that 

it would be required to provide comment description for each component. 

8-3-1 Setting Introduction 

Click [Project] → [Comment] → [Element Comment] in function toolbar; or double clicking [Comment] → 

[Element Comment] in project management window and the [Element Comment] input sectoin will be 

displayed: 

 

Fig. 143: Element comment 

Element Comment_Import: 

First select the file that will be imported. Next, select the column item to be imported and then press [OK]. 

 

Fig. 144: Element comment_import 
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Element Comment_Export:  

First select the file that will be exported. Next, select the column item to be exported and then press [OK]. 

 

Fig. 145: Element comment_export 

Element Comment_Clear All: 

Delete all of the comment and description currently created.  

 

Element Comment_Element Name: 

Executing the GoTo function for entering the selected Register number address automatically.  

 

Component Comment_Set: 

 

 

Fig. 146: Element comment_setting 
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Type Function Description 

Saving 

position 

PLC Save the comment in the PLC and the occupied resources will be 

displayed at the lower-left corner of “Component comment” window. 

Project Save the comment in the Project and will not occupy the PLC resources.  

Scope All Change all components to the selected saving position.  

No. Select the component number. 

Start address Select the starting address of the component comment. 

End address Select the ending address of the component comment. 

Table 18: Introduction of items in equipment window 

8-3-2 Operation method 

 

Fig. 147: Element comment window 

With [Set] or “Shift+Space” quick keys, you may switch the component comment saving position. The 

red circle at the lower-right side of the component means that the component has been saved in the 

project instead of downloading to the PLC.  

 

The field display at lower-left side represents the quantity (U) currently used and the remaining quantity 

(F). 
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8-4 Controlling of Comment Display 

In Ladder Diagram, the program field is used for displaying program unit comment, network comment 

and component comment, etc. Described below is the operating method designed for displaying or 

hiding the aforesaid comments: 

 

Fig. 148: Comment display 

 

Click [View] → [Program Unit Comment] in function toolbar. If the ““ symbol is not marked on the left 

side of text option, then the comment text will not be displayed at the upper side of the program field in 

Ladder Diagram. After completing such action, the ““ symbol will appear on the left side of text 

option.  

Such procedure also applies to Element Comment, Network Comment and Register Value. 
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8-5 Tag 

Tags are variables that are specified as arbitrary strings for input, output, and internal data. Tags can be 

designed to express the logic of the program more clearly through string descriptions. Programs using 

tags can also easily modify the variable configuration without modifying them one by one. 

There are three types of UperLogic tags: global tags, regional tags, and system tags. 

Item Description 

Global Tag A tag that can be used by all programs and settings in the 

project, and can be created by oneself. 

Regional Tag The tags used in each program can only be used in such 

program and can be created by oneself. 

System Tag The default label of M-PLC cannot be created by oneself. 

 

8-5-1 Tag Editor 

Global tags and regional tags can be edited and exported through the following tag editor. The following 

describes each function.。 

 

1. Filter Out 

According to the category selected by the user to be filtered out and the input content, the tags 

that will be kept on the screen are determined. Filterable categories include Name, Type, Address, 

Length, Comments, and None. 
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Fig. 149: Filtering out tags 

2. Display Diagnosis 

When the user checks [Display Diagnosis] on the right, a column will be added in front of the tag 

name, and the diagnosis result will be represented by an icon. When the icon is double-clicked, 

the details of the diagnosis window will be displayed. 

 

Fig. 150: Display diagnostic result 

 

Item Description 

 Jump to the previous diagnostic result. 

 Jump to the next diagnostic result. 

 Indicates that the tag address overlaps with other labels. 

After double-clicking the prompt, the details will be displayed. When 

the user double-clicks the overlapping item, it will directly jump to the 

tag editing page where the item is located. This function can remind 

the designer to avoid reusing the same register location, which may 

lead to program logic malfunction。 
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 Indicates that the tag address overlaps with a special relay or a special 

register. 

 

3. Editing Section 

Including table section, button section and right-click menu, details are as follows: 

 

 

Item Description 

Table 

Name Set a tag name, the maximum length is 32 characters. It cannot 

be pure numbers, registers and reserved words. 

Type Set tag data type, the types are divided into:  

[Bool] 

[16Bit-Int] 

[16Bit-UInt] 

[32Bit-Int] 

[32Bit-UInt] 

[Float] 

Address Set the register or relay address assigned to the tag. 

Comment Set the comment of the tag. 

New After clicking, a row of tags will be added in the editing section 

for users to edit. 

Delete After clicking, delete the tag currently selected by the user, and 

multiple selections can be deleted. 
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Import After clicking, the tag will be imported after selecting the file. 

The file extension is *.csv 

Export After clicking, the tag can be exported after selecting the 

storage location. The file extension is *.csv 

Right-

Click 

Menu 

Cut After clicking, cut the tag currently selected by the user, and 

multiple selections can be cut. 

Copy After clicking, copy the tag currently selected by the user, 

multiple selections can be copied。 

Paste After clicking, paste the tag previously copied or cut by the 

user. 

Insert After clicking, insert a row of tags at the selected position in 

the editor for users to edit. 

Delete After clicking, delete the tag currently selected by the user, and 

multiple selections can be deleted. 

Move Up After clicking, move the tag currently selected by the user up 

one column. 

Move Down After clicking, move the tag currently selected by the user 

down one column. 

 

8-5-2 Global Tag 

The global tag editor can be edited through [Tag] → [Global Tag] in the project management window or 

in the function bar [Project] → [Tag] → [Global Tag]. 

UperLogic will pre-create a set of [Default Tag] tabs, and users can create global tabs by themselves 

through [Add Global Tag] and [Delete Global Tag]. 

d 

Fig. 151: Global Tags 
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8-5-3 Regional Tag 

The regional tag editor can be edited through [Program Unit] → [Arbitrary Program] → [Arbitrary Unit] 

→ [Regional Tag] in the project management window or in the function bar [Project] → [Tag] → 

[Regional Tag]. 

The regional tag cannot create a page by itself. When creating a program unit, UperLogic will directly 

generate a page of the regional tag, and its name will directly correspond to the program unit name. The 

corresponding regional tag can only be used in this program unit. If you need to use it across program 

units, please select the global or system tag. 

The label names of different regional tag pages can be repeated, but cannot be repeated with the global 

tag name. 

 

Fig. 152: Regional Tags 
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8-5-4 System Tag 

The list of system tags can be viewed through [Tag] → [System Tag] in the project management window 

or by clicking [Project] → [Tag] → [System Tag]. The system label is a built-in label, which varies with 

different models. It is only for viewing, and cannot be added or edited. The name of the system tag must 

start with $ font size. 

 

 

Fig. 153: List of System Tags 

There are many tag groups in the system tag, users can view the labels of different categories by selecting 

a tag group. 

 

Fig. 154: Tag group menu 
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8-5-5 Tag Usage 

1. Direct Use 

During the editing process, the user can directly input the relevant words of the corresponding 

tag name, and a drop-down menu will appear at this time to prompt possible tags to be used.

 

Fig. 155 Tags 

2. Use after processing a new tag 

If the user wants to directly create a new tag and use it during the editing process, he can directly 

enter the name of the new tag and press “Enter”, and the system will automatically jump to the 

registration tag window to allow the user to register a new tag. 
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Item Description 

Name Tag Name 

Position 
The registration position of the tag, which can be set in the 

global tag tab or the regional tag tab 

Type Set tag data type, the types are divided into:  

[Bool] 

[16Bit-Int] 

[16Bit-UInt] 

[32Bit-Int] 

[32Bit-UInt] 

[Float] 

Address Set the register or relay address assigned to the tag 

Comment Set the comment of the tag 

Open the Tag Page 

after Registration 

When checked, it will jump to the tag editor page after the 

registration is complete. 
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    Danger 

1. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

2. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

3. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 

malfunction. 



Chapter 9 Motion Control 

7-2 

M-Series PLC Software Interface User Manual 

This section describes the servo and cam related configuration methods. By combining the image-base 

display and the user-friendly interface, it allows the user to control the setting method more quickly and 

more efficiently.  

To understand the detailed operation method of motion control, please refer to the relevant manuals. 

Described below is the operation method of different motions.  

9-1 Motion Network 

After implementing the setting axis in the “Motion Network,” the user will be allowed to set the 

information of the connected slave station (virtual axis).  

 

Setting process:  

By clicking [Motion] → [Motion Network] → “Right mouse button” → [Motion Network] in project 

management row or clicking [Project] → [Motion] → [Motion Network] → [Motion Network], it allows the 

user to open the [Motion Network] page.  

 

Fig. 156: Motion network setting page 
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1. Importing ESI file 

Import the “EtherCAT” slave station data by clicking “Import ESI file.” For details of ESI file, please 

contact your server dealer.  

 

Fig. 157: Importing slave station data 

 

2. Joining slave station 

After being imported, the Slave Station Option List will appear. Double-click or scroll down to [Motion 

Controller] list, and the joining will be allowed.  

※ The indicated sequence is the communication sequence.  

 

 

Fig. 158: Communication sequence list 
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3. Other functions 

 

 

Fig. 159: Other functions 

Function Description 

Cut 
At the axis that will be cut, click the right mouse button and then 

select [Cut] in the menu.  

Copy 
At the axis that will be copied, click the right mouse button and then 

select [Copy] in the menu. 

Paste 

At the position that will be pasted, click the right mouse button and 

then select [Copy] in the menu and you may paste the axis being 

copied or clipped.  

Delete 
At the axis that will be deleted, click the right mouse button and then 

select [Delete] in the menu. 

Rename 
At the axis that will be renamed, click the right mouse button and 

then select [Rename] in the menu. 

Real Axis-Virtual 

Axis Conversion 

At the axis that will be converted, click the right mouse button and 

then select [Real Axis-Virtual Axis Conversion] in the menu. 
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Import ESI file 

At the axis that will be imported, click the right mouse button and 

then select [Import ESI File] in the menu and you can start the 

importing. 

Change 

Sequence 
Drag the Slave Station to be changed to the intended position.  

 

Parameter 

 

Fig. 160: Parameter setting page 

Current fixed PDO setting as below: 

PDO Type Item Name 

RxPDO 

0x6040 Controlword 

0x607A Target position 

0x60FF Target velocity 

0x6071 Target Torque 

0x6060 Mode Of Operation 

0x60B8 Touch Probe Function 

TxPDO 

0x6041 Status Word 

0x6064 Actual Position 
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0x606C Velocity actual value 

0x6077 Actual Torque 

0x6061 Mode Of Operation Display 

0x60FD Digital inputs 

0x603F Error code 

0x60BA Touch Probe Pos1 Pos Value 

0x60BC Touch Probe Pos2 Pos Value 

Table 19: PDO setting table 

Currently, the system uses 3 kinds of modes. Listed below are the parameters and the unit required for 

these modes (DELTA 0x60ff, using 0.1 rpm as the unit). 

 

Table 20: Synchronous Cycle Position Control Mode Table 
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Table 21: Synchronous Cycle Velocity Control Mode Table 

 

 

Table 22: Synchronous Cycle Torque Control Table 
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9-1-1 Servo Test Run  

Click [Motion] → [Motion Network] → “Right mouse button” → [Servo Test Run] in project 

management row. 

 

Fig. 161: Servo Test Run 

Or you may select [Project] → [Motion] → [Motion Network] → [Servo Test Run] from the menu in 

function toolbar icon. 

 

Fig. 162: Servo Test Run 
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Select the Test Run axis:  

 

Fig. 163: Selecting the Test Run axis  

Indicated below is the Test Run page and it comprises three types of control modes (Position, Velocity, 

Torque):  

 

Fig. 164: Position Control Mode 

 



Chapter 9 Motion Control 

7-10 

M-Series PLC Software Interface User Manual 

 

Fig. 165: Velocity Control Mode 

 

 

Fig. 166: Torque Control Mode 
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9-1-2 Monitor Table 

Click [Motion] → [Motion Network] → “Right mouse button” → [Monitor Table] in project management 

row, or you may select [Project] → [Motion Network] → [Monitor Table] from the menu in function toolbar 

icon. 

 

Fig. 167: Motion monitoring table 

Provided below is the window showing the opened Motion Monitor Table. If there isn’t any axis in the 

figure, please set up the axis through [Motion Network]. 

 

Fig. 168: Motion Monitor Table 

Click [Item Setting], and you may select the object to be monitored. 
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Fig. 169: Selecting the item to be monitored 

Click [Axis Display], and you may select the axis to be displayed.  

Click [Export] and [Import], and the system will show the setting required for exporting and importing the 

Motion Monitor Table.  
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9-1-3 Monitor Error Table 

Click [Motion] → [Motion Network] → “Right mouse button” → [Monitor Error Table] in project 

management row, or you may select [Project] → [Motion Network] → [Monitor Error Table] from the 

menu in function toolbar icon. 

 

Fig. 170: Motion eroor monitoring table 
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9-1-4 Monitor Chart 

Click [Motion] → [Motion Network] → “Right mouse button” → [Monitor Chart] in project 

management row, or you may select [Project] → [Motion Network] → [Monitor Chart] from the menu in 

function toolbar icon. 

 

Fig. 171: Motion monitoring chart 

Provided below is the window showing the opened Motion Monitor Chart. 

 

Fig. 173: Motion monitoring page 
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9-2 Motion Axis 

1. Setting process 

Click [Project] → [Motion] → [Motion Axis] in function toolbar, or you may select [Project] → [Motion Axis] 

in project management window and then double click the left mouse button to open the setting page.  

 

Fig. 173: Motion axis setting 

2. Setting method 

After setting adding axis in [Motion Axis], the system will add the desired axis automatically by clicking 

the table setting directly. 

 

3. Display setting 

By clicking [Axis Display Setting], it can be set as displaying the axis for users to create the desired axis 

more easily. 
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Fig. 174: Axis Display Setting 

4. Parameter 

Click the corresponding parameter position, and it allows the user to modify the parameter being created 

for such axis. For detailed description of parameters, please refer to Chapter 4 of Motion Control User 

Manual.  

 

  Fig. 175: Axis Display Setting 
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9-3 Motion Point 

1. Setting process 

Click [Project] → [Motion] → [Motion Point] in function toolbar, or you may select [Project] → [Motion 

Point] in project management window and then double click the left mouse button to open the setting 

page.  

 

Fig. 176: Motion point setting 

You may also click [Point Preview Chart] in the working window to open the preview page.  

 

Fig. 177: Motion point preview page 
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Item Description 

Display 

Setting 

Display all: Display all points (256 points until now) 

Display continuing point: Display the continuing points only and “Starting point” will 

be displayed on right-hand side for selection. 

Point 

Preview 

Chart 

Show the window highlighted by upper side yellow box for simulation reference.  

Setting 

Page 

From the purple block at upper side of the desired point parameter, select the motion 

point to be created. After double clicking, you may start setting the point data.  

Table 23: Descriptive table of motion Point Preview Chart 

2. Setting page parameters 

Through the point data setting function, it allows the user to modify the parameter setting of the motion 

point. For detailed parameter description, please refer to Motion Control User Manual.  

 

Fig. 178: Point Data Setting 
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3. Point Preview Chart 

Click [Point No.] and then select the motion point to be previewed. After setting the [Start Pos], click 

[Execution Calculation] and the preview map of such motion point will be displayed at the lower side 

track. For detailed setting, please refer to Motion Control User Manual.  

 

Fig. 179: Point Preview Chart setting 

4. Trajectory display control 

By clicking the  icon, you may open the scroll-down menu containing the [Trajectory Display Control] 

option. Indicated in the figure below are the functions.  

 

Fig. 180: Trajectory display control 
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9-4 Motion Flow 

1. Setting process 

Click [Project] → [Motion] → [New Motion Flow] in function toolbar, or you may select [Project] → 

[Motion] → [Motion Flow] in project management window and then double click the right mouse button 

to add new motion flow. 

 

Fig. 181: Adding motion process 

In Motion Flow options, click the right mouse button and the flow will be renamed.  

 

Fig. 182: Renaming motion flow 
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2. Adding flow block 

Description Icon 

Simply drag the right-side toolbox to 

the preview window.  

 

When dragging the block to the 

window, both will be connected by 

aligning red box with Node.  

 

After selecting the block, press “F” 

and you will be allowed to add the 

imported block.  

 

Table 24: Flow block adding setting table 

3. Deleting flow block 

Click block (multiple choices available) and then press “Delete.”  
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Fig. 183: Deleting flow block 

4. Adding link 

Press the contact and then drag it to the point to be connected.  

 

 

Fig. 184: Adding link for fkow block 
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5. Deleting link 

Click the respective line and then press “Delete” and the link will be deleted.  

 

 

Fig. 186: Deleting flow block link 

6. Others 

Item Description 

Show None 

 

Show Comment 

 

Show Info 
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Cut 

 

Copy 

 

Paste 

 

Delete 

 

Undo 

 



Chapter 9 Motion Control 

7-25 

M-Series PLC Software Interface User Manual 

Redo 

 

Export Image 

 

Parameter 

Flow setting block introduction. 

 

Basic Description 

 

Fig. 186: Flow block basic description 
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Action number: The number coded for such action. It represents the ID of the action currently displayed 

by Register R36884–R36890.  

 

Action setting: The setting page of each action. After completing the action, Register R36891–R36906 will 

be displayed as “2” (action completed).  

 

To next action condition: If such function is used, the system will go to next action block after meeting 

the conditions.  

 

Note: Taking the GoTo for example (presuming the conditions are met → No. 1; otherwise → No. 3), the 

system has determined to proceed to next action block (if GoTo No. 1) when completing the current 

action. If the system has set up the conditions for proceeding to next action block, then the direction will 

remain unchanged (the system will not GoTo No.3 at this time) even though the system has changed the 

GoTo conditions again (the conditions for GoTo No. 1 no longer exist). 

 

Start 

 

 

Select Branch 
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Fig. 187: Selecting branch 

After selecting the branch blocks, the system will execute the inspection from left to right in order to 

execute the first branch that meets the conditions. The rightmost means “ELSE” and the system will 

execute the process blocks at the rightmost side if failing all of the conditions. Currently, the maximum 

number has been set up to 16 branches.  

 

Item Description 

Branch Count Number of branch blocks (1–16) 

Condition Branching execution conditions 
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Parallel Branch 

 

 

 

 

Fig. 188: Parallel branches 

After executing the parallel branch blocks, the system will execute the process blocks according to the 

quantity set for the branch blocks. Currently, the maximum number has been set up to 16 branches. 

 

Item Description 

Branch Count Number of branch blocks (1–16) 

 



Chapter 9 Motion Control 

7-29 

M-Series PLC Software Interface User Manual 

Merge 

 

 

 

Fig. 189: Merge setting 

 

The selected branches and the parallel branches shall be displayed in pairs. In this case, it means the 

branch setting is finished.  

 

Item Description 

Merge Count Composite quantity (1–6) 

Standby Condition 
1. AND: For parallel process 

2. FOR SELECT: For block selections 
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Origin Return 

 

 

Fig. 190: Origin Return setting 

 

After selecting the desired axis, the system will execute the Origin Return according to the axis setting 

pattern.  

Item Description 

Axis Axis_conveyor 

 

Positioning 
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Fig. 191: Positioning setting 

 

Select the parameters of the corresponding points and then start the positioning.  

Item Description 

Point The points to be controlled 

Change 

Behavior 

Do Nothing 

Change Current Coordinates 

Change Target Position 

Change Speed 

Stop after moving for certain distance 
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Change 

Condition 

Change the desired parameters after meeting such 

condition during the positioning process.  

Changed 

Value 

The value to be changed.  

Speed is expressed as single value. 

When ticking such alignment point in the coordinates, 

the system will change the axis being used.  

 

Speed Control 

 

 

Fig. 192: Speed control setting 

Select the corresponding axis and then start the speed control according to the set value. 

 

Item Description 

Axis The axis requiring speed control.  

Velocity Command The speed to be achieved (min-1) 

Torque limit (0.01%) Torque limit and “0” means unlimited. 



Chapter 9 Motion Control 

7-33 

M-Series PLC Software Interface User Manual 

Torque Control 

 

 

 

 

Fig. 193: Torque control setting 

Select the corresponding axis and then start the torque control according to the set value. 

Item Description 

Axis The axis requiring speed control.  

Torque Command The torque to be achieved. 

Velocity Limit Speed limit and “0” means unlimited. 
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Standby 

 

 

 

 

Fig. 194: Standby setting 

Based on the conditions being created for the mode, GoTo next process block after meeting the intended 

conditions.  

 

Item Description 

Waiting Time The created waiting time, expressed in “ms” as the unit.  

Enable Switch Condition Switch conditions 
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Subroutine 

 

 

 

Fig. 195: Subroutine setting 

When running to this process block, you may execute other process.  

Item Description 

Sub-program Select the process to be executed.  
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GoTo 

 

 

 

 

Fig. 196: GoTo setting 

When running to this process block, you may execute the GoTo for entering other blocks of this process 

or finish the process directly.  

Item Description 

Block Select the process block of this process or finish the process.  

Condition 
Select the GoTo for entering the created setting block after 

meeting the conditions. 
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Synchronization 

 

 

Fig. 197: Synchronization control setting 

Enable or disable the designated axis synchronization control. 

Item Description 

Axis Start or close the synchronized axis.  

Mode Start or close the synchronization control. 
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9-5 Motion Sync Control 

Click [Project] → [Motion] → [Motion Sync Control] in function toolbar and then click the left mouse 

button to open the scroll-down menu in order to select the page that will be set. You may select the page 

to be created by clicking [Project] → [Motion Sync Control] in project management window. 

 

Fig. 198: Motion synchronization setting 

9-5-1 Sync Parameter 

Click [Sync Parameter] in scroll-down menu of [Motion Sync Control], or you may select [Project] → 

[Motion Sync Control] in project management window. Next, click the left mouse button to open the 

scroll-down menu to select [Sync Parameter]. 

 

Fig. 199: Synchronize parameter setting 

You may use the output axis to select the synchronize parameters of the axis that will be created. You may 

also use the copy and paste function next to the [Output Axis] for presetting the corresponding setting 

process. For detailed setting, please refer to Motion Control User Manual.  
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9-5-2 Contact Output (to be released) 

Click [Sync Parameter] in scroll-down menu of [Motion Sync Control], or you may select [Project] → 

[Motion Sync Control] in project management window. Next, click the left mouse button to open the 

scroll-down menu to select [Contact Output]. 

 

Fig. 200: Contact Output setting 

For detailed setting of synchronize contact, please refer to Motion Control User Manual.  

9-5-3 Cam setting 

Click the scroll-down menu of [Motion Sync Control] and you will be allowed to select the required cam 

setting. You may also click [Project] → [Motion Sync Control] in project management window and then 

click the right mouse button to open [ New Cam setting] in the scroll-down menu. 

 

Fig. 201: Cam setting 
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New Cam setting 

Click the scroll-down menu of [Motion Sync Control] and you will be allowed to select [New Cam setting] 

or you may select [Project] → [Motion Sync Control] → [Cam setting] in project management window. 

Next, click the right mouse button to open the scroll-down menu and then select [New Cam setting]. 

 

Fig. 202: New Cam setting 

Delete Cam setting 

Click the scroll-down menu of [Motion Sync Control]. Here, you will be allowed to select [Delete Cam 

Setting] or you may select [Project] → [Motion Sync Control] → [Cam Setting] in project management 

window. Next, click the right mouse button to open the scroll-down menu and then select [Delete Cam 

Setting]. 

 

Fig. 203: Delete Cam setting 

After being selected, such page will show “Delete Motion Cam” window. Select the cam to be deleted 

and then press [OK] to delete such cam.  
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Cam Resolution 

Click the scroll-down menu of [Motion Sync Control]. Here, you will be allowed to select [Cam Resolution] 

or you may select [Project] → [Motion Sync Control] → [Cam Setting] in project management window. 

Next, click the right mouse button to open the scroll-down menu and then select [Cam Resolution]. 

 

 

Fig. 204: Cam resolution setting 

After being selected, such page will show “Dialog” window. Setting up cam resolution will affect the 

maximum quantity of the cam that can be added.  
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9-6 Motion Param Mapping 

Click [Project] → [Motion] → [Motion Param Mapping] in function toolbar. You may also select [Project] → 

[Motion] → [Motion Param Mapping] in project management window and then double clicking the 

pagination function of [Motion Param Mapping]. 

 

 

Fig. 205: Motion Param Mapping setting 

Function Description 

Add Add a new Motion Parameter Table and execute 

the required setting.  

Delete Delete old Motion Parameter Table 

Up/Down Change the sequential address of Motion 

Parameter Table in Summary Table. 

 

Regarding the setting details of Motion Parameter Table, please refer to Motion Control User Manual.  
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9-7 Motion Recipe 

Click [Project] → [Motion] → [Motion Recipe] in function toolbar. You may also select [Project] → [Motion] 

→ [Motion Recipe] in project management window and then double clicking the pagination function of 

[Motion Recipe].  

 

Fig. 206: Motion Recipe setting 

Function Description 

Add Add a new Motion Recipe and execute the required setting.  

Delete Delete old Motion Recipe 

Up/Down Change the sequential address of Motion Parameter Table in Summary Table. 

Import/Export Export or import information from Motion Recipe 

Cut Cut out the selected Motion Recipe information 

Copy Copy selected Motion Recipe information 

Paste Paste the copied or cut Motion Recipe information at the specified location 

 

Regarding the setting details of Motion Recipe, please refer to Motion Control User Manual.  
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10 
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 Module configuration 

 

 

 

 

 

 

    Danger 

1. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

2. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

3. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 

malfunction. 
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This section describes the graphical illustration method for helping the user achieve quick and convenient 

configuration as well as establish the configuration compatible with the PLC application. In the meantime, 

this section also explains the corresponding information setting instructions. Detailed description will be 

provided in the paragraph below.  

10-1 Creating Module Layout Drawing 

Page Display 

Click [Project] → [Device View] in function toolbar, and the module management page will appear as 

below:  

 

Fig. 207: Module management page 

Click the toolbar icon, and you can call out following functions:  

 

Fig. 208: Related functions of Module management page 
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Function Description Detailed 

introduction 

Auto Fit Compress and expand the module to appropriate 

position automatically.  

 

Device 

Dimension 

Indicate the dimensions of the equipment.  Please refer to 

Section 10.1.3 

Select Info Display the information of the selected equipment 

such as ID, firmware version, hardware version, serial 

number and description, etc.  

Please refer to 

Section 10.1.2 

Device 

Monitor 

Display the status of the selected module on the 

right-hand side.  

Please refer to 

Section 10.3 

Power 

Consumption 

Calculate the power consumption status of all 

components being expanded until now.  

Please refer to 

Section 10.4 

Module 

Resource 

Display the resource occupying status of such 

module at the lower side of the module.  

Please refer to 

Section 10.1.4 

Hardware 

Configuration 

Display the module in the toolbox for users to 

expand the module.  

Please refer to 

Section 10.1.1 

Reset 

Configuration 

Reset the module. After being pressed, it will 

remove all of the expanded components in the PLC 

and then return to initial status. 

 

Undo Return to the previous step.   

Redo Redo the next step.   

Table 25: Introduction of equipment window items 
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10-1-1 Operation setting 

First, click [Hardware Configuration]. Next, select the module from the right-side toolbox and then drag it 

to the PLC module. During the dragging process, the intended configuration position will show yellow, as 

per the figure below. When the module reaches the rear section of the existing module, it will be placed at 

the rearmost end of the module automatically. By double clicking the module in the toolbox, the system 

will add new module to the rearmost end of the module that has been configured.  

 

Fig. 209: Dragging the module to the rear section 

The user may drag the module for adjusting the position of the added module in order to match with 

actual PLC configuration pattern.  

 

Fig. 210: Dragging module to the space between modules 
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Caution:  

You cannot click [Download] if the expansion module in UperLogic is incompatible with the connected 

physical module. In this case, you will be allowed to use the uploading function only.  

 

Fig. 211: Download remains inactive if incompatible with the module 

10-1-2 Module information 

Click [Project] → [Device View] → [Select Info] in function toolbar, and then move the cursor to the target 

module. Next, click the left mouse button and the window will show the information of the selected 

module such as version number, number of terminal board point and remark, etc., as per the figure 

below: 

 

Fig. 212: Module information 
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10-1-3 Device Dimension 

Click [Project] → [Device View] → [Device Dimension] in function toolbar and the module dimensions will 

be displayed in the webpage, as per the figure below: 

 

Fig. 213: Module dimensions 

10-1-4 Module Resource 

Click [Project] → [Device View] → [Module Resource] in function toolbar and the resource consuming 

status of each module will be displayed in the webpage, as per the figure below: 

 

Fig. 214: Module Resource
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10-2 Module List 

Click [View] → [Module List] in function toolbar, and the module management page will be displayed, as 

per the figure below: 

 

Fig. 215: Module List 

The module list will display the module currently installed. When clicking the corresponding module, the 

module list will also display the module currently selected.  

 

Fig. 216: Selecting module 
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Click the module in the Module List, and it will show the resource consuming status of the corresponding 

module. 

 

Fig. 217: Module resources in Module List 

Based on the sequential order, the Module List will show the name, ID, and of the module or 

PLC. 

 

[ ]: To expand or compress the resources items of such module. 

[ ]: It allows the user to skip to equipment window directly from other page and the system will also 

mark the selected module automatically. 
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10-3 Device Monitor 

Click [Project] → [Device View] → [Device Monitor] in function toolbar, and the system will show the right-

side device monitoring window:   

 

Fig. 218: Device monitoring 

In the information, you may select the resource that will be displayed such as “Digital Data,” “Logic 

Data,” “Status Data” and “Relay.” 

10-3-1 Digital Data 

When clicking [Digital Data] above [Device Monitor], the Module List will show digital data only. Next, 

point the mouse at the target value. When the switch is shown in blue as per the figure below, it means 

the user will be allowed to change the switch of such register.  
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Fig. 219: Digital data of device monitoring 

10-3-2 Logic Data 

When clicking [Logic Data] of the information above [Device Monitor], the Module List will show logic 

data only. Next, point the mouse at the target value. When the data is shown in blue as per the figure 

below, it means the user will be allowed to change the switch of such register. In the meantime, it also 

allows the user to quickly change the value displaying pattern with [Dec] and [Hex] on the right side of the 

register.  
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Fig. 220: Related logic data of device monitoring 

10-3-3 Status Data 

When clicking [Status Data] above [Device Monitor], the Module List will show status data only. If the data 

is shown in gray as per the figure below, it means the user will not be allowed to change the value of such 

register. However, the user is still allowed to instantly change the value displaying pattern with [Dec] and 

[Hex] on the right side of the register. 

 

Fig. 221: Status data of device monitoring 
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10-3-4 Relay 

When clicking [Relay] above [Device Monitor], the Module List will show status data only. Next, point the 

mouse at such value. If the data is shown in blue as per the figure, it means the user will be allowed to 

change the value of such register; otherwise, it will be impossible to make the change if the register field 

is shown in gray background. 

 

Fig. 222: Status data of device monitoring 
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10-4 Power Consumption 

Click [Device View] → [Power Consumption] in function toolbar, the lower-right side will show the power 

consumption calculation window, as per the figure below:  

 

Fig. 223: Power Consumption 

Function Description 

Module Select the power module that will be used now. 

Power Supply The power capacity supplied by the power module. 

Usage Display the total power capacity consumed by all modules currently used.  

External Display the total power capacity supplied by external power source as 

estimated by the user.  

Power Remain Remaining power capacity after deducting the supplied capacity from the 

power module. 

Table 26: Introduction of detailed power consumption 
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Additional power will be required for certain modules such as M04DA indicated in the figure. The user 

may determine if using the power supplied by the host or by the external source. If external power supply 

will be required, click  and set such power as external power supply and then recalculate the 

capacity currently required, as per the figure below: 

 

Fig. 224: External power supply 
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10-5 Module Setting 

Double clicking the expansion component with the left mouse button and the corresponding module 

setting window will pop up. In addition to creating the equipment name and comment, the user is also 

allowed to set up the module parameters in “Offline Edit” and to calibrate the corresponding module in 

“Online Monitor.” 

 

Fig. 225: Setting the module 

Although the equipment information of each module may vary in name and description, however same 

information will be displayed. Indicated below is the introduction of the equipment information related 

content by using M04TC as the example.  

 

Fig. 226: Device information (M04TC) 
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Information Description 

Module name The name of the module. It is the default value and cannot be edited.  

ID Display present number of the module automatically according to 

the sequence of the string devices.  

Description The functional description of the module. It is A default value and 

cannot be edited. 

Firmware Version By clicking the right-side [Upgrade] button, you may upgrade the 

firmware of all modules installed in the PLC and such function will be 

active only under “Online Monitor.” 

 

Hardware Version Present hardware version of the module. It is a default value that 

cannot be edited. 

Serial Number Present serial number of the module. It is a default value that cannot 

be edited. 

Device Name The user may define the equipment name and then save the 

changed information in the Project.  

Comment The user may define its own comment and then save the changed 

information in the Project. 

Table 27: Device Information List 
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After changing the device name, press [OK] and the changed name will be displayed under such device. 

 

Fig. 227: Changed module name 

Each module will be configured to display the content of the corresponding parameters. Provided below 

is the introduction on how to execute the configuration by using M04TC as the example.  

 

When operated under “Offline Edit,” the user may emable or disable the corresponding channel and 

change the desired parameter. Please refer to the relevant manuals.  

 

Fig. 228: Configuration information_offline edit (M04TC) 
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When the CM Module is under “Office Edit,” it allows the user to set up the packet or the table for the 

corresponding mode. Provided below is the introduction by using MHCM55 as the example.  

 

Fig. 229: Setting parameters for communication module (MHCM55) 

Modbus Master Station 

After selecting the Modbus Master Station, it allows the user to create the table for the Master Station. 

 

Fig. 230: Setting Master Station Table  

In the left-side Master Station Table, the user will be allowed to Add (+) or Delete (-) the table and then 

create its own description for easier identification. After adding the table, the user may add new order in 

the right-side Master Station Table and then click the corresponding parameter to proceed with the 

change.  

Please refer to the relevant manual for details about setting parameters in the table of the master station. 

Modbus Slave Station 

 

Fig. 231: Setting Slave Station Table 
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In the left-side Slave Station Table, select the number that will be edited. After that, you may start setting 

up the corresponding parameters in the right-side Slave Station Table.  

Please refer to the relevant manual for details about setting parameters in the table of the slave station. 

User Defined Value 

The user defined value comprises two tables and they are User Defined Packet and User Defined Table.  

User Defined Packet 

 

Fig. 232: Setting User Defined Packet  

In the left-side User Defined Packet, the user will be allowed to Add (+) or Delete (-) the packet and then 

create its own description for easier identification. After adding the packet, the user may add new 

command in the right-side UserDefined Packet and then click the corresponding parameter to proceed 

with the change. 

Please refer to the relevant manual for details about setting parameters in Use Defined Packet. 

 

User Defined Table 

 

Fig. 233: Setting User Defined Table 

In the left-side User Defined Table, the user will be allowed to Add (+) or Delete (-) the table and create its 

own description for easier identification. After adding the table, the user may add new command in the 

right-side User Defined Table and then click the corresponding parameter to proceed with the change. 

Please refer to the relevant manual for details about setting parameters in User Defined Table. 
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When operated under “Online Monitor,” the AI, AO, TC and LC modules will be provided with 

calibration function. Provided below is the introduction by using M04TC as the example.  

 

Fig. 234: Module calibration_Online monitor (M04TC) 

Click [Calibration] at lower-middle of [Configuration Setting] column, and you can open the calibration 

window for the corresponding module. First, select the left-side channel that will be calibrated. Next, 

select the required setting procedure in calibration setting and then you may complete the calibration 

according to the corresponding steps.  

 

The lower-left side of the module is configured with the export and import options for users to quickly 

export and import the edited setting result.  
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Fig. 235: Export and import of module setting 

It should be noted that the file exported by the CM Module from different setting pages shall not be 

applicable for other purposes. As indicated in the figure below, the file exporting and importing function 

of the module cannot be used for exporting or importing the User Defined Packet.  

 

Fig. 236: Incompatible exporting and importing  
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Copy and Paste 

In [Configuration], move the cursor to [Channel] and then click the right mouse button and you will be 

allowed to execute the copy, paste and reset functions.  

 

Fig. 237: Channel’s right mouse button function 

Function Description 

Reset to Default Restore all of the channel settings to initial preset value. 

Copy Copy all settings of the channels currently selected. 

Paste Paste previously copied channel settings. 
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10-6 I/O Configuration Status 

UperLogic adopts the automatic detection mode for the expansion unit. After connecting with the host, 

UperLogic will automatically read the status of the host and the expansion unit, and at the same time 

automatically allocate the occupied system resources. 

Users can see how many expansion units are connected to the host in [Project] → [Device View], and 

which system resources are occupied by the expansion modules. 

 

 

Fig. 238: Device management window 
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To view the configuration status of the I/O numbering, just click [Device View] → [Device Monitor], and 

then click the relevant module in the working window, and relevant information such as 

Digital/Analog/Status will be displayed on the right side, which is convenient for users to monitor the 

reading values and status of each IO more intuitively, as shown in the figure below: 

 
Fig. 239: The right-side display information such as Digital/Analog/Status 

 



Chapter 11 Communication Function 

8-1 

M-Series PLC Software Interface User Manual 

 

11 
Communication Function 

 Connection .................................................................................................................... 8-2 

 Offline Edit ..................................................................................................................... 8-5 

 Upload ........................................................................................................................... 8-5 

 Download ...................................................................................................................... 8-8 

 Run/Stop PLC ............................................................................................................. 8-10 

 Clear PLC .................................................................................................................... 8-11 

 PLC Status .................................................................................................................. 8-12 

 PLC Setting ................................................................................................................... 8-1 

 Quick Control ................................................................................................................. 8-3 

  Online Edit .................................................................................................................... 8-5 

  



Chapter 11 Communication Function 

8-2 

M-Series PLC Software Interface User Manual 

This section describes the operating procedure required for executing the PLC online and offline as well 

as the PLC program starting and stopping operations. Provided below are detailed operation methods 

required for executive the respective communication.  

11-1 Connection 

It allows the user to connect with the PLC function for changing current online parameters and creating 

online list, etc.  

 

From the function bar [PLC] → [Connection Parameter], you can set the default connection parameter, 

which can be used directly for subsequent connections without additional settings. 

 

 Fig. 240: Connection Parameter 

 

Page 
Connection 

Type 
Attribute Description 

  Network Connection 
Select the network interface card users want to 

use. 

Basic Ethernet 

Type Network online type, in TCP or UDP. 

IP Address Connected PLC network address 

Communication Port Connected PLC network port. 



Chapter 11 Communication Function 

8-3 

M-Series PLC Software Interface User Manual 

Network 

Connection Info 

Display the current network interface card 

information. 

Search 

Search the PLC network address existing on the 

network. 

USB USB 
Select the M-PLC USB port that is currently 

connected to the computer. 

Advanced 

Timeout (ms) 
PLC response timeout setting, the setting range 

is 100-30000 ms. 

Retest Frequency 
Communication failure retest time setting, the 

setting range is 0-10 times 

Command Delay 

(ms) 

The delay time setting of each communication, 

the setting range 0-1000 ms. 

Other Settings 

Connection List 

A list of frequently used connections can be set, 

and the connection information can be quickly 

brought in by clicking the drop-down menu 

option. 

Connection Test 

Use the current parameters to perform a quick 

connection test to confirm that the connection 

parameters are valid parameters. 

Be sure to ask before 

connecting 

When checked, the connection parameter 

window will be displayed before each 

connection action. If it is not checked, the 

previous connection parameters will be used to 

directly connect. 
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Connection List 

Click [Connection Parameter List] → [Connection List] in scroll-down menu and you will be allowed to 

create the Connection List.  

 

 

Fig. 241: Connection Parameter List 

Connection Test 

Click [Connection Parameter List] → [Connection Test] to perform a quick connection test with the current 

parameter. 

[  
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11-2 Offline Edit 

Under PLC online status, click “PLC” → “Offline edit” in function toolbar and you will be allowed to 

execute the offline editing.  

11-3 Upload 

Such function allows users to upload the PLC project to PC for preparing backup copy or for inspection. 

The operation process differs depending on whether the project is opened or not, as detailed below: 

  Upload with Open Project 

1. Select the tab page [PLC] → [Upload], and use the set connection parameters to connect. 

2. After connecting, compare the currently opened project with the PLC project. 

A. When the comparison is the same, [The current project matches the connected PLC] will show. 

 

B. When the compare is not matched, a compare window will be displayed to allow the user to 

select the part to be uploaded. 

 

Fig. 242: Selecting the uploaded data 

3. Click [Upload] to start uploading until the progress window is completed. 
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  Upload with Closed Project 

1. Select the tab page [PLC] → [Upload] 

2. Ask “Do you open the relevan project?” 

A. Click [Yes] → The action is the same as Section 11-3-1. 

B. Click [No] → The connection parameters will be forcibly asked, and the connection will 

be performed using the set connection parameters. 

 

Fig. 243: Opening the relevant project 

 

3. After connecting, the user can choose the data to be uploaded. 
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Fig. 244: Uploading the data 

4. Click [Upload] to start uploading until the progress window is completed. 
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11-4 Download 

Such function allows the user to download the PLC project being planned in PC to the PLC. 

1. Select the tab page [PLC] → [Upload], and use the set connection parameters to connect. 

2. After connecting, compare the currently opened project with the PLC project. 

A. When the compare is the same, [The current project matches the connected PLC] will show. 

 

B. When the compare is not matched, a compare window will be displayed to allow the user to 

select the part to be downloaded. 

 

Fig. 245: Selecting the data to be downloaded 

C. If the compare is different, and there are syntax errors or inconsistent modules, only the 

upload function is provided. 
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3. Click [Download] to start downloading until the progress window is completed. 
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11-5 Run/Stop PLC 

Run PLC 

When operated under online monitoring status, click [PLC] → [Run] in function toolbar or you may press 

“F9” quick key. 

 

Fig. 246: Running PLC 

Stop PLC 

When operated under online monitoring status and when PLC is under Running Mode, click [PLC] → 

[Stop] in function toolbar. 

 

Fig. 247: Stopping PLC 
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11-6 Clear PLC 

When operated under online status, click [PLC] → [Clear PLC Data] in function toolbar, and [Clear All 

(Initialization)], [Clear Program Only], [Clea Registers Only], and [Clear Coils Only] options will appear as 

below: 

 

Fig. 248: Clearing PLC data 

Function Description 

Clear All Clear all PLC data and restore factory settings 

Clear Program Only Clear the program data in the PLC, including motion control data. 

Clea Registers Only Reset all register values in the PLC. 

Clear Coils Only Reset all coils in the PLC. 
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11-7 PLC Status 

When operated under online status, click [PLC] → [PLC Status] in function toolbar and the data will appear 

as below: 

 

Fig. 249: PLC status 

Function Description 

Station Number Station number of the connected main unit. 

Main Unit Type Type of the connected main unit. 

Main Unit Status Working status of the connected main unit. 

PLC OS Version Firmware version of the connected main unit. 

MC OS Version Motion control firmware version of the connected main unit. 

HW Version Hardware version of the connected main unit. 

Memory Pack Whether the connected main unit is installed with a memory card. 

Syntax Check Program syntax checking condition of the connected main unit. 

Data Password Whether to set data password on the connected main unit. 

Program ID Whether to set Program ID on the connected main unit. 

PLC ID Whether to set PLC ID on the connected main unit. 

Upload Protection Whether to set upload protection on the connected main unit. 
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Download Protection Whether to set download protection on the connected main unit. 

Calendar Whether the connected main unit is installed with RTC. 

Total Capacity of Program Total program capacity of the connected main unit. 

Used Capacity of Program Used program capacity of the connected main unit. 

Free Capacity of Program Free program capacity of the connected main unit. 

MAC Address MAC address of the connected main unit. 

HWID HWID of the connected main unit. 

iMonitor Status The iMonitor status of the connected main unit, including offline, 

online, connecting and error status. 
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11-8 PLC Setting 

11-8-1 PLC ID Setting 

When the PLC ID set by the PLC is different from the Program ID, the PLC cannot operate normally. The 

PLC ID can be set through the execution function bar [PLC]→[PLC Setting]→[PLC ID]. The ID rule is setting 

with 8 uppercase alphanumeric letters. 

 

Fig. 250: Setting PLC ID 

11-8-2 RTC Setting 

When the PLC is under “Online” and “Run” status, the user will be allowed to click [PLC] → [PLC 

Setting] → [RTC]. After that, the following window will appear for the user to set up the perpetual 

calendar time required for the PLC. 

 

Fig. 251: Setting RTC 
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Function Description 

Current Time Date and time of the currently connected main unit. 

Setting Time To set the date and time to the currently connected main unit. 

Use Time of PC When checked, the current computer time will be used as the setting time. 

Setup to PLC When clicked, the setting time will be written directly to the currently 

connected main unit. 

 

11-8-3 Firmware Update 

Select the function bar [PLC] → [PLC Setting] → [Firmware Update], and select the corresponding 

firmware file and start updating, until the progress window is closed and the prompt window showing the 

completion of the update is displayed. Wait until the light is displayed normally and then just restart the 

main unit. The extension of the firmware update file is *.os. 

 

 

 

Fig. 252: Firmware Update 
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11-9 Quick Control 

The Quick Control operation is for the convenience of the user. When the connection parameters are set 

correctly, the PLC can be connected to perform some operations without complete synchronization of 

data. 

 

Fig. 253: Quick Control 

11-9-1 Get System Status of PLC 

Under the state of offline edit, when the connection parameters are set correctly, click [PLC] → [Quick 

Control] → [Get System Status of PLC] on the function bar to read various information of the PLC under 

offline conditions , the content is the same as section 11-7. 

11-9-2 Initialize PLC 

Under the state of offline edit, when the connection parameters are set correctly, click [PLC] → [Quick 

Control] → [Initialize PLC] on the function bar to initialize the PLC under offline conditions. 

11-9-3 Run PLC 

Under the state of offline edit, when the connection parameters are set correctly, click [PLC] → [Quick 

Control] → [Run PLC] on the function bar to run PLC under offline conditions. 

11-9-4 Stop PLC 

Under the state of offline edit, when the connection parameters are set correctly, click [PLC] → [Quick 

Control] → [Stop PLC] on the function bar to stop PLC under offline conditions. 

11-9-5 Memory Card Opearation 

Under the state of offline edit, when the connection parameters are set correctly, click [PLC] → [Quick 

Control] → [Memory Card Opearation] on the function bar to configure related PLC settings under 

offline conditions. 
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Fig. 254: Memory card configuration 

For detailed setting description, please refer to Chapter 14-2. 
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11-10 Online Edit 

The online editing function can directly change the program and project content on UperLogic page, so 

that users can make on-site adjustments during the final debugging of the program design. 

 

When using the online editing function in the running state of the PLC, if the wrong method was used, it 

may bring great harm to the device and operators, and users need to carefully check the content during 

operation. 

11-10-1 Starting Online Edit 

The process is shown below: 

1. Click to execute the function bar [PLC] → [Online Edit] when the PLC is connected. 

 

Fig. 255: Online Edit 

2. After connecting, compare the current project with the PLC project. 

A. If the comparison is the same, skip directly to Step 4。 

B. When the comparison is different, the compare window will be displayed to prompt the 

different parts. Since it is necessary to synchronize the project and PLC data to enter the 

online editing mode, the user can choose to download the project or upload the PLC data 

for synchronization. 

 

C. When the comparison is different and the syntax check is wrong or the module list is 

inconsistent, you can only enter the online editing mode after selecting to upload PLC 

data for synchronization. 
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3. After clicking the sync direction, wait for the progress window to complete. 

4. After the synchronization is completed, it will enter the online editing mode and display the PLC 

status window. 

11-10-2 Trial Run 

When editing online, the changed part of the project or program will not be written into the PLC 

immediately, but must be written to the PLC running section through the trial run mechanism to make the 

current changed part take effect. Click [PLC] → [Trial Run] in the function bar to perform a test run on the 

PLC. 

 

Fig. 256: Trial Run 

11-10-3 Discard Change 

 

When editing online, if the debugging result after editing is not as expected, the project can be restored 

to the previous state through [Discard Change]. This operation only restores the project, if you need to 

restore the PLC data, you need to perform a trial run again. 

Click [PLC] → [Discard Change] on the function bar to restore the previous status. 
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Fig. 257: Discard Change 

Function Description 

Content of the 

Previous Trial Run 

Restore to the content of the project at the time of the 

previous trial run. 

Content before 

Online Editing 

Restore to the project content when entering online 

editing. 

 

11-10-4 Finishing Online Edit 

The debugging content during online editing will only exist in the PLC running section, so when you leave 

the online editing mode, you need to re-download the current project content to the PLC. Please note: 

this operation will stop the action. Switching from [Online Edit] to [Offline Edit] or [Online Monitor], the 

following prompt window will appear, allowing the user to select the data to be stored in the PLC. 
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Function Description 

Current Content When the current project content is written to the PLC. 

Contents of Previous Trial Run Restore to the content of the project during the 

previous trial run and write it to the PLC 

Content before Online Edit Restore to the project content when entering online 

editing and write it to PLC 

Restart the PLC after the 

operation is complete 

When checked, restart the PLC after the write to PLC 

operation is completed 
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12 
Monitoring Function 

 

 Displaying Ladder Diagram Status................................................................................. 9-2 
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 Monitoring function 

 

 

 

 

 

 

 

 

 

    Danger 

1. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

2. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

3. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 

malfunction. 
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This section describes the method of applying user-friendly interface as well as convenient operation and 

orderly-arranged pages to execute the required monitoring management for the designed functions 

such as toolbar, project window, status monitoring page and ladder window, etc. The purpose is to 

provide more convenient operation and well-defined window pages. Introduced below is the respective 

monitoring operation method. 

12-1 Displaying Ladder Diagram Status 

For detailed operation procedure, please refer to Section 7.2: “Ladder Diagram.” 

12-1-1 Monitoring and Debugging 

1. Save the imported program in the PLC and then click [File] → [Save Project As] → [Save to PLC] in 

function toolbar. Next, the system will execute the online connection through the created “Online 

Parameter.” After connecting, the window will appear as below: 

 

Fig. 258: Download setting 

If the “Online Parameter” is configured incorrectly or if the online is faulty, then the window will display 

the corresponding error message. 

 

2. After completing the download, click [Online Monitor]. After that, click [PLC] → [Run PLC] in function 

toolbar; or you may input “F9” quick key to instruct the PLC to start running the program. In the 

meantime, you may also click [PLC] → [Stop Run] in function toolbar. 

You may also click “Ctrl” + “F9” quick keys to instruct the PLC to stop running the program. 

 

3. When running the PLC, the ladder program window will change to the following status: 
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Fig. 259: Running PLC ladder program 

The element indicated in the solid line block means it is under conducting state. At this time, you will be 

allowed to control the ladder program display in order to show the program comment or present 

Register value in the window page.  

 

The displayed content in the ladder window comprises the following options:  

⚫ Program Unit Comment 

⚫ Network Comment 

⚫ Element Comment 

⚫ Register Value 

⚫ Font Size 

 

The more the selected options, the more the displayed information; however, less program codes will be 

covered by the same screen space. 

Clicking [View] in function toolbar with mouse and the tick-type menu will appear for selecting the 

desired option. Such menu will show the aforesaid options and then the user will be allowed to select the 

desired option by clicking steps. At this time, a tick symbol will appear on the left side of the selected 

item. Tick again, and this item will return to the unselected status.  

Indicated below is the result after ticking [Element Comment] and [Single Network Comment]: 

 

Fig. 260: Displaying the comment 
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As per the figure below, the ticked comment will appear in the comment field after being selected. 

 

Fig. 261: Displayed in comment field 

Coil enable/disable control:  

After completing the “RUN” process, move the cursor to the coil position and then press the right 

mouse button to show the menu as below:  

 

Fig. 262: Coil enable/disable control 

With “Disable” function, the user will be allowed to remove the component from the program control. 

For example, when “X0” is disabled, its status will not be changed by “X0” status. At this time, you 

may control its status by clicking [ON] and [OFF] and the disabled element will be indicated in the 

respective type of symbol. Provided below are the symbols display for “X0” of the “disabled” 

element:  

 

Fig. 263: Disabling the elememt 

4. You will be allowed to start the test with [Status Page]. By doing so, open an empty status monitoring 

page according to the following procedure:  

Cclick [Project] → [Status Page] → [New Status Page] in function toolbar. You may also double click the 

icon in project management window with mouse or click the toolbar icon with mouse and then click 

[New Status Page]. 
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Fig. 264: New Status Page 

The dialog box will be displayed after completing the aforesaid procedure. In [Status Page Name], import 

“StatusPage1” and then press [Enter] key to show the window as below:  

   

Fig. 265: Status Page 

How to add Status Page? 

To execute, move the mouse cursor to the first empty space in the leftmost [Name] column and then 

import “y0-7.” 

 

Fig. 266: Adding Status Page 
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Press [Enter] key. After that, the window will show the number of Y0–Y7 together with the enable/disable 

and ON/OFF status as well as the present value of the information.  

 

Fig. 267: Monitoring status of Status Page 

How to execute Enable/Disable? 

To enable/disable the contact or the coil, move the cursor to the corresponding [Status] column and then 

double clicking the mouse to show enable/disable option. To set its value, move the cursor to the 

corresponding Information column and then import “0” and “1” values or double clicking the left 

mouse button to open the [Value Input] column. 

 

As far as the Register is concerned, the [Status] column can be used to control its display format. 

Currently, the software is provided with five kinds of display formats and they are systems of [Decimal], 

[Unsigned Decimal], [Binary], [Hexadecimal] and [Float]. To select the desired system, double clicking the 

[Status] column with the left mouse button to call out the menu. In addition to displaying the element 

number, the [Number] column can also display the number through the element comment. To execute, 

press the right mouse button in [Status Page] to call out the pop-up menu or click [Comments] at the top. 
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12-2 Status Page 

12-2-1 Status page management 

Click [Project] → [Status Page] in function toolbar and then select “StatusPage1” that already exists in 

the [Status Page Name] column. In project management window, you may also click [Comment 

Description → [Status Page] and then select “StatusPage0” that already exists in the [Status Page 

Name] column and then the [Status Page] window will appear. All of the existing monitoring names are 

listed in the widow tab. By clicking such tab, you may switch to the selected tab option and then click [X] 

icon at upper-right corner to close [Status Page] window.  

12-2-2 Operating the monitor point 

Definition of monitor point: 

In [Status Page], you can double-click the [Name] column with the left button of the mouse to enter a 

number, such as R1000, indicating that the monitoring point is R1000; or input a range, such as D0-D4, 

indicating the range of monitoring D0 to D4. 

 

Fig. 268: Definition of monitor point 

Deleting the monitor point:  

Click the number to be deleted with the cursor and then press [Delete] key and the selected number will 

be deleted. To delete all points, press [Clear all]. 

Function Description 

Column Set Users can display 1-4 field groups according to their 

own needs. 

Insert After {Add Row} Insert a column below the selected field. 

Insert Above (Add Row) Insert a column above the selected field. 

Element Comment Choose whether to show annotations. 

All Click and then choose the data type (binary, decimal...), 

the data on the page will all be displayed as the same 

data type. 

Binary Display data in binary 
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Decimal Display data in decimal 

Hexdecimal Display data in hexdecimal 

Unsigned Decimal Display data in unsigned decimal 

Float Display data in float point 

Refresh Get the latest information on the elements on the page 

Remove Row Delete the selected row 

Delete Content Delete the selected data 

Clear All Delete all of the data on the page 

Import Import the previous status page data 

Export Export the current status page data 

12-2-3 Run Chart 

Through the run chart, the Register data can be displayed on the curve graph more intuitively at the same 

time, which is convenient for users to compare. 

Click the function bar [PLC] → [Run Chart], click [Project Settings] to select the Register to be viewed, and 

then click [Start], the data of the Register will be displayed in a line chart. 

On the control panel at the upper right of the run chart, operations such as zooming in and zooming out 

the run chart can be performed; the upper left is the sampling interval, which users can set according to 

their own needs; the list at the bottom left displays the registers currently being viewed. Check [Hide] to 

temporarily hide the run chart of the Register. 

 

Fig. 269: Run Chart 
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Function Description 

Start Start monitoring the configured Register 

Stop Stop monitoring the configured Register 

Item Setting Set the Register position to be monitored 

Import Import the previous run chart 

Export Export the currently written run chart 
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13 
Security 
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    Danger 

1. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

2. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

3. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 

malfunction. 
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In general, the Password is used to protect the intellectual property right of the developed program. In 

addition to the password, the M-PLC is also designed with additional ID and PLC ID protective measures. 

This section describes the protective measures such as password as well as program ID and PLC ID in 

order to intensify the security level in protecting the intellectual properties that are laboriously developed 

by the respective user. 

13-1 Program ID 

It helps the user prevent illegal program replication or stealing to achieve the intended protection effect. 

However, it cannot be used to protect the Hardcopy type of program replication.  

The program ID must be identical with the PLC ID, or the PLC will not be functioning as intended.  

You may open, cancel or change the program ID by clicking [Project] → [Security] → [Program ID] in the 

tag page. The password should be presented in capitalized English 8-digit alphanumeric characters (A–Z, 

0–‍9). 

 

Fig. 270: Editing program ID 
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13-2 Project Password 

It provides the “Encrypt Project File” (*.pdwx) function for users.  

You may open, cancel or change the project password by clicking [Project] → [Security] → [Project 

Password] in the tag page. The password should be presented in capitalized English 8-digit alphanumeric 

characters (a–z, A–Z, 0–9). 

 

Fig. 271: Project password 



Chapter 13 Security 

9-4 

  M-Series PLC Software Interface User Manual 

13-3 Program Password 

It provides the “Encrypt Program” function for users.  

You may open the [Program Protection] window by clicking [Project] → [Security] → [Program Protection] 

in the tag page. If such window has been created with the protect password already, then you need to 

input the password beforehand in order to open such window.  

 

 

Fig. 272: Program unit password 

 

After clicking, the window will show the “Program Protection Setting” window page.  

 

Fig. 273: Program Protection Setting 
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Type Function  Description 

Program 

Protection 

Setting 

Password Setting new password or changing old password. 

Confirm 

Password 

The user needs to confirm the imported password again when 

creating new password or changing password. 

Program 

Editor 

File Version Saving currently edited project on the disk. 

Can Edit After being selected, it allows the user to edit the project. 

Can Copy After being selected, it allows the user to copy the project. 

Can Save After being selected, it allows the user to save the project. 

Program 

Protection 

Program 

Protection 

Password for 

Target Item 

Selecting the unit to be protected. 

Customize 

Unit 

Password 

The user may create extra unit password in this column. For 

detailed password setting method please refer to the 

respective paragraph.  

 

Click [Activate Protection], input password and then press [OK] to complete the program unit password 

setting.
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13-4 Program Unit Password 

In customer project applications, programmers want to protect some key program logic or design 

process, and other basic application parameters are open to end customers to modify. At this time, 

program unit passwords can be used for hierarchical protection. UperLogic provides users with the 

function of encrypting program units, which can be used to encrypt individual program organization 

units, including Main Program/Sub Program/Interrupt Program/Function fast program, which has 

achieved the effect of protecting intellectual property rights. 

 

Click [Project Management] → [Ladder Diagram] → [Main Program] and then select the program unit to 

be encrypted. Next, click the right mouse button → [Password Protection] and you will be allowed to set 

the unit password; or you may click [Project] → [Security]→ [Program Protection] → [Customize Unit 

Password in tag page and then select  of the program unit to execute the encryption 

setting. 

 

Fig. 274: Program unit password 

 

Fig. 275: Activate Customize Unit Password 
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After opening the window, set a password to complete the password setting. The icon of the password-

protected program changes to  in the project management window. To open the program, the 

password must be entered to view and edit the program content. 

 

 

Fig. 276: Input Customize Unit Password 
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13-5 Data Password 

Provide users data password function. For the data that is checked and set with a password, when you 

click on the data category, you need to enter the data password to access it. 

From the tab page [Project] → [Security] → [Data Password], you can select the data to be protected, 

and Enable/Cancel/Change the data password. The password should be presented in capitalized English 

8-digit alphanumeric characters (a–z, A–Z, 0–9). 
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13-6 Download Password 

Provide users with the function of setting a download password to protect the project from being 

arbitrarily downloaded to different devices. For projects with a download password set, the correct 

password must be entered during the download process to continue the download process. 

From the tab page [Project] → [Security] → [Download Password], and you can Enable/Cancel/Change 

the data password. The password should be presented in capitalized English 8-digit alphanumeric 

characters (a–z, A–Z, 0–9). 

 

Fig. 277: Download password 
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13-7 Upload Protection 

Provide users with the function of setting upload protection to protect PLC data from being uploaded 

arbitrarily. For a PLC with upload protection set, the correct password must be entered during the process 

to continue uploading. 

From the tab page [Project] → [Security] → [Upload Protection], and you can Enable/Cancel/Change 

the data password. The password should be presented in capitalized English 8-digit alphanumeric 

characters (a–z, A–Z, 0–9). 

13-8 Download Protection 

Provide users with the function of setting download protection to protect PLC data from being 

downloaded arbitrarily. For a PLC with download protection set, the correct password must be entered 

during the process to continue downloading. 

From the tab page [Project] → [Security] → [Download Protection], and you can Enable/Cancel/Change 

the data password. The password should be presented in capitalized English 8-digit alphanumeric 

characters (a–z, A–Z, 0–9). 
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    Danger 

1. When installing or removing the M-series CPU modules and various expansion modules or the 

equipment connected to it, all power must be turned off, otherwise it may cause electric shock or 

wrong action, resulting in death or serious personal injury and damage to the machine equipment. 

2. Before the installation and wiring construction is completed, do not tear off the dust-proof paper on 

the PLC cooling hole, so as to prevent the drilling iron filings or wiring scraps from falling into the 

PLC during construction, causing fire, failure or malfunction. 

3. After confirming that the installation and wiring are all completed, remember to tear off the above-

mentioned dustproof paper to avoid poor heat dissipation of the PLC, resulting in fire, failure or 

malfunction. 
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This section describes the auxiliary functions provided by the software for users to check and calculate 

the corresponding functions more easily.  

14-1 System Backup and Restore 

This section describes how to execute the Register content backup function and the Register content 

backup saving function. 

14-1-1 System Backup 

This function can quickly backup PLC parameters, programs and data to files. Combined with the system 

restore function, it can be used as an error-prone PLC copy application. The extension of the system 

backup file is *.fsbx.  

The backup process is as follows: 

1. When operated under “Offline Edit” status, click [Tool] → [System Backup] in function toolbar, as 

below: 

 

Fig. 278: System backup 

Function  Description 

Parameter System Parameter PLC current connection parameter setting 

Program All Program Units PLC current complete program data 

Data 

Memory 

Discrete Status PLC current input contact (X), output relay (Y), internal relay 

(M) and step relay (S) values 
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Special Discrete 

Status 

PLC current special relay (M) value 

Data Register PLC current data register (R、D) values 

Special Data 

Register 

PLC current input register (R), output register (R), special 

register (R) values 

Timer and 

Counter Value 

PLC current timer (T) and counter (C) values 

File Register PLC current file register (F) value 

Expansion Expansion Data PLC current expansion module setting data 

Motion Motion Program PLC current motion data 

 

2. If password should be created for such project, then it allows the user to select the intended 

protection method and add the required password.  

 

Fig. 279: System backup setting 
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Function Description 

No Protection When restoring such backup file, it is not required to input 

the password and such file will be restored directly.  

PC Locked Protection When using this backup file to restore, it can be restored 

directly but only on the currently operating PC, and cannot 

be restored on another PC. Typically used in factory 

production situations. 

Password Protection To restore such backup file, the user needs to input the 

password in order to restore the backup file.  

 

3. Users can enter the file name and file comment in the save dialog box, and start the backup after 

confirmation. 

 

Fig. 280: Saving System backup 

4. After the progress window ends, it will prompt that the system backup is complete. 
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14-1-2 System Restore 

This function can quickly write the system restore file ( *.fsbx ) data to the PLC. 

The backup process is as follows: 

1. When operated under “Offline Edit” status, click [Tool] → [System Restore] in function toolbar to 

select the file to restore, as below: 

 

Fig. 281: System restore 

2. If the file is protected by a password, a password confirmation dialog box will appear at this time, and 

the restoration will start after the correct input. 

 

 

Fig. 282: Input system restoration password 

3. After the progress window ends, it will prompt that the system restore is complete. 
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14-2 Memory Card Operations 

Click [Tool] → [Memory Card Operations] in function toolbar to show the following window, as below: 

 

Fig. 283: Memory Card Operations 

14-2-1 Write Backup Information 

Click [Write Backup Information] and you will see the following screen. Users can perform functions 

related to memory card backup. 

 

Fig. 284: Memory card backup operation 
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Function Description 

Backup Program and 

Register to Memory Card 

This function can replicate the program and register 

contents to the memory card. After pressing [Next], 

there will be detailed settings that can be adjusted. 

For detailed functions, please refer to the 

Application manual. 

Clear Backup Data in 

Memory Card 

This function can clear the program or data stored 

in the memory card, click [Next] to start the action. 

Enter Trial Mode This function allows the user to choose whether to 

enter the trial modification mode (that is, whether to 

let the program and data in the memory card 

overwrite the program and data in the host). Press 

[Next] to start the action. 

Enter Normal Mode This functoin allows users to choose whether to 

enter normal mode. Press [Next] to start the action. 

 

14-2-2 Write OS Information 

Click [Write OS Information] and you will see the following screen. The user can choose to write the 

update or rescue file of the host or the expansion module. After the import is completed, the 

corresponding version will be displayed on the OS information side. Please refer to the Application 

manual for the detailed functions of the OS update and rescue functions of the memory card. 

  

Fig. 285: Write OS Information 

Item Description 

Device Select the OS written to the [PC] or [Expansion] device. 

Type Choose to write the OS for [Update] or [Rescue]. 

OS Info Displays the OS version. 



Chapter 14 Tools 

9-8 

M-Series PLC Software Interface User Manual 

When the user chooses to write “OS Update” in “Expansion”, the 

OS information can be written to multiple firmwares at the same 

time, as shown in the figure below: 

 

OS File Select the path of the OS file to be written. 

When the user chooses to write “OS Update” in “Expanded”, this 

path exists in the OS information. 

 

14-2-3 Switch Copy Protection 

After clicking [Switch Copy Protection], the user can set whether to enable the copy protection of the 

memory card. After copy protection is enabled, the memory card will be bound to the PC, and the 

memory card data cannot be transferred to aother PC for use. 

  

Fig. 286: Copy Protection 

14-2-4 Memory Card Information 

Click [Memory Card Information] and you will see the following screen. Users can check the relevant 

information of the memory card through the memory card information. 
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Fig. 287: Memory Card Information 

Item Description 

Capacity Indicates the full capacity of the memory card. 

Available Capacity Indicates the available capacity of the memory card. 

Memory Card Type Indicates the type of the memory card. 

Copy Proyection Indicates whether to enable copy protection. 

System Backup Indicates whether there is write backup information. 

System Backup Type Indicates the model of the write backup. 

System Backup Version Indicates the firmware and hardware version of the backup. 

PC OS Update/Rescue 

Version 

Indicates the PC update/rescue firmware and hardware 

version written. 

Expansoin OS 

Update/Rescue Version 

Indicates the Expansionsion update/rescue firmware and 

hardware version written. 
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14-2-5 Clear Memory Card 

Click [Clear Memory Card] and you will see the following screen. The user can select the items to be 

cleared: 

 

Fig. 288: Clear Memory Card 

Function Description 

Clear All Clear all data on the memory card. 

Clear Backup Data Clear the data backed up in Section 14-2-1. 

Clear Information Register Clear the data register backed up in Section 14-2-1 

Clear PLC OS File Clear the PLC OS files written in Section 14-2-2 

Clear Expansoin OS File Clear the Expansion OS files written in Section 14-2-2 
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14-3 CRC16 Calculator 

The CRC value is generally used to check Communication Protocols. This function allows the system to 

automatically calculate and generate or inspect the check values after the user enters the data content, 

which is convenient for planning the packet content when communicating with third-party devices. 

 

Click [Tool] → [CRC16 Calculator] in function toolbar to show the following window, as below: 

 

Fig. 289: CRC16 Calculator 

 

After inputting the code to be checked, such function will display the number of bytes (Len) being 

imported until now and then it will calculate the Checksum value and the CRC16 value automatically. 

After completing the input, press [Save] for saving as the sub-file named as “txt” text file. In this way, it 

allows the user to call out the text file by pressing [Open] during the next round of operation without the 

need of executing input steps once again. Press [New], the input field will be cleared as blank ready for 

inputting again. Clicking the upper-right [X] icon or [Close], the user will be allowed to close the CRC16 

Calculator window.  
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Appendix 1_Quick Start 

This section will guide the user to quickly create the intended project and download it to PLC to run.  

1. First, download the UperLogic from the website and then start the installation. For detailed 

installation steps, please refer to Chapter 2.  

2. Click [UperLogic] to open new project. Next, click [Project] → [Project] → [Options] → [File] in 

function toolbar and then execute the project backup setting so as to prevent the designed project 

from losing inadvertently.  

Regarding detailed file setting steps, please refer to Chapter 4

 

Fig. 290: Setting backup project 

3. Open a new Project. 

4. Click [Designer] → [Ladder Diagram] in function toolbar to create an easy-to-use project.  

For detailed information of Ladder Diagram, please refer to Chapter 6. 

 

Fig. 291: Creating easy-to-use project 
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5. After creating the desired project, click [PLC] → [Connection Parameter] in function toolbar to 

establish the online communication with the PLC. In this example, the online will be established 

through USB/Type C. Therefore, the user needs to confirm that the PLC is properly connected with 

the PC with the USB/Type C cable and then check if the communication is correctly established 

through the online test. 

For detailed information of online parameter, please refer to Chapter 11. 

 

Fig. 290: Creating connection 

6. After creating the desired connection parameter, click [PLC] → [Operation] → [Download] in function 

toolbar to download the project to the PLC. Before starting the download procedure, the software 

will compare the project with the PLC and then tell the user about the difference between both for 

the user to select the desired download item.  

For detailed information of downloading, please refer to Chapter 11. 
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Fig. 291: Downloading project to PLC 

7. After completing the download process, click [PLC] → [Mode] → [Online Monitor] in function toolbar 

and you will be allowed to monitor the PLC program operating status. When accessing the [Online 

Monitor], the system will display the window showing present PLC status for reference by the user. 

For detailed information of monitoring, please refer to Chapter 12. 

 

Fig. 292: Online monitoring PLC 
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8. After finishing the “Online Monitor” mode, the user may click the upper-left “File” → 

“Save Project” to finish the online monitoring. 

For detailed project saving steps, please refer to Chapter 4.  

9. Now, you have completed the editing of the easy-to-use project.



 

 

 


